source: projects/specs/trunk/s/suitesparse/suitesparse-vl.spec @ 12305

Revision 12305, 18.4 KB checked in by ara_t, 4 years ago (diff)

suitesparse: update to 5.4.0

Line 
1%define pkg_name    suitesparse
2%define pkg_version 5.4.0
3%define pkg_release 1%{?_dist_release}
4
5%global amd_version_major 2
6%global btf_version_major 1
7%global camd_version_major 2
8%global ccolamd_version_major 2
9%global cholmod_version_major 3
10%global colamd_version_major 2
11%global csparse_version_major 3
12%global cxsparse_version_major 3
13%global klu_version_major 1
14%global ldl_version_major 2
15%global rbio_version_major 2
16%global spqr_version_major 2
17%global SuiteSparse_config_major 5
18%global umfpack_version_major 5
19
20### CXSparse is a superset of CSparse, and the two share common header
21### names, so it does not make sense to build both. CXSparse is built
22### by default, but CSparse can be built instead by defining
23### enable_csparse as 1 below.
24%define enable_csparse 0
25
26# Whether to build a separate version of libraries linked against an ILP64 BLAS
27%if 0%{?__isa_bits} == 64
28%global build64 1
29%endif
30
31
32Name:        %{pkg_name}
33Version:     %{pkg_version}
34Release:     %{pkg_release}
35
36Summary:     A collection of sparse matrix libraries
37Summary(ja): 疎行列ライブラリ集
38
39Group:       System Environment/Libraries
40License:     (LGPLv2+ or BSD) and LGPLv2+ and GPLv2+
41URL:         http://faculty.cse.tamu.edu/davis/suitesparse.html
42
43Source0:     http://faculty.cse.tamu.edu/davis/SuiteSparse/SuiteSparse-%{version}.tar.gz
44
45# # Move #include <math.h> out of StuiteSparse_config.h and into SuiteSparse_config.c
46# Patch0:      suitesparse-math.patch
47
48BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
49
50BuildRequires:  openblas-devel
51%if 0%{?build64}
52BuildRequires:  openblas64-devel
53%endif
54BuildRequires:  tbb-devel
55
56Provides:       ufsparse = %{version}-%{release}
57
58
59%description
60suitesparse is a collection of libraries for computations involving sparse
61matrices.  The package includes the following libraries:
62  AMD                 approximate minimum degree ordering
63  BTF                 permutation to block triangular form (beta)
64  CAMD                constrained approximate minimum degree ordering
65  COLAMD              column approximate minimum degree ordering
66  CCOLAMD             constrained column approximate minimum degree ordering
67  CHOLMOD             sparse Cholesky factorization
68  CSparse             a concise sparse matrix package
69  CXSparse            CSparse extended: complex matrix, int and long int support
70  KLU                 sparse LU factorization, primarily for circuit simulation
71  LDL                 a simple LDL factorization
72  SQPR                a multithread, multifrontal, rank-revealing sparse QR
73                      factorization method
74  UMFPACK             sparse LU factorization
75  SuiteSparse_config  configuration file for all the above packages.
76  RBio                read/write files in Rutherford/Boeing format
77
78
79%package devel
80Summary:        Development headers for SuiteSparse
81Summary(ja):    SuiteSparse の開発用ヘッダファイル集
82Group:          Development/Libraries
83Requires:       %{name} = %{version}-%{release}
84
85%description devel
86The suitesparse-devel package contains files needed for developing
87applications which use the suitesparse libraries.
88
89
90%package static
91Summary:        Static version of SuiteSparse libraries
92Summary(ja):    SuiteSparse の静的ライブラリ
93Group:          Development/Libraries
94Requires:       %{name}-devel = %{version}-%{release}
95
96%description static
97The suitesparse-static package contains the statically linkable
98version of the suitesparse libraries.
99
100
101%if 0%{?build64}
102%package -n %{name}64
103Summary:        A collection of sparse matrix libraries (ILP64 version)
104
105%description -n %{name}64
106The suitesparse collection compiled against an ILP64 BLAS library.
107
108
109%package -n %{name}64-devel
110Summary:        Development headers for SuiteSparse (ILP64 version)
111Requires:       %{name}-devel = %{version}-%{release}
112Requires:       %{name}64 = %{version}-%{release}
113
114%description -n %{name}64-devel
115The suitesparse64-devel package contains files needed for developing
116applications which use the suitesparse libraries (ILP64 version).
117
118
119%package -n %{name}64-static
120Summary:        Static version of SuiteSparse libraries (ILP64 version)
121Requires:       %{name}-devel = %{version}-%{release}
122
123%description -n %{name}64-static
124The suitesparse64-static package contains the statically linkable
125version of the suitesparse libraries (ILP64 version).
126
127
128%package -n %{name}64_
129Summary:        A collection of sparse matrix libraries (ILP64 version)
130
131%description -n %{name}64_
132The suitesparse collection compiled against an ILP64 BLAS library.
133
134
135%package -n %{name}64_-devel
136Summary:        Development headers for SuiteSparse (ILP64 version)
137Requires:       %{name}-devel = %{version}-%{release}
138Requires:       %{name}64_ = %{version}-%{release}
139
140%description -n %{name}64_-devel
141The suitesparse64_-devel package contains files needed for developing
142applications which use the suitesparse libraries (ILP64 version) compiled
143against a BLAS library with the "64_" symbol name suffix (see openblas-*64_
144packages).
145
146
147%package -n %{name}64_-static
148Summary:        Static version of SuiteSparse libraries (ILP64 version)
149Requires:       %{name}-devel = %{version}-%{release}
150
151%description -n %{name}64_-static
152The suitesparse64_-static package contains the statically linkable
153version of the suitesparse libraries (ILP64 version) compiled against a
154BLAS library with the "64_" symbol name suffix (see openblas-*64_ packages).
155%endif
156
157%package doc
158Summary:        Documentation files for SuiteSparse
159BuildArch:      noarch
160Requires:       %{name} = %{version}-%{release}
161
162%description doc
163This package contains documentation files for %{name}.
164
165
166%prep
167%setup -c -q
168
169pushd SuiteSparse
170  # Remove bundled metis
171  rm -r metis*
172  # Makefiles look for metis.h specifically
173  ln -s %{_includedir}/metis/*.h include/
174
175  # Fix pragma ivdep so gcc understands it.
176  for fil in $(grep -Frl 'pragma ivdep' .); do
177    sed -i.orig 's/pragma ivdep/pragma GCC ivdep/' $fil
178    touch -r ${fil}.orig $fil
179    rm -f ${fil}.orig
180  done
181
182  # drop non-standard -O3 and duplicate -fexceptions from default CFLAGS
183  sed -i -e '/^  CF =/ s/ -O3 -fexceptions//' SuiteSparse_config/SuiteSparse_config.mk
184
185  # Allow adding a suffix to the library name
186  sed -i -e '/SO.*=/s/$(LIBRARY).so/$(LIBRARY)$(LIBRARY_SUFFIX).so/' \
187         -e '/AR_TARGET *=/s/$(LIBRARY).a/$(LIBRARY)$(LIBRARY_SUFFIX).a/' SuiteSparse_config/SuiteSparse_config.mk
188  sed -i -e 's/-l\(amd\|btf\|camd\|ccolamd\|cholmod\|colamd\|csparse\|cxsparse\|klu\|ldl\|rbio\|spqr\|suitesparseconfig\|umfpack\)/-l\1$(LIBRARY_SUFFIX)/g' \
189    $(find -name Makefile\* -o -name \*.mk)
190popd
191
192%if 0%{?build64}
193cp -a SuiteSparse SuiteSparse64
194cp -a SuiteSparse SuiteSparse64_
195%endif
196
197
198%build
199for build in SuiteSparse %{?build64:SuiteSparse64 SuiteSparse64_}
200do
201  pushd $build
202
203  # TODO - Try to use upstream makefile - will build more components
204  mkdir -p Doc/{AMD,BTF,CAMD,CCOLAMD,CHOLMOD,COLAMD,KLU,LDL,UMFPACK,SPQR,RBio} Include
205
206  export CFLAGS="$RPM_OPT_FLAGS -I%{_includedir}/metis"
207  export LAPACK=""
208  # Set flags for ILP64 build
209  if [ $build = SuiteSparse64 ]
210  then
211     export CFLAGS="$CFLAGS -DBLAS64"
212     export BLAS=-lopenblas64
213     export LIBRARY_SUFFIX=64
214  elif [ $build = SuiteSparse64_ ]
215  then
216     export CFLAGS="$CFLAGS -DBLAS64 -DSUN64"
217     export BLAS=-lopenblas64_
218     export LIBRARY_SUFFIX=64_
219  else
220     export BLAS=-lopenblas
221  fi   
222   
223  # SuiteSparse_config needs to come first
224  pushd SuiteSparse_config
225    %make_build CFLAGS="$CFLAGS" BLAS="$BLAS" LIBRARY_SUFFIX="$LIBRARY_SUFFIX"
226    cp -p *.h ../Include
227  popd
228
229  pushd AMD
230    pushd Lib
231      %make_build CFLAGS="$CFLAGS" BLAS="$BLAS" LIBRARY_SUFFIX="$LIBRARY_SUFFIX"
232    popd
233    cp -p Include/*.h ../Include
234    cp -p README.txt Doc/License.txt Doc/lesser.txt Doc/ChangeLog Doc/*.pdf ../Doc/AMD
235  popd
236
237  pushd BTF
238    pushd Lib
239      %make_build CFLAGS="$CFLAGS" BLAS="$BLAS" LIBRARY_SUFFIX="$LIBRARY_SUFFIX"
240    popd
241    cp -p Include/*.h ../Include
242    cp -p README.txt Doc/* ../Doc/BTF
243  popd
244
245  pushd CAMD
246    pushd Lib
247      %make_build CFLAGS="$CFLAGS" BLAS="$BLAS" LIBRARY_SUFFIX="$LIBRARY_SUFFIX"
248    popd
249    cp -p Include/*.h ../Include
250    cp -p README.txt Doc/ChangeLog Doc/License.txt Doc/*.pdf ../Doc/CAMD
251  popd
252
253  pushd CCOLAMD
254    pushd Lib
255      %make_build CFLAGS="$CFLAGS" BLAS="$BLAS" LIBRARY_SUFFIX="$LIBRARY_SUFFIX"
256    popd
257    cp -p Include/*.h ../Include
258    cp -p README.txt Doc/* ../Doc/CCOLAMD
259  popd
260
261  pushd COLAMD
262    pushd Lib
263      %make_build CFLAGS="$CFLAGS" BLAS="$BLAS" LIBRARY_SUFFIX="$LIBRARY_SUFFIX"
264    popd
265    cp -p Include/*.h ../Include
266    cp -p README.txt Doc/* ../Doc/COLAMD
267  popd
268
269  pushd CHOLMOD
270    pushd Lib
271      %make_build CFLAGS="$CFLAGS" BLAS="$BLAS" LIBRARY_SUFFIX="$LIBRARY_SUFFIX"
272    popd
273    cp -p Include/*.h ../Include
274    cp -p README.txt Doc/*.pdf ../Doc/CHOLMOD
275    cp -p Cholesky/lesser.txt ../Doc/CHOLMOD/Cholesky_License.txt
276    cp -p Core/lesser.txt ../Doc/CHOLMOD/Core_License.txt
277    cp -p MatrixOps/gpl.txt ../Doc/CHOLMOD/MatrixOps_License.txt
278    cp -p Partition/lesser.txt ../Doc/CHOLMOD/Partition_License.txt
279    cp -p Supernodal/gpl.txt ../Doc/CHOLMOD/Supernodal_License.txt
280  popd
281
282  %if "%{?enable_csparse}" == "1"
283  pushd CSparse
284    pushd Source
285      %make_build CFLAGS="$CFLAGS" BLAS="$BLAS" LIBRARY_SUFFIX="$LIBRARY_SUFFIX"
286      cp -p cs.h ../../Include
287    popd
288    mkdir ../Doc/CSparse/
289    cp -p Doc/* ../Doc/CSparse
290  popd
291
292  %else
293  pushd CXSparse
294    pushd Lib
295      %make_build CFLAGS="$CFLAGS" BLAS="$BLAS" LIBRARY_SUFFIX="$LIBRARY_SUFFIX"
296    popd
297    cp -p Include/cs.h ../Include
298    mkdir ../Doc/CXSparse/
299    cp -p Doc/* ../Doc/CXSparse
300  popd
301  %endif
302
303  pushd KLU
304    pushd Lib
305      %make_build CFLAGS="$CFLAGS" BLAS="$BLAS" LIBRARY_SUFFIX="$LIBRARY_SUFFIX"
306    popd
307    cp -p Include/*.h ../Include
308    cp -p README.txt Doc/lesser.txt ../Doc/KLU
309  popd
310
311  pushd LDL
312    pushd Lib
313      %make_build CFLAGS="$CFLAGS" BLAS="$BLAS" LIBRARY_SUFFIX="$LIBRARY_SUFFIX"
314    popd
315    cp -p Include/*.h ../Include
316    cp -p README.txt Doc/ChangeLog Doc/lesser.txt Doc/*.pdf ../Doc/LDL
317  popd
318
319  pushd UMFPACK
320    pushd Lib
321      %make_build CFLAGS="$CFLAGS" BLAS="$BLAS" LIBRARY_SUFFIX="$LIBRARY_SUFFIX"
322    popd
323    cp -p Include/*.h ../Include
324    cp -p README.txt Doc/License.txt Doc/ChangeLog Doc/gpl.txt Doc/*.pdf ../Doc/UMFPACK
325  popd
326
327  pushd SPQR
328    pushd Lib
329    %make_build CFLAGS="$CFLAGS -DHAVE_TBB -DNPARTITION" TBB=-ltbb \
330                BLAS="$BLAS" LIBRARY_SUFFIX="$LIBRARY_SUFFIX"
331    popd
332    cp -p Include/*.h* ../Include
333    cp -p README{,_SPQR}.txt
334    cp -p README_SPQR.txt Doc/* ../Doc/SPQR
335  popd
336
337  pushd RBio
338    pushd Lib
339      %make_build CFLAGS="$CFLAGS" BLAS="$BLAS" LIBRARY_SUFFIX="$LIBRARY_SUFFIX"
340    popd
341    cp -p Include/*.h ../Include
342    cp -p README.txt Doc/ChangeLog Doc/License.txt ../Doc/RBio
343  popd
344
345  popd
346done
347
348
349%install
350mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
351mkdir -p ${RPM_BUILD_ROOT}%{_includedir}/%{name}
352cp -a SuiteSparse/Include/*.{h,hpp} ${RPM_BUILD_ROOT}%{_includedir}/%{name}/
353for build in SuiteSparse %{?build64:SuiteSparse64 SuiteSparse64_}
354do
355  pushd $build
356    cp -a */Lib/*.a lib/*.so* ${RPM_BUILD_ROOT}%{_libdir}/
357    chmod 755 ${RPM_BUILD_ROOT}%{_libdir}/*.so.*
358
359    # collect licenses in one place to ship as base package documentation
360    rm -rf Licenses
361    mkdir Licenses
362    find */ -iname lesser.txt -o -iname license.txt -o -iname gpl.txt -o \
363        -iname license | while read f; do
364            b="${f%%/*}"
365            r="${f#$b}"
366            x="$(echo "$r" | sed 's|/doc/|/|gi')"
367            install -m0644 -D "$f" "./Licenses/$b/$x"
368        done
369
370    # hardlink duplicate documentation files
371    hardlink -cvf Docs/ Licenses/
372  popd
373done
374
375
376%check
377TESTDIRS="AMD CAMD CCOLAMD CHOLMOD COLAMD KLU LDL SPQR RBio UMFPACK"
378%if "%{?enable_csparse}" == "1"
379TESTDIRS="$TESTDIRS CSparse"
380%else
381TESTDIRS="$TESTDIRS CXSparse"
382%endif
383for build in SuiteSparse %{?build64:SuiteSparse64 SuiteSparse64_}
384do
385  pushd $build
386    export CFLAGS="$RPM_OPT_FLAGS -I%{_includedir}/metis"
387    export LAPACK=""
388    # Set flags for ILP64 build
389    if [ $build = SuiteSparse64 ]
390    then
391       export CFLAGS="$CFLAGS -DBLAS64"
392       export BLAS=-lopenblas64
393       export LIBRARY_SUFFIX=64
394    elif [ $build = SuiteSparse64_ ]
395    then
396       export CFLAGS="$CFLAGS -DBLAS64 -DSUN64"
397       export BLAS=-lopenblas64_
398       export LIBRARY_SUFFIX=64_
399    else
400       export BLAS=-lopenblas
401    fi
402
403    for d in $TESTDIRS ; do
404        %make_build -C $d/Demo \
405                    CFLAGS="$CFLAGS" LIB="%{?__global_ldflags} -lm -lrt" \
406                    BLAS="$BLAS" LIBRARY_SUFFIX="$LIBRARY_SUFFIX" \
407                    SPQR_CONFIG=-DHAVE_TBB TBB=-ltbb
408    done
409  popd
410done
411
412
413%clean
414rm -rf ${RPM_BUILD_ROOT}
415
416%post -p /sbin/ldconfig
417
418%postun -p /sbin/ldconfig
419
420
421%files
422%license SuiteSparse/Licenses
423%{_libdir}/libamd.so.%{amd_version_major}*
424%{_libdir}/libbtf.so.%{btf_version_major}*
425%{_libdir}/libcamd.so.%{camd_version_major}*
426%{_libdir}/libccolamd.so.%{ccolamd_version_major}*
427%{_libdir}/libcholmod.so.%{cholmod_version_major}*
428%{_libdir}/libcolamd.so.%{colamd_version_major}*
429%if "%{?enable_csparse}" == "1"
430%{_libdir}/libcsparse.so.%{csparse_version_major}*
431%endif
432%{_libdir}/libcxsparse.so.%{cxsparse_version_major}*
433%{_libdir}/libklu.so.%{klu_version_major}*
434%{_libdir}/libldl.so.%{ldl_version_major}*
435%{_libdir}/librbio.so.%{rbio_version_major}*
436%{_libdir}/libspqr.so.%{spqr_version_major}*
437%{_libdir}/libsuitesparseconfig.so.%{SuiteSparse_config_major}*
438%{_libdir}/libumfpack.so.%{umfpack_version_major}*
439
440%files devel
441%{_includedir}/%{name}
442%{_libdir}/lib*.so
443%if 0%{?build64}
444%exclude %{_libdir}/lib*64*.so
445%endif
446
447%files static
448%{_libdir}/lib*.a
449%if 0%{?build64}
450%exclude %{_libdir}/lib*64*.a
451%endif
452
453%if 0%{?build64}
454%files -n %{name}64
455%license SuiteSparse64/Licenses
456%{_libdir}/libamd64.so.%{amd_version_major}*
457%{_libdir}/libbtf64.so.%{btf_version_major}*
458%{_libdir}/libcamd64.so.%{camd_version_major}*
459%{_libdir}/libccolamd64.so.%{ccolamd_version_major}*
460%{_libdir}/libcholmod64.so.%{cholmod_version_major}*
461%{_libdir}/libcolamd64.so.%{colamd_version_major}*
462%if "%{?enable_csparse}" == "1"
463%{_libdir}/libcsparse64.so.%{csparse_version_major}*
464%endif
465%{_libdir}/libcxsparse64.so.%{cxsparse_version_major}*
466%{_libdir}/libklu64.so.%{klu_version_major}*
467%{_libdir}/libldl64.so.%{ldl_version_major}*
468%{_libdir}/librbio64.so.%{rbio_version_major}*
469%{_libdir}/libspqr64.so.%{spqr_version_major}*
470%{_libdir}/libsuitesparseconfig64.so.%{SuiteSparse_config_major}*
471%{_libdir}/libumfpack64.so.%{umfpack_version_major}*
472
473%files -n %{name}64-devel
474%{_libdir}/lib*64.so
475
476%files -n %{name}64-static
477%{_libdir}/lib*64.a
478
479%files -n %{name}64_
480%license SuiteSparse64_/Licenses
481%{_libdir}/libamd64_.so.%{amd_version_major}*
482%{_libdir}/libbtf64_.so.%{btf_version_major}*
483%{_libdir}/libcamd64_.so.%{camd_version_major}*
484%{_libdir}/libccolamd64_.so.%{ccolamd_version_major}*
485%{_libdir}/libcholmod64_.so.%{cholmod_version_major}*
486%{_libdir}/libcolamd64_.so.%{colamd_version_major}*
487%if "%{?enable_csparse}" == "1"
488%{_libdir}/libcsparse64_.so.%{csparse_version_major}*
489%endif
490%{_libdir}/libcxsparse64_.so.%{cxsparse_version_major}*
491%{_libdir}/libklu64_.so.%{klu_version_major}*
492%{_libdir}/libldl64_.so.%{ldl_version_major}*
493%{_libdir}/librbio64_.so.%{rbio_version_major}*
494%{_libdir}/libspqr64_.so.%{spqr_version_major}*
495%{_libdir}/libsuitesparseconfig64_.so.%{SuiteSparse_config_major}*
496%{_libdir}/libumfpack64_.so.%{umfpack_version_major}*
497
498%files -n %{name}64_-devel
499%{_libdir}/lib*64_.so
500
501%files -n %{name}64_-static
502%{_libdir}/lib*64_.a
503%endif
504
505%files doc
506%doc SuiteSparse/Doc/*
507
508
509%changelog
510* Sun Nov 03 2019 Toshiaki Ara <ara_t@384.jp> 5.4.0-1
511- update to 5.4.0
512- Build ILP64 version
513
514* Fri Jan 25 2019 Toshiaki Ara <ara_t@384.jp> 4.4.6-2
515- rebuild with gfortran-8.2.0
516
517* Wed Aug 22 2018 Toshiaki Ara <ara_t@384.jp> 4.4.6-1
518- update to 4.4.6
519- drop Patch0
520
521* Mon Jul 18 2016 Toshiaki Ara <ara_t@384.jp> 4.3.1-3
522- rebuild with gcc-5.4.0
523
524* Thu Mar  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.3.1-2
525- built with tbb 4.3u3
526
527* Tue Feb 17 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.3.1-1
528- updated to 4.3.1
529
530* Thu Mar 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> 3.7.0-1
531- Updated to 3.7.0
532
533* Mon Dec 01 2008 NAKAMURA Kenta <kenta@vinelinux.org> 3.6.1-1
534- Updated to 3.6.1
535
536* Sat Oct 11 2008 Shu KONNO <owa@bg.wakwak.com> 3.1.0-3vl5
537- applied new versioning policy
538
539* Wed Jan 02 2008 NAKAMURA Kenta <kenta@vinelinux.org> 3.1.0-2vl1
540- New release.
541
542* Wed Jan 02 2008 NAKAMURA Kenta <kenta@vinelinux.org> 3.0.0-2vl1
543- Rebuild for VineSeed
544
545* Fri Aug 24 2007 Quentin Spencer <qspencer@users.sourceforge.net> 3.0.0-2
546- Rebuild for F8.
547
548* Tue Jul  3 2007 Quentin Spencer <qspencer@users.sourceforge.net> 3.0.0-1
549- Change package name to match upstream, including provides and obsoletes.
550- New release. Numerous changes in build to reflect source reorganization.
551- Moved static libs into separate package.
552
553* Mon Oct 16 2006 Quentin Spencer <qspencer@users.sourceforge.net> 2.1.1-1
554- New release, and package name change from UFsparse to SuiteSparse. Fixes
555  bug #210846. Keep the ufsparse package name for now.
556
557* Thu Sep  7 2006 Quentin Spencer <qspencer@users.sourceforge.net> 2.1.0-1
558- New release. Increment versions of some libraries.
559- Rearrange and clean up spec file so all definitions are in one place.
560
561* Mon Aug  7 2006 Quentin Spencer <qspencer@users.sourceforge.net> 2.0.0-1
562- New release.
563- Build newly added CAMD library.
564- Misc minor spec changes.
565
566* Tue Mar  7 2006 Quentin Spencer <qspencer@users.sourceforge.net> 1.2-1
567- New release.
568- Build newly added library CXSparse (but not CSparse--see comments
569  in build section).
570
571* Wed Feb 15 2006 Quentin Spencer <qspencer@users.sourceforge.net> 0.93-2
572- Rebuild for Fedora Extras 5.
573
574* Thu Feb  9 2006 Quentin Spencer <qspencer@users.sourceforge.net> 0.93-1
575- New release. Remove old patch.
576
577* Wed Dec 14 2005 Quentin Spencer <qspencer@users.sourceforge.net> 0.92-2
578- Add patch0--fixes LDL/Makefile so CFLAGS are used when compiling ldl.a.
579
580* Wed Dec 14 2005 Quentin Spencer <qspencer@users.sourceforge.net> 0.92-1
581- Update to Dec 8 2005 version.
582
583* Tue Oct 25 2005 Quentin Spencer <qspencer@users.sourceforge.net> 0.91-2
584- Rebuild.
585
586* Tue Oct 18 2005 Quentin Spencer <qspencer@users.sourceforge.net> 0.91-1
587- New upstream release, incorporating previous patches
588- chmod the build directory to ensure all headers are world readable
589
590* Fri Oct 07 2005 Quentin Spencer <qspencer@users.sourceforge.net> 0.9-3
591- Build cholmod, but disable METIS using -DNPARTITION flag.
592
593* Sat Oct 01 2005 Quentin Spencer <qspencer@users.sourceforge.net> 0.9-2
594- Modify description, other modifications for import into FE.
595- Add dist tag, cosmetic changes.
596
597* Thu Sep 08 2005 David Bateman <dbateman@free.fr> 0.9-1
598- First version.
Note: See TracBrowser for help on using the repository browser.