source: projects/specs/trunk/s/sudo/sudo-vl.spec @ 521

Revision 521, 7.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Allows command execution as root for specified users
2Summary(ja): スーパーユーザ権限でのコマンドの実行
3Name: sudo
4Version: 1.7.2p1
5Release: 1%{?_dist_release}
6License: ISC-style
7Group: Applications/System
8URL: http://www.sudo.ws/
9
10Source0: http://www.sudo.ws/sudo/dist/sudo-%{version}.tar.gz
11Source1: sudo-sudoers-vine
12
13Patch1: sudo-1.6.7p5-strip.patch
14Patch2: sudo-1.7.2-login.patch
15Patch3: sudo-1.7.1-getgrouplist.patch
16Patch4: sudo-1.7.1-envdebug.patch
17Patch5: sudo-1.7.1-libtool.patch
18
19Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
20BuildRequires: pam-devel
21BuildRequires: groff
22BuildRequires: flex
23BuildRequires: bison
24BuildRequires: openldap-devel
25BuildRequires: automake autoconf libtool
26BuildRequires: libcap-devel
27
28Vendor: Project Vine
29Distribution: Vine Linux
30
31%description
32Sudo (superuser do) allows a system administrator to give certain users
33(or groups of users) the ability to run some (or all) commands as root while
34logging all commands and arguments. Sudo operates on a per-command basis,
35it is not a replacement for the shell.
36
37%description -l ja
38sudo は、特定のユーザや特定のグループに所属するユーザが、スーパーユーザ権限で
39いくつかのコマンド操作を行うことを許可するためのプログラムです。
40
41%prep
42%setup -q
43%patch1 -p1 -b .strip
44%patch2 -p1 -b .login
45%patch3 -p1 -b .getgrouplist
46%patch4 -p1 -b .envdebug
47%patch5 -p1 -b .libtool
48
49libtoolize --force && rm acsite.m4 && mv aclocal.m4 acinclude.m4 && autoreconf
50
51%build
52%configure \
53  --prefix=%{_prefix} \
54  --sbindir=%{_sbindir} \
55  --libdir=%{_libdir} \
56  --sysconfdir=%{_sysconfdir} \
57  --with-pam \
58  --with-pam-login \
59  --with-logging=syslog \
60  --with-logfac=authpriv \
61  --with-tty-tickets \
62  --with-ignore-dot \
63  --with-editor=/bin/vi \
64  --with-env-editor \
65  --with-ldap \
66  --with-passprompt="[sudo] password for %p: " \
67  --with-secure-path="/sbin:/bin:/usr/sbin:/usr/bin" \
68  --without-interfaces
69make
70
71%install
72rm -rf $RPM_BUILD_ROOT
73mkdir $RPM_BUILD_ROOT
74make install DESTDIR="$RPM_BUILD_ROOT" install_uid=`id -u` install_gid=`id -g` sudoers_uid=`id -u` sudoers_gid=`id -g`
75chmod 755 $RPM_BUILD_ROOT%{_bindir}/* $RPM_BUILD_ROOT%{_sbindir}/*
76install -p -d -m 700 $RPM_BUILD_ROOT/var/run/sudo
77install -p -c -m 0440 %{SOURCE1} $RPM_BUILD_ROOT/etc/sudoers
78
79mkdir -p $RPM_BUILD_ROOT/etc/pam.d
80cat > $RPM_BUILD_ROOT/etc/pam.d/sudo << EOF
81#%PAM-1.0
82auth       include      system-auth
83account    include      system-auth
84password   include      system-auth
85session    optional     pam_keyinit.so revoke
86session    required     pam_limits.so
87EOF
88
89cat > $RPM_BUILD_ROOT/etc/pam.d/sudo-i << EOF
90#%PAM-1.0
91auth       include      sudo
92account    include      sudo
93password   include      sudo
94session    optional     pam_keyinit.so force revoke
95session    required     pam_limits.so
96EOF
97
98
99%clean
100rm -rf $RPM_BUILD_ROOT
101
102%files
103%defattr(-,root,root)
104%doc BUGS CHANGES HISTORY LICENSE README* TROUBLESHOOTING UPGRADE
105%doc *.pod schema.* sudoers2ldif sample.*
106%attr(0440,root,root) %config(noreplace) /etc/sudoers
107%config(noreplace) /etc/pam.d/sudo
108%config(noreplace) /etc/pam.d/sudo-i
109%dir /var/run/sudo
110%attr(4111,root,root) %{_bindir}/sudo
111%attr(4111,root,root) %{_bindir}/sudoedit
112%attr(0755,root,root) %{_sbindir}/visudo
113%{_libexecdir}/sudo_noexec.*
114%{_mandir}/man5/sudoers.5*
115%{_mandir}/man8/sudo.8*
116%{_mandir}/man8/sudoedit.8*
117%{_mandir}/man8/visudo.8*
118
119%post
120/bin/chmod 0440 /etc/sudoers || :
121
122%changelog
123* Tue Nov 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.2p1-1
124- new upstream release
125- modified default sudoers
126  - keep more environment variables:
127    EDITOR, GTK_IM_MODULE, QT_IM_MODULE, XMODIFIERS and EMACS_IME
128
129* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.2-1
130- new upstream release
131
132* Wed Jun 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.1-1
133- new upstream release
134- update patches
135- disable "Defaults requiretty"
136
137* Fri Feb 13 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.6.9p20-2
138- rebuilt with openldap-2.4.11
139
140* Thu Feb 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.9p20-1
141- new upstream release with security fix (CVE 2009-0034)
142
143* Sat Aug 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.9p17-1
144- new upstream release
145- merge some changes from fedoraproject
146  - include [sudo] in password prompt
147  - compiled with secure path
148  - also use getgrouplist() to determine group membership
149  - add sudoers file
150    - add command aliases, default environment config
151- build with openldap
152
153* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.8p12-1vl5
154- applied new versioning policy, spec in utf-8
155
156* Fri May 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.8p12-0vl2
157- change PAM configuration to use system-auth
158- add --with-ignore-dot, --with-editor and --with-env-editor to
159  configure option.
160
161* Mon Jan 23 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.8p12-0vl1
162- new upstream release (included security fix)
163- add patch1 for fix CVE-2006-0151
164
165* Mon May 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.8p8-0vl1
166- new upstream release
167- use macros
168- build with pam
169
170* Wed Jan 19 2005 IWAI, Masaharu <iwai@alib.jp> 1.6.8p6-0vl1
171- new upstream release
172
173* Sun Oct 10 2004 IWAI, Masaharu <iwai@alib.jp> 1.6.8p1-0vl1
174- SECURITY FIX: new upstream release
175- update rpmnonroot.patch ( Patch0 )
176- add new man page: sudoedit(8)
177
178* Wed Sep  1 2004 IWAI, Masaharu <iwai@alib.jp> 1.6.8-0vl1
179- new upstream release
180- update rpmnonroot.patch ( Patch0 )
181- change Copyrigh tag to License tag
182- update License
183- update URL and Source0: official web site moved.
184- new files: %%{_bindir}/sudoedit and %%{_libexecdir}/sudo_noexec.*
185
186* Mon Apr 14 2003 IWAI Masaharu <iwai@alib.jp> 1.6.7p3-0vl1
187- upstream release
188
189* Wed May 08 2002 Satoshi MACHINO <machino@vinelinux.org> 1.6.6-0vl3
190- fixed changelog
191        -- don't expand macros in changelog ;P
192               
193* Wed May 01 2002 Satoshi MACHINO <machino@vinelinux.org> 1.6.6-0vl2
194- changed to use configure in build section
195        (can't build on sparc)
196
197* Fri Apr 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.6-0vl1
198- upstream release
199- fix security hole : buffer over flow
200
201* Thu Jan 24 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.5p2-0vl1
202- upstream release
203- updated sudo.rpmnonroot.diff
204
205* Fri Jan 18 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.5p1-0vl1
206- upstream release
207- added configure script option '--disable-root-mailer'
208
209* Tue Jan 15 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.4p1-0vl1
210- upstream release
211- eliminated FAQ from %doc
212
213* Mon Jan 14 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.4-0vl1
214- upstream release
215- added noreplace flag (%{_sysconfdir}/sudoers file is not replaced)
216- updated sudo.rpmnonroot.diff
217
218* Wed May 09 2001 <sagami@vinelinux.org>
219- 1.6.3p7-0vl2: follow up 1.6.2p6-0.6vl1
220
221* Fri Mar 02 2001 sagami@vinelinux.org
222- 1.6.3p7-0vl1
223- use better macros
224
225* Tue Mar 1 2001 Kunio Murasawa <murasawa@marineroad.com>
226- 1.6.3p6-0vl1
227- changed sudo.rpmnonroot.diff for 1.6.3p6
228
229* Tue Sep 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
230- 1.6.1-2vl5
231- patch -p1 -> patch -p0
232
233* Mon Sep 18 2000 MATSUMOTO Shoji <shom@vinelinux.org>
234- 1.6.1-2vl4
235- fix uid/gid to root.root
236- add sudo.rpmnonroot.diff to built by non-root users
237
238* Tue Sep 12 2000 Jun Nishii <jun@vinelinux.org>
239- 1.6.1-2vl3
240- fix attr
241
242* Sun Sep 10 2000 Jun Nishii <jun@vinelinux.org>
243- 1.6.1-2vl2
244- enable to build by non-root useres
245
246* Fri Sep 08 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
247- 1.6.1-2vl1
248- modified %files section to handle compressed man page(s)
249
250* Fri Jan  7 2000 Jun Nishii <jun@vinelinux.org>
251- change group
252
253* Thu Dec 30 1999 Jun Nishii <jun@vinelinux.org>
254- version 1.6.1
255- build for Vine Linux 2.0
256
257* Fri May 14  1999 Takeda Eiji <keda@flatout.org>
258- sudo reads $BuildRoot%{_sysconfdir}/sudoers. Make change to read /etc/sudoers.
259
260* Wed Apr 21 1999 Hiroto Watanabe <watanabe@cij.co.jp>
261- Initial Release
262
Note: See TracBrowser for help on using the repository browser.