source: projects/specs/trunk/s/sudo/sudo-vl.spec @ 1393

Revision 1393, 8.0 KB checked in by inagaki, 14 years ago (diff)

updated: libindi, libpng, cups, sudo, sylpheed and tar

Line 
1Summary: Allows command execution as root for specified users
2Summary(ja): スーパーユーザ権限でのコマンドの実行
3Name: sudo
4Version: 1.7.2p7
5Release: 1%{?_dist_release}
6License: ISC-style
7Group: Applications/System
8URL: http://www.sudo.ws/
9
10Source0: http://www.sudo.ws/sudo/dist/sudo-%{version}.tar.gz
11Source1: sudo-sudoers-vine
12
13Patch1: sudo-1.6.7p5-strip.patch
14Patch2: sudo-1.7.2-login.patch
15Patch3: sudo-1.7.2p4-getgrouplist.patch
16Patch4: sudo-1.7.1-envdebug.patch
17Patch5: sudo-1.7.1-libtool.patch
18
19Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
20BuildRequires: pam-devel
21BuildRequires: groff
22BuildRequires: flex
23BuildRequires: bison
24BuildRequires: openldap-devel
25BuildRequires: automake autoconf libtool
26BuildRequires: libcap-devel
27
28Vendor: Project Vine
29Distribution: Vine Linux
30
31%description
32Sudo (superuser do) allows a system administrator to give certain users
33(or groups of users) the ability to run some (or all) commands as root while
34logging all commands and arguments. Sudo operates on a per-command basis,
35it is not a replacement for the shell.
36
37%description -l ja
38sudo は、特定のユーザや特定のグループに所属するユーザが、スーパーユーザ権限で
39いくつかのコマンド操作を行うことを許可するためのプログラムです。
40
41%prep
42%setup -q
43%patch1 -p1 -b .strip
44%patch2 -p1 -b .login
45%patch3 -p1 -b .getgrouplist
46%patch4 -p1 -b .envdebug
47%patch5 -p1 -b .libtool
48
49libtoolize --force && rm acsite.m4 && mv aclocal.m4 acinclude.m4 && autoreconf
50
51%build
52%configure \
53  --prefix=%{_prefix} \
54  --sbindir=%{_sbindir} \
55  --libdir=%{_libdir} \
56  --sysconfdir=%{_sysconfdir} \
57  --with-pam \
58  --with-pam-login \
59  --with-logging=syslog \
60  --with-logfac=authpriv \
61  --with-tty-tickets \
62  --with-ignore-dot \
63  --with-editor=/bin/vi \
64  --with-env-editor \
65  --with-ldap \
66  --with-passprompt="[sudo] password for %p: " \
67  --with-secure-path="/sbin:/bin:/usr/sbin:/usr/bin" \
68  --without-interfaces
69make
70
71%install
72rm -rf $RPM_BUILD_ROOT
73mkdir $RPM_BUILD_ROOT
74make install DESTDIR="$RPM_BUILD_ROOT" install_uid=`id -u` install_gid=`id -g` sudoers_uid=`id -u` sudoers_gid=`id -g`
75chmod 755 $RPM_BUILD_ROOT%{_bindir}/* $RPM_BUILD_ROOT%{_sbindir}/*
76install -p -d -m 700 $RPM_BUILD_ROOT/var/run/sudo
77install -p -c -m 0440 %{SOURCE1} $RPM_BUILD_ROOT/etc/sudoers
78
79mkdir -p $RPM_BUILD_ROOT/etc/pam.d
80cat > $RPM_BUILD_ROOT/etc/pam.d/sudo << EOF
81#%PAM-1.0
82auth       include      system-auth
83account    include      system-auth
84password   include      system-auth
85session    optional     pam_keyinit.so revoke
86session    required     pam_limits.so
87EOF
88
89cat > $RPM_BUILD_ROOT/etc/pam.d/sudo-i << EOF
90#%PAM-1.0
91auth       include      sudo
92account    include      sudo
93password   include      sudo
94session    optional     pam_keyinit.so force revoke
95session    required     pam_limits.so
96EOF
97
98
99%clean
100rm -rf $RPM_BUILD_ROOT
101
102%files
103%defattr(-,root,root)
104%doc BUGS CHANGES HISTORY LICENSE README* TROUBLESHOOTING UPGRADE
105%doc *.pod schema.* sudoers2ldif sample.*
106%attr(0440,root,root) %config(noreplace) /etc/sudoers
107%config(noreplace) /etc/pam.d/sudo
108%config(noreplace) /etc/pam.d/sudo-i
109%dir /var/run/sudo
110%attr(4111,root,root) %{_bindir}/sudo
111%attr(4111,root,root) %{_bindir}/sudoedit
112%attr(0755,root,root) %{_sbindir}/visudo
113%{_libexecdir}/sudo_noexec.*
114%{_mandir}/man5/sudoers*.5*
115%{_mandir}/man8/sudo.8*
116%{_mandir}/man8/sudoedit.8*
117%{_mandir}/man8/visudo.8*
118
119%post
120/bin/chmod 0440 /etc/sudoers || :
121
122%changelog
123* Sun Jun 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-1
124- new upstream release with security fix (CVE-2010-1646)
125- change specfile name (-vl)
126
127* Sun Apr 25 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p6-1
128- new upstream release with security fix (CVE-2010-1163)
129- add sudoers.ldap.5 into files section
130
131* Wed Feb 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p4-1
132- new upstream release with security fix (CVE-2010-0426)
133- update Patch3
134
135* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.2-1
136- new upstream release
137
138* Wed Jun 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.1-1
139- new upstream release
140- update patches
141- disable "Defaults requiretty"
142
143* Fri Feb 13 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.6.9p20-2
144- rebuilt with openldap-2.4.11
145
146* Thu Feb 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.9p20-1
147- new upstream release with security fix (CVE 2009-0034)
148
149* Sat Aug 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.9p17-1
150- new upstream release
151- merge some changes from fedoraproject
152  - include [sudo] in password prompt
153  - compiled with secure path
154  - also use getgrouplist() to determine group membership
155  - add sudoers file
156    - add command aliases, default environment config
157- build with openldap
158
159* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.8p12-1vl5
160- applied new versioning policy, spec in utf-8
161
162* Fri May 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.8p12-0vl2
163- change PAM configuration to use system-auth
164- add --with-ignore-dot, --with-editor and --with-env-editor to
165  configure option.
166
167* Mon Jan 23 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.8p12-0vl1
168- new upstream release (included security fix)
169- add patch1 for fix CVE-2006-0151
170
171* Mon May 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.8p8-0vl1
172- new upstream release
173- use macros
174- build with pam
175
176* Wed Jan 19 2005 IWAI, Masaharu <iwai@alib.jp> 1.6.8p6-0vl1
177- new upstream release
178
179* Sun Oct 10 2004 IWAI, Masaharu <iwai@alib.jp> 1.6.8p1-0vl1
180- SECURITY FIX: new upstream release
181- update rpmnonroot.patch ( Patch0 )
182- add new man page: sudoedit(8)
183
184* Wed Sep  1 2004 IWAI, Masaharu <iwai@alib.jp> 1.6.8-0vl1
185- new upstream release
186- update rpmnonroot.patch ( Patch0 )
187- change Copyrigh tag to License tag
188- update License
189- update URL and Source0: official web site moved.
190- new files: %%{_bindir}/sudoedit and %%{_libexecdir}/sudo_noexec.*
191
192* Mon Apr 14 2003 IWAI Masaharu <iwai@alib.jp> 1.6.7p3-0vl1
193- upstream release
194
195* Wed May 08 2002 Satoshi MACHINO <machino@vinelinux.org> 1.6.6-0vl3
196- fixed changelog
197        -- don't expand macros in changelog ;P
198               
199* Wed May 01 2002 Satoshi MACHINO <machino@vinelinux.org> 1.6.6-0vl2
200- changed to use configure in build section
201        (can't build on sparc)
202
203* Fri Apr 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.6-0vl1
204- upstream release
205- fix security hole : buffer over flow
206
207* Thu Jan 24 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.5p2-0vl1
208- upstream release
209- updated sudo.rpmnonroot.diff
210
211* Fri Jan 18 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.5p1-0vl1
212- upstream release
213- added configure script option '--disable-root-mailer'
214
215* Tue Jan 15 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.4p1-0vl1
216- upstream release
217- eliminated FAQ from %doc
218
219* Mon Jan 14 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.4-0vl1
220- upstream release
221- added noreplace flag (%{_sysconfdir}/sudoers file is not replaced)
222- updated sudo.rpmnonroot.diff
223
224* Wed May 09 2001 <sagami@vinelinux.org>
225- 1.6.3p7-0vl2: follow up 1.6.2p6-0.6vl1
226
227* Fri Mar 02 2001 sagami@vinelinux.org
228- 1.6.3p7-0vl1
229- use better macros
230
231* Tue Mar 1 2001 Kunio Murasawa <murasawa@marineroad.com>
232- 1.6.3p6-0vl1
233- changed sudo.rpmnonroot.diff for 1.6.3p6
234
235* Tue Sep 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
236- 1.6.1-2vl5
237- patch -p1 -> patch -p0
238
239* Mon Sep 18 2000 MATSUMOTO Shoji <shom@vinelinux.org>
240- 1.6.1-2vl4
241- fix uid/gid to root.root
242- add sudo.rpmnonroot.diff to built by non-root users
243
244* Tue Sep 12 2000 Jun Nishii <jun@vinelinux.org>
245- 1.6.1-2vl3
246- fix attr
247
248* Sun Sep 10 2000 Jun Nishii <jun@vinelinux.org>
249- 1.6.1-2vl2
250- enable to build by non-root useres
251
252* Fri Sep 08 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
253- 1.6.1-2vl1
254- modified %files section to handle compressed man page(s)
255
256* Fri Jan  7 2000 Jun Nishii <jun@vinelinux.org>
257- change group
258
259* Thu Dec 30 1999 Jun Nishii <jun@vinelinux.org>
260- version 1.6.1
261- build for Vine Linux 2.0
262
263* Fri May 14  1999 Takeda Eiji <keda@flatout.org>
264- sudo reads $BuildRoot%{_sysconfdir}/sudoers. Make change to read /etc/sudoers.
265
266* Wed Apr 21 1999 Hiroto Watanabe <watanabe@cij.co.jp>
267- Initial Release
268
Note: See TracBrowser for help on using the repository browser.