source: projects/specs/trunk/s/sudo/sudo-vl.spec @ 8240

Revision 8240, 9.6 KB checked in by iwamoto, 10 years ago (diff)

sudo: update to 1.8.6p8

Line 
1Summary: Allows command execution as root for specified users
2Summary(ja): スーパーユーザ権限でのコマンドの実行
3Name: sudo
4Version: 1.8.6p8
5Release: 1%{?_dist_release}
6License: ISC-style
7Group: Applications/System
8URL: http://www.sudo.ws/sudo/
9
10Source0: http://www.sudo.ws/sudo/dist/sudo-%{version}.tar.gz
11Source1: sudo-sudoers-vine
12
13Patch1: sudo-1.6.7p5-strip.patch
14Patch4: sudo-1.7.2p1-envdebug.patch
15
16Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
17BuildRequires: pam-devel
18BuildRequires: groff
19BuildRequires: flex
20BuildRequires: bison
21BuildRequires: openldap-devel
22BuildRequires: automake autoconf libtool
23BuildRequires: libcap-devel
24
25Vendor: Project Vine
26Distribution: Vine Linux
27
28%description
29Sudo (superuser do) allows a system administrator to give certain users
30(or groups of users) the ability to run some (or all) commands as root while
31logging all commands and arguments. Sudo operates on a per-command basis,
32it is not a replacement for the shell.
33
34%description -l ja
35sudo は、特定のユーザや特定のグループに所属するユーザが、スーパーユーザ権限で
36いくつかのコマンド操作を行うことを許可するためのプログラムです。
37
38%prep
39%setup -q
40%patch1 -p1 -b .strip
41%patch4 -p1 -b .envdebug
42
43autoreconf -I m4 -fv --install
44
45%build
46%configure \
47  --prefix=%{_prefix} \
48  --sbindir=%{_sbindir} \
49  --libdir=%{_libdir} \
50  --sysconfdir=%{_sysconfdir} \
51  --docdir=%{_datadir}/doc/%{name}-%{version} \
52  --with-iologdir=/var/log/sudo-io \
53  --with-pam \
54  --with-pam-login \
55  --with-logging=syslog \
56  --with-logfac=authpriv \
57  --with-tty-tickets \
58  --with-ignore-dot \
59  --with-editor=/bin/vi \
60  --with-env-editor \
61  --with-ldap \
62  --with-passprompt="[sudo] password for %p: " \
63  --with-secure-path="/sbin:/bin:/usr/sbin:/usr/bin" \
64  --without-interfaces \
65  --without-selinux
66make %{?_smp_mflags}
67
68%install
69rm -rf $RPM_BUILD_ROOT
70mkdir $RPM_BUILD_ROOT
71make install DESTDIR="$RPM_BUILD_ROOT" install_uid=`id -u` install_gid=`id -g` sudoers_uid=`id -u` sudoers_gid=`id -g`
72chmod 755 $RPM_BUILD_ROOT%{_bindir}/* $RPM_BUILD_ROOT%{_sbindir}/*
73install -p -d -m 700 $RPM_BUILD_ROOT/var/run/sudo
74install -p -d -m 700 $RPM_BUILD_ROOT/var/log/sudo-io
75install -p -d -m 750 $RPM_BUILD_ROOT/etc/sudoers.d
76install -p -c -m 0440 %{SOURCE1} $RPM_BUILD_ROOT/etc/sudoers
77
78chmod +x $RPM_BUILD_ROOT%{_libexecdir}/*.so # for stripping, reset in %%files
79
80# Remove execute permission on this script so we don't pull in perl deps
81chmod -x $RPM_BUILD_ROOT%{_docdir}/sudo-*/sudoers2ldif
82
83%find_lang sudo
84%find_lang sudoers
85
86cat sudo.lang sudoers.lang > sudo_all.lang
87rm sudo.lang sudoers.lang
88
89mkdir -p $RPM_BUILD_ROOT/etc/pam.d
90cat > $RPM_BUILD_ROOT/etc/pam.d/sudo << EOF
91#%PAM-1.0
92auth       include      system-auth
93account    include      system-auth
94password   include      system-auth
95session    optional     pam_keyinit.so revoke
96session    required     pam_limits.so
97EOF
98
99cat > $RPM_BUILD_ROOT/etc/pam.d/sudo-i << EOF
100#%PAM-1.0
101auth       include      sudo
102account    include      sudo
103password   include      sudo
104session    optional     pam_keyinit.so force revoke
105session    required     pam_limits.so
106EOF
107
108
109%clean
110rm -rf $RPM_BUILD_ROOT
111
112%files -f sudo_all.lang
113%defattr(-,root,root)
114%doc plugins/sample/sample_plugin.c
115%attr(0440,root,root) %config(noreplace) /etc/sudoers
116%attr(0750,root,root) %dir /etc/sudoers.d/
117%config(noreplace) /etc/pam.d/sudo
118%config(noreplace) /etc/pam.d/sudo-i
119%dir /var/run/sudo
120%attr(0750,root,root) %dir /var/log/sudo-io
121%attr(4111,root,root) %{_bindir}/sudo
122%attr(4111,root,root) %{_bindir}/sudoedit
123%attr(0111,root,root) %{_bindir}/sudoreplay
124%attr(0755,root,root) %{_sbindir}/visudo
125%attr(0644,root,root) %{_libexecdir}/sudo_noexec.so
126%attr(0644,root,root) %{_libexecdir}/sudoers.so*
127%{_mandir}/man5/sudoers*.5*
128%{_mandir}/man8/sudo.8*
129%{_mandir}/man8/sudoedit.8*
130%{_mandir}/man8/sudoreplay.8*
131%{_mandir}/man8/visudo.8*
132%dir %{_docdir}/sudo-%{version}
133%{_docdir}/sudo-%{version}/*
134# should be splitted to -devel?
135%{_includedir}/sudo_plugin.h
136%{_mandir}/man8/sudo_plugin.8*
137
138
139%post
140/bin/chmod 0440 /etc/sudoers || :
141
142%changelog
143* Mon Feb  3 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.8.6p8-1
144- update to 1.8.6p8
145
146* Mon Mar 04 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6p7-3
147- fix permission of sudoreplay
148
149* Mon Mar 04 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6p7-2
150- add /var/log/sudo-io
151- add some comments to default sudoers
152
153* Mon Mar 04 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6p7-1
154- update to 1.8.6p7
155- drop unneeded patches.
156
157* Sat May 19 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-5
158- add patch120 for fix CVE-2012-2337 (netmask match)
159
160* Fri Jun 03 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.2p7-4
161- update sudoers
162  - enable "%wheel ALL=(ALL) ALL" by default.
163
164* Thu Feb 10 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-3
165- add patch110,111 for fix CVE-2011-0010 ("-g" option)
166
167* Wed Sep  8 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-2
168- add Patch100 for fix CVE-2010-2956 (sudo Runas)
169- add _smp_mflags flag into make section
170- fix doc filelist (no longer exist BUGS, CHANGSE)
171
172* Sun Jun 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p7-1
173- new upstream release with security fix (CVE-2010-1646)
174- change specfile name (-vl)
175
176* Sun Apr 25 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p6-1
177- new upstream release with security fix (CVE-2010-1163)
178- add sudoers.ldap.5 into files section
179
180* Wed Feb 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.2p4-1
181- new upstream release with security fix (CVE-2010-0426)
182- update Patch3
183
184* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.2-1
185- new upstream release
186
187* Wed Jun 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.1-1
188- new upstream release
189- update patches
190- disable "Defaults requiretty"
191
192* Fri Feb 13 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.6.9p20-2
193- rebuilt with openldap-2.4.11
194
195* Thu Feb 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.9p20-1
196- new upstream release with security fix (CVE 2009-0034)
197
198* Sat Aug 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.9p17-1
199- new upstream release
200- merge some changes from fedoraproject
201  - include [sudo] in password prompt
202  - compiled with secure path
203  - also use getgrouplist() to determine group membership
204  - add sudoers file
205    - add command aliases, default environment config
206- build with openldap
207
208* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.8p12-1vl5
209- applied new versioning policy, spec in utf-8
210
211* Fri May 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.8p12-0vl2
212- change PAM configuration to use system-auth
213- add --with-ignore-dot, --with-editor and --with-env-editor to
214  configure option.
215
216* Mon Jan 23 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.8p12-0vl1
217- new upstream release (included security fix)
218- add patch1 for fix CVE-2006-0151
219
220* Mon May 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.8p8-0vl1
221- new upstream release
222- use macros
223- build with pam
224
225* Wed Jan 19 2005 IWAI, Masaharu <iwai@alib.jp> 1.6.8p6-0vl1
226- new upstream release
227
228* Sun Oct 10 2004 IWAI, Masaharu <iwai@alib.jp> 1.6.8p1-0vl1
229- SECURITY FIX: new upstream release
230- update rpmnonroot.patch ( Patch0 )
231- add new man page: sudoedit(8)
232
233* Wed Sep  1 2004 IWAI, Masaharu <iwai@alib.jp> 1.6.8-0vl1
234- new upstream release
235- update rpmnonroot.patch ( Patch0 )
236- change Copyrigh tag to License tag
237- update License
238- update URL and Source0: official web site moved.
239- new files: %%{_bindir}/sudoedit and %%{_libexecdir}/sudo_noexec.*
240
241* Mon Apr 14 2003 IWAI Masaharu <iwai@alib.jp> 1.6.7p3-0vl1
242- upstream release
243
244* Wed May 08 2002 Satoshi MACHINO <machino@vinelinux.org> 1.6.6-0vl3
245- fixed changelog
246        -- don't expand macros in changelog ;P
247               
248* Wed May 01 2002 Satoshi MACHINO <machino@vinelinux.org> 1.6.6-0vl2
249- changed to use configure in build section
250        (can't build on sparc)
251
252* Fri Apr 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.6-0vl1
253- upstream release
254- fix security hole : buffer over flow
255
256* Thu Jan 24 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.5p2-0vl1
257- upstream release
258- updated sudo.rpmnonroot.diff
259
260* Fri Jan 18 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.5p1-0vl1
261- upstream release
262- added configure script option '--disable-root-mailer'
263
264* Tue Jan 15 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.4p1-0vl1
265- upstream release
266- eliminated FAQ from %doc
267
268* Mon Jan 14 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.6.4-0vl1
269- upstream release
270- added noreplace flag (%{_sysconfdir}/sudoers file is not replaced)
271- updated sudo.rpmnonroot.diff
272
273* Wed May 09 2001 <sagami@vinelinux.org>
274- 1.6.3p7-0vl2: follow up 1.6.2p6-0.6vl1
275
276* Fri Mar 02 2001 sagami@vinelinux.org
277- 1.6.3p7-0vl1
278- use better macros
279
280* Thu Mar 1 2001 Kunio Murasawa <murasawa@marineroad.com>
281- 1.6.3p6-0vl1
282- changed sudo.rpmnonroot.diff for 1.6.3p6
283
284* Tue Sep 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
285- 1.6.1-2vl5
286- patch -p1 -> patch -p0
287
288* Mon Sep 18 2000 MATSUMOTO Shoji <shom@vinelinux.org>
289- 1.6.1-2vl4
290- fix uid/gid to root.root
291- add sudo.rpmnonroot.diff to built by non-root users
292
293* Tue Sep 12 2000 Jun Nishii <jun@vinelinux.org>
294- 1.6.1-2vl3
295- fix attr
296
297* Sun Sep 10 2000 Jun Nishii <jun@vinelinux.org>
298- 1.6.1-2vl2
299- enable to build by non-root useres
300
301* Fri Sep 08 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
302- 1.6.1-2vl1
303- modified %files section to handle compressed man page(s)
304
305* Fri Jan  7 2000 Jun Nishii <jun@vinelinux.org>
306- change group
307
308* Thu Dec 30 1999 Jun Nishii <jun@vinelinux.org>
309- version 1.6.1
310- build for Vine Linux 2.0
311
312* Fri May 14  1999 Takeda Eiji <keda@flatout.org>
313- sudo reads $BuildRoot%{_sysconfdir}/sudoers. Make change to read /etc/sudoers.
314
315* Wed Apr 21 1999 Hiroto Watanabe <watanabe@cij.co.jp>
316- Initial Release
317
Note: See TracBrowser for help on using the repository browser.