source: projects/specs/trunk/s/subversion/subversion-vl.spec @ 8693

Revision 8693, 17.8 KB checked in by iwaim, 10 years ago (diff)

subversion 1.8.9-3

Line 
1%define neon_version 0.25.5
2%define swig_version 3.0.0
3%define apache_version 2.4
4%define apache_dir /usr
5
6%define swigdirs swig_pydir=%{python_sitearch}/libsvn swig_pydir_extra=%{python_sitearch}/svn
7
8# set to zero to avoid running test suite
9%define make_check 0
10
11Summary: Modern Version Control System
12Summary(ja): モダンなバージョン管理システム
13Name: subversion
14Version: 1.8.9
15Release: 3%{?_dist_release}
16License: ASL 2.0
17Group: Development/Tools
18URL: http://subversion.apache.org/
19
20Vendor: Project Vine
21Distribution: Vine Linux
22Packager: iwaim, daisuke
23
24SOURCE0: subversion-%{version}.tar.bz2
25SOURCE1: subversion.conf
26SOURCE2: httpd.davcheck.conf
27SOURCE3: filter-requires.sh
28Patch3: subversion-1.7.0-rpath.patch
29#Patch4: subversion-1.7.2-ruby19.patch
30
31BuildRequires: apache2-devel >= %{apache_version}
32BuildRequires: apr-devel, apr-util-devel
33BuildRequires: autoconf >= 2.53
34BuildRequires: libdb-devel
35BuildRequires: expat-devel
36BuildRequires: gdbm-devel
37BuildRequires: libtool >= 1.4.2
38BuildRequires: neon-devel >= %{neon_version}
39BuildRequires: openssl-devel
40BuildRequires: python
41BuildRequires: python-devel
42BuildRequires: swig >= %{swig_version}
43BuildRequires: texinfo
44BuildRequires: zlib-devel
45BuildRequires: openldap-devel
46BuildRequires: ruby >= 2.1.2-6
47BuildRequires: ruby-devel >= 2.1.2-6
48BuildRequires: perl >= 5.8.0
49BuildRequires: sqlite3-devel
50BuildRequires: krb5-devel
51BuildRequires: keyutils-libs-devel
52BuildRequires: dbus-devel
53BuildRequires: libgnome-keyring-devel
54BuildRequires: libserf-devel
55BuildRoot: %{_tmppath}/%{name}-%{version}-root
56
57%define __perllib_requires %{SOURCE3}
58
59%description
60Subversion is a concurrent version control system which enables one
61or more users to collaborate in developing and maintaining a
62hierarchy of files and directories while keeping a history of all
63changes.  Subversion only stores the differences between versions,
64instead of every complete file.  Subversion is intended to be a
65compelling replacement for CVS.
66
67%package devel
68Group: Development/Libraries
69Summary: Development package for Subversion developers.
70Requires: subversion = %{version}-%{release}
71Requires: apr-devel, apr-util-devel
72%description devel
73The subversion-devel package includes the static libraries and include files
74for developers interacting with the subversion package.
75
76%package mod_dav_svn
77Group: System Environment/Daemons
78Summary: Apache server module for Subversion server.
79Requires: apache2 >= %{apache_version}
80Requires: subversion = %{version}-%{release}
81%description mod_dav_svn
82The subversion-mod_dav_svn package adds the Subversion server Apache module to
83the Apache directories and configuration.
84
85%package tools
86Group: Development/Tools
87Summary: Tools for Subversion
88BuildRequires: perl >= 5.8.0
89Requires: perl >= 5.8.0
90Requires: subversion = %{version}-%{release}
91
92%description tools
93Tools for Subversion.
94
95%package perl
96Group: Development/Libraries
97Summary: Perl bindings to the Subversion libraries
98Requires: subversion = %{version}-%{release}
99Requires: perl >= 5.8.0
100Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
101
102%description perl
103This package includes the Perl bindings to the Subversion libraries.
104
105%package ruby
106Group: Development/Libraries
107Summary: Ruby bindings to the Subversion libraries
108Requires: subversion = %{version}-%{release}
109Requires: ruby >= 2.0
110
111%description ruby
112This package includes the Ruby bindings to the Subversion libraries.
113
114%package python
115Group: Development/Libraries
116Summary: Python bindings to the Subversion libraries
117Requires: subversion = %{version}-%{release}, python
118
119%description python
120This package includes the Python bindings to the Subversion libraries.
121
122%prep
123%setup -q
124%patch3 -p1 -b .rpath
125
126%build
127PATH=/usr/bin:$PATH ./autogen.sh --release
128
129# fix shebang lines, #111498
130perl -pi -e 's|/usr/bin/env perl -w|/usr/bin/perl -w|' tools/hook-scripts/*.pl.in
131
132# override weird -shrext from ruby
133export svn_cv_ruby_link="%{__cc} -shared"
134export svn_cv_ruby_sitedir_libsuffix=""
135export svn_cv_ruby_sitedir_archsuffix=""
136
137export CC=gcc CXX=g++ JAVA_HOME=%{jdk_path} CFLAGS="$RPM_OPT_FLAGS"
138export LIBTOOL=/usr/bin/libtool
139%configure --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
140        --with-swig --with-serf=%{_prefix} \
141        --with-ruby-sitedir=%{rarchdir} \
142        --with-apxs=%{_bindir}/apxs \
143        --disable-mod-activation \
144        --with-apache-libexecdir=%{_libdir}/apache2/modules/ \
145        --with-gnome-keyring \
146        --with-berkeley-db \
147        --disable-mod-activation \
148        --disable-static
149
150make %{?_smp_mflags} all tools
151make swig-py swig-py-lib %{swigdirs}
152make swig-pl swig-pl-lib swig-rb swig-rb-lib
153
154
155%install
156echo %{rarchdir}
157rm -rf $RPM_BUILD_ROOT
158make install \
159        install-swig-py \
160        install-swig-pl-lib \
161        install-swig-rb \
162        DESTDIR=$RPM_BUILD_ROOT %{swigdirs}
163
164make pure_vendor_install -C subversion/bindings/swig/perl/native \
165        PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
166install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/subversion
167
168install -m 755 -d $RPM_BUILD_ROOT%{_libdir}/apache2/modules
169
170# Add subversion.conf configuration file into apache2/conf.d directory.
171install -m 755 -d $RPM_BUILD_ROOT/etc/apache2/conf.d
172install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/apache2/conf.d
173
174# Remove unpackaged files
175rm -rf $RPM_BUILD_ROOT%{_includedir}/subversion-*/*.txt \
176       $RPM_BUILD_ROOT%{python_sitearch}/*/*.{a,la} \
177       $RPM_BUILD_ROOT%{_libdir}/*.la
178
179# The SVN build system is broken w.r.t. DSO support; it treats
180# normal libraries as DSOs and puts them in $libdir, whereas they
181# should go in some subdir somewhere, and be linked using -module,
182# etc.  So, forcibly nuke the .so's for libsvn_auth_{gnome,kde},
183# since nothing should ever link against them directly.
184rm -f ${RPM_BUILD_ROOT}%{_libdir}/libsvn_auth_*.so
185
186# remove stuff produced with Perl modules
187find $RPM_BUILD_ROOT -type f \
188     -a \( -name .packlist -o \( -name '*.bs' -a -empty \) \) \
189     -print0 | xargs -0 rm -f
190
191# make Perl modules writable so they get stripped
192find $RPM_BUILD_ROOT%{_libdir}/perl5 -type f -perm 555 -print0 |
193     xargs -0 chmod 755
194
195# unnecessary libraries for swig bindings
196rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig_*.{so,la,a}
197
198# Remove unnecessary ruby libraries
199rm -f $RPM_BUILD_ROOT%{rarchdir}/svn/ext/*.*a
200
201# Trim what goes in docdir
202rm -rf tools/*/*.in tools/test-scripts
203
204# Rename authz_svn INSTALL doc for docdir
205ln -f subversion/mod_authz_svn/INSTALL mod_authz_svn-INSTALL
206
207# Install bash completion
208install -Dpm 644 tools/client-side/bash_completion \
209        $RPM_BUILD_ROOT%{_datadir}/bash-completion/completions/svn
210for comp in svnadmin svndumpfilter svnlook svnsync svnversion; do
211    ln -s svn \
212       $RPM_BUILD_ROOT%{_datadir}/bash-completion/completions/${comp}
213done
214
215# Install tools ex diff*
216make install-tools DESTDIR=$RPM_BUILD_ROOT toolsdir=%{_bindir}
217rm -f $RPM_BUILD_ROOT%{_bindir}/diff*
218
219for f in svn-populate-node-origins-index svn-rep-sharing-stats \
220         svnauthz-validate svnmucc svnraisetreeconflict; do
221    echo %{_bindir}/$f
222done | tee tools.files | sed 's/^/%%exclude /' > exclude.tools.files
223
224%find_lang %{name}
225
226cat %{name}.lang exclude.tools.files >> %{name}.files
227
228%clean
229rm -rf $RPM_BUILD_ROOT
230
231%post -p /sbin/ldconfig
232
233%postun -p /sbin/ldconfig
234
235%post perl -p /sbin/ldconfig
236
237%postun perl -p /sbin/ldconfig
238
239%post ruby -p /sbin/ldconfig
240
241%postun ruby -p /sbin/ldconfig
242
243%post python -p /sbin/ldconfig
244
245%postun python -p /sbin/ldconfig
246
247%post tools -p /sbin/ldconfig
248
249%postun tools -p /sbin/ldconfig
250
251
252%files
253%defattr(-,root,root)
254%doc BUGS CHANGES COMMITTERS LICENSE NOTICE INSTALL README
255%doc subversion/LICENSE
256%{_bindir}/*
257%{_libdir}/libsvn_*.so.*
258%{_localedir}/*/*/subversion.mo
259%{_mandir}/man*/*
260%{_datadir}/bash-completion/completions/*
261%dir %{_sysconfdir}/subversion
262%exclude %{_mandir}/man*/*::*
263%exclude %{_libdir}/libsvn_swig_perl*.so.*
264%exclude %{_libdir}/libsvn_swig_py*.so.*
265%exclude %{_libdir}/libsvn_swig_ruby*.so.*
266
267%files devel
268%defattr(-,root,root)
269%{_includedir}/subversion-1
270%{_libdir}/libsvn*.so
271%exclude %{_libdir}/libsvn_swig_perl*
272%exclude %{_libdir}/libsvn_swig_py*
273%exclude %{_libdir}/libsvn_swig_ruby*
274
275%files mod_dav_svn
276%defattr(-,root,root)
277%config(noreplace) /etc/apache2/conf.d/subversion.conf
278%{apache_dir}/%{_lib}/apache2/modules/mod_*.*
279
280%files tools -f tools.files
281%defattr(-,root,root)
282
283%files perl
284%defattr(-,root,root,-)
285%{perl_vendorarch}/auto/SVN
286%{perl_vendorarch}/SVN
287%{_libdir}/libsvn_swig_perl*
288%{_mandir}/man*/*::*
289
290%files ruby
291%defattr(-,root,root,-)
292%{_libdir}/libsvn_swig_ruby*
293%{rarchdir}/svn
294
295%files python
296%defattr(-,root,root,-)
297%{_libdir}/libsvn_swig_py*
298%{python_sitearch}/libsvn
299%{python_sitearch}/svn
300
301
302%changelog
303* Mon Jun 30 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.9-3
304- build with Perl 5.16
305- using %%__perllib_requires
306
307* Fri Jun 27 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.8.9-2
308- rebuild with ruby-2.1.2-6
309
310* Wed Jun 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.8.9-1
311- update to 1.8.9
312- remove unneeded explisit dependency
313- add BR: apache2-devel >= 2.4
314- add BR: libdb-devel instead of db4-devel
315- add R: apache2 > 2.4 to mod_dav_svn
316
317* Fri Apr 18 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.8-1
318- update to 1.8.8
319- add BR: libserf-devel to handle http* scheme
320
321* Thu Oct 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.7-1
322- update to 1.7.7
323- rebuild with ruby-1.9.3
324
325* Tue Sep 18 2012 IWAI, Masaharu <iwai@alib.jp> 1.7.6-1
326- new upstream release
327- update License
328- update rpath patch (Patch3) from Fedora 1.7.6-1.fc19
329- drop deplibs patch (Patch1)
330- drop obsolete patch files: Patch6, 10
331
332* Fri Jun  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
333- new upstream release with security fix (CVE-2011-1752, 1783, 1921)
334- add configure option with-gnome-keyring
335- add BR: keyutils-libs-devel, dbus-devel, libgnome-keyring-devel
336- fix Packager name
337
338* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.16-2
339- build with perl 5.12.3
340- add Requires: perl(:MODULE_COMPAT_...)
341
342* Sat Mar  5 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.16-1
343- new upstream release with security fix
344- add Vendor/Distri tags
345
346* Mon Nov 29 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.15-1
347- new upstream release
348
349* Tue Mar  2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-2
350- fix <BTS:VineLinux:941>
351  - using rpm macro: rarchdir
352  - export svn_cv_ruby_sitedir_libsuffix and svn_cv_ruby_sitedir_archsuffix
353- using rpm macros: perl_vendorarch and python_sitearch
354- add BuildRequires: sqlite3-devel krb5-devel
355
356* Thu Feb 18 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
357- new upstream release
358- update URL
359- update deplibs patch (Patch1) from Fedora 1.6.9-2.fc13
360- update rpath patch (Patch3) from Fedora 1.6.9-2.fc13
361- stop applying pia patch (Patch6): sync Fedora 1.6.9-2.fc13
362- stop applying update-neon-m4 patch (Patch10): sync Fedora 1.6.9-2.fc13
363
364* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.7-1
365- new upstream release
366
367* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.2-1
368- new upstream release
369
370* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.6-2vl5
371- rebuilt with python-2.5.2
372
373* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.6-1vl5
374- new upstream release
375- rebuild with neon-0.28.2
376- dropped old-Patch10 by adding --disable-neon-version-check to %%configure
377- added Patch6, 8, 9, 10 from Fedora Core
378  * Thu Feb 21 2008 Lubomir Kundrak <lkundrak@redhat.com> 1.4.6-5
379  - Correct install location of java stuff (#433295)
380  * Wed Aug  8 2007 Joe Orton <jorton@redhat.com> 1.4.4-3
381  - fix build with new glibc open()-as-macro
382  - build all swig code in %%build, not %%install
383  * Fri May 21 2004 Joe Orton <jorton@redhat.com> 1.0.3-2
384  - build /usr/bin/* as PIEs
385
386* Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.3-0vl2
387- rebuild with expat-2.0.1
388
389* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.3-0vl1
390- new upstream release
391- add Patch10 to build with neon.
392  1.3.2-0vl5 does not support neon..
393
394* Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl4
395- rebuild with new neon
396
397* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.2-0vl3
398- rebuilt with new toolchain and db4-4.3.x
399
400* Sat Mar 31 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.2-0vl2
401- modified %%files section for lib64 architecture
402
403* Tue Aug 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl1
404- new upstream release
405- rebuild with new openldap-2.3.24
406
407* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.1-0vl1
408- new upstream release
409- change Group to Develoment/Tools
410- build with apr-1.2.7/apr-util-1.2.7
411  - require apr/apr-util instead of apache2-apr
412- build with swig-1.3.29
413- split {perl,python,ruby} related files to subpackage.
414
415* Tue Oct 18 2005 IWAI, Masaharu <iwai@alib.jp> 1.2.3-0vl1
416- new upstream release
417- add noreplace option for config file
418
419* Sun Jan 30 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl3
420- fix Requires and BuildPreReq.
421
422* Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl2
423- new upstream release.
424- add swig-runtime to 'BuildPreReq:'.
425- fix %%files.
426
427* Sun Oct 17 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.0.6-0vl1.1
428- require neon version 0.24.7 for ra_dav
429- add BuildPreReq: openldap-devel
430- replace BuildPreReq: httpd to BuildPreReq: apache2
431- replace tools Requires: perl(:MODULE_COMPAT_version) to perl >= 5.8.0
432
433* Wed Jul 21 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.6-0vl1
434- new upstream release
435
436* Tue Jun 22 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.5-0vl1
437- new upstream release
438
439* Fri Jun  4 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.4-0vl1
440- new upstream release
441- clean up specfile.
442
443* Tue Nov 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.32.1-0vl1
444- new upstream release
445- build with apache2-2.0.47
446
447* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.20.0-0vl1
448- build Vine Linux
449
450* Sat Mar 01 2003 David Summers <david@summersoft.fay.ar.us> 0.18.1-5173
451- Enabled RA_DAV checking.
452  Now requires httpd package to build because of RA_DAV tests.
453
454* Sat Jan 18 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4433
455- Created tools package to hold the tools.
456
457* Thu Jan 16 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4405
458- Now requires httpd >= 2.0.44-0.1 (APACHE_2_0_BRANCH) which contains the new
459  version of APR/APR-UTILS as of 2003.01.15.
460- Added svnversion command.
461
462* Tue Dec 31 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4218
463- Create a svnadmin.static which is copied to svnadmin-version-release
464  when the package is erased, so users can still dump/load their repositories
465  even after they have upgraded the RPM package.
466
467* Sat Dec 14 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4128
468- SWIG now builds so we can use cvs2svn.
469
470* Fri Oct 04 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3280
471- Made cvs2svn conditional (at least until we can get it to build consistently
472  and work).
473
474* Sat Sep 21 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3205
475- Added SWIG dependencies to add cvs2svn capabilities.
476
477* Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2984
478- Now requires neon-0.22.0.
479
480* Thu Aug 15 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2978
481- Took out loading mod_dav_svn from subversion.spec file and put it in
482  subversion.conf file which goes into the apache conf directory.
483- Simplify what gets put into httpd.conf to only the include for the
484  subversion.conf file.
485  (Thanks to Scott Harrison <sharrison@users.sourceforge.net> for prompting
486  me to do this).
487
488* Thu Aug 08 2002 David Summers <david@summersoft.fay.ar.us> 0.14.0-2919
489- Updated to APR/APR-UTIL 2002-08-08.
490
491* Tue Jun 25 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2332
492- Updated to APACHE/APR/APR-UTIL 2002-06-25.
493- Previous version had a few problems because of missing apache error/ files.
494
495* Sun Jun 23 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2318
496- Updated to apache-2.0.40-0.3.
497- Updated to subversion-0.13.1-2318.
498
499* Tue Jun 18 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2277
500- Updated for RedHat 7.3 (autoconf253).
501- Added a bunch of pre-requisites I didn't know were needed because I built a
502  new machine that didn't have them already installed.
503- Fixed installation of man and info documentation pages.
504
505* Wed Mar 06 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1447
506- Back to apache-libapr* stuff, hopefully to stay.
507
508* Sun Feb 24 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1373
509- Fixed expat.patch to not have to make so many changes by writing a small
510  shell script that changes libexpat to -lexpat.
511
512* Fri Feb 22 2002 Blair Zajac <blair@orcaware.com> 0.9.0-1364
513- Updated to neon-0.19.2.
514
515* Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1250
516- Back to using apr and apr-util separately from apache.
517
518* Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1232
519- Updated to APR and APR-UTIL 2002.02.11.
520- Updated to apache-2.0.32-0.2. (Requires apache-libapr and apache-libapr-util).
521- Took out a (now non-existant) documentation file.
522- Moved SPEC file changelog to after all package definitions.
523 
524* Sun Feb 03 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1153
525- Updated to neon-0.18.5.
526- Broke up apache and apache-devel into apache-apr, apache-apr-devel,
527  apache-apr-utils, and apache-apr-utils-devel.
528- Updated apache to APR and APR-UTILS to 2002.02.03 version.
529
530* Sat Feb 02 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1147
531- Now builds without the separate APR package as it is built into and
532  "exported" from apache-2.0.31-0.3.
533
534* Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1132
535- Took out patches to install procedure now not required because of fixes
536  in rev 1130.
537
538* Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1129
539- Added requirement for APR 0.2002.01.19 rev 2 where the /usr/bin/apr-config
540  program was added.
541
542* Sun Oct 28 2001 David Summers <david@summersoft.fay.ar.us>
543- Release M5-r340: Added the subversion-server package.
544
545* Fri Oct 26 2001 David Summers <david@summersoft.fay.ar.us>
546- Release M5-r327: No longer need expat-lite. We can use the normal expat.
547
548* Thu Sep 27 2001 David Summers <david@summersoft.fay.ar.us>
549- Release M3-r117: Initial Version.
550
Note: See TracBrowser for help on using the repository browser.