source: projects/specs/trunk/s/subversion/subversion-vl.spec @ 8366

Revision 8366, 17.4 KB checked in by daisuke, 10 years ago (diff)

subversion: update to 1.8.8

Line 
1%define neon_version 0.25.5
2%define swig_version 1.3.29
3%define apache_dir /usr
4
5%define db_version 4.3.29
6
7%define swigdirs swig_pydir=%{python_sitearch}/libsvn swig_pydir_extra=%{python_sitearch}/svn
8
9# set to zero to avoid running test suite
10%define make_check 0
11
12Summary: Modern Version Control System
13Summary(ja): モダンなバージョン管理システム
14Name: subversion
15Version: 1.8.8
16Release: 1%{?_dist_release}
17License: ASL 2.0
18Group: Development/Tools
19URL: http://subversion.apache.org/
20
21Packager: iwaim
22Vendor: Project Vine
23Distribution: Vine Linux
24
25SOURCE0: subversion-%{version}.tar.bz2
26SOURCE1: subversion.conf
27SOURCE2: httpd.davcheck.conf
28SOURCE3: filter-requires.sh
29Patch3: subversion-1.7.0-rpath.patch
30#Patch4: subversion-1.7.2-ruby19.patch
31
32Requires: db4 >= %{db_version}
33Requires: expat
34Requires: neon >= %{neon_version}
35BuildRequires: apache2-devel
36BuildRequires: apr-devel, apr-util-devel
37BuildRequires: autoconf >= 2.53
38BuildRequires: db4-devel >= %{db_version}
39BuildRequires: expat-devel
40BuildRequires: gdbm-devel
41BuildRequires: libtool >= 1.4.2
42BuildRequires: neon-devel >= %{neon_version}
43BuildRequires: openssl-devel
44BuildRequires: python
45BuildRequires: python-devel
46BuildRequires: swig >= %{swig_version}
47BuildRequires: texinfo
48BuildRequires: zlib-devel
49BuildRequires: openldap-devel
50BuildRequires: ruby >= 1.8.2
51BuildRequires: ruby-devel >= 1.8.2
52BuildRequires: perl >= 5.8.0
53BuildRequires: sqlite3-devel
54BuildRequires: krb5-devel
55BuildRequires: keyutils-libs-devel
56BuildRequires: dbus-devel
57BuildRequires: libgnome-keyring-devel
58BuildRequires: libserf-devel
59BuildRoot: %{_tmppath}/%{name}-%{version}-root
60
61%define __perl_requires %{SOURCE3}
62
63%description
64Subversion is a concurrent version control system which enables one
65or more users to collaborate in developing and maintaining a
66hierarchy of files and directories while keeping a history of all
67changes.  Subversion only stores the differences between versions,
68instead of every complete file.  Subversion is intended to be a
69compelling replacement for CVS.
70
71%package devel
72Group: Development/Libraries
73Summary: Development package for Subversion developers.
74Requires: subversion = %{version}-%{release}
75Requires: apr-devel, apr-util-devel
76%description devel
77The subversion-devel package includes the static libraries and include files
78for developers interacting with the subversion package.
79
80%package mod_dav_svn
81Group: System Environment/Daemons
82Summary: Apache server module for Subversion server.
83Requires: httpd >= %{apache_version}
84Requires: subversion = %{version}-%{release}
85%description mod_dav_svn
86The subversion-mod_dav_svn package adds the Subversion server Apache module to
87the Apache directories and configuration.
88
89%package tools
90Group: Development/Tools
91Summary: Tools for Subversion
92BuildRequires: perl >= 5.8.0
93Requires: perl >= 5.8.0
94Requires: subversion = %{version}-%{release}
95
96%description tools
97Tools for Subversion.
98
99%package perl
100Group: Development/Libraries
101Summary: Perl bindings to the Subversion libraries
102Requires: subversion = %{version}-%{release}
103Requires: perl >= 5.8.0
104Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
105
106%description perl
107This package includes the Perl bindings to the Subversion libraries.
108
109%package ruby
110Group: Development/Libraries
111Summary: Ruby bindings to the Subversion libraries
112Requires: subversion = %{version}-%{release}
113Requires: ruby >= 1.9.3
114
115%description ruby
116This package includes the Ruby bindings to the Subversion libraries.
117
118%package python
119Group: Development/Libraries
120Summary: Python bindings to the Subversion libraries
121Requires: subversion = %{version}-%{release}, python
122
123%description python
124This package includes the Python bindings to the Subversion libraries.
125
126%prep
127%setup -q
128%patch3 -p1 -b .rpath
129
130%build
131PATH=/usr/bin:$PATH ./autogen.sh --release
132
133# fix shebang lines, #111498
134perl -pi -e 's|/usr/bin/env perl -w|/usr/bin/perl -w|' tools/hook-scripts/*.pl.in
135
136# override weird -shrext from ruby
137export svn_cv_ruby_link="%{__cc} -shared"
138export svn_cv_ruby_sitedir_libsuffix=""
139export svn_cv_ruby_sitedir_archsuffix=""
140
141export CC=gcc CXX=g++ JAVA_HOME=%{jdk_path} CFLAGS="$RPM_OPT_FLAGS"
142export LIBTOOL=/usr/bin/libtool
143%configure --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
144        --with-swig --with-serf=%{_prefix} \
145        --with-ruby-sitedir=%{rarchdir} \
146        --with-apxs=%{_bindir}/apxs \
147        --disable-mod-activation \
148        --with-apache-libexecdir=%{_libdir}/apache2/modules/ \
149        --with-gnome-keyring \
150        --with-berkeley-db \
151        --disable-mod-activation \
152        --disable-static
153
154make %{?_smp_mflags} all tools
155make swig-py swig-py-lib %{swigdirs}
156make swig-pl swig-pl-lib swig-rb swig-rb-lib
157
158
159%install
160echo %{rarchdir}
161rm -rf $RPM_BUILD_ROOT
162make install \
163        install-swig-py \
164        install-swig-pl-lib \
165        install-swig-rb \
166        DESTDIR=$RPM_BUILD_ROOT %{swigdirs}
167
168make pure_vendor_install -C subversion/bindings/swig/perl/native \
169        PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
170install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/subversion
171
172install -m 755 -d $RPM_BUILD_ROOT%{_libdir}/apache2/modules
173
174# Add subversion.conf configuration file into httpd/conf.d directory.
175install -m 755 -d $RPM_BUILD_ROOT/etc/apache2/conf.d
176install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/apache2/conf.d
177
178# Remove unpackaged files
179rm -rf $RPM_BUILD_ROOT%{_includedir}/subversion-*/*.txt \
180       $RPM_BUILD_ROOT%{python_sitearch}/*/*.{a,la} \
181       $RPM_BUILD_ROOT%{_libdir}/*.la
182
183# The SVN build system is broken w.r.t. DSO support; it treats
184# normal libraries as DSOs and puts them in $libdir, whereas they
185# should go in some subdir somewhere, and be linked using -module,
186# etc.  So, forcibly nuke the .so's for libsvn_auth_{gnome,kde},
187# since nothing should ever link against them directly.
188rm -f ${RPM_BUILD_ROOT}%{_libdir}/libsvn_auth_*.so
189
190# remove stuff produced with Perl modules
191find $RPM_BUILD_ROOT -type f \
192     -a \( -name .packlist -o \( -name '*.bs' -a -empty \) \) \
193     -print0 | xargs -0 rm -f
194
195# make Perl modules writable so they get stripped
196find $RPM_BUILD_ROOT%{_libdir}/perl5 -type f -perm 555 -print0 |
197     xargs -0 chmod 755
198
199# unnecessary libraries for swig bindings
200rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig_*.{so,la,a}
201
202# Remove unnecessary ruby libraries
203rm -f $RPM_BUILD_ROOT%{rarchdir}/svn/ext/*.*a
204
205# Trim what goes in docdir
206rm -rf tools/*/*.in tools/test-scripts
207
208# Rename authz_svn INSTALL doc for docdir
209ln -f subversion/mod_authz_svn/INSTALL mod_authz_svn-INSTALL
210
211# Install bash completion
212install -Dpm 644 tools/client-side/bash_completion \
213        $RPM_BUILD_ROOT%{_datadir}/bash-completion/completions/svn
214for comp in svnadmin svndumpfilter svnlook svnsync svnversion; do
215    ln -s svn \
216       $RPM_BUILD_ROOT%{_datadir}/bash-completion/completions/${comp}
217done
218
219# Install tools ex diff*
220make install-tools DESTDIR=$RPM_BUILD_ROOT toolsdir=%{_bindir}
221rm -f $RPM_BUILD_ROOT%{_bindir}/diff*
222
223for f in svn-populate-node-origins-index svn-rep-sharing-stats \
224         svnauthz-validate svnmucc svnraisetreeconflict; do
225    echo %{_bindir}/$f
226done | tee tools.files | sed 's/^/%%exclude /' > exclude.tools.files
227
228%find_lang %{name}
229
230cat %{name}.lang exclude.tools.files >> %{name}.files
231
232%clean
233rm -rf $RPM_BUILD_ROOT
234
235%post -p /sbin/ldconfig
236
237%postun -p /sbin/ldconfig
238
239%post perl -p /sbin/ldconfig
240
241%postun perl -p /sbin/ldconfig
242
243%post ruby -p /sbin/ldconfig
244
245%postun ruby -p /sbin/ldconfig
246
247%post python -p /sbin/ldconfig
248
249%postun python -p /sbin/ldconfig
250
251%post tools -p /sbin/ldconfig
252
253%postun tools -p /sbin/ldconfig
254
255
256%files
257%defattr(-,root,root)
258%doc BUGS CHANGES COMMITTERS LICENSE NOTICE INSTALL README
259%doc subversion/LICENSE
260%{_bindir}/*
261%{_libdir}/libsvn_*.so.*
262%{_localedir}/*/*/subversion.mo
263%{_mandir}/man*/*
264%{_datadir}/bash-completion/completions/*
265%dir %{_sysconfdir}/subversion
266%exclude %{_mandir}/man*/*::*
267%exclude %{_libdir}/libsvn_swig_perl*.so.*
268%exclude %{_libdir}/libsvn_swig_py*.so.*
269%exclude %{_libdir}/libsvn_swig_ruby*.so.*
270
271%files devel
272%defattr(-,root,root)
273%{_includedir}/subversion-1
274%{_libdir}/libsvn*.so
275%exclude %{_libdir}/libsvn_swig_perl*
276%exclude %{_libdir}/libsvn_swig_py*
277%exclude %{_libdir}/libsvn_swig_ruby*
278
279%files mod_dav_svn
280%defattr(-,root,root)
281%config(noreplace) /etc/apache2/conf.d/subversion.conf
282%{apache_dir}/%{_lib}/apache2/modules/mod_*.*
283
284%files tools -f tools.files
285%defattr(-,root,root)
286
287%files perl
288%defattr(-,root,root,-)
289%{perl_vendorarch}/auto/SVN
290%{perl_vendorarch}/SVN
291%{_libdir}/libsvn_swig_perl*
292%{_mandir}/man*/*::*
293
294%files ruby
295%defattr(-,root,root,-)
296%{_libdir}/libsvn_swig_ruby*
297%{rarchdir}/svn
298
299%files python
300%defattr(-,root,root,-)
301%{_libdir}/libsvn_swig_py*
302%{python_sitearch}/libsvn
303%{python_sitearch}/svn
304
305
306%changelog
307* Fri Apr 18 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.8-1
308- update to 1.8.8
309- add BR: libserf-devel to handle http* scheme
310
311* Thu Oct 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.7-1
312- update to 1.7.7
313- rebuild with ruby-1.9.3
314
315* Tue Sep 18 2012 IWAI, Masaharu <iwai@alib.jp> 1.7.6-1
316- new upstream release
317- update License
318- update rpath patch (Patch3) from Fedora 1.7.6-1.fc19
319- drop deplibs patch (Patch1)
320- drop obsolete patch files: Patch6, 10
321
322* Fri Jun  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
323- new upstream release with security fix (CVE-2011-1752, 1783, 1921)
324- add configure option with-gnome-keyring
325- add BR: keyutils-libs-devel, dbus-devel, libgnome-keyring-devel
326- fix Packager name
327
328* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.16-2
329- build with perl 5.12.3
330- add Requires: perl(:MODULE_COMPAT_...)
331
332* Sat Mar  5 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.16-1
333- new upstream release with security fix
334- add Vendor/Distri tags
335
336* Mon Nov 29 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.15-1
337- new upstream release
338
339* Tue Mar  2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-2
340- fix <BTS:VineLinux:941>
341  - using rpm macro: rarchdir
342  - export svn_cv_ruby_sitedir_libsuffix and svn_cv_ruby_sitedir_archsuffix
343- using rpm macros: perl_vendorarch and python_sitearch
344- add BuildRequires: sqlite3-devel krb5-devel
345
346* Thu Feb 18 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
347- new upstream release
348- update URL
349- update deplibs patch (Patch1) from Fedora 1.6.9-2.fc13
350- update rpath patch (Patch3) from Fedora 1.6.9-2.fc13
351- stop applying pia patch (Patch6): sync Fedora 1.6.9-2.fc13
352- stop applying update-neon-m4 patch (Patch10): sync Fedora 1.6.9-2.fc13
353
354* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.7-1
355- new upstream release
356
357* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.2-1
358- new upstream release
359
360* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.6-2vl5
361- rebuilt with python-2.5.2
362
363* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.6-1vl5
364- new upstream release
365- rebuild with neon-0.28.2
366- dropped old-Patch10 by adding --disable-neon-version-check to %%configure
367- added Patch6, 8, 9, 10 from Fedora Core
368  * Thu Feb 21 2008 Lubomir Kundrak <lkundrak@redhat.com> 1.4.6-5
369  - Correct install location of java stuff (#433295)
370  * Wed Aug  8 2007 Joe Orton <jorton@redhat.com> 1.4.4-3
371  - fix build with new glibc open()-as-macro
372  - build all swig code in %%build, not %%install
373  * Fri May 21 2004 Joe Orton <jorton@redhat.com> 1.0.3-2
374  - build /usr/bin/* as PIEs
375
376* Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.3-0vl2
377- rebuild with expat-2.0.1
378
379* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.3-0vl1
380- new upstream release
381- add Patch10 to build with neon.
382  1.3.2-0vl5 does not support neon..
383
384* Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl4
385- rebuild with new neon
386
387* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.2-0vl3
388- rebuilt with new toolchain and db4-4.3.x
389
390* Sat Mar 31 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.2-0vl2
391- modified %%files section for lib64 architecture
392
393* Tue Aug 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl1
394- new upstream release
395- rebuild with new openldap-2.3.24
396
397* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.1-0vl1
398- new upstream release
399- change Group to Develoment/Tools
400- build with apr-1.2.7/apr-util-1.2.7
401  - require apr/apr-util instead of apache2-apr
402- build with swig-1.3.29
403- split {perl,python,ruby} related files to subpackage.
404
405* Tue Oct 18 2005 IWAI, Masaharu <iwai@alib.jp> 1.2.3-0vl1
406- new upstream release
407- add noreplace option for config file
408
409* Sun Jan 30 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl3
410- fix Requires and BuildPreReq.
411
412* Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl2
413- new upstream release.
414- add swig-runtime to 'BuildPreReq:'.
415- fix %%files.
416
417* Sun Oct 17 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.0.6-0vl1.1
418- require neon version 0.24.7 for ra_dav
419- add BuildPreReq: openldap-devel
420- replace BuildPreReq: httpd to BuildPreReq: apache2
421- replace tools Requires: perl(:MODULE_COMPAT_version) to perl >= 5.8.0
422
423* Wed Jul 21 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.6-0vl1
424- new upstream release
425
426* Tue Jun 22 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.5-0vl1
427- new upstream release
428
429* Fri Jun  4 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.4-0vl1
430- new upstream release
431- clean up specfile.
432
433* Tue Nov 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.32.1-0vl1
434- new upstream release
435- build with apache2-2.0.47
436
437* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.20.0-0vl1
438- build Vine Linux
439
440* Sat Mar 01 2003 David Summers <david@summersoft.fay.ar.us> 0.18.1-5173
441- Enabled RA_DAV checking.
442  Now requires httpd package to build because of RA_DAV tests.
443
444* Sat Jan 18 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4433
445- Created tools package to hold the tools.
446
447* Thu Jan 16 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4405
448- Now requires httpd >= 2.0.44-0.1 (APACHE_2_0_BRANCH) which contains the new
449  version of APR/APR-UTILS as of 2003.01.15.
450- Added svnversion command.
451
452* Tue Dec 31 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4218
453- Create a svnadmin.static which is copied to svnadmin-version-release
454  when the package is erased, so users can still dump/load their repositories
455  even after they have upgraded the RPM package.
456
457* Sat Dec 14 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4128
458- SWIG now builds so we can use cvs2svn.
459
460* Fri Oct 04 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3280
461- Made cvs2svn conditional (at least until we can get it to build consistently
462  and work).
463
464* Sat Sep 21 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3205
465- Added SWIG dependencies to add cvs2svn capabilities.
466
467* Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2984
468- Now requires neon-0.22.0.
469
470* Thu Aug 15 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2978
471- Took out loading mod_dav_svn from subversion.spec file and put it in
472  subversion.conf file which goes into the apache conf directory.
473- Simplify what gets put into httpd.conf to only the include for the
474  subversion.conf file.
475  (Thanks to Scott Harrison <sharrison@users.sourceforge.net> for prompting
476  me to do this).
477
478* Thu Aug 08 2002 David Summers <david@summersoft.fay.ar.us> 0.14.0-2919
479- Updated to APR/APR-UTIL 2002-08-08.
480
481* Tue Jun 25 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2332
482- Updated to APACHE/APR/APR-UTIL 2002-06-25.
483- Previous version had a few problems because of missing apache error/ files.
484
485* Sun Jun 23 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2318
486- Updated to apache-2.0.40-0.3.
487- Updated to subversion-0.13.1-2318.
488
489* Tue Jun 18 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2277
490- Updated for RedHat 7.3 (autoconf253).
491- Added a bunch of pre-requisites I didn't know were needed because I built a
492  new machine that didn't have them already installed.
493- Fixed installation of man and info documentation pages.
494
495* Wed Mar 06 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1447
496- Back to apache-libapr* stuff, hopefully to stay.
497
498* Sun Feb 24 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1373
499- Fixed expat.patch to not have to make so many changes by writing a small
500  shell script that changes libexpat to -lexpat.
501
502* Fri Feb 22 2002 Blair Zajac <blair@orcaware.com> 0.9.0-1364
503- Updated to neon-0.19.2.
504
505* Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1250
506- Back to using apr and apr-util separately from apache.
507
508* Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1232
509- Updated to APR and APR-UTIL 2002.02.11.
510- Updated to apache-2.0.32-0.2. (Requires apache-libapr and apache-libapr-util).
511- Took out a (now non-existant) documentation file.
512- Moved SPEC file changelog to after all package definitions.
513 
514* Sun Feb 03 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1153
515- Updated to neon-0.18.5.
516- Broke up apache and apache-devel into apache-apr, apache-apr-devel,
517  apache-apr-utils, and apache-apr-utils-devel.
518- Updated apache to APR and APR-UTILS to 2002.02.03 version.
519
520* Sat Feb 02 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1147
521- Now builds without the separate APR package as it is built into and
522  "exported" from apache-2.0.31-0.3.
523
524* Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1132
525- Took out patches to install procedure now not required because of fixes
526  in rev 1130.
527
528* Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1129
529- Added requirement for APR 0.2002.01.19 rev 2 where the /usr/bin/apr-config
530  program was added.
531
532* Sun Oct 28 2001 David Summers <david@summersoft.fay.ar.us>
533- Release M5-r340: Added the subversion-server package.
534
535* Fri Oct 26 2001 David Summers <david@summersoft.fay.ar.us>
536- Release M5-r327: No longer need expat-lite. We can use the normal expat.
537
538* Thu Sep 27 2001 David Summers <david@summersoft.fay.ar.us>
539- Release M3-r117: Initial Version.
540
Note: See TracBrowser for help on using the repository browser.