source: projects/specs/trunk/s/subversion/subversion-vl.spec @ 7012

Revision 7012, 16.1 KB checked in by daisuke, 12 years ago (diff)

subversion:

  • update to 1.7.7
  • add patch to build with ruby-1.9.3
Line 
1%define neon_version 0.25.5
2%define swig_version 1.3.29
3%define apache_dir /usr
4
5%define db_version 4.3.29
6
7%define swigdirs swig_pydir=%{python_sitearch}/libsvn swig_pydir_extra=%{python_sitearch}/svn
8
9# set to zero to avoid running test suite
10%define make_check 0
11
12Summary: Modern Version Control System
13Summary(ja): モダンなバージョン管理システム
14Name: subversion
15Version: 1.7.7
16Release: 1%{?_dist_release}
17License: ASL 2.0
18Group: Development/Tools
19URL: http://subversion.apache.org/
20
21Packager: iwaim
22Vendor: Project Vine
23Distribution: Vine Linux
24
25SOURCE0: subversion-%{version}.tar.bz2
26SOURCE1: subversion.conf
27SOURCE2: httpd.davcheck.conf
28SOURCE3: filter-requires.sh
29Patch3: subversion-1.7.0-rpath.patch
30Patch4: subversion-1.7.2-ruby19.patch
31
32Requires: db4 >= %{db_version}
33Requires: expat
34Requires: neon >= %{neon_version}
35BuildRequires: apache2-devel
36BuildRequires: apr-devel, apr-util-devel
37BuildRequires: autoconf >= 2.53
38BuildRequires: db4-devel >= %{db_version}
39BuildRequires: expat-devel
40BuildRequires: gdbm-devel
41BuildRequires: libtool >= 1.4.2
42BuildRequires: neon-devel >= %{neon_version}
43BuildRequires: openssl-devel
44BuildRequires: python
45BuildRequires: python-devel
46BuildRequires: swig >= %{swig_version}
47BuildRequires: texinfo
48BuildRequires: zlib-devel
49BuildRequires: openldap-devel
50BuildRequires: ruby >= 1.8.2
51BuildRequires: ruby-devel >= 1.8.2
52BuildRequires: perl >= 5.8.0
53BuildRequires: sqlite3-devel
54BuildRequires: krb5-devel
55BuildRequires: keyutils-libs-devel
56BuildRequires: dbus-devel
57BuildRequires: libgnome-keyring-devel
58BuildRoot: %{_tmppath}/%{name}-%{version}-root
59
60%define __perl_requires %{SOURCE3}
61
62%description
63Subversion is a concurrent version control system which enables one
64or more users to collaborate in developing and maintaining a
65hierarchy of files and directories while keeping a history of all
66changes.  Subversion only stores the differences between versions,
67instead of every complete file.  Subversion is intended to be a
68compelling replacement for CVS.
69
70%package devel
71Group: Development/Libraries
72Summary: Development package for Subversion developers.
73Requires: subversion = %{version}-%{release}
74Requires: apr-devel, apr-util-devel
75%description devel
76The subversion-devel package includes the static libraries and include files
77for developers interacting with the subversion package.
78
79%package mod_dav_svn
80Group: System Environment/Daemons
81Summary: Apache server module for Subversion server.
82Requires: httpd >= %{apache_version}
83Requires: subversion = %{version}-%{release}
84%description mod_dav_svn
85The subversion-mod_dav_svn package adds the Subversion server Apache module to
86the Apache directories and configuration.
87
88%package tools
89Group: Development/Tools
90Summary: Tools for Subversion
91BuildRequires: perl >= 5.8.0
92Requires: perl >= 5.8.0
93Requires: subversion = %{version}-%{release}
94
95%description tools
96Tools for Subversion.
97
98%package perl
99Group: Development/Libraries
100Summary: Perl bindings to the Subversion libraries
101Requires: subversion = %{version}-%{release}
102Requires: perl >= 5.8.0
103Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
104
105%description perl
106This package includes the Perl bindings to the Subversion libraries.
107
108%package ruby
109Group: Development/Libraries
110Summary: Ruby bindings to the Subversion libraries
111Requires: subversion = %{version}-%{release}
112Requires: ruby >= 1.9.3
113
114%description ruby
115This package includes the Ruby bindings to the Subversion libraries.
116
117%package python
118Group: Development/Libraries
119Summary: Python bindings to the Subversion libraries
120Requires: subversion = %{version}-%{release}, python
121
122%description python
123This package includes the Python bindings to the Subversion libraries.
124
125%prep
126%setup -q
127%patch3 -p1 -b .rpath
128%patch4 -p1 -b .ruby19
129
130rm -rf neon apr apr-util db4
131
132%build
133./autogen.sh
134
135# fix shebang lines, #111498
136perl -pi -e 's|/usr/bin/env perl -w|/usr/bin/perl -w|' tools/hook-scripts/*.pl.in
137
138# override weird -shrext from ruby
139export svn_cv_ruby_link="%{__cc} -shared"
140export svn_cv_ruby_sitedir_libsuffix=""
141export svn_cv_ruby_sitedir_archsuffix=""
142
143export CC=gcc CXX=g++ JAVA_HOME=%{jdk_path} CFLAGS="$RPM_OPT_FLAGS"
144%configure --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
145        --with-swig --with-neon=%{_prefix} \
146        --with-ruby-sitedir=%{rarchdir} \
147        --with-apxs=%{_bindir}/apxs \
148        --with-gnome-keyring \
149        --disable-mod-activation \
150        --disable-static \
151        --disable-neon-version-check
152# 1.3.0 tarball ships with generated swig sources
153make extraclean-swig-headers
154make %{?_smp_mflags} all tools
155make swig-py swig-py-lib %{swigdirs}
156make swig-pl swig-pl-lib swig-rb swig-rb-lib
157
158
159%install
160echo %{rarchdir}
161rm -rf $RPM_BUILD_ROOT
162make install \
163        install-swig-py \
164        install-swig-pl-lib \
165        install-swig-rb \
166        DESTDIR=$RPM_BUILD_ROOT %{swigdirs}
167
168make pure_vendor_install -C subversion/bindings/swig/perl/native \
169        PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
170install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/subversion
171
172# Add subversion.conf configuration file into httpd/conf.d directory.
173install -m 755 -d $RPM_BUILD_ROOT/etc/apache2/conf.d
174install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/apache2/conf.d
175
176# Set up tools package files.
177mkdir -p $RPM_BUILD_ROOT/usr/lib/subversion
178cp -r tools $RPM_BUILD_ROOT/usr/lib/subversion
179
180# Remove unpackaged files
181rm -rf $RPM_BUILD_ROOT%{_includedir}/subversion-*/*.txt \
182       $RPM_BUILD_ROOT%{python_sitearch}/*/*.{a,la} \
183       $RPM_BUILD_ROOT%{_libdir}/*.la
184       
185# remove stuff produced with Perl modules
186find $RPM_BUILD_ROOT -type f \
187     -a \( -name .packlist -o \( -name '*.bs' -a -empty \) \) \
188     -print0 | xargs -0 rm -f
189
190# make Perl modules writable so they get stripped
191find $RPM_BUILD_ROOT%{_libdir}/perl5 -type f -perm 555 -print0 |
192     xargs -0 chmod 755
193
194# unnecessary libraries for swig bindings
195rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig_*.{so,la,a}
196
197# Remove unnecessary ruby libraries
198rm -f $RPM_BUILD_ROOT%{rarchdir}/svn/ext/*.*a
199
200# Trim what goes in docdir
201rm -rf tools/*/*.in tools/test-scripts
202                       
203# Rename authz_svn INSTALL doc for docdir
204ln -f subversion/mod_authz_svn/INSTALL mod_authz_svn-INSTALL
205
206%clean
207rm -rf $RPM_BUILD_ROOT
208
209%post -p /sbin/ldconfig
210
211%postun -p /sbin/ldconfig
212
213%post tools -p /sbin/ldconfig
214
215%postun tools -p /sbin/ldconfig
216
217
218%files
219%defattr(-,root,root)
220%doc BUGS CHANGES COMMITTERS COPYING HACKING INSTALL README
221%doc subversion/LICENSE
222%{_bindir}/*
223%{_libdir}/libsvn_*.so.*
224%{_localedir}/*/*/subversion.mo
225%{_mandir}/man*/*
226%dir %{_sysconfdir}/subversion
227%exclude %{_mandir}/man*/*::*
228%exclude %{_libdir}/libsvn_swig_perl*.so.*
229%exclude %{_libdir}/libsvn_swig_py*.so.*
230%exclude %{_libdir}/libsvn_swig_ruby*.so.*
231
232%files devel
233%defattr(-,root,root)
234%{_includedir}/subversion-1
235%{_libdir}/libsvn*.so
236%exclude %{_libdir}/libsvn_swig_perl*.so.*
237%exclude %{_libdir}/libsvn_swig_py*.so.*
238%exclude %{_libdir}/libsvn_swig_ruby*.so.*
239
240%files mod_dav_svn
241%defattr(-,root,root)
242%config(noreplace) /etc/apache2/conf.d/subversion.conf
243%{apache_dir}/%{_lib}/apache2/modules/mod_*.*
244
245%files tools
246%defattr(-,root,root)
247%{_prefix}/lib/subversion/tools
248
249%files perl
250%defattr(-,root,root,-)
251%{perl_vendorarch}/auto/SVN
252%{perl_vendorarch}/SVN
253%{_libdir}/libsvn_swig_perl*
254%{_mandir}/man*/*::*
255
256%files ruby
257%defattr(-,root,root,-)
258%{_libdir}/libsvn_swig_ruby*
259%{rarchdir}/svn
260
261%files python
262%defattr(-,root,root,-)
263%{_libdir}/libsvn_swig_py*
264%{python_sitearch}/libsvn
265%{python_sitearch}/svn
266
267
268%changelog
269* Thu Oct 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.7-1
270- update to 1.7.7
271- rebuild with ruby-1.9.3
272
273* Tue Sep 18 2012 IWAI, Masaharu <iwai@alib.jp> 1.7.6-1
274- new upstream release
275- update License
276- update rpath patch (Patch3) from Fedora 1.7.6-1.fc19
277- drop deplibs patch (Patch1)
278- drop obsolete patch files: Patch6, 10
279
280* Fri Jun  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
281- new upstream release with security fix (CVE-2011-1752, 1783, 1921)
282- add configure option with-gnome-keyring
283- add BR: keyutils-libs-devel, dbus-devel, libgnome-keyring-devel
284- fix Packager name
285
286* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.16-2
287- build with perl 5.12.3
288- add Requires: perl(:MODULE_COMPAT_...)
289
290* Sat Mar  5 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.16-1
291- new upstream release with security fix
292- add Vendor/Distri tags
293
294* Mon Nov 29 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.15-1
295- new upstream release
296
297* Tue Mar  2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-2
298- fix <BTS:VineLinux:941>
299  - using rpm macro: rarchdir
300  - export svn_cv_ruby_sitedir_libsuffix and svn_cv_ruby_sitedir_archsuffix
301- using rpm macros: perl_vendorarch and python_sitearch
302- add BuildRequires: sqlite3-devel krb5-devel
303
304* Thu Feb 18 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
305- new upstream release
306- update URL
307- update deplibs patch (Patch1) from Fedora 1.6.9-2.fc13
308- update rpath patch (Patch3) from Fedora 1.6.9-2.fc13
309- stop applying pia patch (Patch6): sync Fedora 1.6.9-2.fc13
310- stop applying update-neon-m4 patch (Patch10): sync Fedora 1.6.9-2.fc13
311
312* Wed Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.7-1
313- new upstream release
314
315* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.2-1
316- new upstream release
317
318* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.6-2vl5
319- rebuilt with python-2.5.2
320
321* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.6-1vl5
322- new upstream release
323- rebuild with neon-0.28.2
324- dropped old-Patch10 by adding --disable-neon-version-check to %%configure
325- added Patch6, 8, 9, 10 from Fedora Core
326  * Thu Feb 21 2008 Lubomir Kundrak <lkundrak@redhat.com> 1.4.6-5
327  - Correct install location of java stuff (#433295)
328  * Wed Aug  8 2007 Joe Orton <jorton@redhat.com> 1.4.4-3
329  - fix build with new glibc open()-as-macro
330  - build all swig code in %%build, not %%install
331  * Fri May 21 2004 Joe Orton <jorton@redhat.com> 1.0.3-2
332  - build /usr/bin/* as PIEs
333
334* Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.3-0vl2
335- rebuild with expat-2.0.1
336
337* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.3-0vl1
338- new upstream release
339- add Patch10 to build with neon.
340  1.3.2-0vl5 does not support neon..
341
342* Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl4
343- rebuild with new neon
344
345* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.2-0vl3
346- rebuilt with new toolchain and db4-4.3.x
347
348* Sat Mar 31 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.2-0vl2
349- modified %%files section for lib64 architecture
350
351* Tue Aug 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl1
352- new upstream release
353- rebuild with new openldap-2.3.24
354
355* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.1-0vl1
356- new upstream release
357- change Group to Develoment/Tools
358- build with apr-1.2.7/apr-util-1.2.7
359  - require apr/apr-util instead of apache2-apr
360- build with swig-1.3.29
361- split {perl,python,ruby} related files to subpackage.
362
363* Tue Oct 18 2005 IWAI, Masaharu <iwai@alib.jp> 1.2.3-0vl1
364- new upstream release
365- add noreplace option for config file
366
367* Sun Jan 30 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl3
368- fix Requires and BuildPreReq.
369
370* Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl2
371- new upstream release.
372- add swig-runtime to 'BuildPreReq:'.
373- fix %%files.
374
375* Sun Oct 17 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.0.6-0vl1.1
376- require neon version 0.24.7 for ra_dav
377- add BuildPreReq: openldap-devel
378- replace BuildPreReq: httpd to BuildPreReq: apache2
379- replace tools Requires: perl(:MODULE_COMPAT_version) to perl >= 5.8.0
380
381* Wed Jul 21 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.6-0vl1
382- new upstream release
383
384* Tue Jun 22 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.5-0vl1
385- new upstream release
386
387* Fri Jun  4 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.4-0vl1
388- new upstream release
389- clean up specfile.
390
391* Tue Nov 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.32.1-0vl1
392- new upstream release
393- build with apache2-2.0.47
394
395* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.20.0-0vl1
396- build Vine Linux
397
398* Sat Mar 01 2003 David Summers <david@summersoft.fay.ar.us> 0.18.1-5173
399- Enabled RA_DAV checking.
400  Now requires httpd package to build because of RA_DAV tests.
401
402* Sat Jan 18 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4433
403- Created tools package to hold the tools.
404
405* Thu Jan 16 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4405
406- Now requires httpd >= 2.0.44-0.1 (APACHE_2_0_BRANCH) which contains the new
407  version of APR/APR-UTILS as of 2003.01.15.
408- Added svnversion command.
409
410* Tue Dec 31 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4218
411- Create a svnadmin.static which is copied to svnadmin-version-release
412  when the package is erased, so users can still dump/load their repositories
413  even after they have upgraded the RPM package.
414
415* Sat Dec 14 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4128
416- SWIG now builds so we can use cvs2svn.
417
418* Fri Oct 04 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3280
419- Made cvs2svn conditional (at least until we can get it to build consistently
420  and work).
421
422* Sat Sep 21 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3205
423- Added SWIG dependencies to add cvs2svn capabilities.
424
425* Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2984
426- Now requires neon-0.22.0.
427
428* Thu Aug 15 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2978
429- Took out loading mod_dav_svn from subversion.spec file and put it in
430  subversion.conf file which goes into the apache conf directory.
431- Simplify what gets put into httpd.conf to only the include for the
432  subversion.conf file.
433  (Thanks to Scott Harrison <sharrison@users.sourceforge.net> for prompting
434  me to do this).
435
436* Thu Aug 08 2002 David Summers <david@summersoft.fay.ar.us> 0.14.0-2919
437- Updated to APR/APR-UTIL 2002-08-08.
438
439* Tue Jun 25 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2332
440- Updated to APACHE/APR/APR-UTIL 2002-06-25.
441- Previous version had a few problems because of missing apache error/ files.
442
443* Sun Jun 23 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2318
444- Updated to apache-2.0.40-0.3.
445- Updated to subversion-0.13.1-2318.
446
447* Tue Jun 18 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2277
448- Updated for RedHat 7.3 (autoconf253).
449- Added a bunch of pre-requisites I didn't know were needed because I built a
450  new machine that didn't have them already installed.
451- Fixed installation of man and info documentation pages.
452
453* Wed Mar 06 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1447
454- Back to apache-libapr* stuff, hopefully to stay.
455
456* Sun Feb 24 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1373
457- Fixed expat.patch to not have to make so many changes by writing a small
458  shell script that changes libexpat to -lexpat.
459
460* Fri Feb 22 2002 Blair Zajac <blair@orcaware.com> 0.9.0-1364
461- Updated to neon-0.19.2.
462
463* Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1250
464- Back to using apr and apr-util separately from apache.
465
466* Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1232
467- Updated to APR and APR-UTIL 2002.02.11.
468- Updated to apache-2.0.32-0.2. (Requires apache-libapr and apache-libapr-util).
469- Took out a (now non-existant) documentation file.
470- Moved SPEC file changelog to after all package definitions.
471 
472* Sun Feb 03 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1153
473- Updated to neon-0.18.5.
474- Broke up apache and apache-devel into apache-apr, apache-apr-devel,
475  apache-apr-utils, and apache-apr-utils-devel.
476- Updated apache to APR and APR-UTILS to 2002.02.03 version.
477
478* Sat Feb 02 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1147
479- Now builds without the separate APR package as it is built into and
480  "exported" from apache-2.0.31-0.3.
481
482* Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1132
483- Took out patches to install procedure now not required because of fixes
484  in rev 1130.
485
486* Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1129
487- Added requirement for APR 0.2002.01.19 rev 2 where the /usr/bin/apr-config
488  program was added.
489
490* Sun Oct 28 2001 David Summers <david@summersoft.fay.ar.us>
491- Release M5-r340: Added the subversion-server package.
492
493* Fri Oct 26 2001 David Summers <david@summersoft.fay.ar.us>
494- Release M5-r327: No longer need expat-lite. We can use the normal expat.
495
496* Thu Sep 27 2001 David Summers <david@summersoft.fay.ar.us>
497- Release M3-r117: Initial Version.
498
Note: See TracBrowser for help on using the repository browser.