source: projects/specs/trunk/s/subversion/subversion-vl.spec @ 6838

Revision 6838, 15.9 KB checked in by iwaim, 12 years ago (diff)

subversion 1.7.6-1

Line 
1%define neon_version 0.25.5
2%define swig_version 1.3.29
3%define apache_dir /usr
4
5%define db_version 4.3.29
6
7%define swigdirs swig_pydir=%{python_sitearch}/libsvn swig_pydir_extra=%{python_sitearch}/svn
8
9# set to zero to avoid running test suite
10%define make_check 0
11
12Summary: Modern Version Control System
13Summary(ja): モダンなバージョン管理システム
14Name: subversion
15Version: 1.7.6
16Release: 1%{?_dist_release}
17License: ASL 2.0
18Group: Development/Tools
19URL: http://subversion.apache.org/
20
21Packager: iwaim
22Vendor: Project Vine
23Distribution: Vine Linux
24
25SOURCE0: subversion-%{version}.tar.bz2
26SOURCE1: subversion.conf
27SOURCE2: httpd.davcheck.conf
28SOURCE3: filter-requires.sh
29Patch3: subversion-1.7.0-rpath.patch
30
31Requires: db4 >= %{db_version}
32Requires: expat
33Requires: neon >= %{neon_version}
34BuildRequires: apache2-devel
35BuildRequires: apr-devel, apr-util-devel
36BuildRequires: autoconf >= 2.53
37BuildRequires: db4-devel >= %{db_version}
38BuildRequires: expat-devel
39BuildRequires: gdbm-devel
40BuildRequires: libtool >= 1.4.2
41BuildRequires: neon-devel >= %{neon_version}
42BuildRequires: openssl-devel
43BuildRequires: python
44BuildRequires: python-devel
45BuildRequires: swig >= %{swig_version}
46BuildRequires: texinfo
47BuildRequires: zlib-devel
48BuildRequires: openldap-devel
49BuildRequires: ruby >= 1.8.2
50BuildRequires: ruby-devel >= 1.8.2
51BuildRequires: perl >= 5.8.0
52BuildRequires: sqlite3-devel
53BuildRequires: krb5-devel
54BuildRequires: keyutils-libs-devel
55BuildRequires: dbus-devel
56BuildRequires: libgnome-keyring-devel
57BuildRoot: %{_tmppath}/%{name}-%{version}-root
58
59%define __perl_requires %{SOURCE3}
60
61%description
62Subversion is a concurrent version control system which enables one
63or more users to collaborate in developing and maintaining a
64hierarchy of files and directories while keeping a history of all
65changes.  Subversion only stores the differences between versions,
66instead of every complete file.  Subversion is intended to be a
67compelling replacement for CVS.
68
69%package devel
70Group: Development/Libraries
71Summary: Development package for Subversion developers.
72Requires: subversion = %{version}-%{release}
73Requires: apr-devel, apr-util-devel
74%description devel
75The subversion-devel package includes the static libraries and include files
76for developers interacting with the subversion package.
77
78%package mod_dav_svn
79Group: System Environment/Daemons
80Summary: Apache server module for Subversion server.
81Requires: httpd >= %{apache_version}
82Requires: subversion = %{version}-%{release}
83%description mod_dav_svn
84The subversion-mod_dav_svn package adds the Subversion server Apache module to
85the Apache directories and configuration.
86
87%package tools
88Group: Development/Tools
89Summary: Tools for Subversion
90BuildRequires: perl >= 5.8.0
91Requires: perl >= 5.8.0
92Requires: subversion = %{version}-%{release}
93
94%description tools
95Tools for Subversion.
96
97%package perl
98Group: Development/Libraries
99Summary: Perl bindings to the Subversion libraries
100Requires: subversion = %{version}-%{release}
101Requires: perl >= 5.8.0
102Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
103
104%description perl
105This package includes the Perl bindings to the Subversion libraries.
106
107%package ruby
108Group: Development/Libraries
109Summary: Ruby bindings to the Subversion libraries
110Requires: subversion = %{version}-%{release}
111Requires: ruby >= 1.8.2
112
113%description ruby
114This package includes the Ruby bindings to the Subversion libraries.
115
116%package python
117Group: Development/Libraries
118Summary: Python bindings to the Subversion libraries
119Requires: subversion = %{version}-%{release}, python
120
121%description python
122This package includes the Python bindings to the Subversion libraries.
123
124%prep
125%setup -q
126%patch3 -p1 -b .rpath
127
128rm -rf neon apr apr-util db4
129
130%build
131./autogen.sh
132
133# fix shebang lines, #111498
134perl -pi -e 's|/usr/bin/env perl -w|/usr/bin/perl -w|' tools/hook-scripts/*.pl.in
135
136# override weird -shrext from ruby
137export svn_cv_ruby_link="%{__cc} -shared"
138export svn_cv_ruby_sitedir_libsuffix=""
139export svn_cv_ruby_sitedir_archsuffix=""
140
141export CC=gcc CXX=g++ JAVA_HOME=%{jdk_path}
142export CPPFLAGS="-DSVN_NEON_0_26 -DSVN_NEON_0_25"
143%configure --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
144        --with-swig --with-neon=%{_prefix} \
145        --with-ruby-sitedir=%{rarchdir} \
146        --with-apxs=%{_bindir}/apxs \
147        --with-gnome-keyring \
148        --disable-mod-activation \
149        --disable-static \
150        --disable-neon-version-check
151# 1.3.0 tarball ships with generated swig sources
152make extraclean-swig-headers
153make %{?_smp_mflags} all
154make swig-py swig-py-lib %{swigdirs}
155make swig-pl swig-pl-lib swig-rb swig-rb-lib
156
157
158%install
159echo %{rarchdir}
160rm -rf $RPM_BUILD_ROOT
161make install \
162        install-swig-py \
163        install-swig-pl-lib \
164        install-swig-rb \
165        DESTDIR=$RPM_BUILD_ROOT %{swigdirs}
166
167make pure_vendor_install -C subversion/bindings/swig/perl/native \
168        PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
169install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/subversion
170
171# Add subversion.conf configuration file into httpd/conf.d directory.
172install -m 755 -d $RPM_BUILD_ROOT/etc/apache2/conf.d
173install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/apache2/conf.d
174
175# Set up tools package files.
176mkdir -p $RPM_BUILD_ROOT/usr/lib/subversion
177cp -r tools $RPM_BUILD_ROOT/usr/lib/subversion
178
179# Remove unpackaged files
180rm -rf $RPM_BUILD_ROOT%{_includedir}/subversion-*/*.txt \
181       $RPM_BUILD_ROOT%{python_sitearch}/*/*.{a,la} \
182       $RPM_BUILD_ROOT%{_libdir}/*.la
183       
184# remove stuff produced with Perl modules
185find $RPM_BUILD_ROOT -type f \
186     -a \( -name .packlist -o \( -name '*.bs' -a -empty \) \) \
187     -print0 | xargs -0 rm -f
188
189# make Perl modules writable so they get stripped
190find $RPM_BUILD_ROOT%{_libdir}/perl5 -type f -perm 555 -print0 |
191     xargs -0 chmod 755
192
193# unnecessary libraries for swig bindings
194rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig_*.{so,la,a}
195
196# Remove unnecessary ruby libraries
197rm -f $RPM_BUILD_ROOT%{rarchdir}/svn/ext/*.*a
198
199# Trim what goes in docdir
200rm -rf tools/*/*.in tools/test-scripts
201                       
202# Rename authz_svn INSTALL doc for docdir
203ln -f subversion/mod_authz_svn/INSTALL mod_authz_svn-INSTALL
204
205%clean
206rm -rf $RPM_BUILD_ROOT
207
208%post -p /sbin/ldconfig
209
210%postun -p /sbin/ldconfig
211
212%post tools -p /sbin/ldconfig
213
214%postun tools -p /sbin/ldconfig
215
216
217%files
218%defattr(-,root,root)
219%doc BUGS CHANGES COMMITTERS COPYING HACKING INSTALL README
220%doc subversion/LICENSE
221%{_bindir}/*
222%{_libdir}/libsvn_*.so.*
223%{_localedir}/*/*/subversion.mo
224%{_mandir}/man*/*
225%dir %{_sysconfdir}/subversion
226%exclude %{_mandir}/man*/*::*
227%exclude %{_libdir}/libsvn_swig_perl*.so.*
228%exclude %{_libdir}/libsvn_swig_py*.so.*
229%exclude %{_libdir}/libsvn_swig_ruby*.so.*
230
231%files devel
232%defattr(-,root,root)
233%{_includedir}/subversion-1
234%{_libdir}/libsvn*.so
235%exclude %{_libdir}/libsvn_swig_perl*.so.*
236%exclude %{_libdir}/libsvn_swig_py*.so.*
237%exclude %{_libdir}/libsvn_swig_ruby*.so.*
238
239%files mod_dav_svn
240%defattr(-,root,root)
241%config(noreplace) /etc/apache2/conf.d/subversion.conf
242%{apache_dir}/%{_lib}/apache2/modules/mod_*.*
243
244%files tools
245%defattr(-,root,root)
246%{_prefix}/lib/subversion/tools
247
248%files perl
249%defattr(-,root,root,-)
250%{perl_vendorarch}/auto/SVN
251%{perl_vendorarch}/SVN
252%{_libdir}/libsvn_swig_perl*
253%{_mandir}/man*/*::*
254
255%files ruby
256%defattr(-,root,root,-)
257%{_libdir}/libsvn_swig_ruby*
258%{rarchdir}/svn
259
260%files python
261%defattr(-,root,root,-)
262%{_libdir}/libsvn_swig_py*
263%{python_sitearch}/libsvn
264%{python_sitearch}/svn
265
266
267%changelog
268* Tue Sep 18 2012 IWAI, Masaharu <iwai@alib.jp> 1.7.6-1
269- new upstream release
270- update License
271- update rpath patch (Patch3) from Fedora 1.7.6-1.fc19
272- drop deplibs patch (Patch1)
273- drop obsolete patch files: Patch6, 10
274
275* Fri Jun  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
276- new upstream release with security fix (CVE-2011-1752, 1783, 1921)
277- add configure option with-gnome-keyring
278- add BR: keyutils-libs-devel, dbus-devel, libgnome-keyring-devel
279- fix Packager name
280
281* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.16-2
282- build with perl 5.12.3
283- add Requires: perl(:MODULE_COMPAT_...)
284
285* Sat Mar  5 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.16-1
286- new upstream release with security fix
287- add Vendor/Distri tags
288
289* Mon Nov 29 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.15-1
290- new upstream release
291
292* Tue Mar  2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-2
293- fix <BTS:VineLinux:941>
294  - using rpm macro: rarchdir
295  - export svn_cv_ruby_sitedir_libsuffix and svn_cv_ruby_sitedir_archsuffix
296- using rpm macros: perl_vendorarch and python_sitearch
297- add BuildRequires: sqlite3-devel krb5-devel
298
299* Thu Feb 18 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
300- new upstream release
301- update URL
302- update deplibs patch (Patch1) from Fedora 1.6.9-2.fc13
303- update rpath patch (Patch3) from Fedora 1.6.9-2.fc13
304- stop applying pia patch (Patch6): sync Fedora 1.6.9-2.fc13
305- stop applying update-neon-m4 patch (Patch10): sync Fedora 1.6.9-2.fc13
306
307* Wed Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.7-1
308- new upstream release
309
310* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.2-1
311- new upstream release
312
313* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.6-2vl5
314- rebuilt with python-2.5.2
315
316* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.6-1vl5
317- new upstream release
318- rebuild with neon-0.28.2
319- dropped old-Patch10 by adding --disable-neon-version-check to %%configure
320- added Patch6, 8, 9, 10 from Fedora Core
321  * Thu Feb 21 2008 Lubomir Kundrak <lkundrak@redhat.com> 1.4.6-5
322  - Correct install location of java stuff (#433295)
323  * Wed Aug  8 2007 Joe Orton <jorton@redhat.com> 1.4.4-3
324  - fix build with new glibc open()-as-macro
325  - build all swig code in %%build, not %%install
326  * Fri May 21 2004 Joe Orton <jorton@redhat.com> 1.0.3-2
327  - build /usr/bin/* as PIEs
328
329* Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.3-0vl2
330- rebuild with expat-2.0.1
331
332* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.3-0vl1
333- new upstream release
334- add Patch10 to build with neon.
335  1.3.2-0vl5 does not support neon..
336
337* Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl4
338- rebuild with new neon
339
340* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.2-0vl3
341- rebuilt with new toolchain and db4-4.3.x
342
343* Sat Mar 31 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.2-0vl2
344- modified %%files section for lib64 architecture
345
346* Tue Aug 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl1
347- new upstream release
348- rebuild with new openldap-2.3.24
349
350* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.1-0vl1
351- new upstream release
352- change Group to Develoment/Tools
353- build with apr-1.2.7/apr-util-1.2.7
354  - require apr/apr-util instead of apache2-apr
355- build with swig-1.3.29
356- split {perl,python,ruby} related files to subpackage.
357
358* Tue Oct 18 2005 IWAI, Masaharu <iwai@alib.jp> 1.2.3-0vl1
359- new upstream release
360- add noreplace option for config file
361
362* Sun Jan 30 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl3
363- fix Requires and BuildPreReq.
364
365* Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl2
366- new upstream release.
367- add swig-runtime to 'BuildPreReq:'.
368- fix %%files.
369
370* Sun Oct 17 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.0.6-0vl1.1
371- require neon version 0.24.7 for ra_dav
372- add BuildPreReq: openldap-devel
373- replace BuildPreReq: httpd to BuildPreReq: apache2
374- replace tools Requires: perl(:MODULE_COMPAT_version) to perl >= 5.8.0
375
376* Wed Jul 21 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.6-0vl1
377- new upstream release
378
379* Tue Jun 22 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.5-0vl1
380- new upstream release
381
382* Fri Jun  4 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.4-0vl1
383- new upstream release
384- clean up specfile.
385
386* Tue Nov 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.32.1-0vl1
387- new upstream release
388- build with apache2-2.0.47
389
390* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.20.0-0vl1
391- build Vine Linux
392
393* Sat Mar 01 2003 David Summers <david@summersoft.fay.ar.us> 0.18.1-5173
394- Enabled RA_DAV checking.
395  Now requires httpd package to build because of RA_DAV tests.
396
397* Sat Jan 18 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4433
398- Created tools package to hold the tools.
399
400* Thu Jan 16 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4405
401- Now requires httpd >= 2.0.44-0.1 (APACHE_2_0_BRANCH) which contains the new
402  version of APR/APR-UTILS as of 2003.01.15.
403- Added svnversion command.
404
405* Tue Dec 31 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4218
406- Create a svnadmin.static which is copied to svnadmin-version-release
407  when the package is erased, so users can still dump/load their repositories
408  even after they have upgraded the RPM package.
409
410* Sat Dec 14 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4128
411- SWIG now builds so we can use cvs2svn.
412
413* Fri Oct 04 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3280
414- Made cvs2svn conditional (at least until we can get it to build consistently
415  and work).
416
417* Sat Sep 21 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3205
418- Added SWIG dependencies to add cvs2svn capabilities.
419
420* Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2984
421- Now requires neon-0.22.0.
422
423* Thu Aug 15 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2978
424- Took out loading mod_dav_svn from subversion.spec file and put it in
425  subversion.conf file which goes into the apache conf directory.
426- Simplify what gets put into httpd.conf to only the include for the
427  subversion.conf file.
428  (Thanks to Scott Harrison <sharrison@users.sourceforge.net> for prompting
429  me to do this).
430
431* Thu Aug 08 2002 David Summers <david@summersoft.fay.ar.us> 0.14.0-2919
432- Updated to APR/APR-UTIL 2002-08-08.
433
434* Tue Jun 25 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2332
435- Updated to APACHE/APR/APR-UTIL 2002-06-25.
436- Previous version had a few problems because of missing apache error/ files.
437
438* Sun Jun 23 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2318
439- Updated to apache-2.0.40-0.3.
440- Updated to subversion-0.13.1-2318.
441
442* Tue Jun 18 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2277
443- Updated for RedHat 7.3 (autoconf253).
444- Added a bunch of pre-requisites I didn't know were needed because I built a
445  new machine that didn't have them already installed.
446- Fixed installation of man and info documentation pages.
447
448* Wed Mar 06 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1447
449- Back to apache-libapr* stuff, hopefully to stay.
450
451* Sun Feb 24 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1373
452- Fixed expat.patch to not have to make so many changes by writing a small
453  shell script that changes libexpat to -lexpat.
454
455* Fri Feb 22 2002 Blair Zajac <blair@orcaware.com> 0.9.0-1364
456- Updated to neon-0.19.2.
457
458* Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1250
459- Back to using apr and apr-util separately from apache.
460
461* Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1232
462- Updated to APR and APR-UTIL 2002.02.11.
463- Updated to apache-2.0.32-0.2. (Requires apache-libapr and apache-libapr-util).
464- Took out a (now non-existant) documentation file.
465- Moved SPEC file changelog to after all package definitions.
466 
467* Sun Feb 03 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1153
468- Updated to neon-0.18.5.
469- Broke up apache and apache-devel into apache-apr, apache-apr-devel,
470  apache-apr-utils, and apache-apr-utils-devel.
471- Updated apache to APR and APR-UTILS to 2002.02.03 version.
472
473* Sat Feb 02 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1147
474- Now builds without the separate APR package as it is built into and
475  "exported" from apache-2.0.31-0.3.
476
477* Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1132
478- Took out patches to install procedure now not required because of fixes
479  in rev 1130.
480
481* Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1129
482- Added requirement for APR 0.2002.01.19 rev 2 where the /usr/bin/apr-config
483  program was added.
484
485* Sun Oct 28 2001 David Summers <david@summersoft.fay.ar.us>
486- Release M5-r340: Added the subversion-server package.
487
488* Fri Oct 26 2001 David Summers <david@summersoft.fay.ar.us>
489- Release M5-r327: No longer need expat-lite. We can use the normal expat.
490
491* Thu Sep 27 2001 David Summers <david@summersoft.fay.ar.us>
492- Release M3-r117: Initial Version.
493
Note: See TracBrowser for help on using the repository browser.