source: projects/specs/trunk/s/subversion/subversion-vl.spec @ 12333

Revision 12333, 19.3 KB checked in by tomop, 4 years ago (diff)

updated 5 packages

graphviz-2.42.2-1

rrdtool-1.7.2-1

ruby-2.6.5-1

subversion-1.13.0-1

vim-8.2.0390-1

Line 
1%define neon_version 0.30.2
2%define swig_version 3.0.0
3%define apache_version 2.4
4%define apache_dir /usr
5
6%define swigdirs swig_pydir=%{python3_sitearch}/libsvn swig_pydir_extra=%{python3_sitearch}/svn
7
8# set to zero to avoid running test suite
9%define make_check 0
10
11Summary: Modern Version Control System
12Summary(ja): モダンなバージョン管理システム
13Name: subversion
14Version: 1.13.0
15Release: 1%{?_dist_release}
16License: ASL 2.0
17Group: Development/Tools
18URL: https://subversion.apache.org/
19
20Vendor: Project Vine
21Distribution: Vine Linux
22Packager: iwaim, daisuke
23
24SOURCE0: http://ftp.jaist.ac.jp/pub/apache/subversion/subversion-%{version}.tar.bz2
25SOURCE1: subversion.conf
26SOURCE2: httpd.davcheck.conf
27SOURCE3: filter-requires.sh
28Patch1: subversion-1.12.0-linking.patch
29Patch2: subversion-1.12.2-py3tests.patch
30Patch4: subversion-1.8.0-rubybind.patch
31Patch5: subversion-1.8.5-swigplWall.patch
32
33BuildRequires: apache2-devel >= %{apache_version}
34BuildRequires: apr-devel, apr-util-devel
35BuildRequires: autoconf >= 2.53
36BuildRequires: libdb-devel
37BuildRequires: expat-devel
38BuildRequires: gdbm-devel
39BuildRequires: libtool >= 1.4.2
40BuildRequires: neon-devel >= %{neon_version}
41BuildRequires: openssl-devel
42BuildRequires: swig >= %{swig_version}
43BuildRequires: texinfo
44BuildRequires: zlib-devel
45BuildRequires: lz4-devel
46BuildRequires: utf8proc-devel
47BuildRequires: openldap-devel
48BuildRequires: ruby >= 2.2.3
49BuildRequires: ruby-devel >= 2.2.3
50BuildRequires: perl >= 2:5.26.2
51BuildRequires: sqlite3-devel
52BuildRequires: krb5-devel
53BuildRequires: keyutils-libs-devel
54BuildRequires: dbus-devel
55BuildRequires: libsecret-devel
56BuildRequires: libserf-devel
57BuildRequires: libxcrypt-devel
58BuildRequires: libnsl2-devel
59BuildRoot: %{_tmppath}/%{name}-%{version}-root
60
61%define __perllib_requires %{SOURCE3}
62
63%description
64Subversion is a concurrent version control system which enables one
65or more users to collaborate in developing and maintaining a
66hierarchy of files and directories while keeping a history of all
67changes.  Subversion only stores the differences between versions,
68instead of every complete file.  Subversion is intended to be a
69compelling replacement for CVS.
70
71%package devel
72Group: Development/Libraries
73Summary: Development package for Subversion developers.
74Requires: subversion = %{version}-%{release}
75Requires: apr-devel, apr-util-devel
76%description devel
77The subversion-devel package includes the static libraries and include files
78for developers interacting with the subversion package.
79
80%package mod_dav_svn
81Group: System Environment/Daemons
82Summary: Apache server module for Subversion server.
83Requires: apache2 >= %{apache_version}
84Requires: subversion = %{version}-%{release}
85%description mod_dav_svn
86The subversion-mod_dav_svn package adds the Subversion server Apache module to
87the Apache directories and configuration.
88
89%package tools
90Group: Development/Tools
91Summary: Tools for Subversion
92BuildRequires: perl >= 5.8.0
93Requires: perl >= 5.8.0
94Requires: subversion = %{version}-%{release}
95
96%description tools
97Tools for Subversion.
98
99%package perl
100Group: Development/Libraries
101Summary: Perl bindings to the Subversion libraries
102Requires: subversion = %{version}-%{release}
103Requires: perl >= 5.8.0
104Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
105
106%description perl
107This package includes the Perl bindings to the Subversion libraries.
108
109%package ruby
110Group: Development/Libraries
111Summary: Ruby bindings to the Subversion libraries
112Requires: subversion = %{version}-%{release}
113Requires: ruby >= 2.0
114
115%description ruby
116This package includes the Ruby bindings to the Subversion libraries.
117
118%package -n python3-subversion
119Group: Development/Libraries
120Summary: Python bindings to the Subversion libraries
121BuildRequires: python3
122BuildRequires: python3-devel
123BuildRequires: python3-rpm-macros
124Requires: subversion = %{version}-%{release}, python3
125
126%description -n python3-subversion
127This package includes the Python bindings to the Subversion libraries.
128
129%prep
130%setup -q
131%patch1 -p1 -b .link
132%patch2 -p1 -b .python3
133%patch4 -p1 -b .rubybind
134%patch5 -p1 -b .swigplWall
135
136%build
137export LANG=ja_JP.UTF-8
138
139# Regenerate the buildsystem, so that:
140#  1) patches applied to configure.in take effect
141#  2) the swig bindings are regenerated using the system swig
142# (2) is not ideal since typically upstream test with a different
143# swig version
144# This PATH order makes the fugly test for libtoolize work...
145mv build-outputs.mk build-outputs.mk.old
146export PYTHON=%{__python3}
147
148PATH=/usr/bin:$PATH ./autogen.sh --release
149
150# fix shebang lines, #111498
151perl -pi -e 's|/usr/bin/env perl -w|/usr/bin/perl -w|' tools/hook-scripts/*.pl.in
152
153# fix python executable
154perl -pi -e 's|/usr/bin/env python.*|%{svn_python}|' subversion/tests/cmdline/svneditor.py
155
156# override weird -shrext from ruby
157export svn_cv_ruby_link="%{__cc} -shared"
158export svn_cv_ruby_sitedir_libsuffix=""
159export svn_cv_ruby_sitedir_archsuffix=""
160
161export CC=gcc CXX=g++ JAVA_HOME=%{jdk_path} CFLAGS="$RPM_OPT_FLAGS"
162export LIBTOOL=/usr/bin/libtool
163%configure --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
164        --with-swig --with-serf=%{_prefix} \
165        --with-ruby-sitedir=%{rarchdir} \
166        --with-apxs=%{_bindir}/apxs \
167        --disable-mod-activation \
168        --with-apache-libexecdir=%{_libdir}/apache2/modules/ \
169        --with-gnome-keyring \
170        --with-berkeley-db \
171        --disable-mod-activation \
172        --disable-static
173
174make %{?_smp_mflags} all tools
175make swig-py swig-py-lib %{swigdirs}
176make swig-pl swig-pl-lib swig-rb swig-rb-lib
177
178
179%install
180echo %{rarchdir}
181rm -rf $RPM_BUILD_ROOT
182make install \
183        install-swig-py \
184        install-swig-pl-lib \
185        install-swig-rb \
186        DESTDIR=$RPM_BUILD_ROOT %{swigdirs}
187
188make pure_vendor_install -C subversion/bindings/swig/perl/native \
189        PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
190install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/subversion
191
192install -m 755 -d $RPM_BUILD_ROOT%{_libdir}/apache2/modules
193
194# Add subversion.conf configuration file into apache2/conf.d directory.
195install -m 755 -d $RPM_BUILD_ROOT/etc/apache2/conf.d
196install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/apache2/conf.d
197
198# Remove unpackaged files
199rm -rf $RPM_BUILD_ROOT%{_includedir}/subversion-*/*.txt \
200       $RPM_BUILD_ROOT%{python3_sitearch}/*/*.{a,la} \
201       $RPM_BUILD_ROOT%{_libdir}/*.la
202
203# The SVN build system is broken w.r.t. DSO support; it treats
204# normal libraries as DSOs and puts them in $libdir, whereas they
205# should go in some subdir somewhere, and be linked using -module,
206# etc.  So, forcibly nuke the .so's for libsvn_auth_{gnome,kde},
207# since nothing should ever link against them directly.
208rm -f ${RPM_BUILD_ROOT}%{_libdir}/libsvn_auth_*.so
209
210# remove stuff produced with Perl modules
211find $RPM_BUILD_ROOT -type f \
212     -a \( -name .packlist -o \( -name '*.bs' -a -empty \) \) \
213     -print0 | xargs -0 rm -f
214
215# make Perl modules writable so they get stripped
216find $RPM_BUILD_ROOT%{_libdir}/perl5 -type f -perm 555 -print0 |
217     xargs -0 chmod 755
218
219# unnecessary libraries for swig bindings
220rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig_*.{so,la,a}
221
222# Remove unnecessary ruby libraries
223rm -f $RPM_BUILD_ROOT%{rarchdir}/svn/ext/*.*a
224
225# Trim what goes in docdir
226rm -rf tools/*/*.in tools/test-scripts
227
228# Rename authz_svn INSTALL doc for docdir
229ln -f subversion/mod_authz_svn/INSTALL mod_authz_svn-INSTALL
230
231# Install bash completion
232install -Dpm 644 tools/client-side/bash_completion \
233        $RPM_BUILD_ROOT%{_datadir}/bash-completion/completions/svn
234for comp in svnadmin svndumpfilter svnlook svnsync svnversion; do
235    ln -s svn \
236       $RPM_BUILD_ROOT%{_datadir}/bash-completion/completions/${comp}
237done
238
239# Install tools ex diff*
240make install-tools DESTDIR=$RPM_BUILD_ROOT toolsdir=%{_bindir}
241rm -f $RPM_BUILD_ROOT%{_bindir}/diff*
242
243for f in svn-populate-node-origins-index \
244         svnauthz-validate svnmucc svnraisetreeconflict; do
245    echo %{_bindir}/$f
246done | tee tools.files | sed 's/^/%%exclude /' > exclude.tools.files
247
248%find_lang %{name}
249
250cat %{name}.lang exclude.tools.files >> %{name}.files
251
252%clean
253rm -rf $RPM_BUILD_ROOT
254
255%post -p /sbin/ldconfig
256
257%postun -p /sbin/ldconfig
258
259%post perl -p /sbin/ldconfig
260
261%postun perl -p /sbin/ldconfig
262
263%post ruby -p /sbin/ldconfig
264
265%postun ruby -p /sbin/ldconfig
266
267%post -n python3-subversion -p /sbin/ldconfig
268
269%postun -n python3-subversion -p /sbin/ldconfig
270
271%post tools -p /sbin/ldconfig
272
273%postun tools -p /sbin/ldconfig
274
275
276%files
277%defattr(-,root,root)
278%license LICENSE
279%doc BUGS CHANGES COMMITTERS NOTICE INSTALL README
280%{_bindir}/*
281%{_libdir}/libsvn_*.so.*
282%{_localedir}/*/*/subversion.mo
283%{_mandir}/man*/*
284%{_datadir}/bash-completion/completions/*
285%dir %{_sysconfdir}/subversion
286%exclude %{_mandir}/man*/*::*
287%exclude %{_libdir}/libsvn_swig_perl*.so.*
288%exclude %{_libdir}/libsvn_swig_py*.so.*
289%exclude %{_libdir}/libsvn_swig_ruby*.so.*
290
291%files devel
292%defattr(-,root,root)
293%{_includedir}/subversion-1
294%{_libdir}/libsvn*.so
295%exclude %{_libdir}/libsvn_swig_perl*
296%exclude %{_libdir}/libsvn_swig_py*
297%exclude %{_libdir}/libsvn_swig_ruby*
298%{_datadir}/pkgconfig/*
299
300%files mod_dav_svn
301%defattr(-,root,root)
302%config(noreplace) /etc/apache2/conf.d/subversion.conf
303%{apache_dir}/%{_lib}/apache2/modules/mod_*.*
304
305%files tools -f tools.files
306%defattr(-,root,root)
307
308%files perl
309%defattr(-,root,root,-)
310%{perl_vendorarch}/auto/SVN
311%{perl_vendorarch}/SVN
312%{_libdir}/libsvn_swig_perl*
313%{_mandir}/man*/*::*
314
315%files ruby
316%defattr(-,root,root,-)
317%{_libdir}/libsvn_swig_ruby*
318%{rarchdir}/svn
319
320%files -n python3-subversion
321%defattr(-,root,root,-)
322%{_libdir}/libsvn_swig_py*
323%{python3_sitearch}/*
324
325
326%changelog
327* Mon Mar 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.13.0-1
328- new upstream release.
329
330* Sat Oct 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.2-1
331- new upstream release.
332- dropped Patch1 and 2.
333- imported Patch1 and 2 from rawhide.
334- switched to python3.
335
336* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.4-1
337- new upstream release.
338- rebuilt with perl-5.26.
339- dropped BR:libgnome-keyring-devel.
340- added BR:libxcrypt-devel,libnsl2-devel,libsecret-devel,utf8proc-devel.
341
342* Wed May 31 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.17-1
343- update to 1.8.17
344
345* Sat Sep 12 2015 Daisuke SUZUKI <daisuke@vinelinux.org> 1.8.9-4
346- rebuild with ruby-2.2.3
347
348* Mon Jun 30 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.9-3
349- build with Perl 5.16
350- using %%__perllib_requires
351
352* Fri Jun 27 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.8.9-2
353- rebuild with ruby-2.1.2-6
354
355* Wed Jun 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.8.9-1
356- update to 1.8.9
357- remove unneeded explisit dependency
358- add BR: apache2-devel >= 2.4
359- add BR: libdb-devel instead of db4-devel
360- add R: apache2 > 2.4 to mod_dav_svn
361
362* Fri Apr 18 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.8-1
363- update to 1.8.8
364- add BR: libserf-devel to handle http* scheme
365
366* Thu Oct 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.7-1
367- update to 1.7.7
368- rebuild with ruby-1.9.3
369
370* Tue Sep 18 2012 IWAI, Masaharu <iwai@alib.jp> 1.7.6-1
371- new upstream release
372- update License
373- update rpath patch (Patch3) from Fedora 1.7.6-1.fc19
374- drop deplibs patch (Patch1)
375- drop obsolete patch files: Patch6, 10
376
377* Fri Jun  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
378- new upstream release with security fix (CVE-2011-1752, 1783, 1921)
379- add configure option with-gnome-keyring
380- add BR: keyutils-libs-devel, dbus-devel, libgnome-keyring-devel
381- fix Packager name
382
383* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.16-2
384- build with perl 5.12.3
385- add Requires: perl(:MODULE_COMPAT_...)
386
387* Sat Mar  5 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.16-1
388- new upstream release with security fix
389- add Vendor/Distri tags
390
391* Mon Nov 29 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.15-1
392- new upstream release
393
394* Tue Mar  2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-2
395- fix <BTS:VineLinux:941>
396  - using rpm macro: rarchdir
397  - export svn_cv_ruby_sitedir_libsuffix and svn_cv_ruby_sitedir_archsuffix
398- using rpm macros: perl_vendorarch and python_sitearch
399- add BuildRequires: sqlite3-devel krb5-devel
400
401* Thu Feb 18 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
402- new upstream release
403- update URL
404- update deplibs patch (Patch1) from Fedora 1.6.9-2.fc13
405- update rpath patch (Patch3) from Fedora 1.6.9-2.fc13
406- stop applying pia patch (Patch6): sync Fedora 1.6.9-2.fc13
407- stop applying update-neon-m4 patch (Patch10): sync Fedora 1.6.9-2.fc13
408
409* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.7-1
410- new upstream release
411
412* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.2-1
413- new upstream release
414
415* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.6-2vl5
416- rebuilt with python-2.5.2
417
418* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.6-1vl5
419- new upstream release
420- rebuild with neon-0.28.2
421- dropped old-Patch10 by adding --disable-neon-version-check to %%configure
422- added Patch6, 8, 9, 10 from Fedora Core
423  * Thu Feb 21 2008 Lubomir Kundrak <lkundrak@redhat.com> 1.4.6-5
424  - Correct install location of java stuff (#433295)
425  * Wed Aug  8 2007 Joe Orton <jorton@redhat.com> 1.4.4-3
426  - fix build with new glibc open()-as-macro
427  - build all swig code in %%build, not %%install
428  * Fri May 21 2004 Joe Orton <jorton@redhat.com> 1.0.3-2
429  - build /usr/bin/* as PIEs
430
431* Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.3-0vl2
432- rebuild with expat-2.0.1
433
434* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.3-0vl1
435- new upstream release
436- add Patch10 to build with neon.
437  1.3.2-0vl5 does not support neon..
438
439* Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl4
440- rebuild with new neon
441
442* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.2-0vl3
443- rebuilt with new toolchain and db4-4.3.x
444
445* Sat Mar 31 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.2-0vl2
446- modified %%files section for lib64 architecture
447
448* Tue Aug 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl1
449- new upstream release
450- rebuild with new openldap-2.3.24
451
452* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.1-0vl1
453- new upstream release
454- change Group to Develoment/Tools
455- build with apr-1.2.7/apr-util-1.2.7
456  - require apr/apr-util instead of apache2-apr
457- build with swig-1.3.29
458- split {perl,python,ruby} related files to subpackage.
459
460* Tue Oct 18 2005 IWAI, Masaharu <iwai@alib.jp> 1.2.3-0vl1
461- new upstream release
462- add noreplace option for config file
463
464* Sun Jan 30 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl3
465- fix Requires and BuildPreReq.
466
467* Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl2
468- new upstream release.
469- add swig-runtime to 'BuildPreReq:'.
470- fix %%files.
471
472* Sun Oct 17 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.0.6-0vl1.1
473- require neon version 0.24.7 for ra_dav
474- add BuildPreReq: openldap-devel
475- replace BuildPreReq: httpd to BuildPreReq: apache2
476- replace tools Requires: perl(:MODULE_COMPAT_version) to perl >= 5.8.0
477
478* Wed Jul 21 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.6-0vl1
479- new upstream release
480
481* Tue Jun 22 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.5-0vl1
482- new upstream release
483
484* Fri Jun  4 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.4-0vl1
485- new upstream release
486- clean up specfile.
487
488* Tue Nov 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.32.1-0vl1
489- new upstream release
490- build with apache2-2.0.47
491
492* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.20.0-0vl1
493- build Vine Linux
494
495* Sat Mar 01 2003 David Summers <david@summersoft.fay.ar.us> 0.18.1-5173
496- Enabled RA_DAV checking.
497  Now requires httpd package to build because of RA_DAV tests.
498
499* Sat Jan 18 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4433
500- Created tools package to hold the tools.
501
502* Thu Jan 16 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4405
503- Now requires httpd >= 2.0.44-0.1 (APACHE_2_0_BRANCH) which contains the new
504  version of APR/APR-UTILS as of 2003.01.15.
505- Added svnversion command.
506
507* Tue Dec 31 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4218
508- Create a svnadmin.static which is copied to svnadmin-version-release
509  when the package is erased, so users can still dump/load their repositories
510  even after they have upgraded the RPM package.
511
512* Sat Dec 14 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4128
513- SWIG now builds so we can use cvs2svn.
514
515* Fri Oct 04 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3280
516- Made cvs2svn conditional (at least until we can get it to build consistently
517  and work).
518
519* Sat Sep 21 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3205
520- Added SWIG dependencies to add cvs2svn capabilities.
521
522* Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2984
523- Now requires neon-0.22.0.
524
525* Thu Aug 15 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2978
526- Took out loading mod_dav_svn from subversion.spec file and put it in
527  subversion.conf file which goes into the apache conf directory.
528- Simplify what gets put into httpd.conf to only the include for the
529  subversion.conf file.
530  (Thanks to Scott Harrison <sharrison@users.sourceforge.net> for prompting
531  me to do this).
532
533* Thu Aug 08 2002 David Summers <david@summersoft.fay.ar.us> 0.14.0-2919
534- Updated to APR/APR-UTIL 2002-08-08.
535
536* Tue Jun 25 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2332
537- Updated to APACHE/APR/APR-UTIL 2002-06-25.
538- Previous version had a few problems because of missing apache error/ files.
539
540* Sun Jun 23 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2318
541- Updated to apache-2.0.40-0.3.
542- Updated to subversion-0.13.1-2318.
543
544* Tue Jun 18 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2277
545- Updated for RedHat 7.3 (autoconf253).
546- Added a bunch of pre-requisites I didn't know were needed because I built a
547  new machine that didn't have them already installed.
548- Fixed installation of man and info documentation pages.
549
550* Wed Mar 06 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1447
551- Back to apache-libapr* stuff, hopefully to stay.
552
553* Sun Feb 24 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1373
554- Fixed expat.patch to not have to make so many changes by writing a small
555  shell script that changes libexpat to -lexpat.
556
557* Fri Feb 22 2002 Blair Zajac <blair@orcaware.com> 0.9.0-1364
558- Updated to neon-0.19.2.
559
560* Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1250
561- Back to using apr and apr-util separately from apache.
562
563* Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1232
564- Updated to APR and APR-UTIL 2002.02.11.
565- Updated to apache-2.0.32-0.2. (Requires apache-libapr and apache-libapr-util).
566- Took out a (now non-existant) documentation file.
567- Moved SPEC file changelog to after all package definitions.
568 
569* Sun Feb 03 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1153
570- Updated to neon-0.18.5.
571- Broke up apache and apache-devel into apache-apr, apache-apr-devel,
572  apache-apr-utils, and apache-apr-utils-devel.
573- Updated apache to APR and APR-UTILS to 2002.02.03 version.
574
575* Sat Feb 02 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1147
576- Now builds without the separate APR package as it is built into and
577  "exported" from apache-2.0.31-0.3.
578
579* Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1132
580- Took out patches to install procedure now not required because of fixes
581  in rev 1130.
582
583* Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1129
584- Added requirement for APR 0.2002.01.19 rev 2 where the /usr/bin/apr-config
585  program was added.
586
587* Sun Oct 28 2001 David Summers <david@summersoft.fay.ar.us>
588- Release M5-r340: Added the subversion-server package.
589
590* Fri Oct 26 2001 David Summers <david@summersoft.fay.ar.us>
591- Release M5-r327: No longer need expat-lite. We can use the normal expat.
592
593* Thu Sep 27 2001 David Summers <david@summersoft.fay.ar.us>
594- Release M3-r117: Initial Version.
595
Note: See TracBrowser for help on using the repository browser.