source: projects/specs/trunk/s/subversion/subversion-vl.spec @ 12120

Revision 12120, 18.8 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1%define neon_version 0.30.2
2%define swig_version 3.0.0
3%define apache_version 2.4
4%define apache_dir /usr
5
6%define swigdirs swig_pydir=%{python_sitearch}/libsvn swig_pydir_extra=%{python_sitearch}/svn
7
8# set to zero to avoid running test suite
9%define make_check 0
10
11Summary: Modern Version Control System
12Summary(ja): モダンなバージョン管理システム
13Name: subversion
14Version: 1.10.4
15Release: 1%{?_dist_release}
16License: ASL 2.0
17Group: Development/Tools
18URL: http://subversion.apache.org/
19
20Vendor: Project Vine
21Distribution: Vine Linux
22Packager: iwaim, daisuke
23
24SOURCE0: subversion-%{version}.tar.bz2
25SOURCE1: subversion.conf
26SOURCE2: httpd.davcheck.conf
27SOURCE3: filter-requires.sh
28Patch1: subversion-1.10.0-rpath.patch
29Patch2: subversion-1.10.0-pie.patch
30Patch4: subversion-1.8.0-rubybind.patch
31Patch5: subversion-1.8.5-swigplWall.patch
32
33BuildRequires: apache2-devel >= %{apache_version}
34BuildRequires: apr-devel, apr-util-devel
35BuildRequires: autoconf >= 2.53
36BuildRequires: libdb-devel
37BuildRequires: expat-devel
38BuildRequires: gdbm-devel
39BuildRequires: libtool >= 1.4.2
40BuildRequires: neon-devel >= %{neon_version}
41BuildRequires: openssl-devel
42BuildRequires: python
43BuildRequires: python-devel
44BuildRequires: swig >= %{swig_version}
45BuildRequires: texinfo
46BuildRequires: zlib-devel
47BuildRequires: lz4-devel
48BuildRequires: utf8proc-devel
49BuildRequires: openldap-devel
50BuildRequires: ruby >= 2.2.3
51BuildRequires: ruby-devel >= 2.2.3
52BuildRequires: perl >= 2:5.26.2
53BuildRequires: sqlite3-devel
54BuildRequires: krb5-devel
55BuildRequires: keyutils-libs-devel
56BuildRequires: dbus-devel
57BuildRequires: libsecret-devel
58BuildRequires: libserf-devel
59BuildRequires: libxcrypt-devel
60BuildRequires: libnsl2-devel
61BuildRoot: %{_tmppath}/%{name}-%{version}-root
62
63%define __perllib_requires %{SOURCE3}
64
65%description
66Subversion is a concurrent version control system which enables one
67or more users to collaborate in developing and maintaining a
68hierarchy of files and directories while keeping a history of all
69changes.  Subversion only stores the differences between versions,
70instead of every complete file.  Subversion is intended to be a
71compelling replacement for CVS.
72
73%package devel
74Group: Development/Libraries
75Summary: Development package for Subversion developers.
76Requires: subversion = %{version}-%{release}
77Requires: apr-devel, apr-util-devel
78%description devel
79The subversion-devel package includes the static libraries and include files
80for developers interacting with the subversion package.
81
82%package mod_dav_svn
83Group: System Environment/Daemons
84Summary: Apache server module for Subversion server.
85Requires: apache2 >= %{apache_version}
86Requires: subversion = %{version}-%{release}
87%description mod_dav_svn
88The subversion-mod_dav_svn package adds the Subversion server Apache module to
89the Apache directories and configuration.
90
91%package tools
92Group: Development/Tools
93Summary: Tools for Subversion
94BuildRequires: perl >= 5.8.0
95Requires: perl >= 5.8.0
96Requires: subversion = %{version}-%{release}
97
98%description tools
99Tools for Subversion.
100
101%package perl
102Group: Development/Libraries
103Summary: Perl bindings to the Subversion libraries
104Requires: subversion = %{version}-%{release}
105Requires: perl >= 5.8.0
106Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
107
108%description perl
109This package includes the Perl bindings to the Subversion libraries.
110
111%package ruby
112Group: Development/Libraries
113Summary: Ruby bindings to the Subversion libraries
114Requires: subversion = %{version}-%{release}
115Requires: ruby >= 2.0
116
117%description ruby
118This package includes the Ruby bindings to the Subversion libraries.
119
120%package python
121Group: Development/Libraries
122Summary: Python bindings to the Subversion libraries
123Requires: subversion = %{version}-%{release}, python
124
125%description python
126This package includes the Python bindings to the Subversion libraries.
127
128%prep
129%setup -q
130%patch1 -p1 -b .rpath
131%patch2 -p1 -b .pie
132%patch4 -p1 -b .rubybind
133%patch5 -p1 -b .swigplWall
134
135%build
136# Regenerate the buildsystem, so that:
137#  1) patches applied to configure.in take effect
138#  2) the swig bindings are regenerated using the system swig
139# (2) is not ideal since typically upstream test with a different
140# swig version
141# This PATH order makes the fugly test for libtoolize work...
142mv build-outputs.mk build-outputs.mk.old
143#export PYTHON=%{__python3}
144
145PATH=/usr/bin:$PATH ./autogen.sh --release
146
147# fix shebang lines, #111498
148perl -pi -e 's|/usr/bin/env perl -w|/usr/bin/perl -w|' tools/hook-scripts/*.pl.in
149
150# override weird -shrext from ruby
151export svn_cv_ruby_link="%{__cc} -shared"
152export svn_cv_ruby_sitedir_libsuffix=""
153export svn_cv_ruby_sitedir_archsuffix=""
154
155export CC=gcc CXX=g++ JAVA_HOME=%{jdk_path} CFLAGS="$RPM_OPT_FLAGS"
156export LIBTOOL=/usr/bin/libtool
157%configure --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
158        --with-swig --with-serf=%{_prefix} \
159        --with-ruby-sitedir=%{rarchdir} \
160        --with-apxs=%{_bindir}/apxs \
161        --disable-mod-activation \
162        --with-apache-libexecdir=%{_libdir}/apache2/modules/ \
163        --with-gnome-keyring \
164        --with-berkeley-db \
165        --disable-mod-activation \
166        --disable-static
167
168make %{?_smp_mflags} all tools
169make swig-py swig-py-lib %{swigdirs}
170make swig-pl swig-pl-lib swig-rb swig-rb-lib
171
172
173%install
174echo %{rarchdir}
175rm -rf $RPM_BUILD_ROOT
176make install \
177        install-swig-py \
178        install-swig-pl-lib \
179        install-swig-rb \
180        DESTDIR=$RPM_BUILD_ROOT %{swigdirs}
181
182make pure_vendor_install -C subversion/bindings/swig/perl/native \
183        PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
184install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/subversion
185
186install -m 755 -d $RPM_BUILD_ROOT%{_libdir}/apache2/modules
187
188# Add subversion.conf configuration file into apache2/conf.d directory.
189install -m 755 -d $RPM_BUILD_ROOT/etc/apache2/conf.d
190install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/apache2/conf.d
191
192# Remove unpackaged files
193rm -rf $RPM_BUILD_ROOT%{_includedir}/subversion-*/*.txt \
194       $RPM_BUILD_ROOT%{python_sitearch}/*/*.{a,la} \
195       $RPM_BUILD_ROOT%{_libdir}/*.la
196
197# The SVN build system is broken w.r.t. DSO support; it treats
198# normal libraries as DSOs and puts them in $libdir, whereas they
199# should go in some subdir somewhere, and be linked using -module,
200# etc.  So, forcibly nuke the .so's for libsvn_auth_{gnome,kde},
201# since nothing should ever link against them directly.
202rm -f ${RPM_BUILD_ROOT}%{_libdir}/libsvn_auth_*.so
203
204# remove stuff produced with Perl modules
205find $RPM_BUILD_ROOT -type f \
206     -a \( -name .packlist -o \( -name '*.bs' -a -empty \) \) \
207     -print0 | xargs -0 rm -f
208
209# make Perl modules writable so they get stripped
210find $RPM_BUILD_ROOT%{_libdir}/perl5 -type f -perm 555 -print0 |
211     xargs -0 chmod 755
212
213# unnecessary libraries for swig bindings
214rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig_*.{so,la,a}
215
216# Remove unnecessary ruby libraries
217rm -f $RPM_BUILD_ROOT%{rarchdir}/svn/ext/*.*a
218
219# Trim what goes in docdir
220rm -rf tools/*/*.in tools/test-scripts
221
222# Rename authz_svn INSTALL doc for docdir
223ln -f subversion/mod_authz_svn/INSTALL mod_authz_svn-INSTALL
224
225# Install bash completion
226install -Dpm 644 tools/client-side/bash_completion \
227        $RPM_BUILD_ROOT%{_datadir}/bash-completion/completions/svn
228for comp in svnadmin svndumpfilter svnlook svnsync svnversion; do
229    ln -s svn \
230       $RPM_BUILD_ROOT%{_datadir}/bash-completion/completions/${comp}
231done
232
233# Install tools ex diff*
234make install-tools DESTDIR=$RPM_BUILD_ROOT toolsdir=%{_bindir}
235rm -f $RPM_BUILD_ROOT%{_bindir}/diff*
236
237for f in svn-populate-node-origins-index \
238         svnauthz-validate svnmucc svnraisetreeconflict; do
239    echo %{_bindir}/$f
240done | tee tools.files | sed 's/^/%%exclude /' > exclude.tools.files
241
242%find_lang %{name}
243
244cat %{name}.lang exclude.tools.files >> %{name}.files
245
246%clean
247rm -rf $RPM_BUILD_ROOT
248
249%post -p /sbin/ldconfig
250
251%postun -p /sbin/ldconfig
252
253%post perl -p /sbin/ldconfig
254
255%postun perl -p /sbin/ldconfig
256
257%post ruby -p /sbin/ldconfig
258
259%postun ruby -p /sbin/ldconfig
260
261%post python -p /sbin/ldconfig
262
263%postun python -p /sbin/ldconfig
264
265%post tools -p /sbin/ldconfig
266
267%postun tools -p /sbin/ldconfig
268
269
270%files
271%defattr(-,root,root)
272%license LICENSE subversion/LICENSE
273%doc BUGS CHANGES COMMITTERS NOTICE INSTALL README
274%{_bindir}/*
275%{_libdir}/libsvn_*.so.*
276%{_localedir}/*/*/subversion.mo
277%{_mandir}/man*/*
278%{_datadir}/bash-completion/completions/*
279%dir %{_sysconfdir}/subversion
280%exclude %{_mandir}/man*/*::*
281%exclude %{_libdir}/libsvn_swig_perl*.so.*
282%exclude %{_libdir}/libsvn_swig_py*.so.*
283%exclude %{_libdir}/libsvn_swig_ruby*.so.*
284
285%files devel
286%defattr(-,root,root)
287%{_includedir}/subversion-1
288%{_libdir}/libsvn*.so
289%exclude %{_libdir}/libsvn_swig_perl*
290%exclude %{_libdir}/libsvn_swig_py*
291%exclude %{_libdir}/libsvn_swig_ruby*
292%{_datadir}/pkgconfig/*
293
294%files mod_dav_svn
295%defattr(-,root,root)
296%config(noreplace) /etc/apache2/conf.d/subversion.conf
297%{apache_dir}/%{_lib}/apache2/modules/mod_*.*
298
299%files tools -f tools.files
300%defattr(-,root,root)
301
302%files perl
303%defattr(-,root,root,-)
304%{perl_vendorarch}/auto/SVN
305%{perl_vendorarch}/SVN
306%{_libdir}/libsvn_swig_perl*
307%{_mandir}/man*/*::*
308
309%files ruby
310%defattr(-,root,root,-)
311%{_libdir}/libsvn_swig_ruby*
312%{rarchdir}/svn
313
314%files python
315%defattr(-,root,root,-)
316%{_libdir}/libsvn_swig_py*
317%{python_sitearch}/libsvn
318%{python_sitearch}/svn
319
320
321%changelog
322* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.4-1
323- new upstream release.
324- rebuilt with perl-5.26.
325- dropped BR:libgnome-keyring-devel.
326- added BR:libxcrypt-devel,libnsl2-devel,libsecret-devel,utf8proc-devel.
327
328* Wed May 31 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.17-1
329- update to 1.8.17
330
331* Sat Sep 12 2015 Daisuke SUZUKI <daisuke@vinelinux.org> 1.8.9-4
332- rebuild with ruby-2.2.3
333
334* Mon Jun 30 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.9-3
335- build with Perl 5.16
336- using %%__perllib_requires
337
338* Fri Jun 27 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.8.9-2
339- rebuild with ruby-2.1.2-6
340
341* Wed Jun 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.8.9-1
342- update to 1.8.9
343- remove unneeded explisit dependency
344- add BR: apache2-devel >= 2.4
345- add BR: libdb-devel instead of db4-devel
346- add R: apache2 > 2.4 to mod_dav_svn
347
348* Fri Apr 18 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.8-1
349- update to 1.8.8
350- add BR: libserf-devel to handle http* scheme
351
352* Thu Oct 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.7-1
353- update to 1.7.7
354- rebuild with ruby-1.9.3
355
356* Tue Sep 18 2012 IWAI, Masaharu <iwai@alib.jp> 1.7.6-1
357- new upstream release
358- update License
359- update rpath patch (Patch3) from Fedora 1.7.6-1.fc19
360- drop deplibs patch (Patch1)
361- drop obsolete patch files: Patch6, 10
362
363* Fri Jun  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
364- new upstream release with security fix (CVE-2011-1752, 1783, 1921)
365- add configure option with-gnome-keyring
366- add BR: keyutils-libs-devel, dbus-devel, libgnome-keyring-devel
367- fix Packager name
368
369* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.16-2
370- build with perl 5.12.3
371- add Requires: perl(:MODULE_COMPAT_...)
372
373* Sat Mar  5 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.16-1
374- new upstream release with security fix
375- add Vendor/Distri tags
376
377* Mon Nov 29 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.15-1
378- new upstream release
379
380* Tue Mar  2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-2
381- fix <BTS:VineLinux:941>
382  - using rpm macro: rarchdir
383  - export svn_cv_ruby_sitedir_libsuffix and svn_cv_ruby_sitedir_archsuffix
384- using rpm macros: perl_vendorarch and python_sitearch
385- add BuildRequires: sqlite3-devel krb5-devel
386
387* Thu Feb 18 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
388- new upstream release
389- update URL
390- update deplibs patch (Patch1) from Fedora 1.6.9-2.fc13
391- update rpath patch (Patch3) from Fedora 1.6.9-2.fc13
392- stop applying pia patch (Patch6): sync Fedora 1.6.9-2.fc13
393- stop applying update-neon-m4 patch (Patch10): sync Fedora 1.6.9-2.fc13
394
395* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.7-1
396- new upstream release
397
398* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.2-1
399- new upstream release
400
401* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.6-2vl5
402- rebuilt with python-2.5.2
403
404* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.6-1vl5
405- new upstream release
406- rebuild with neon-0.28.2
407- dropped old-Patch10 by adding --disable-neon-version-check to %%configure
408- added Patch6, 8, 9, 10 from Fedora Core
409  * Thu Feb 21 2008 Lubomir Kundrak <lkundrak@redhat.com> 1.4.6-5
410  - Correct install location of java stuff (#433295)
411  * Wed Aug  8 2007 Joe Orton <jorton@redhat.com> 1.4.4-3
412  - fix build with new glibc open()-as-macro
413  - build all swig code in %%build, not %%install
414  * Fri May 21 2004 Joe Orton <jorton@redhat.com> 1.0.3-2
415  - build /usr/bin/* as PIEs
416
417* Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.3-0vl2
418- rebuild with expat-2.0.1
419
420* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.3-0vl1
421- new upstream release
422- add Patch10 to build with neon.
423  1.3.2-0vl5 does not support neon..
424
425* Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl4
426- rebuild with new neon
427
428* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.2-0vl3
429- rebuilt with new toolchain and db4-4.3.x
430
431* Sat Mar 31 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.2-0vl2
432- modified %%files section for lib64 architecture
433
434* Tue Aug 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl1
435- new upstream release
436- rebuild with new openldap-2.3.24
437
438* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.1-0vl1
439- new upstream release
440- change Group to Develoment/Tools
441- build with apr-1.2.7/apr-util-1.2.7
442  - require apr/apr-util instead of apache2-apr
443- build with swig-1.3.29
444- split {perl,python,ruby} related files to subpackage.
445
446* Tue Oct 18 2005 IWAI, Masaharu <iwai@alib.jp> 1.2.3-0vl1
447- new upstream release
448- add noreplace option for config file
449
450* Sun Jan 30 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl3
451- fix Requires and BuildPreReq.
452
453* Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl2
454- new upstream release.
455- add swig-runtime to 'BuildPreReq:'.
456- fix %%files.
457
458* Sun Oct 17 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.0.6-0vl1.1
459- require neon version 0.24.7 for ra_dav
460- add BuildPreReq: openldap-devel
461- replace BuildPreReq: httpd to BuildPreReq: apache2
462- replace tools Requires: perl(:MODULE_COMPAT_version) to perl >= 5.8.0
463
464* Wed Jul 21 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.6-0vl1
465- new upstream release
466
467* Tue Jun 22 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.5-0vl1
468- new upstream release
469
470* Fri Jun  4 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.4-0vl1
471- new upstream release
472- clean up specfile.
473
474* Tue Nov 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.32.1-0vl1
475- new upstream release
476- build with apache2-2.0.47
477
478* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.20.0-0vl1
479- build Vine Linux
480
481* Sat Mar 01 2003 David Summers <david@summersoft.fay.ar.us> 0.18.1-5173
482- Enabled RA_DAV checking.
483  Now requires httpd package to build because of RA_DAV tests.
484
485* Sat Jan 18 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4433
486- Created tools package to hold the tools.
487
488* Thu Jan 16 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4405
489- Now requires httpd >= 2.0.44-0.1 (APACHE_2_0_BRANCH) which contains the new
490  version of APR/APR-UTILS as of 2003.01.15.
491- Added svnversion command.
492
493* Tue Dec 31 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4218
494- Create a svnadmin.static which is copied to svnadmin-version-release
495  when the package is erased, so users can still dump/load their repositories
496  even after they have upgraded the RPM package.
497
498* Sat Dec 14 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4128
499- SWIG now builds so we can use cvs2svn.
500
501* Fri Oct 04 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3280
502- Made cvs2svn conditional (at least until we can get it to build consistently
503  and work).
504
505* Sat Sep 21 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3205
506- Added SWIG dependencies to add cvs2svn capabilities.
507
508* Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2984
509- Now requires neon-0.22.0.
510
511* Thu Aug 15 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2978
512- Took out loading mod_dav_svn from subversion.spec file and put it in
513  subversion.conf file which goes into the apache conf directory.
514- Simplify what gets put into httpd.conf to only the include for the
515  subversion.conf file.
516  (Thanks to Scott Harrison <sharrison@users.sourceforge.net> for prompting
517  me to do this).
518
519* Thu Aug 08 2002 David Summers <david@summersoft.fay.ar.us> 0.14.0-2919
520- Updated to APR/APR-UTIL 2002-08-08.
521
522* Tue Jun 25 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2332
523- Updated to APACHE/APR/APR-UTIL 2002-06-25.
524- Previous version had a few problems because of missing apache error/ files.
525
526* Sun Jun 23 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2318
527- Updated to apache-2.0.40-0.3.
528- Updated to subversion-0.13.1-2318.
529
530* Tue Jun 18 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2277
531- Updated for RedHat 7.3 (autoconf253).
532- Added a bunch of pre-requisites I didn't know were needed because I built a
533  new machine that didn't have them already installed.
534- Fixed installation of man and info documentation pages.
535
536* Wed Mar 06 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1447
537- Back to apache-libapr* stuff, hopefully to stay.
538
539* Sun Feb 24 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1373
540- Fixed expat.patch to not have to make so many changes by writing a small
541  shell script that changes libexpat to -lexpat.
542
543* Fri Feb 22 2002 Blair Zajac <blair@orcaware.com> 0.9.0-1364
544- Updated to neon-0.19.2.
545
546* Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1250
547- Back to using apr and apr-util separately from apache.
548
549* Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1232
550- Updated to APR and APR-UTIL 2002.02.11.
551- Updated to apache-2.0.32-0.2. (Requires apache-libapr and apache-libapr-util).
552- Took out a (now non-existant) documentation file.
553- Moved SPEC file changelog to after all package definitions.
554 
555* Sun Feb 03 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1153
556- Updated to neon-0.18.5.
557- Broke up apache and apache-devel into apache-apr, apache-apr-devel,
558  apache-apr-utils, and apache-apr-utils-devel.
559- Updated apache to APR and APR-UTILS to 2002.02.03 version.
560
561* Sat Feb 02 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1147
562- Now builds without the separate APR package as it is built into and
563  "exported" from apache-2.0.31-0.3.
564
565* Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1132
566- Took out patches to install procedure now not required because of fixes
567  in rev 1130.
568
569* Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1129
570- Added requirement for APR 0.2002.01.19 rev 2 where the /usr/bin/apr-config
571  program was added.
572
573* Sun Oct 28 2001 David Summers <david@summersoft.fay.ar.us>
574- Release M5-r340: Added the subversion-server package.
575
576* Fri Oct 26 2001 David Summers <david@summersoft.fay.ar.us>
577- Release M5-r327: No longer need expat-lite. We can use the normal expat.
578
579* Thu Sep 27 2001 David Summers <david@summersoft.fay.ar.us>
580- Release M3-r117: Initial Version.
581
Note: See TracBrowser for help on using the repository browser.