source: projects/specs/trunk/s/subversion/subversion-vl.spec @ 9744

Revision 9744, 17.9 KB checked in by daisuke, 9 years ago (diff)

subversion; rebuild with ruby-2.2.3

Line 
1%define neon_version 0.25.5
2%define swig_version 3.0.0
3%define apache_version 2.4
4%define apache_dir /usr
5
6%define swigdirs swig_pydir=%{python_sitearch}/libsvn swig_pydir_extra=%{python_sitearch}/svn
7
8# set to zero to avoid running test suite
9%define make_check 0
10
11Summary: Modern Version Control System
12Summary(ja): モダンなバージョン管理システム
13Name: subversion
14Version: 1.8.9
15Release: 4%{?_dist_release}
16License: ASL 2.0
17Group: Development/Tools
18URL: http://subversion.apache.org/
19
20Vendor: Project Vine
21Distribution: Vine Linux
22Packager: iwaim, daisuke
23
24SOURCE0: subversion-%{version}.tar.bz2
25SOURCE1: subversion.conf
26SOURCE2: httpd.davcheck.conf
27SOURCE3: filter-requires.sh
28Patch3: subversion-1.7.0-rpath.patch
29
30BuildRequires: apache2-devel >= %{apache_version}
31BuildRequires: apr-devel, apr-util-devel
32BuildRequires: autoconf >= 2.53
33BuildRequires: libdb-devel
34BuildRequires: expat-devel
35BuildRequires: gdbm-devel
36BuildRequires: libtool >= 1.4.2
37BuildRequires: neon-devel >= %{neon_version}
38BuildRequires: openssl-devel
39BuildRequires: python
40BuildRequires: python-devel
41BuildRequires: swig >= %{swig_version}
42BuildRequires: texinfo
43BuildRequires: zlib-devel
44BuildRequires: openldap-devel
45BuildRequires: ruby >= 2.2.3
46BuildRequires: ruby-devel >= 2.2.3
47BuildRequires: perl >= 5.8.0
48BuildRequires: sqlite3-devel
49BuildRequires: krb5-devel
50BuildRequires: keyutils-libs-devel
51BuildRequires: dbus-devel
52BuildRequires: libgnome-keyring-devel
53BuildRequires: libserf-devel
54BuildRoot: %{_tmppath}/%{name}-%{version}-root
55
56%define __perllib_requires %{SOURCE3}
57
58%description
59Subversion is a concurrent version control system which enables one
60or more users to collaborate in developing and maintaining a
61hierarchy of files and directories while keeping a history of all
62changes.  Subversion only stores the differences between versions,
63instead of every complete file.  Subversion is intended to be a
64compelling replacement for CVS.
65
66%package devel
67Group: Development/Libraries
68Summary: Development package for Subversion developers.
69Requires: subversion = %{version}-%{release}
70Requires: apr-devel, apr-util-devel
71%description devel
72The subversion-devel package includes the static libraries and include files
73for developers interacting with the subversion package.
74
75%package mod_dav_svn
76Group: System Environment/Daemons
77Summary: Apache server module for Subversion server.
78Requires: apache2 >= %{apache_version}
79Requires: subversion = %{version}-%{release}
80%description mod_dav_svn
81The subversion-mod_dav_svn package adds the Subversion server Apache module to
82the Apache directories and configuration.
83
84%package tools
85Group: Development/Tools
86Summary: Tools for Subversion
87BuildRequires: perl >= 5.8.0
88Requires: perl >= 5.8.0
89Requires: subversion = %{version}-%{release}
90
91%description tools
92Tools for Subversion.
93
94%package perl
95Group: Development/Libraries
96Summary: Perl bindings to the Subversion libraries
97Requires: subversion = %{version}-%{release}
98Requires: perl >= 5.8.0
99Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
100
101%description perl
102This package includes the Perl bindings to the Subversion libraries.
103
104%package ruby
105Group: Development/Libraries
106Summary: Ruby bindings to the Subversion libraries
107Requires: subversion = %{version}-%{release}
108Requires: ruby >= 2.0
109
110%description ruby
111This package includes the Ruby bindings to the Subversion libraries.
112
113%package python
114Group: Development/Libraries
115Summary: Python bindings to the Subversion libraries
116Requires: subversion = %{version}-%{release}, python
117
118%description python
119This package includes the Python bindings to the Subversion libraries.
120
121%prep
122%setup -q
123%patch3 -p1 -b .rpath
124
125%build
126PATH=/usr/bin:$PATH ./autogen.sh --release
127
128# fix shebang lines, #111498
129perl -pi -e 's|/usr/bin/env perl -w|/usr/bin/perl -w|' tools/hook-scripts/*.pl.in
130
131# override weird -shrext from ruby
132export svn_cv_ruby_link="%{__cc} -shared"
133export svn_cv_ruby_sitedir_libsuffix=""
134export svn_cv_ruby_sitedir_archsuffix=""
135
136export CC=gcc CXX=g++ JAVA_HOME=%{jdk_path} CFLAGS="$RPM_OPT_FLAGS"
137export LIBTOOL=/usr/bin/libtool
138%configure --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
139        --with-swig --with-serf=%{_prefix} \
140        --with-ruby-sitedir=%{rarchdir} \
141        --with-apxs=%{_bindir}/apxs \
142        --disable-mod-activation \
143        --with-apache-libexecdir=%{_libdir}/apache2/modules/ \
144        --with-gnome-keyring \
145        --with-berkeley-db \
146        --disable-mod-activation \
147        --disable-static
148
149make %{?_smp_mflags} all tools
150make swig-py swig-py-lib %{swigdirs}
151make swig-pl swig-pl-lib swig-rb swig-rb-lib
152
153
154%install
155echo %{rarchdir}
156rm -rf $RPM_BUILD_ROOT
157make install \
158        install-swig-py \
159        install-swig-pl-lib \
160        install-swig-rb \
161        DESTDIR=$RPM_BUILD_ROOT %{swigdirs}
162
163make pure_vendor_install -C subversion/bindings/swig/perl/native \
164        PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
165install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/subversion
166
167install -m 755 -d $RPM_BUILD_ROOT%{_libdir}/apache2/modules
168
169# Add subversion.conf configuration file into apache2/conf.d directory.
170install -m 755 -d $RPM_BUILD_ROOT/etc/apache2/conf.d
171install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/apache2/conf.d
172
173# Remove unpackaged files
174rm -rf $RPM_BUILD_ROOT%{_includedir}/subversion-*/*.txt \
175       $RPM_BUILD_ROOT%{python_sitearch}/*/*.{a,la} \
176       $RPM_BUILD_ROOT%{_libdir}/*.la
177
178# The SVN build system is broken w.r.t. DSO support; it treats
179# normal libraries as DSOs and puts them in $libdir, whereas they
180# should go in some subdir somewhere, and be linked using -module,
181# etc.  So, forcibly nuke the .so's for libsvn_auth_{gnome,kde},
182# since nothing should ever link against them directly.
183rm -f ${RPM_BUILD_ROOT}%{_libdir}/libsvn_auth_*.so
184
185# remove stuff produced with Perl modules
186find $RPM_BUILD_ROOT -type f \
187     -a \( -name .packlist -o \( -name '*.bs' -a -empty \) \) \
188     -print0 | xargs -0 rm -f
189
190# make Perl modules writable so they get stripped
191find $RPM_BUILD_ROOT%{_libdir}/perl5 -type f -perm 555 -print0 |
192     xargs -0 chmod 755
193
194# unnecessary libraries for swig bindings
195rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig_*.{so,la,a}
196
197# Remove unnecessary ruby libraries
198rm -f $RPM_BUILD_ROOT%{rarchdir}/svn/ext/*.*a
199
200# Trim what goes in docdir
201rm -rf tools/*/*.in tools/test-scripts
202
203# Rename authz_svn INSTALL doc for docdir
204ln -f subversion/mod_authz_svn/INSTALL mod_authz_svn-INSTALL
205
206# Install bash completion
207install -Dpm 644 tools/client-side/bash_completion \
208        $RPM_BUILD_ROOT%{_datadir}/bash-completion/completions/svn
209for comp in svnadmin svndumpfilter svnlook svnsync svnversion; do
210    ln -s svn \
211       $RPM_BUILD_ROOT%{_datadir}/bash-completion/completions/${comp}
212done
213
214# Install tools ex diff*
215make install-tools DESTDIR=$RPM_BUILD_ROOT toolsdir=%{_bindir}
216rm -f $RPM_BUILD_ROOT%{_bindir}/diff*
217
218for f in svn-populate-node-origins-index svn-rep-sharing-stats \
219         svnauthz-validate svnmucc svnraisetreeconflict; do
220    echo %{_bindir}/$f
221done | tee tools.files | sed 's/^/%%exclude /' > exclude.tools.files
222
223%find_lang %{name}
224
225cat %{name}.lang exclude.tools.files >> %{name}.files
226
227%clean
228rm -rf $RPM_BUILD_ROOT
229
230%post -p /sbin/ldconfig
231
232%postun -p /sbin/ldconfig
233
234%post perl -p /sbin/ldconfig
235
236%postun perl -p /sbin/ldconfig
237
238%post ruby -p /sbin/ldconfig
239
240%postun ruby -p /sbin/ldconfig
241
242%post python -p /sbin/ldconfig
243
244%postun python -p /sbin/ldconfig
245
246%post tools -p /sbin/ldconfig
247
248%postun tools -p /sbin/ldconfig
249
250
251%files
252%defattr(-,root,root)
253%doc BUGS CHANGES COMMITTERS LICENSE NOTICE INSTALL README
254%doc subversion/LICENSE
255%{_bindir}/*
256%{_libdir}/libsvn_*.so.*
257%{_localedir}/*/*/subversion.mo
258%{_mandir}/man*/*
259%{_datadir}/bash-completion/completions/*
260%dir %{_sysconfdir}/subversion
261%exclude %{_mandir}/man*/*::*
262%exclude %{_libdir}/libsvn_swig_perl*.so.*
263%exclude %{_libdir}/libsvn_swig_py*.so.*
264%exclude %{_libdir}/libsvn_swig_ruby*.so.*
265
266%files devel
267%defattr(-,root,root)
268%{_includedir}/subversion-1
269%{_libdir}/libsvn*.so
270%exclude %{_libdir}/libsvn_swig_perl*
271%exclude %{_libdir}/libsvn_swig_py*
272%exclude %{_libdir}/libsvn_swig_ruby*
273
274%files mod_dav_svn
275%defattr(-,root,root)
276%config(noreplace) /etc/apache2/conf.d/subversion.conf
277%{apache_dir}/%{_lib}/apache2/modules/mod_*.*
278
279%files tools -f tools.files
280%defattr(-,root,root)
281
282%files perl
283%defattr(-,root,root,-)
284%{perl_vendorarch}/auto/SVN
285%{perl_vendorarch}/SVN
286%{_libdir}/libsvn_swig_perl*
287%{_mandir}/man*/*::*
288
289%files ruby
290%defattr(-,root,root,-)
291%{_libdir}/libsvn_swig_ruby*
292%{rarchdir}/svn
293
294%files python
295%defattr(-,root,root,-)
296%{_libdir}/libsvn_swig_py*
297%{python_sitearch}/libsvn
298%{python_sitearch}/svn
299
300
301%changelog
302* Sat Sep 12 2015 Daisuke SUZUKI <daisuke@vinelinux.org> 1.8.9-4
303- rebuild with ruby-2.2.3
304
305* Mon Jun 30 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.9-3
306- build with Perl 5.16
307- using %%__perllib_requires
308
309* Fri Jun 27 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.8.9-2
310- rebuild with ruby-2.1.2-6
311
312* Wed Jun 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.8.9-1
313- update to 1.8.9
314- remove unneeded explisit dependency
315- add BR: apache2-devel >= 2.4
316- add BR: libdb-devel instead of db4-devel
317- add R: apache2 > 2.4 to mod_dav_svn
318
319* Fri Apr 18 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.8-1
320- update to 1.8.8
321- add BR: libserf-devel to handle http* scheme
322
323* Thu Oct 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.7-1
324- update to 1.7.7
325- rebuild with ruby-1.9.3
326
327* Tue Sep 18 2012 IWAI, Masaharu <iwai@alib.jp> 1.7.6-1
328- new upstream release
329- update License
330- update rpath patch (Patch3) from Fedora 1.7.6-1.fc19
331- drop deplibs patch (Patch1)
332- drop obsolete patch files: Patch6, 10
333
334* Fri Jun  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
335- new upstream release with security fix (CVE-2011-1752, 1783, 1921)
336- add configure option with-gnome-keyring
337- add BR: keyutils-libs-devel, dbus-devel, libgnome-keyring-devel
338- fix Packager name
339
340* Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.16-2
341- build with perl 5.12.3
342- add Requires: perl(:MODULE_COMPAT_...)
343
344* Sat Mar  5 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.6.16-1
345- new upstream release with security fix
346- add Vendor/Distri tags
347
348* Mon Nov 29 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.15-1
349- new upstream release
350
351* Tue Mar  2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-2
352- fix <BTS:VineLinux:941>
353  - using rpm macro: rarchdir
354  - export svn_cv_ruby_sitedir_libsuffix and svn_cv_ruby_sitedir_archsuffix
355- using rpm macros: perl_vendorarch and python_sitearch
356- add BuildRequires: sqlite3-devel krb5-devel
357
358* Thu Feb 18 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
359- new upstream release
360- update URL
361- update deplibs patch (Patch1) from Fedora 1.6.9-2.fc13
362- update rpath patch (Patch3) from Fedora 1.6.9-2.fc13
363- stop applying pia patch (Patch6): sync Fedora 1.6.9-2.fc13
364- stop applying update-neon-m4 patch (Patch10): sync Fedora 1.6.9-2.fc13
365
366* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.7-1
367- new upstream release
368
369* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.2-1
370- new upstream release
371
372* Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.6-2vl5
373- rebuilt with python-2.5.2
374
375* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.6-1vl5
376- new upstream release
377- rebuild with neon-0.28.2
378- dropped old-Patch10 by adding --disable-neon-version-check to %%configure
379- added Patch6, 8, 9, 10 from Fedora Core
380  * Thu Feb 21 2008 Lubomir Kundrak <lkundrak@redhat.com> 1.4.6-5
381  - Correct install location of java stuff (#433295)
382  * Wed Aug  8 2007 Joe Orton <jorton@redhat.com> 1.4.4-3
383  - fix build with new glibc open()-as-macro
384  - build all swig code in %%build, not %%install
385  * Fri May 21 2004 Joe Orton <jorton@redhat.com> 1.0.3-2
386  - build /usr/bin/* as PIEs
387
388* Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.3-0vl2
389- rebuild with expat-2.0.1
390
391* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.3-0vl1
392- new upstream release
393- add Patch10 to build with neon.
394  1.3.2-0vl5 does not support neon..
395
396* Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl4
397- rebuild with new neon
398
399* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.2-0vl3
400- rebuilt with new toolchain and db4-4.3.x
401
402* Sat Mar 31 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.2-0vl2
403- modified %%files section for lib64 architecture
404
405* Tue Aug 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl1
406- new upstream release
407- rebuild with new openldap-2.3.24
408
409* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.1-0vl1
410- new upstream release
411- change Group to Develoment/Tools
412- build with apr-1.2.7/apr-util-1.2.7
413  - require apr/apr-util instead of apache2-apr
414- build with swig-1.3.29
415- split {perl,python,ruby} related files to subpackage.
416
417* Tue Oct 18 2005 IWAI, Masaharu <iwai@alib.jp> 1.2.3-0vl1
418- new upstream release
419- add noreplace option for config file
420
421* Sun Jan 30 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl3
422- fix Requires and BuildPreReq.
423
424* Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl2
425- new upstream release.
426- add swig-runtime to 'BuildPreReq:'.
427- fix %%files.
428
429* Sun Oct 17 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.0.6-0vl1.1
430- require neon version 0.24.7 for ra_dav
431- add BuildPreReq: openldap-devel
432- replace BuildPreReq: httpd to BuildPreReq: apache2
433- replace tools Requires: perl(:MODULE_COMPAT_version) to perl >= 5.8.0
434
435* Wed Jul 21 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.6-0vl1
436- new upstream release
437
438* Tue Jun 22 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.5-0vl1
439- new upstream release
440
441* Fri Jun  4 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.4-0vl1
442- new upstream release
443- clean up specfile.
444
445* Tue Nov 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.32.1-0vl1
446- new upstream release
447- build with apache2-2.0.47
448
449* Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.20.0-0vl1
450- build Vine Linux
451
452* Sat Mar 01 2003 David Summers <david@summersoft.fay.ar.us> 0.18.1-5173
453- Enabled RA_DAV checking.
454  Now requires httpd package to build because of RA_DAV tests.
455
456* Sat Jan 18 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4433
457- Created tools package to hold the tools.
458
459* Thu Jan 16 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4405
460- Now requires httpd >= 2.0.44-0.1 (APACHE_2_0_BRANCH) which contains the new
461  version of APR/APR-UTILS as of 2003.01.15.
462- Added svnversion command.
463
464* Tue Dec 31 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4218
465- Create a svnadmin.static which is copied to svnadmin-version-release
466  when the package is erased, so users can still dump/load their repositories
467  even after they have upgraded the RPM package.
468
469* Sat Dec 14 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4128
470- SWIG now builds so we can use cvs2svn.
471
472* Fri Oct 04 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3280
473- Made cvs2svn conditional (at least until we can get it to build consistently
474  and work).
475
476* Sat Sep 21 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3205
477- Added SWIG dependencies to add cvs2svn capabilities.
478
479* Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2984
480- Now requires neon-0.22.0.
481
482* Thu Aug 15 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2978
483- Took out loading mod_dav_svn from subversion.spec file and put it in
484  subversion.conf file which goes into the apache conf directory.
485- Simplify what gets put into httpd.conf to only the include for the
486  subversion.conf file.
487  (Thanks to Scott Harrison <sharrison@users.sourceforge.net> for prompting
488  me to do this).
489
490* Thu Aug 08 2002 David Summers <david@summersoft.fay.ar.us> 0.14.0-2919
491- Updated to APR/APR-UTIL 2002-08-08.
492
493* Tue Jun 25 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2332
494- Updated to APACHE/APR/APR-UTIL 2002-06-25.
495- Previous version had a few problems because of missing apache error/ files.
496
497* Sun Jun 23 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2318
498- Updated to apache-2.0.40-0.3.
499- Updated to subversion-0.13.1-2318.
500
501* Tue Jun 18 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2277
502- Updated for RedHat 7.3 (autoconf253).
503- Added a bunch of pre-requisites I didn't know were needed because I built a
504  new machine that didn't have them already installed.
505- Fixed installation of man and info documentation pages.
506
507* Wed Mar 06 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1447
508- Back to apache-libapr* stuff, hopefully to stay.
509
510* Sun Feb 24 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1373
511- Fixed expat.patch to not have to make so many changes by writing a small
512  shell script that changes libexpat to -lexpat.
513
514* Fri Feb 22 2002 Blair Zajac <blair@orcaware.com> 0.9.0-1364
515- Updated to neon-0.19.2.
516
517* Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1250
518- Back to using apr and apr-util separately from apache.
519
520* Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1232
521- Updated to APR and APR-UTIL 2002.02.11.
522- Updated to apache-2.0.32-0.2. (Requires apache-libapr and apache-libapr-util).
523- Took out a (now non-existant) documentation file.
524- Moved SPEC file changelog to after all package definitions.
525 
526* Sun Feb 03 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1153
527- Updated to neon-0.18.5.
528- Broke up apache and apache-devel into apache-apr, apache-apr-devel,
529  apache-apr-utils, and apache-apr-utils-devel.
530- Updated apache to APR and APR-UTILS to 2002.02.03 version.
531
532* Sat Feb 02 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1147
533- Now builds without the separate APR package as it is built into and
534  "exported" from apache-2.0.31-0.3.
535
536* Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1132
537- Took out patches to install procedure now not required because of fixes
538  in rev 1130.
539
540* Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1129
541- Added requirement for APR 0.2002.01.19 rev 2 where the /usr/bin/apr-config
542  program was added.
543
544* Sun Oct 28 2001 David Summers <david@summersoft.fay.ar.us>
545- Release M5-r340: Added the subversion-server package.
546
547* Fri Oct 26 2001 David Summers <david@summersoft.fay.ar.us>
548- Release M5-r327: No longer need expat-lite. We can use the normal expat.
549
550* Thu Sep 27 2001 David Summers <david@summersoft.fay.ar.us>
551- Release M3-r117: Initial Version.
552
Note: See TracBrowser for help on using the repository browser.