source: projects/specs/trunk/s/stunnel/stunnel-vl.spec @ 11960

Revision 11960, 15.4 KB checked in by tomop, 5 years ago (diff)

stunnel-5.49-1

Line 
1%define ver 5.49
2%define rel 1
3
4Summary: An SSL-encrypting socket wrapper
5Name: stunnel
6Version: %{ver}
7Release: %{rel}%{?_dist_release}
8License: GPLv2
9Group: Applications/Internet
10URL: https://www.stunnel.org/
11Source0: https://www.stunnel.org/downloads/stunnel-%{version}.tar.gz
12Source1: https://www.stunnel.org/downloads/stunnel-%{version}.tar.gz.asc
13Source2: Certificate-Creation
14Source3: sfinger.xinetd
15Source4: stunnel-sfinger.conf
16Source5: pop3-redirect.xinetd
17Source6: stunnel-pop3s-client.conf
18Source100: stunnel.init
19Patch0: 0001-authpriv.patch
20Patch1: 0002-config.patch
21Buildroot: %{_tmppath}/stunnel-root
22# util-linux is needed for rename
23BuildRequires: openssl-devel
24BuildRequires: pkgconfig
25BuildRequires: tcp_wrappers
26BuildRequires: util-linux
27
28Vendor: Project Vine
29Distribution: Vine Linux
30Packager: iwaim
31
32%description
33Stunnel is a socket wrapper which can provide SSL (Secure Sockets
34Layer) support to ordinary applications. For example, it can be used
35in conjunction with imapd to create an SSL secure IMAP server.
36
37%prep
38%setup -q
39%patch0 -p1 -b .authpriv
40%patch1 -p1 -b .config
41
42%build
43CFLAGS="$RPM_OPT_FLAGS -fPIC"; export CFLAGS
44if pkg-config openssl ; then
45        CFLAGS="$CFLAGS `pkg-config --cflags openssl`";
46        LDFLAGS="`pkg-config --libs-only-L openssl`"; export LDFLAGS
47fi
48%configure --disable-fips --enable-ipv6 \
49        CPPFLAGS="-UPIDFILE -DPIDFILE='\"%{_localstatedir}/run/stunnel.pid\"'"
50make LDADD="-pie -Wl,-z,defs,-z,relro,-z,now"
51
52%install
53rm -rf $RPM_BUILD_ROOT
54mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/stunnel/conf.d
55touch $RPM_BUILD_ROOT%{_sysconfdir}/stunnel/stunnel.pem
56make install DESTDIR=$RPM_BUILD_ROOT
57# Move the translated man pages to the right subdirectories, and strip off the
58# language suffixes.
59for lang in pl ; do
60        mkdir -p $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8
61        mv $RPM_BUILD_ROOT/%{_mandir}/man8/*.${lang}.8* $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8/
62        rename ".${lang}" "" $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8/*
63done
64
65install -d -m755 %{buildroot}%{_initdir}
66install -m755 %{SOURCE100} %{buildroot}%{_initdir}/stunnel
67
68install -d m755 %{buildroot}%{_sysconfdir}/sysconfig
69cat <<EOF > %{buildroot}%{_sysconfdir}/sysconfig/stunnel
70ENABLED=0
71EOF
72
73mkdir -p srpm-docs
74cp %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} srpm-docs
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79%pre
80getent group stunnel >/dev/null || groupadd -r stunnel
81getent passwd stunnel >/dev/null || \
82useradd -r -g stunnel -d /dev/null -s /sbin/nologin \
83  -c "stunnel service account" stunnel
84
85%post
86/sbin/chkconfig --add stunnel
87
88%preun
89if [ $1 -eq 0 ]; then
90  /sbin/chkconfig --del stunnel
91fi
92
93%files
94%defattr(-,root,root)
95%doc AUTHORS BUGS ChangeLog COPY* CREDITS PORTS README TODO
96%doc tools/stunnel.conf-sample
97%doc srpm-docs/*
98%lang(en) %doc doc/en/*
99%lang(po) %doc doc/pl/*
100%{_bindir}/stunnel
101%{_initdir}/stunnel
102%exclude %{_bindir}/stunnel3
103%exclude %{_datadir}/doc/stunnel
104%{_libdir}/stunnel
105%exclude %{_libdir}/stunnel/libstunnel.la
106%{_mandir}/man8/stunnel.8*
107%lang(pl) %{_mandir}/pl/man8/stunnel.8*
108%dir %{_sysconfdir}/%{name}
109%dir %{_sysconfdir}/%{name}/conf.d
110%exclude %{_sysconfdir}/stunnel/stunnel.conf-sample
111%exclude %{_sysconfdir}/stunnel/stunnel.pem
112%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
113
114%changelog
115* Sat Dec 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.49-1
116- new upstream release.
117- updated Patch0,1.
118
119* Mon Jun 05 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 5.32-2
120- rebuid with OpenSSL 1.0.2k
121
122* Tue May 10 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.32-1
123- new upstream release.
124
125* Tue Mar 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.31-1
126- new upstream release.
127
128* Fri Nov  6 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.25-1
129- new upstream release.
130- fixed dates in %%changelog.
131- updated all patches.
132
133* Tue Jan 15 2013 IWAI, Masaharu <iwai@alib.jp> 4.54-1
134- initial build for Vine Linux
135
136*Mon Dec 10 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.54-2
137- 884183: support for full relro.
138
139*Tue Oct 16 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.54-1
140- New upstream realease 4.54
141- Updated local patches
142
143* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.53-2
144- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
145
146* Mon May 14 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.53-1
147- New upstream realease 4.53
148- Updated local patches
149
150* Tue Mar 6 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.52-1
151- New upstream realease 4.52
152- Updated local patches
153
154* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.50-2
155- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
156
157* Tue Jan 3 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.50-1
158- New upstream realease 4.50
159- Updated local patches
160
161* Tue Sep 20 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.44-1
162- New upstream realease 4.44
163- Updated local patches
164
165* Fri Aug 19 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.42-1
166- New upstream realease 4.42
167- Updated local patches
168- Fixes #732069
169
170* Mon Aug 1 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.41-1
171- New upstream realease 4.41
172- Updated local patches to match the new release
173
174* Tue Jun 28 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.37-1
175- New upstream realease 4.37
176- Updated local patches to match the new release
177
178* Mon Apr 4 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.35-1
179- New upstream realease 4.35
180- Updated authpriv and sample patches to match the new release
181
182* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.34-2
183- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
184
185* Mon Oct 4 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.34-1
186- New upstream realease 4.34
187- Updated authpriv and sample patches to match the new release
188
189* Wed Apr 7 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.33-1
190- New upstream realease 4.33
191- Updated authpriv and sample patches to match the new release
192- Addresses bz 580117 (inted mode support issue)
193
194* Mon Mar 29 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.32-1
195- New upstream realease 4.32
196- Updated authpriv and sample patches to match the new release
197
198* Tue Feb 16 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.31-1
199- New upstream realease 4.31
200- Updated authpriv and sample patches to match the new release
201
202* Tue Jan 26 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.30-1
203- New upstream realease 4.30
204- Updated authpriv and sample patches for the new release
205
206* Wed Dec 09 2009 Avesh Agarwal <avagarwa@redhat.com> - 4.29-1
207- New upstream realease 4.29
208- Updated authpriv and sample patches for the new release
209- Modified spec file to include dist tag
210
211* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 4.27-5
212- rebuilt with new openssl
213
214* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.27-4
215- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
216
217* Sun May  3 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-3
218- Fix the previous patch.
219
220* Wed Apr 29 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-2
221- Avoid aliasing undefined by ISO C
222
223* Thu Apr 16 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-1
224- Update to stunnel-4.27.
225
226* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.26-3
227- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
228
229* Sun Jan 18 2009 Tomas Mraz <tmraz@redhat.com> - 4.26-2
230- disable openssl upstream fips mode
231
232* Mon Sep 22 2008 Miloslav Trmač <mitr@redhat.com> - 4.26-1
233- Update to stunnel-4.26.
234
235* Sun Jun  8 2008 Miloslav Trmač <mitr@redhat.com> - 4.25-2
236- Use a clearer error message if the service name is unknown in "accept"
237  Resolves: #450344
238
239* Mon Jun  2 2008 Miloslav Trmač <mitr@redhat.com> - 4.25-1
240- Update to stunnel-4.25
241
242* Tue May 20 2008 Miloslav Trmač <mitr@redhat.com> - 4.24-2
243- Drop stunnel3
244  Resolves: #442842
245
246* Mon May 19 2008 Miloslav Trmač <mitr@redhat.com> - 4.24-1
247- Update to stunnel-4.24
248
249* Fri Mar 28 2008 Miloslav Trmač <mitr@redhat.com> - 4.22-1
250- Update to stunnel-4.22
251
252* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 4.20-6
253- Autorebuild for GCC 4.3
254
255* Tue Dec  4 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-5
256- Rebuild with openssl-0.9.8g
257
258* Tue Oct 16 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-4
259- Revert the port to NSS, wait for NSS-based stunnel 5.x instead
260  Resolves: #301971
261- Mark localized man pages with %%lang (patch by Ville Skyttä)
262  Resolves: #322281
263
264* Tue Aug 28 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-3.nss
265- Port to NSS
266
267* Mon Dec  4 2006 Miloslav Trmac <mitr@redhat.com> - 4.20-2
268- Update BuildRequires for the separate tcp_wrappers-devel package
269
270* Thu Nov 30 2006 Miloslav Trmac <mitr@redhat.com> - 4.20-1
271- Update to stunnel-4.20
272
273* Sat Nov 11 2006 Miloslav Trmac <mitr@redhat.com> - 4.19-1
274- Update to stunnel-4.19
275
276* Wed Oct 25 2006 Miloslav Trmac <mitr@redhat.com> - 4.18-1
277- Update to stunnel-4.18
278- Remove unused stunnel.cnf from the src.rpm
279- Fix some rpmlint warnings
280
281* Fri Aug 18 2006 Jesse Keating <jkeating@redhat.com> - 4.15-2
282- rebuilt with latest binutils to pick up 64K -z commonpagesize on ppc*
283  (#203001)
284
285* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 4.15-1.1
286- rebuild
287
288* Sat Mar 18 2006 Miloslav Trmac <mitr@redhat.com> - 4.15-1
289- Update to stunnel-4.15
290
291* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.14-3.2
292- bump again for double-long bug on ppc(64)
293
294* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.14-3.1
295- rebuilt for new gcc4.1 snapshot and glibc changes
296
297* Tue Jan 31 2006 Miloslav Trmac <mitr@redhat.com> - 4.14-3
298- Use pthread threading to fix crash on x86_64 (#179236)
299
300* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
301- rebuilt
302
303* Wed Nov  9 2005 Miloslav Trmac <mitr@redhat.com> - 4.14-2
304- Rebuild with newer openssl
305
306* Thu Nov  3 2005 Miloslav Trmac <mitr@redhat.com> - 4.14-1
307- Update to stunnel-4.14
308- Override changed default pid file location, keep it in %%{_localstatedir}/run
309
310* Sat Oct 22 2005 Miloslav Trmac <mitr@redhat.com> - 4.13-1
311- Update to stunnel-4.13
312
313* Fri Sep 30 2005 Miloslav Trmac <mitr@redhat.com> - 4.12-1
314- Update to stunnel-4.12
315
316* Thu Sep 22 2005 Miloslav Trmac <mitr@redhat.com> - 4.11-2
317- Enable IPv6 (#169050, patch by Peter Bieringer)
318- Don't ship another copy of man pages in HTML
319
320* Tue Jul 12 2005 Miloslav Trmac <mitr@redhat.com> - 4.11-1
321- Update to stunnel-4.11
322- Fix int/size_t mismatches in stack_info ()
323- Update Certificate-Creation for /etc/pki
324
325* Wed Jun  1 2005 Miloslav Trmac <mitr@redhat.com> - 4.10-2
326- Fix inetd mode
327- Remove unnecessary Requires: and BuildRequires:
328- Clean up the spec file
329
330* Tue Apr 26 2005 Nalin Dahyabhai <nalin@redhat.com> 4.10-1
331- update to 4.10
332
333* Tue Apr 26 2005 Nalin Dahyabhai <nalin@redhat.com> 4.08-2
334- add buildprereqs on libtool, util-linux; change textutils/fileutils dep to
335  coreutils (#133961)
336
337* Wed Mar 16 2005 Nalin Dahyabhai <nalin@redhat.com> 4.08-1
338- update to 4.08
339- build stunnel as a PIE binary
340
341* Mon Nov 22 2004 Miloslav Trmac <mitr@redhat.com> - 4.05-4
342- Convert man pages to UTF-8
343
344* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
345- rebuilt
346
347* Thu May 27 2004 Nalin Dahyabhai <nalin@redhat.com> 4.05-2
348- move the sample configuration to %%doc, it shouldn't be used as-is (#124373)
349
350* Thu Mar 11 2004 Nalin Dahyabhai <nalin@redhat.com> 4.05-1
351- update to 4.05
352
353* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
354- rebuilt
355
356* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
357- rebuilt
358
359* Thu Aug  7 2003 Elliot Lee <sopwith@redhat.com> 4.04-6
360- Fix libtool
361
362* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
363- rebuilt
364
365* Fri Mar 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-4
366- fix xinetd configuration samples
367
368* Mon Feb 10 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-3
369- rebuild
370
371* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
372- rebuilt
373
374* Wed Jan 15 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-1
375- update to 4.04
376
377* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 4.03-1
378- use pkgconfig for information about openssl, if available
379
380* Fri Jan  3 2003 Nalin Dahyabhai <nalin@redhat.com>
381- update to 4.03
382
383* Mon Oct 21 2002 Nalin Dahyabhai <nalin@redhat.com> 4.02-1
384- update to 4.02
385
386* Fri Oct  4 2002 Nalin Dahyabhai <nalin@redhat.com> 4.00-1
387- don't create a dummy cert
388
389* Wed Sep 25 2002 Nalin Dahyabhai <nalin@redhat.com>
390- update to 4.00
391- remove textutils and fileutils as buildreqs, add automake/autoconf
392
393* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
394- automated rebuild
395
396* Sun May 26 2002 Tim Powers <timp@redhat.com>
397- automated rebuild
398
399* Fri May 17 2002 Nalin Dahyabhai <nalin@redhat.com> 3.22-2
400- rebuild in new environment
401
402* Wed Jan  2 2002 Nalin Dahyabhai <nalin@redhat.com> 3.22-1
403- update to 3.22, correcting a format-string vulnerability
404
405* Wed Oct 31 2001 Nalin Dahyabhai <nalin@redhat.com> 3.21a-1
406- update to 3.21a
407
408* Tue Aug 28 2001 Nalin Dahyabhai <nalin@redhat.com> 3.20-1
409- log using LOG_AUTHPRIV facility by default (#47289)
410- make permissions on stunnel binary 0755
411- implicitly trust certificates in %%{_datadir}/ssl/trusted (#24034)
412
413* Fri Aug 10 2001 Nalin Dahyabhai <nalin@redhat.com> 3.19-1
414- update to 3.19 to avoid problems with stunnel being multithreaded, but
415  tcp wrappers not being thrad-safe
416
417* Mon Jul 30 2001 Nalin Dahyabhai <nalin@redhat.com>
418- update to 3.17
419
420* Mon Jul 23 2001 Nalin Dahyabhai <nalin@redhat.com>
421- update to 3.16
422
423* Mon Jul 16 2001 Nalin Dahyabhai <nalin@redhat.com>
424- update to 3.15
425- enable tcp-wrappers support
426
427* Tue May 29 2001 Nalin Dahyabhai <nalin@redhat.com>
428- remove explicit requirement on openssl (specific version isn't enough,
429  we have to depend on shared library version anyway)
430
431* Fri Apr 27 2001 Nalin Dahyabhai <nalin@redhat.com>
432- update to 3.14
433
434* Mon Mar 26 2001 Preston Brown <pbrown@redhat.com>
435- depend on make (#33148)
436
437* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
438- rebuild in new environment
439
440* Tue Feb  6 2001 Nalin Dahyabhai <nalin@redhat.com>
441- update to 3.13 to get pthread, OOB, 64-bit fixes
442- don't need sdf any more
443
444* Thu Dec 28 2000 Nalin Dahyabhai <nalin@redhat.com>
445- pull in sdf to build the man page (#22892)
446
447* Fri Dec 22 2000 Nalin Dahyabhai <nalin@redhat.com>
448- update to 3.11
449- chuck the SIGHUP patch (went upstream)
450- chuck parts of the 64-bit clean patch (went upstream)
451
452* Thu Dec 21 2000 Nalin Dahyabhai <nalin@redhat.com>
453- update to 3.10
454- more 64-bit clean changes, hopefully the last bunch
455
456* Wed Dec 20 2000 Nalin Dahyabhai <nalin@redhat.com>
457- change piddir from the default /var/stunnel to /var/run
458- clean out pid file on SIGHUP
459
460* Fri Dec 15 2000 Nalin Dahyabhai <nalin@redhat.com>
461- update to 3.9 to get a security fix
462
463* Wed Oct 25 2000 Matt Wilson <msw@redhat.com>
464- change all unsigned longs to u_int32_t when dealing with network
465  addresses
466
467* Fri Aug 18 2000 Nalin Dahyabhai <nalin@redhat.com>
468- make stunnel.pem also be (missingok)
469
470* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
471- move to Applications/Internet group
472- clean up %%post script
473- make stunnel.pem %%ghost %%config(noreplace)
474- provide a sample file for use with xinetd
475
476* Thu Jun  8 2000 Nalin Dahyabhai <nalin@redhat.com>
477- FHS compliance fixes
478- modify defaults
479
480* Tue Mar 14 2000 Florian La Roche <Florian.LaRoche@redhat.com>
481- update to 3.8
482- do not create certificate if one already exists
483
484* Mon Feb 21 2000 Florian La Roche <Florian.LaRoche@redhat.com>
485- update to 3.7
486- add patch to find /usr/share/ssl
487- change some perms
488
489* Sat Oct 30 1999 Bernhard Rosenkraenzer <bero@redhat.com>
490- Modify spec file to match Red Hat standards
491
492* Thu Aug 12 1999 Damien Miller <damien@ibs.com.au>
493- Updated to 3.4a
494- Patched for OpenSSL 0.9.4
495- Cleaned up files section
496
497* Sun Jul 11 1999 Damien Miller <dmiller@ilogic.com.au>
498- Updated to 3.3
499
500* Sat Nov 28 1998 Damien Miller <dmiller@ilogic.com.au>
501- Initial RPMification
Note: See TracBrowser for help on using the repository browser.