source: projects/specs/trunk/s/stunnel/stunnel-vl.spec @ 11095

Revision 11095, 15.3 KB checked in by iwaim, 7 years ago (diff)

stunnel 5.32-2

Line 
1%define ver 5.32
2%define rel 2
3
4Summary: An SSL-encrypting socket wrapper
5Name: stunnel
6Version: %{ver}
7Release: %{rel}%{?_dist_release}
8License: GPLv2
9Group: Applications/Internet
10URL: https://www.stunnel.org/
11Source0: https://www.stunnel.org/downloads/stunnel-%{version}.tar.gz
12Source1: https://www.stunnel.org/downloads/stunnel-%{version}.tar.gz.asc
13Source2: Certificate-Creation
14Source3: sfinger.xinetd
15Source4: stunnel-sfinger.conf
16Source5: pop3-redirect.xinetd
17Source6: stunnel-pop3s-client.conf
18Source100: stunnel.init
19Patch0: stunnel-5.25-authpriv.patch
20Patch1: stunnel-5.25-config.patch
21Buildroot: %{_tmppath}/stunnel-root
22# util-linux is needed for rename
23BuildRequires: openssl-devel
24BuildRequires: pkgconfig
25BuildRequires: tcp_wrappers
26BuildRequires: util-linux
27
28Vendor: Project Vine
29Distribution: Vine Linux
30Packager: iwaim
31
32%description
33Stunnel is a socket wrapper which can provide SSL (Secure Sockets
34Layer) support to ordinary applications. For example, it can be used
35in conjunction with imapd to create an SSL secure IMAP server.
36
37%prep
38%setup -q
39%patch0 -p1 -b .authpriv
40%patch1 -p1 -b .config
41
42%build
43CFLAGS="$RPM_OPT_FLAGS -fPIC"; export CFLAGS
44if pkg-config openssl ; then
45        CFLAGS="$CFLAGS `pkg-config --cflags openssl`";
46        LDFLAGS="`pkg-config --libs-only-L openssl`"; export LDFLAGS
47fi
48%configure --disable-fips --enable-ipv6 \
49        CPPFLAGS="-UPIDFILE -DPIDFILE='\"%{_localstatedir}/run/stunnel.pid\"'"
50make LDADD="-pie -Wl,-z,defs,-z,relro,-z,now"
51
52%install
53rm -rf $RPM_BUILD_ROOT
54mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/stunnel/conf.d
55touch $RPM_BUILD_ROOT%{_sysconfdir}/stunnel/stunnel.pem
56make install DESTDIR=$RPM_BUILD_ROOT
57# Move the translated man pages to the right subdirectories, and strip off the
58# language suffixes.
59for lang in pl ; do
60        mkdir -p $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8
61        mv $RPM_BUILD_ROOT/%{_mandir}/man8/*.${lang}.8* $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8/
62        rename ".${lang}" "" $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8/*
63done
64
65install -d -m755 %{buildroot}%{_initdir}
66install -m755 %{SOURCE100} %{buildroot}%{_initdir}/stunnel
67
68install -d m755 %{buildroot}%{_sysconfdir}/sysconfig
69cat <<EOF > %{buildroot}%{_sysconfdir}/sysconfig/stunnel
70ENABLED=0
71EOF
72
73mkdir -p srpm-docs
74cp %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} srpm-docs
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79%pre
80getent group stunnel >/dev/null || groupadd -r stunnel
81getent passwd stunnel >/dev/null || \
82useradd -r -g stunnel -d /dev/null -s /sbin/nologin \
83  -c "stunnel service account" stunnel
84
85%post
86/sbin/chkconfig --add stunnel
87
88%preun
89if [ $1 -eq 0 ]; then
90  /sbin/chkconfig --del stunnel
91fi
92
93%files
94%defattr(-,root,root)
95%doc AUTHORS BUGS ChangeLog COPY* CREDITS PORTS README TODO
96%doc tools/stunnel.conf-sample
97%doc srpm-docs/*
98%lang(en) %doc doc/en/*
99%lang(po) %doc doc/pl/*
100%{_bindir}/stunnel
101%{_initdir}/stunnel
102%exclude %{_bindir}/stunnel3
103%exclude %{_datadir}/doc/stunnel
104%{_libdir}/stunnel
105%exclude %{_libdir}/stunnel/libstunnel.la
106%{_mandir}/man8/stunnel.8*
107%lang(pl) %{_mandir}/pl/man8/stunnel.8*
108%dir %{_sysconfdir}/%{name}
109%dir %{_sysconfdir}/%{name}/conf.d
110%exclude %{_sysconfdir}/stunnel/stunnel.conf-sample
111%exclude %{_sysconfdir}/stunnel/stunnel.pem
112%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
113
114%changelog
115* Mon Jun 05 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 5.32-2
116- rebuid with OpenSSL 1.0.2k
117
118* Tue May 10 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.32-1
119- new upstream release.
120
121* Tue Mar 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.31-1
122- new upstream release.
123
124* Fri Nov  6 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.25-1
125- new upstream release.
126- fixed dates in %%changelog.
127- updated all patches.
128
129* Tue Jan 15 2013 IWAI, Masaharu <iwai@alib.jp> 4.54-1
130- initial build for Vine Linux
131
132*Mon Dec 10 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.54-2
133- 884183: support for full relro.
134
135*Tue Oct 16 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.54-1
136- New upstream realease 4.54
137- Updated local patches
138
139* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.53-2
140- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
141
142* Mon May 14 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.53-1
143- New upstream realease 4.53
144- Updated local patches
145
146* Tue Mar 6 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.52-1
147- New upstream realease 4.52
148- Updated local patches
149
150* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.50-2
151- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
152
153* Tue Jan 3 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.50-1
154- New upstream realease 4.50
155- Updated local patches
156
157* Tue Sep 20 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.44-1
158- New upstream realease 4.44
159- Updated local patches
160
161* Fri Aug 19 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.42-1
162- New upstream realease 4.42
163- Updated local patches
164- Fixes #732069
165
166* Mon Aug 1 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.41-1
167- New upstream realease 4.41
168- Updated local patches to match the new release
169
170* Tue Jun 28 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.37-1
171- New upstream realease 4.37
172- Updated local patches to match the new release
173
174* Mon Apr 4 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.35-1
175- New upstream realease 4.35
176- Updated authpriv and sample patches to match the new release
177
178* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.34-2
179- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
180
181* Mon Oct 4 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.34-1
182- New upstream realease 4.34
183- Updated authpriv and sample patches to match the new release
184
185* Wed Apr 7 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.33-1
186- New upstream realease 4.33
187- Updated authpriv and sample patches to match the new release
188- Addresses bz 580117 (inted mode support issue)
189
190* Mon Mar 29 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.32-1
191- New upstream realease 4.32
192- Updated authpriv and sample patches to match the new release
193
194* Tue Feb 16 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.31-1
195- New upstream realease 4.31
196- Updated authpriv and sample patches to match the new release
197
198* Tue Jan 26 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.30-1
199- New upstream realease 4.30
200- Updated authpriv and sample patches for the new release
201
202* Wed Dec 09 2009 Avesh Agarwal <avagarwa@redhat.com> - 4.29-1
203- New upstream realease 4.29
204- Updated authpriv and sample patches for the new release
205- Modified spec file to include dist tag
206
207* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 4.27-5
208- rebuilt with new openssl
209
210* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.27-4
211- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
212
213* Sun May  3 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-3
214- Fix the previous patch.
215
216* Wed Apr 29 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-2
217- Avoid aliasing undefined by ISO C
218
219* Thu Apr 16 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-1
220- Update to stunnel-4.27.
221
222* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.26-3
223- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
224
225* Sun Jan 18 2009 Tomas Mraz <tmraz@redhat.com> - 4.26-2
226- disable openssl upstream fips mode
227
228* Mon Sep 22 2008 Miloslav Trmač <mitr@redhat.com> - 4.26-1
229- Update to stunnel-4.26.
230
231* Sun Jun  8 2008 Miloslav Trmač <mitr@redhat.com> - 4.25-2
232- Use a clearer error message if the service name is unknown in "accept"
233  Resolves: #450344
234
235* Mon Jun  2 2008 Miloslav Trmač <mitr@redhat.com> - 4.25-1
236- Update to stunnel-4.25
237
238* Tue May 20 2008 Miloslav Trmač <mitr@redhat.com> - 4.24-2
239- Drop stunnel3
240  Resolves: #442842
241
242* Mon May 19 2008 Miloslav Trmač <mitr@redhat.com> - 4.24-1
243- Update to stunnel-4.24
244
245* Fri Mar 28 2008 Miloslav Trmač <mitr@redhat.com> - 4.22-1
246- Update to stunnel-4.22
247
248* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 4.20-6
249- Autorebuild for GCC 4.3
250
251* Tue Dec  4 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-5
252- Rebuild with openssl-0.9.8g
253
254* Tue Oct 16 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-4
255- Revert the port to NSS, wait for NSS-based stunnel 5.x instead
256  Resolves: #301971
257- Mark localized man pages with %%lang (patch by Ville Skyttä)
258  Resolves: #322281
259
260* Tue Aug 28 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-3.nss
261- Port to NSS
262
263* Mon Dec  4 2006 Miloslav Trmac <mitr@redhat.com> - 4.20-2
264- Update BuildRequires for the separate tcp_wrappers-devel package
265
266* Thu Nov 30 2006 Miloslav Trmac <mitr@redhat.com> - 4.20-1
267- Update to stunnel-4.20
268
269* Sat Nov 11 2006 Miloslav Trmac <mitr@redhat.com> - 4.19-1
270- Update to stunnel-4.19
271
272* Wed Oct 25 2006 Miloslav Trmac <mitr@redhat.com> - 4.18-1
273- Update to stunnel-4.18
274- Remove unused stunnel.cnf from the src.rpm
275- Fix some rpmlint warnings
276
277* Fri Aug 18 2006 Jesse Keating <jkeating@redhat.com> - 4.15-2
278- rebuilt with latest binutils to pick up 64K -z commonpagesize on ppc*
279  (#203001)
280
281* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 4.15-1.1
282- rebuild
283
284* Sat Mar 18 2006 Miloslav Trmac <mitr@redhat.com> - 4.15-1
285- Update to stunnel-4.15
286
287* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.14-3.2
288- bump again for double-long bug on ppc(64)
289
290* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.14-3.1
291- rebuilt for new gcc4.1 snapshot and glibc changes
292
293* Tue Jan 31 2006 Miloslav Trmac <mitr@redhat.com> - 4.14-3
294- Use pthread threading to fix crash on x86_64 (#179236)
295
296* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
297- rebuilt
298
299* Wed Nov  9 2005 Miloslav Trmac <mitr@redhat.com> - 4.14-2
300- Rebuild with newer openssl
301
302* Thu Nov  3 2005 Miloslav Trmac <mitr@redhat.com> - 4.14-1
303- Update to stunnel-4.14
304- Override changed default pid file location, keep it in %%{_localstatedir}/run
305
306* Sat Oct 22 2005 Miloslav Trmac <mitr@redhat.com> - 4.13-1
307- Update to stunnel-4.13
308
309* Fri Sep 30 2005 Miloslav Trmac <mitr@redhat.com> - 4.12-1
310- Update to stunnel-4.12
311
312* Thu Sep 22 2005 Miloslav Trmac <mitr@redhat.com> - 4.11-2
313- Enable IPv6 (#169050, patch by Peter Bieringer)
314- Don't ship another copy of man pages in HTML
315
316* Tue Jul 12 2005 Miloslav Trmac <mitr@redhat.com> - 4.11-1
317- Update to stunnel-4.11
318- Fix int/size_t mismatches in stack_info ()
319- Update Certificate-Creation for /etc/pki
320
321* Wed Jun  1 2005 Miloslav Trmac <mitr@redhat.com> - 4.10-2
322- Fix inetd mode
323- Remove unnecessary Requires: and BuildRequires:
324- Clean up the spec file
325
326* Tue Apr 26 2005 Nalin Dahyabhai <nalin@redhat.com> 4.10-1
327- update to 4.10
328
329* Tue Apr 26 2005 Nalin Dahyabhai <nalin@redhat.com> 4.08-2
330- add buildprereqs on libtool, util-linux; change textutils/fileutils dep to
331  coreutils (#133961)
332
333* Wed Mar 16 2005 Nalin Dahyabhai <nalin@redhat.com> 4.08-1
334- update to 4.08
335- build stunnel as a PIE binary
336
337* Mon Nov 22 2004 Miloslav Trmac <mitr@redhat.com> - 4.05-4
338- Convert man pages to UTF-8
339
340* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
341- rebuilt
342
343* Thu May 27 2004 Nalin Dahyabhai <nalin@redhat.com> 4.05-2
344- move the sample configuration to %%doc, it shouldn't be used as-is (#124373)
345
346* Thu Mar 11 2004 Nalin Dahyabhai <nalin@redhat.com> 4.05-1
347- update to 4.05
348
349* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
350- rebuilt
351
352* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
353- rebuilt
354
355* Thu Aug  7 2003 Elliot Lee <sopwith@redhat.com> 4.04-6
356- Fix libtool
357
358* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
359- rebuilt
360
361* Fri Mar 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-4
362- fix xinetd configuration samples
363
364* Mon Feb 10 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-3
365- rebuild
366
367* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
368- rebuilt
369
370* Wed Jan 15 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-1
371- update to 4.04
372
373* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 4.03-1
374- use pkgconfig for information about openssl, if available
375
376* Fri Jan  3 2003 Nalin Dahyabhai <nalin@redhat.com>
377- update to 4.03
378
379* Mon Oct 21 2002 Nalin Dahyabhai <nalin@redhat.com> 4.02-1
380- update to 4.02
381
382* Fri Oct  4 2002 Nalin Dahyabhai <nalin@redhat.com> 4.00-1
383- don't create a dummy cert
384
385* Wed Sep 25 2002 Nalin Dahyabhai <nalin@redhat.com>
386- update to 4.00
387- remove textutils and fileutils as buildreqs, add automake/autoconf
388
389* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
390- automated rebuild
391
392* Sun May 26 2002 Tim Powers <timp@redhat.com>
393- automated rebuild
394
395* Fri May 17 2002 Nalin Dahyabhai <nalin@redhat.com> 3.22-2
396- rebuild in new environment
397
398* Wed Jan  2 2002 Nalin Dahyabhai <nalin@redhat.com> 3.22-1
399- update to 3.22, correcting a format-string vulnerability
400
401* Wed Oct 31 2001 Nalin Dahyabhai <nalin@redhat.com> 3.21a-1
402- update to 3.21a
403
404* Tue Aug 28 2001 Nalin Dahyabhai <nalin@redhat.com> 3.20-1
405- log using LOG_AUTHPRIV facility by default (#47289)
406- make permissions on stunnel binary 0755
407- implicitly trust certificates in %%{_datadir}/ssl/trusted (#24034)
408
409* Fri Aug 10 2001 Nalin Dahyabhai <nalin@redhat.com> 3.19-1
410- update to 3.19 to avoid problems with stunnel being multithreaded, but
411  tcp wrappers not being thrad-safe
412
413* Mon Jul 30 2001 Nalin Dahyabhai <nalin@redhat.com>
414- update to 3.17
415
416* Mon Jul 23 2001 Nalin Dahyabhai <nalin@redhat.com>
417- update to 3.16
418
419* Mon Jul 16 2001 Nalin Dahyabhai <nalin@redhat.com>
420- update to 3.15
421- enable tcp-wrappers support
422
423* Tue May 29 2001 Nalin Dahyabhai <nalin@redhat.com>
424- remove explicit requirement on openssl (specific version isn't enough,
425  we have to depend on shared library version anyway)
426
427* Fri Apr 27 2001 Nalin Dahyabhai <nalin@redhat.com>
428- update to 3.14
429
430* Mon Mar 26 2001 Preston Brown <pbrown@redhat.com>
431- depend on make (#33148)
432
433* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
434- rebuild in new environment
435
436* Tue Feb  6 2001 Nalin Dahyabhai <nalin@redhat.com>
437- update to 3.13 to get pthread, OOB, 64-bit fixes
438- don't need sdf any more
439
440* Thu Dec 28 2000 Nalin Dahyabhai <nalin@redhat.com>
441- pull in sdf to build the man page (#22892)
442
443* Fri Dec 22 2000 Nalin Dahyabhai <nalin@redhat.com>
444- update to 3.11
445- chuck the SIGHUP patch (went upstream)
446- chuck parts of the 64-bit clean patch (went upstream)
447
448* Thu Dec 21 2000 Nalin Dahyabhai <nalin@redhat.com>
449- update to 3.10
450- more 64-bit clean changes, hopefully the last bunch
451
452* Wed Dec 20 2000 Nalin Dahyabhai <nalin@redhat.com>
453- change piddir from the default /var/stunnel to /var/run
454- clean out pid file on SIGHUP
455
456* Fri Dec 15 2000 Nalin Dahyabhai <nalin@redhat.com>
457- update to 3.9 to get a security fix
458
459* Wed Oct 25 2000 Matt Wilson <msw@redhat.com>
460- change all unsigned longs to u_int32_t when dealing with network
461  addresses
462
463* Fri Aug 18 2000 Nalin Dahyabhai <nalin@redhat.com>
464- make stunnel.pem also be (missingok)
465
466* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
467- move to Applications/Internet group
468- clean up %%post script
469- make stunnel.pem %%ghost %%config(noreplace)
470- provide a sample file for use with xinetd
471
472* Thu Jun  8 2000 Nalin Dahyabhai <nalin@redhat.com>
473- FHS compliance fixes
474- modify defaults
475
476* Tue Mar 14 2000 Florian La Roche <Florian.LaRoche@redhat.com>
477- update to 3.8
478- do not create certificate if one already exists
479
480* Mon Feb 21 2000 Florian La Roche <Florian.LaRoche@redhat.com>
481- update to 3.7
482- add patch to find /usr/share/ssl
483- change some perms
484
485* Sat Oct 30 1999 Bernhard Rosenkraenzer <bero@redhat.com>
486- Modify spec file to match Red Hat standards
487
488* Thu Aug 12 1999 Damien Miller <damien@ibs.com.au>
489- Updated to 3.4a
490- Patched for OpenSSL 0.9.4
491- Cleaned up files section
492
493* Sun Jul 11 1999 Damien Miller <dmiller@ilogic.com.au>
494- Updated to 3.3
495
496* Sat Nov 28 1998 Damien Miller <dmiller@ilogic.com.au>
497- Initial RPMification
Note: See TracBrowser for help on using the repository browser.