source: projects/specs/trunk/s/strongswan/strongswan-vl.spec @ 12476

Revision 12476, 26.6 KB checked in by tomop, 4 years ago (diff)

updated 9 packages

createrepo_c-0.16.0-1

dovecot-2.3.11.3-2

libsmbios-2.4.3-2

python-sphinx-3.2.1-2

python-sphinxcontrib-jsmath-1.0.1-10

rspamd-2.5-3

strongswan-5.9.0-1

system-storage-manager-1.4-1

trousers-0.3.14-1

Line 
1%bcond_with systemd
2%bcond_with fips2
3%bcond_without tss
4
5%global _unpackaged_files_terminate_build 1
6%global _hardened_build 0
7#%%define prerelease dr1
8
9Name:           strongswan
10Version:        5.9.0
11Release:        1%{?_dist_release}%{?with_systemd:.systemd}
12Summary:        An OpenSource IPsec-based VPN and TNC solution
13Summary(ja):    オープンソースのIPsec VPN/TNCソリューション
14Group:          servers,security
15Vendor:         Project Vine
16Distribution:   Vine Linux
17
18License:        GPLv2+
19URL:            https://www.strongswan.org/
20Source0:        https://download.strongswan.org/%{name}-%{version}%{?prerelease}.tar.bz2
21Source1:        tmpfiles-strongswan.conf
22Source1000:     strongswan.init
23Patch0:         strongswan-5.8.4-runtime-dir.patch
24Patch1:         strongswan-5.6.0-uintptr_t.patch
25Patch3:         strongswan-5.6.2-CVE-2018-5388.patch
26
27# only needed for pre-release versions
28#BuildRequires:  autoconf automake
29
30BuildRequires:  gmp-devel
31BuildRequires:  curl-devel
32BuildRequires:  openldap-devel
33BuildRequires:  openssl-devel
34BuildRequires:  sqlite3-devel
35BuildRequires:  gettext-devel
36BuildRequires:  libxml2-devel
37BuildRequires:  pam-devel
38BuildRequires:  libgcrypt-devel
39BuildRequires:  iptables-devel
40%if %{with tss}
41BuildRequires:  trousers-devel
42BuildRequires:  json-c-devel >= 0.14
43%endif
44
45%if "%{?_dist_release}" != "vl6"
46BuildRequires:  NetworkManager-libnm-devel
47%endif
48
49%if %{with systemd}
50BuildRequires:  systemd-devel
51Requires(post): systemd
52Requires(preun): systemd
53Requires(postun): systemd
54%else
55Requires(post): /sbin/chkconfig
56Requires(preun): /sbin/chkconfig
57Requires(postun): /sbin/chkconfig
58%endif
59
60%description
61The strongSwan IPsec implementation supports both the IKEv1 and IKEv2 key
62exchange protocols in conjunction with the native NETKEY IPsec stack of the
63Linux kernel.
64
65%package libipsec
66Summary: Strongswan's libipsec backend
67%description libipsec
68The kernel-libipsec plugin provides an IPsec backend that works entirely
69in userland, using TUN devices and its own IPsec implementation libipsec.
70
71%package charon-nm
72Summary:        NetworkManager plugin for Strongswan
73Requires:       dbus
74Obsoletes:      %{name}-NetworkManager < 0:5.0.4-5
75Conflicts:      %{name}-NetworkManger < 0:5.0.4-5
76%description charon-nm
77NetworkManager plugin integrates a subset of Strongswan capabilities
78to NetworkManager.
79
80%if %{with tss}
81%package tnc-imcvs
82Summary: Trusted network connect (TNC)'s IMC/IMV functionality
83Requires: %{name} = %{version}
84%description tnc-imcvs
85This package provides Trusted Network Connect's (TNC) architecture support.
86It includes support for TNC client and server (IF-TNCCS), IMC and IMV message
87exchange (IF-M), interface between IMC/IMV and TNC client/server (IF-IMC
88and IF-IMV). It also includes PTS based IMC/IMV for TPM based remote
89attestation, SWID IMC/IMV, and OS IMC/IMV. It's IMC/IMV dynamic libraries
90modules can be used by any third party TNC Client/Server implementation
91possessing a standard IF-IMC/IMV interface. In addition, it implements
92PT-TLS to support TNC over TLS.
93%endif
94
95
96%debug_package
97
98
99%prep
100%setup -q -n %{name}-%{version}%{?prerelease}
101%patch0 -p1
102%patch1 -p1
103%patch3 -p1
104
105
106%build
107# only for snapshots
108#autoreconf
109
110# --with-ipsecdir moves internal commands to /usr/libexec/strongswan
111# --bindir moves 'pki' command to /usr/libexec/strongswan
112# See: http://wiki.strongswan.org/issues/552
113# too broken to enable:    --enable-sha3 --enable-rdrand --enable-connmark --enable-forecast
114%configure --disable-static \
115    --with-ipsec-script=strongswan \
116    --sysconfdir=%{_sysconfdir}/strongswan \
117    --with-ipsecdir=%{_libexecdir}/strongswan \
118    --bindir=%{_libexecdir}/strongswan \
119    --with-ipseclibdir=%{_libdir}/strongswan \
120%if %{with fips2}
121    --with-fips-mode=2 \
122%endif
123%if "%{?_dist_release}" != "vl6"
124    --enable-nm \
125%endif
126    --enable-openssl \
127    --enable-unity \
128    --enable-ctr \
129    --enable-ccm \
130    --enable-gcm \
131    --enable-chapoly \
132    --enable-md4 \
133    --enable-gcrypt \
134    --enable-newhope \
135    --enable-xauth-eap \
136    --enable-xauth-pam \
137    --enable-xauth-noauth \
138    --enable-eap-identity \
139    --enable-eap-md5 \
140    --enable-eap-gtc \
141    --enable-eap-tls \
142    --enable-eap-ttls \
143    --enable-eap-peap \
144    --enable-eap-mschapv2 \
145    --enable-eap-tnc \
146    --enable-eap-sim \
147    --enable-eap-sim-file \
148    --enable-eap-aka \
149    --enable-eap-aka-3gpp \
150    --enable-eap-aka-3gpp2 \
151    --enable-eap-dynamic \
152    --enable-eap-radius \
153    --enable-ext-auth \
154    --enable-ipseckey \
155    --enable-pkcs11 \
156    --enable-farp \
157    --enable-dhcp \
158    --enable-ha \
159    --enable-led \
160    --enable-sqlite \
161    --enable-tnc-ifmap \
162    --enable-tnc-pdp \
163    --enable-tnc-imc \
164    --enable-tnc-imv \
165    --enable-tnccs-20 \
166    --enable-tnccs-11 \
167    --enable-tnccs-dynamic \
168    --enable-curl \
169    --enable-cmd \
170    --enable-acert \
171    --enable-vici \
172    --enable-swanctl \
173    --enable-duplicheck \
174%if %{with tss}
175    --enable-tss-trousers \
176    --enable-aikgen \
177    --enable-tpm \
178    --enable-imc-test \
179    --enable-imv-test \
180    --enable-imc-scanner \
181    --enable-imv-scanner  \
182    --enable-imc-attestation \
183    --enable-imv-attestation \
184    --enable-imv-os \
185    --enable-imc-os \
186    --enable-imc-swid \
187    --enable-imv-swid \
188    --enable-imc-swima \
189    --enable-imv-swima \
190    --enable-imc-hcd \
191    --enable-imv-hcd \
192%endif
193%ifarch x86_64 %{ix86}
194    --enable-aesni \
195%endif
196%if %{with systemd}
197    --enable-systemd \
198%endif
199    --enable-kernel-libipsec
200
201make %{?_smp_mflags}
202
203
204%install
205rm -rf %{buildroot}
206
207make install DESTDIR=%{buildroot}
208
209# prefix man pages
210for i in %{buildroot}%{_mandir}/*/*; do
211    if echo "$i" | grep -vq '/strongswan[^\/]*$'; then
212        mv "$i" "`echo "$i" | sed -re 's|/([^/]+)$|/strongswan_\1|'`"
213    fi
214done
215find %{buildroot} -type f -name '*.la' -delete
216# delete unwanted library files - no consumers, so no -devel package
217rm %{buildroot}%{_libdir}/strongswan/*.so
218# fix config permissions
219chmod 644 %{buildroot}%{_sysconfdir}/%{name}/%{name}.conf
220
221# Create ipsec.d directory tree.
222install -d -m 700 %{buildroot}%{_sysconfdir}/%{name}/ipsec.d
223for i in aacerts acerts certs cacerts crls ocspcerts private reqs; do
224    install -d -m 700 %{buildroot}%{_sysconfdir}/%{name}/ipsec.d/${i}
225done
226
227%if %{with systemd}
228install -D -p -m 0644 %{SOURCE1} %{buildroot}/%{_tmpfilesdir}/strongswan.conf
229%else
230mkdir -p %{buildroot}%{_initdir}
231install -m755 %{SOURCE1000} %{buildroot}%{_initdir}/ipsec
232%endif
233
234
235%post
236%if %{with systemd}
237%systemd_post %{name}.service
238%else
239/sbin/chkconfig --add ipsec
240%endif
241
242%preun
243%if %{with systemd}
244%systemd_preun %{name}.service
245%else
246if [ $1 -eq 0  -o -x /bin/systemctl ]; then
247  /sbin/service ipsec stop
248  /sbin/chkconfig --del ipsec
249fi
250%endif
251
252%postun
253%if %{with systemd}
254%systemd_postun_with_restart %{name}.service
255%else
256if [ $1 -gt 0 ]; then
257  /sbin/service ipsec condrestart
258fi
259%endif
260
261
262%files
263%doc README NEWS TODO ChangeLog
264%{!?_licensedir:%global license %%doc}
265%license COPYING
266%dir %attr(0700,root,root) %{_sysconfdir}/strongswan
267%config(noreplace) %{_sysconfdir}/strongswan/*
268%dir %{_libdir}/strongswan
269%dir %{_libdir}/strongswan/plugins
270%dir %{_libexecdir}/strongswan
271%{_sbindir}/charon-cmd
272%{_sbindir}/strongswan
273%{_sbindir}/swanctl
274%{_libdir}/strongswan/*.so.*
275%exclude %{_libdir}/strongswan/libipsec.so.*
276%{_libdir}/strongswan/plugins/*.so
277%exclude %{_libdir}/strongswan/plugins/libstrongswan-kernel-libipsec.so
278%{_libexecdir}/strongswan/*
279%if "%{?_dist_release}" != "vl6"
280%exclude %{_libexecdir}/strongswan/charon-nm
281%endif
282%{_mandir}/man?/*.gz
283%{_datadir}/strongswan/templates/config/
284%if %{with tss}
285%exclude %{_libdir}/strongswan/imcvs
286%exclude %{_libdir}/strongswan/libimcv.so.*
287%exclude %{_libdir}/strongswan/libtnccs.so.*
288%exclude %{_libdir}/strongswan/libradius.so.*
289%exclude %{_libdir}/strongswan/plugins/libstrongswan-pkcs7.so
290%exclude %{_libdir}/strongswan/plugins/libstrongswan-sqlite.so
291%exclude %{_libdir}/strongswan/plugins/libstrongswan-*tnc*.so
292%exclude %{_libdir}/strongswan/plugins/libstrongswan-eap-radius.so
293%exclude %{_libexecdir}/strongswan/attest
294%exclude %{_libexecdir}/strongswan/pt-tls-client
295%{_datadir}/strongswan/templates/database/
296%exclude %dir %{_datadir}/strongswan/swidtag
297%endif
298%if %{with systemd}
299%{_sbindir}/charon-systemd
300%{_unitdir}/strongswan.service
301%{_unitdir}/strongswan-starter.service
302%{_tmpfilesdir}/strongswan.conf
303%else
304%{_initdir}/ipsec
305%endif
306
307%if %{with tss}
308%files tnc-imcvs
309%{_sbindir}/sw-collector
310%{_sbindir}/sec-updater
311%dir %{_libdir}/strongswan/imcvs
312%dir %{_libdir}/strongswan/plugins
313%{_libdir}/strongswan/libimcv.so.*
314%{_libdir}/strongswan/libtnccs.so.*
315%{_libdir}/strongswan/libradius.so.*
316%{_libdir}/strongswan/plugins/libstrongswan-pkcs7.so
317%{_libdir}/strongswan/plugins/libstrongswan-sqlite.so
318%{_libdir}/strongswan/plugins/libstrongswan-*tnc*.so
319%{_libdir}/strongswan/plugins/libstrongswan-eap-radius.so
320%{_libexecdir}/strongswan/attest
321%{_libexecdir}/strongswan/pt-tls-client
322%dir %{_datadir}/strongswan/swidtag
323%{_datadir}/strongswan/swidtag/*.swidtag
324%endif
325
326%files libipsec
327%{_libdir}/strongswan/libipsec.so.*
328%{_libdir}/strongswan/plugins/libstrongswan-kernel-libipsec.so
329
330%if "%{?_dist_release}" != "vl6"
331%files charon-nm
332%license COPYING
333%{_datadir}/dbus-1/system.d/nm-strongswan-service.conf
334%{_libexecdir}/strongswan/charon-nm
335%endif
336
337
338%changelog
339* Tue Aug 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.9.0-1
340- new upstream release.
341
342* Sat May 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.8.4-1
343- new upstream release.
344- imported Patch0 from rawhide.
345- fixed systemd stuff.
346
347* Sun Mar 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.8.2-1
348- new upstream release.
349
350* Wed Nov 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.8.1-1
351- new upstream release.
352
353* Tue Jan 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.7.2-1
354- new upstream release.
355
356* Wed Nov 07 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.7.1-1
357- new upstream release.
358- imported Patch3 from rawhide.
359
360* Mon Mar 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.2-2
361- initial build for Vine Linux.
362
363* Wed Feb 21 2018 Lubomir Rintel <lkundrak@v3.sk> - 5.6.2-1
364- Updated to 5.6.2 (Dropped libnm-glib use in charon-nm)
365
366* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.1-2
367- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
368
369* Fri Dec 22 2017 Paul Wouters <pwouters@redhat.com> - 5.6.1-1
370- Updated to 5.6.1 (RSA-PSS support)
371
372* Sun Dec 10 2017 Björn Esser <besser82@fedoraproject.org> - 5.6.0-3
373- Rebuilt for libjson-c.so.3
374
375* Fri Dec 01 2017 Lubomir Rintel <lkundrak@v3.sk> - 5.6.0-2
376- Fix the placement of charon-nm D-Bus policy
377
378* Sat Sep 09 2017 Paul Wouters <pwouters@redhat.com> - 5.6.0-1
379- Updated to 5.6.0
380- Fixup configure arguments, enabled a bunch of new features
381- Added new BuildRequires:
382- Fixup Obsolete/Conflicts, use license macro
383- Don't require autoconf/autotools for non-snapshots
384- Remove macro overuse, remove fedora/rhel checks and sysvinit support
385- Make listings/grouping of all plugins/libs to reduce file listing
386
387* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.5.3-3
388- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
389
390* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.5.3-2
391- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
392
393* Mon Jun 12 2017 Paul Wouters <pwouters@redhat.com> - 5.5.3-1
394- Updated to 5.5.3
395
396* Sat May 27 2017 Paul Wouters <pwouters@redhat.com> - 5.5.2-1
397- Updated to 5.5.2
398
399* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.5.0-3
400- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
401
402* Thu Sep 15 2016 Pavel Šimerda <psimerda@redhat.com> - 5.5.0-2
403- Resolves: #1367796 - Enable the unity plugin
404
405* Mon Aug 08 2016 Pavel Šimerda <psimerda@redhat.com> - 5.5.0-1
406- New version 5.5.0
407
408* Wed Jun 22 2016 Pavel Šimerda <psimerda@redhat.com>
409- Enable IKEv2 GCM (requires gcrypt module as well) - merged from f22 by Paul Wouters
410
411* Wed Jun 22 2016 Pavel Šimerda <psimerda@redhat.com> - 5.4.0-1
412- New version 5.4.0
413
414* Thu Mar 03 2016 Pavel Šimerda <psimerda@redhat.com> - 5.3.5-1
415- New version 5.3.5
416
417* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.3.3-3
418- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
419
420* Fri Jan 15 2016 Paul Wouters <pwouters@redhat.com> - 5.3.3-2
421- Enable IKEv2 GCM (requires gcrypt module as well)
422
423* Tue Sep 29 2015 Pavel Šimerda <psimerda@redhat.com> - 5.3.3-1
424- new version 5.3.3
425
426* Thu Sep 24 2015 Pavel Šimerda <psimerda@redhat.com> - 5.3.2-3
427- Resolves: #1264598 - strongswan: many configuration files are not protected
428
429* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.2-2
430- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
431
432* Tue Jun 09 2015 Pavel Šimerda <psimerda@redhat.com>
433- new version 5.3.2
434
435* Fri Jun 05 2015 Pavel Šimerda <psimerda@redhat.com> - 5.3.1-1
436- new version 5.3.1
437
438* Tue Mar 31 2015 Pavel Šimerda <psimerda@redhat.com> - 5.3.0-1
439- new version 5.3.0
440
441* Fri Feb 20 2015 Avesh Agarwal <avagarwa@redhat.com> - 5.2.2-2
442- Fixes strongswan swanctl service issue rhbz#1193106
443
444* Tue Jan 06 2015 Pavel Šimerda <psimerda@redhat.com> - 5.2.2-1
445- new version 5.2.2
446
447* Thu Dec 18 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.2-0.2.dr1
448- Enabled ccm, and ctr plugins as it seems enabling just openssl does
449  not work for using ccm and ctr algos.
450
451* Mon Dec 8 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.2-0.1.dr1
452- New strongswan developer release 5.2.2dr1
453
454* Mon Nov 24 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.1-2
455- 1167331: Enabled native systemd support.
456- Does not disable old systemd, starter, ipsec.conf support yet.
457
458* Thu Oct 30 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.1-1
459- New upstream release 5.2.1
460
461* Thu Oct 16 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.1-0.2.rc1
462- New upstream release candidate 5.2.1rc1
463
464* Fri Oct 10 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.1-1
465- new version 5.2.1dr1
466
467* Thu Sep 25 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-7
468- use upstream patch for json/json-c dependency
469
470* Thu Sep 25 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-6
471- Resolves: #1146145 - Strongswan is compiled without xauth-noauth plugin
472
473* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.0-5
474- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
475
476* Tue Aug 05 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-4
477- Resolves: #1081804 - enable Kernel IPSec support
478
479* Wed Jul 30 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-3
480- rebuilt
481
482* Tue Jul 29 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-2
483- fix json-c dependency
484
485* Tue Jul 15 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.0-1
486- New upstream release 5.2.0
487- The Attestation IMC/IMV pair supports the IMA-NG
488  measurement format
489- Aikgen tool to generate an Attestation Identity Key bound
490  to a TPM
491- Swanctl tool to provide a portable, complete IKE
492  configuration and control interface for the command
493  line using vici interface with libvici library
494- PT-EAP transport protocol (RFC 7171) for TNC
495- Enabled support for acert for checking X509 attribute certificate
496- Updated patches, removed selinux patch as upstream has fixed it
497  in this release.
498- Updated spec file with minor cleanups
499
500* Thu Jun 26 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-0.4.dr6
501- improve prerelease macro
502
503* Thu Jun 26 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-0.3
504- Resolves: #1111895 - bump to 5.2.0dr6
505
506* Thu Jun 12 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-0.2
507- Related: #1087437 - remove or upstream all patches not specific to fedora/epel
508
509* Thu Jun 12 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-0.1.dr5
510- fix the pre-release version according to guidelines before it gets branched
511
512* Fri Jun 06 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0dr5-1
513- new version 5.2.0dr5
514- add json-c-devel to build deps
515
516* Mon May 26 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0dr4-3
517- merge two related patches
518
519* Mon May 26 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0dr4-2
520- clean up the patches a bit
521
522* Thu May 22 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.0dr4-1
523- New upstream developer release 5.2.0dr4
524- Attestation IMV/IMC supports IMA-NG measurement format now
525- Aikgen tool to generate an Attestation Identity Key bound
526  to a TPM
527- PT-EAP transport protocol (RFC 7171) for TNC
528- vici plugin provides IKE Configuration Interface for charon
529- Enabled support for acert for checking X509 attribute certificate
530- Updated patches
531- Updated spec file with minor cleanups
532
533* Tue Apr 15 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.3-1
534- new version 5.1.3
535
536* Mon Apr 14 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.3rc1-1
537- new version 5.1.3rc1
538
539* Mon Mar 24 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.2-4
540- #1069928 - updated libexec patch.
541
542* Tue Mar 18 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.2-3
543- fixed el6 initscript
544- fixed pki directory location
545
546* Fri Mar 14 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.2-2
547- clean up the specfile a bit
548- replace the initscript patch with an individual initscript
549- patch to build for epel6
550
551* Mon Mar 03 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.2-1
552- #1071353 - bump to 5.1.2
553- #1071338 - strongswan is compiled without xauth-pam plugin
554- remove obsolete patches
555- sent all patches upstream
556- added comments to all patches
557- don't touch the config with sed
558
559* Thu Feb 20 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.1.1-6
560- Fixed full hardening for strongswan (full relro and PIE).
561  The previous macros had a typo and did not work
562  (see bz#1067119).
563- Fixed tnc package description to reflect the current state of
564  the package.
565- Fixed pki binary and moved it to /usr/libexece/strongswan as
566  others binaries are there too.
567
568* Wed Feb 19 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.1-5
569- #903638 - SELinux is preventing /usr/sbin/xtables-multi from 'read' accesses on the chr_file /dev/random
570
571* Thu Jan 09 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.1-4
572- Removed redundant patches and *.spec commands caused by branch merging
573
574* Wed Jan 08 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.1-3
575- rebuilt
576
577* Mon Dec 2 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.1.1-2
578- Resolves: 973315
579- Resolves: 1036844
580
581* Fri Nov 1 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.1.1-1
582- Support for PT-TLS  (RFC 6876)
583- Support for SWID IMC/IMV
584- Support for command line IKE client charon-cmd
585- Changed location of pki to /usr/bin
586- Added swid tags files
587- Added man pages for pki and charon-cmd
588- Renamed pki to strongswan-pki to avoid conflict with
589  pki-core/pki-tools package.
590- Update local patches
591- Fixes CVE-2013-6075
592- Fixes CVE-2013-6076
593- Fixed autoconf/automake issue as configure.ac got changed
594  and it required running autoreconf during the build process.
595- added strongswan signature file to the sources.
596
597* Thu Sep 12 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.1.0-3
598- Fixed initialization crash of IMV and IMC particularly
599  attestation imv/imc as libstrongswas was not getting
600  initialized.
601
602* Fri Aug 30 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.1.0-2
603- Enabled fips support
604- Enabled TNC's ifmap support
605- Enabled TNC's pdp support
606- Fixed hardocded package name in this spec file
607
608* Wed Aug 7 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.1.0-1
609- rhbz#981429: New upstream release
610- Fixes CVE-2013-5018: rhbz#991216, rhbz#991215
611- Fixes rhbz#991859 failed to build in rawhide
612- Updated local patches and removed which are not needed
613- Fixed errors around charon-nm
614- Added plugins libstrongswan-pkcs12.so, libstrongswan-rc2.so,
615  libstrongswan-sshkey.so
616- Added utility imv_policy_manager
617
618* Thu Jul 25 2013 Jamie Nguyen <jamielinux@fedoraproject.org> - 5.0.4-5
619- rename strongswan-NetworkManager to strongswan-charon-nm
620- fix enable_nm macro
621
622* Mon Jul 15 2013 Jamie Nguyen <jamielinux@fedoraproject.org> - 5.0.4-4
623- %%files tries to package some of the shared objects as directories (#984437)
624- fix broken systemd unit file (#984300)
625- fix rpmlint error: description-line-too-long
626- fix rpmlint error: macro-in-comment
627- fix rpmlint error: spelling-error Summary(en_US) fuctionality
628- depend on 'systemd' instead of 'systemd-units'
629- use new systemd scriptlet macros
630- NetworkManager subpackage should have a copy of the license (#984490)
631- enable hardened_build as this package meets the PIE criteria (#984429)
632- invocation of "ipsec _updown iptables" is broken as ipsec is renamed
633  to strongswan in this package (#948306)
634- invocation of "ipsec scepclient" is broken as ipsec is renamed
635  to strongswan in this package
636- add /etc/strongswan/ipsec.d and missing subdirectories
637- conditionalize building of strongswan-NetworkManager subpackage as the
638  version of NetworkManager in EL6 is too old (#984497)
639
640* Fri Jun 28 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.4-3
641- Patch to fix a major crash issue when Freeradius loads
642  attestatiom-imv and does not initialize libstrongswan which
643  causes crash due to calls to PTS algorithms probing APIs.
644  So this patch fixes the order of initialization. This issues
645  does not occur with charon because libstrongswan gets
646  initialized earlier.
647- Patch that allows to outputs errors when there are permission
648  issues when accessing strongswan.conf.
649- Patch to make loading of modules configurable when libimcv
650  is used in stand alone mode without charon with freeradius
651  and wpa_supplicant.
652
653* Tue Jun 11 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.4-2
654- Enabled TNCCS 1.1 protocol
655- Fixed libxm2-devel build dependency
656- Patch to fix the issue with loading of plugins
657
658* Wed May 1 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.4-1
659- New upstream release
660- Fixes for CVE-2013-2944
661- Enabled support for OS IMV/IMC
662- Created and applied a patch to disable ECP in fedora, because
663  Openssl in Fedora does not allow ECP_256 and ECP_384. It makes
664  it non-compliant to TCG's PTS standard, but there is no choice
665  right now. see redhat bz # 319901.
666- Enabled Trousers support for TPM based operations.
667
668* Sat Apr 20 2013 Pavel Šimerda <psimerda@redhat.com> - 5.0.3-2
669- Rebuilt for a single specfile for rawhide/f19/f18/el6
670
671* Fri Apr 19 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.3-1
672- New upstream release
673- Enabled curl and eap-identity plugins
674- Enabled support for eap-radius plugin.
675
676* Thu Apr 18 2013 Pavel Šimerda <psimerda@redhat.com> - 5.0.2-3
677- Add gettext-devel to BuildRequires because of epel6
678- Remove unnecessary comments
679
680* Tue Mar 19 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.2-2
681- Enabled support for eap-radius plugin.
682
683* Mon Mar 11 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.2-1
684- Update to upstream release 5.0.2
685- Created sub package strongswan-tnc-imcvs that provides trusted network
686  connect's IMC and IMV funtionality. Specifically it includes PTS
687  based IMC/IMV for TPM based remote attestation and scanner and test
688  IMCs and IMVs. The Strongswan's IMC/IMV dynamic libraries can be used
689  by any third party TNC Client/Server implementation possessing a
690  standard IF-IMC/IMV interface.
691
692* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.0.1-2
693- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
694
695* Thu Oct 04 2012 Pavel Šimerda <psimerda@redhat.com> - 5.0.1-1
696- Update to release 5.0.1
697
698* Thu Oct 04 2012 Pavel Šimerda <psimerda@redhat.com> - 5.0.0-4.git20120619
699- Add plugins to interoperate with Windows 7 and Android (#862472)
700  (contributed by Haim Gelfenbeyn)
701
702* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.0.0-3.git20120619
703- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
704
705* Sun Jul 08 2012 Pavel Šimerda <pavlix@pavlix.net> - 5.0.0-2.git20120619
706- Fix configure substitutions in initscripts
707
708* Wed Jul 04 2012 Pavel Šimerda <psimerda@redhat.com> - 5.0.0-1.git20120619
709- Update to current upstream release
710- Comment out all stuff that is only needed for git builds
711- Remove renaming patch from git
712- Improve init patch used for EPEL
713
714* Thu Jun 21 2012 Pavel Šimerda <psimerda@redhat.com> - 5.0.0-0.3.git20120619
715- Build with openssl plugin enabled
716
717* Wed Jun 20 2012 Pavel Šimerda <psimerda@redhat.com> - 5.0.0-0.2.git20120619
718- Add README.Fedora with link to 4.6 to 5.0 migration information
719
720* Tue Jun 19 2012 Pavel Šimerda - 5.0.0-0.1.git20120619
721- Snapshot of upcoming major release
722- Move patches and renaming upstream
723  http://wiki.strongswan.org/issues/194
724  http://wiki.strongswan.org/issues/195
725- Notified upstream about manpage issues
726
727* Tue Jun 19 2012 Pavel Šimerda - 4.6.4-2
728- Make initscript patch more distro-neutral
729- Add links to bugreports for patches
730
731* Fri Jun 01 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.4-1
732- New upstream version (CVE-2012-2388)
733
734* Sat May 26 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.3-2
735- Add --enable-nm to configure
736- Add NetworkManager-devel to BuildRequires
737- Add NetworkManager-glib-devel to BuildRequires
738- Add strongswan-NetworkManager package
739
740* Sat May 26 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.3-1
741- New version of Strongswan
742- Support for RFC 3110 DNSKEY (see upstream changelog)
743- Fix corrupt scriptlets
744
745* Fri Mar 30 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.2-2
746- #808612 - strongswan binary renaming side-effect
747
748* Sun Feb 26 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.2-1
749- New upstream version
750- Changed from .tar.gz to .tar.bz2
751- Added libstrongswan-pkcs8.so
752
753* Wed Feb 15 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-8
754- Fix initscript's status function
755
756* Wed Feb 15 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-7
757- Expand tabs in config files for better readability
758- Add sysvinit script for epel6
759
760* Wed Feb 15 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-6
761- Fix program name in systemd unit file
762
763* Tue Feb 14 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-5
764- Improve fedora/epel conditionals
765
766* Sat Jan 21 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-4
767- Protect configuration directory from ordinary users
768- Add still missing directory /etc/strongswan
769
770* Fri Jan 20 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-3
771- Change directory structure to avoid clashes with Openswan
772- Prefixed all manpages with 'strongswan_'
773- Every file now includes 'strongswan' somewhere in its path
774- Removed conflict with Openswan
775- Finally fix permissions on strongswan.conf
776
777* Fri Jan 20 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-2
778- Change license tag from GPL to GPLv2+
779- Change permissions on /etc/strongswan.conf to 644
780- Rename ipsec.8 manpage to strongswan.8
781- Fix empty scriptlets for non-fedora builds
782- Add ldconfig scriptlet
783- Add missing directories and files
784
785* Sun Jan 01 2012 Pavel Šimerda <pavlix@pavlix.net - 4.6.1-1
786- Bump to version 4.6.1
787
788* Sun Jan 01 2012 Pavel Šimerda <pavlix@pavlix.net - 4.6.0-3
789- Add systemd scriptlets
790- Add conditions to also support EPEL6
791
792* Sat Dec 10 2011 Pavel Šimerda <pavlix@pavlix.net> - 4.6.0-2
793- Experimental build for development
Note: See TracBrowser for help on using the repository browser.