source: projects/specs/trunk/s/strongswan/strongswan-vl.spec @ 12546

Revision 12546, 26.8 KB checked in by tomop, 3 years ago (diff)

updated 28 packages

autoconf-2.71-1

automake-1.16.3-1

bison-3.7.5-1

e2fsprogs-1.46.1-1

findutils-4.8.0-1

galera-26.4.7-1

gawk-5.1.0-1

gdbm-1.19-1

gjs-1.66.2-1

gnome-initial-setup-3.36.4-2

grep-3.6-1

help2man-1.48.1-1

ipvsadm-1.31-1

less-563-1

libidn-1.36-1

make-4.3-1

mariadb-10.5.9-1

mozjs78-78.7.0-1

mpfr-4.1.0-1

nettle-3.7.1-1

parted-3.4-1

pcre2-10.36-1

polkit-0.118-1

strongswan-5.9.1-1

tar-1.34-1

trousers-0.3.15-1

wget-1.21-1

wireshark-3.4.3-1

Line 
1%bcond_with systemd
2%bcond_with fips2
3%bcond_without tss
4
5%global _unpackaged_files_terminate_build 1
6%global _hardened_build 0
7#%%define prerelease dr1
8
9Name:           strongswan
10Version:        5.9.1
11Release:        1%{?_dist_release}%{?with_systemd:.systemd}
12Summary:        An OpenSource IPsec-based VPN and TNC solution
13Summary(ja):    オープンソースのIPsec VPN/TNCソリューション
14Group:          servers,security
15Vendor:         Project Vine
16Distribution:   Vine Linux
17
18License:        GPLv2+
19URL:            https://www.strongswan.org/
20Source0:        https://download.strongswan.org/%{name}-%{version}%{?prerelease}.tar.bz2
21Source1:        tmpfiles-strongswan.conf
22Source1000:     strongswan.init
23Patch0:         strongswan-5.8.4-runtime-dir.patch
24Patch1:         strongswan-5.6.0-uintptr_t.patch
25Patch3:         strongswan-5.6.2-CVE-2018-5388.patch
26
27# only needed for pre-release versions
28#BuildRequires:  autoconf automake
29
30BuildRequires:  gmp-devel
31BuildRequires:  curl-devel
32BuildRequires:  openldap-devel
33BuildRequires:  openssl-devel
34BuildRequires:  sqlite3-devel
35BuildRequires:  gettext-devel
36BuildRequires:  libxml2-devel
37BuildRequires:  pam-devel
38BuildRequires:  libgcrypt-devel
39BuildRequires:  iptables-devel
40%if %{with tss}
41BuildRequires:  trousers-devel
42BuildRequires:  json-c-devel >= 0.14
43%endif
44
45%if "%{?_dist_release}" != "vl6"
46BuildRequires:  NetworkManager-libnm-devel
47%endif
48
49%if %{with systemd}
50BuildRequires:  systemd-devel
51Requires(post): systemd
52Requires(preun): systemd
53Requires(postun): systemd
54%else
55Requires(post): /sbin/chkconfig
56Requires(preun): /sbin/chkconfig
57Requires(postun): /sbin/chkconfig
58%endif
59
60%description
61The strongSwan IPsec implementation supports both the IKEv1 and IKEv2 key
62exchange protocols in conjunction with the native NETKEY IPsec stack of the
63Linux kernel.
64
65
66%package libipsec
67Summary: Strongswan's libipsec backend
68Group: servers,security
69
70%description libipsec
71The kernel-libipsec plugin provides an IPsec backend that works entirely
72in userland, using TUN devices and its own IPsec implementation libipsec.
73
74
75%package charon-nm
76Summary:        NetworkManager plugin for Strongswan
77Group:          servers,security
78Requires:       dbus
79Obsoletes:      %{name}-NetworkManager < 0:5.0.4-5
80Conflicts:      %{name}-NetworkManger < 0:5.0.4-5
81
82%description charon-nm
83NetworkManager plugin integrates a subset of Strongswan capabilities
84to NetworkManager.
85
86
87%if %{with tss}
88%package tnc-imcvs
89Summary: Trusted network connect (TNC)'s IMC/IMV functionality
90Group: servers,security
91Requires: %{name} = %{version}
92
93%description tnc-imcvs
94This package provides Trusted Network Connect's (TNC) architecture support.
95It includes support for TNC client and server (IF-TNCCS), IMC and IMV message
96exchange (IF-M), interface between IMC/IMV and TNC client/server (IF-IMC
97and IF-IMV). It also includes PTS based IMC/IMV for TPM based remote
98attestation, SWID IMC/IMV, and OS IMC/IMV. It's IMC/IMV dynamic libraries
99modules can be used by any third party TNC Client/Server implementation
100possessing a standard IF-IMC/IMV interface. In addition, it implements
101PT-TLS to support TNC over TLS.
102%endif
103
104
105%debug_package
106
107
108%prep
109%setup -q -n %{name}-%{version}%{?prerelease}
110%patch0 -p1
111%patch1 -p1
112%patch3 -p1
113
114
115%build
116# only for snapshots
117#autoreconf
118
119# --with-ipsecdir moves internal commands to /usr/libexec/strongswan
120# --bindir moves 'pki' command to /usr/libexec/strongswan
121# See: http://wiki.strongswan.org/issues/552
122# too broken to enable:    --enable-sha3 --enable-rdrand --enable-connmark --enable-forecast
123%configure --disable-static \
124    --with-ipsec-script=strongswan \
125    --sysconfdir=%{_sysconfdir}/strongswan \
126    --with-ipsecdir=%{_libexecdir}/strongswan \
127    --bindir=%{_libexecdir}/strongswan \
128    --with-ipseclibdir=%{_libdir}/strongswan \
129%if %{with fips2}
130    --with-fips-mode=2 \
131%endif
132%if "%{?_dist_release}" != "vl6"
133    --enable-nm \
134%endif
135    --enable-openssl \
136    --enable-unity \
137    --enable-ctr \
138    --enable-ccm \
139    --enable-gcm \
140    --enable-chapoly \
141    --enable-md4 \
142    --enable-gcrypt \
143    --enable-newhope \
144    --enable-xauth-eap \
145    --enable-xauth-pam \
146    --enable-xauth-noauth \
147    --enable-eap-identity \
148    --enable-eap-md5 \
149    --enable-eap-gtc \
150    --enable-eap-tls \
151    --enable-eap-ttls \
152    --enable-eap-peap \
153    --enable-eap-mschapv2 \
154    --enable-eap-tnc \
155    --enable-eap-sim \
156    --enable-eap-sim-file \
157    --enable-eap-aka \
158    --enable-eap-aka-3gpp \
159    --enable-eap-aka-3gpp2 \
160    --enable-eap-dynamic \
161    --enable-eap-radius \
162    --enable-ext-auth \
163    --enable-ipseckey \
164    --enable-pkcs11 \
165    --enable-farp \
166    --enable-dhcp \
167    --enable-ha \
168    --enable-led \
169    --enable-sqlite \
170    --enable-tnc-ifmap \
171    --enable-tnc-pdp \
172    --enable-tnc-imc \
173    --enable-tnc-imv \
174    --enable-tnccs-20 \
175    --enable-tnccs-11 \
176    --enable-tnccs-dynamic \
177    --enable-curl \
178    --enable-cmd \
179    --enable-acert \
180    --enable-vici \
181    --enable-swanctl \
182    --enable-duplicheck \
183%if %{with tss}
184    --enable-tss-trousers \
185    --enable-aikgen \
186    --enable-tpm \
187    --enable-imc-test \
188    --enable-imv-test \
189    --enable-imc-scanner \
190    --enable-imv-scanner  \
191    --enable-imc-attestation \
192    --enable-imv-attestation \
193    --enable-imv-os \
194    --enable-imc-os \
195    --enable-imc-swid \
196    --enable-imv-swid \
197    --enable-imc-swima \
198    --enable-imv-swima \
199    --enable-imc-hcd \
200    --enable-imv-hcd \
201%endif
202%ifarch x86_64 %{ix86}
203    --enable-aesni \
204%endif
205%if %{with systemd}
206    --enable-systemd \
207%endif
208    --enable-kernel-libipsec
209
210make %{?_smp_mflags}
211
212
213%install
214rm -rf %{buildroot}
215
216make install DESTDIR=%{buildroot}
217
218# prefix man pages
219for i in %{buildroot}%{_mandir}/*/*; do
220    if echo "$i" | grep -vq '/strongswan[^\/]*$'; then
221        mv "$i" "`echo "$i" | sed -re 's|/([^/]+)$|/strongswan_\1|'`"
222    fi
223done
224find %{buildroot} -type f -name '*.la' -delete
225# delete unwanted library files - no consumers, so no -devel package
226rm %{buildroot}%{_libdir}/strongswan/*.so
227# fix config permissions
228chmod 644 %{buildroot}%{_sysconfdir}/%{name}/%{name}.conf
229
230# Create ipsec.d directory tree.
231install -d -m 700 %{buildroot}%{_sysconfdir}/%{name}/ipsec.d
232for i in aacerts acerts certs cacerts crls ocspcerts private reqs; do
233    install -d -m 700 %{buildroot}%{_sysconfdir}/%{name}/ipsec.d/${i}
234done
235
236%if %{with systemd}
237install -D -p -m 0644 %{SOURCE1} %{buildroot}/%{_tmpfilesdir}/strongswan.conf
238%else
239mkdir -p %{buildroot}%{_initdir}
240install -m755 %{SOURCE1000} %{buildroot}%{_initdir}/ipsec
241%endif
242
243
244%post
245%if %{with systemd}
246%systemd_post %{name}.service
247%else
248/sbin/chkconfig --add ipsec
249%endif
250
251%preun
252%if %{with systemd}
253%systemd_preun %{name}.service
254%else
255if [ $1 -eq 0  -o -x /bin/systemctl ]; then
256  /sbin/service ipsec stop
257  /sbin/chkconfig --del ipsec
258fi
259%endif
260
261%postun
262%if %{with systemd}
263%systemd_postun_with_restart %{name}.service
264%else
265if [ $1 -gt 0 ]; then
266  /sbin/service ipsec condrestart
267fi
268%endif
269
270
271%files
272%doc README NEWS TODO ChangeLog
273%{!?_licensedir:%global license %%doc}
274%license COPYING
275%dir %attr(0700,root,root) %{_sysconfdir}/strongswan
276%config(noreplace) %{_sysconfdir}/strongswan/*
277%dir %{_libdir}/strongswan
278%dir %{_libdir}/strongswan/plugins
279%dir %{_libexecdir}/strongswan
280%{_sbindir}/charon-cmd
281%{_sbindir}/strongswan
282%{_sbindir}/swanctl
283%{_libdir}/strongswan/*.so.*
284%exclude %{_libdir}/strongswan/libipsec.so.*
285%{_libdir}/strongswan/plugins/*.so
286%exclude %{_libdir}/strongswan/plugins/libstrongswan-kernel-libipsec.so
287%{_libexecdir}/strongswan/*
288%if "%{?_dist_release}" != "vl6"
289%exclude %{_libexecdir}/strongswan/charon-nm
290%endif
291%{_mandir}/man?/*.gz
292%{_datadir}/strongswan/templates/config/
293%if %{with tss}
294%exclude %{_libdir}/strongswan/imcvs
295%exclude %{_libdir}/strongswan/libimcv.so.*
296%exclude %{_libdir}/strongswan/libtnccs.so.*
297%exclude %{_libdir}/strongswan/libradius.so.*
298%exclude %{_libdir}/strongswan/plugins/libstrongswan-pkcs7.so
299%exclude %{_libdir}/strongswan/plugins/libstrongswan-sqlite.so
300%exclude %{_libdir}/strongswan/plugins/libstrongswan-*tnc*.so
301%exclude %{_libdir}/strongswan/plugins/libstrongswan-eap-radius.so
302%exclude %{_libexecdir}/strongswan/attest
303%exclude %{_libexecdir}/strongswan/pt-tls-client
304%{_datadir}/strongswan/templates/database/
305%exclude %dir %{_datadir}/strongswan/swidtag
306%endif
307%if %{with systemd}
308%{_sbindir}/charon-systemd
309%{_unitdir}/strongswan.service
310%{_unitdir}/strongswan-starter.service
311%{_tmpfilesdir}/strongswan.conf
312%else
313%{_initdir}/ipsec
314%endif
315
316%if %{with tss}
317%files tnc-imcvs
318%{_sbindir}/sw-collector
319%{_sbindir}/sec-updater
320%dir %{_libdir}/strongswan/imcvs
321%dir %{_libdir}/strongswan/plugins
322%{_libdir}/strongswan/libimcv.so.*
323%{_libdir}/strongswan/libtnccs.so.*
324%{_libdir}/strongswan/libradius.so.*
325%{_libdir}/strongswan/plugins/libstrongswan-pkcs7.so
326%{_libdir}/strongswan/plugins/libstrongswan-sqlite.so
327%{_libdir}/strongswan/plugins/libstrongswan-*tnc*.so
328%{_libdir}/strongswan/plugins/libstrongswan-eap-radius.so
329%{_libexecdir}/strongswan/attest
330%{_libexecdir}/strongswan/pt-tls-client
331%dir %{_datadir}/strongswan/swidtag
332%{_datadir}/strongswan/swidtag/*.swidtag
333%endif
334
335%files libipsec
336%{_libdir}/strongswan/libipsec.so.*
337%{_libdir}/strongswan/plugins/libstrongswan-kernel-libipsec.so
338
339%if "%{?_dist_release}" != "vl6"
340%files charon-nm
341%license COPYING
342%{_datadir}/dbus-1/system.d/nm-strongswan-service.conf
343%{_libexecdir}/strongswan/charon-nm
344%endif
345
346
347%changelog
348* Mon Feb 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.9.1-1
349- new upstream release.
350
351* Tue Aug 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.9.0-1
352- new upstream release.
353
354* Sat May 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.8.4-1
355- new upstream release.
356- imported Patch0 from rawhide.
357- fixed systemd stuff.
358
359* Sun Mar 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.8.2-1
360- new upstream release.
361
362* Wed Nov 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.8.1-1
363- new upstream release.
364
365* Tue Jan 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.7.2-1
366- new upstream release.
367
368* Wed Nov 07 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.7.1-1
369- new upstream release.
370- imported Patch3 from rawhide.
371
372* Mon Mar 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.2-2
373- initial build for Vine Linux.
374
375* Wed Feb 21 2018 Lubomir Rintel <lkundrak@v3.sk> - 5.6.2-1
376- Updated to 5.6.2 (Dropped libnm-glib use in charon-nm)
377
378* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.1-2
379- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
380
381* Fri Dec 22 2017 Paul Wouters <pwouters@redhat.com> - 5.6.1-1
382- Updated to 5.6.1 (RSA-PSS support)
383
384* Sun Dec 10 2017 Björn Esser <besser82@fedoraproject.org> - 5.6.0-3
385- Rebuilt for libjson-c.so.3
386
387* Fri Dec 01 2017 Lubomir Rintel <lkundrak@v3.sk> - 5.6.0-2
388- Fix the placement of charon-nm D-Bus policy
389
390* Sat Sep 09 2017 Paul Wouters <pwouters@redhat.com> - 5.6.0-1
391- Updated to 5.6.0
392- Fixup configure arguments, enabled a bunch of new features
393- Added new BuildRequires:
394- Fixup Obsolete/Conflicts, use license macro
395- Don't require autoconf/autotools for non-snapshots
396- Remove macro overuse, remove fedora/rhel checks and sysvinit support
397- Make listings/grouping of all plugins/libs to reduce file listing
398
399* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.5.3-3
400- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
401
402* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.5.3-2
403- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
404
405* Mon Jun 12 2017 Paul Wouters <pwouters@redhat.com> - 5.5.3-1
406- Updated to 5.5.3
407
408* Sat May 27 2017 Paul Wouters <pwouters@redhat.com> - 5.5.2-1
409- Updated to 5.5.2
410
411* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.5.0-3
412- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
413
414* Thu Sep 15 2016 Pavel Šimerda <psimerda@redhat.com> - 5.5.0-2
415- Resolves: #1367796 - Enable the unity plugin
416
417* Mon Aug 08 2016 Pavel Šimerda <psimerda@redhat.com> - 5.5.0-1
418- New version 5.5.0
419
420* Wed Jun 22 2016 Pavel Šimerda <psimerda@redhat.com>
421- Enable IKEv2 GCM (requires gcrypt module as well) - merged from f22 by Paul Wouters
422
423* Wed Jun 22 2016 Pavel Šimerda <psimerda@redhat.com> - 5.4.0-1
424- New version 5.4.0
425
426* Thu Mar 03 2016 Pavel Šimerda <psimerda@redhat.com> - 5.3.5-1
427- New version 5.3.5
428
429* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.3.3-3
430- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
431
432* Fri Jan 15 2016 Paul Wouters <pwouters@redhat.com> - 5.3.3-2
433- Enable IKEv2 GCM (requires gcrypt module as well)
434
435* Tue Sep 29 2015 Pavel Šimerda <psimerda@redhat.com> - 5.3.3-1
436- new version 5.3.3
437
438* Thu Sep 24 2015 Pavel Šimerda <psimerda@redhat.com> - 5.3.2-3
439- Resolves: #1264598 - strongswan: many configuration files are not protected
440
441* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.2-2
442- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
443
444* Tue Jun 09 2015 Pavel Šimerda <psimerda@redhat.com>
445- new version 5.3.2
446
447* Fri Jun 05 2015 Pavel Šimerda <psimerda@redhat.com> - 5.3.1-1
448- new version 5.3.1
449
450* Tue Mar 31 2015 Pavel Šimerda <psimerda@redhat.com> - 5.3.0-1
451- new version 5.3.0
452
453* Fri Feb 20 2015 Avesh Agarwal <avagarwa@redhat.com> - 5.2.2-2
454- Fixes strongswan swanctl service issue rhbz#1193106
455
456* Tue Jan 06 2015 Pavel Šimerda <psimerda@redhat.com> - 5.2.2-1
457- new version 5.2.2
458
459* Thu Dec 18 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.2-0.2.dr1
460- Enabled ccm, and ctr plugins as it seems enabling just openssl does
461  not work for using ccm and ctr algos.
462
463* Mon Dec 8 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.2-0.1.dr1
464- New strongswan developer release 5.2.2dr1
465
466* Mon Nov 24 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.1-2
467- 1167331: Enabled native systemd support.
468- Does not disable old systemd, starter, ipsec.conf support yet.
469
470* Thu Oct 30 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.1-1
471- New upstream release 5.2.1
472
473* Thu Oct 16 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.1-0.2.rc1
474- New upstream release candidate 5.2.1rc1
475
476* Fri Oct 10 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.1-1
477- new version 5.2.1dr1
478
479* Thu Sep 25 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-7
480- use upstream patch for json/json-c dependency
481
482* Thu Sep 25 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-6
483- Resolves: #1146145 - Strongswan is compiled without xauth-noauth plugin
484
485* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.0-5
486- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
487
488* Tue Aug 05 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-4
489- Resolves: #1081804 - enable Kernel IPSec support
490
491* Wed Jul 30 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-3
492- rebuilt
493
494* Tue Jul 29 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-2
495- fix json-c dependency
496
497* Tue Jul 15 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.0-1
498- New upstream release 5.2.0
499- The Attestation IMC/IMV pair supports the IMA-NG
500  measurement format
501- Aikgen tool to generate an Attestation Identity Key bound
502  to a TPM
503- Swanctl tool to provide a portable, complete IKE
504  configuration and control interface for the command
505  line using vici interface with libvici library
506- PT-EAP transport protocol (RFC 7171) for TNC
507- Enabled support for acert for checking X509 attribute certificate
508- Updated patches, removed selinux patch as upstream has fixed it
509  in this release.
510- Updated spec file with minor cleanups
511
512* Thu Jun 26 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-0.4.dr6
513- improve prerelease macro
514
515* Thu Jun 26 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-0.3
516- Resolves: #1111895 - bump to 5.2.0dr6
517
518* Thu Jun 12 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-0.2
519- Related: #1087437 - remove or upstream all patches not specific to fedora/epel
520
521* Thu Jun 12 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0-0.1.dr5
522- fix the pre-release version according to guidelines before it gets branched
523
524* Fri Jun 06 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0dr5-1
525- new version 5.2.0dr5
526- add json-c-devel to build deps
527
528* Mon May 26 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0dr4-3
529- merge two related patches
530
531* Mon May 26 2014 Pavel Šimerda <psimerda@redhat.com> - 5.2.0dr4-2
532- clean up the patches a bit
533
534* Thu May 22 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.2.0dr4-1
535- New upstream developer release 5.2.0dr4
536- Attestation IMV/IMC supports IMA-NG measurement format now
537- Aikgen tool to generate an Attestation Identity Key bound
538  to a TPM
539- PT-EAP transport protocol (RFC 7171) for TNC
540- vici plugin provides IKE Configuration Interface for charon
541- Enabled support for acert for checking X509 attribute certificate
542- Updated patches
543- Updated spec file with minor cleanups
544
545* Tue Apr 15 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.3-1
546- new version 5.1.3
547
548* Mon Apr 14 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.3rc1-1
549- new version 5.1.3rc1
550
551* Mon Mar 24 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.2-4
552- #1069928 - updated libexec patch.
553
554* Tue Mar 18 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.2-3
555- fixed el6 initscript
556- fixed pki directory location
557
558* Fri Mar 14 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.2-2
559- clean up the specfile a bit
560- replace the initscript patch with an individual initscript
561- patch to build for epel6
562
563* Mon Mar 03 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.2-1
564- #1071353 - bump to 5.1.2
565- #1071338 - strongswan is compiled without xauth-pam plugin
566- remove obsolete patches
567- sent all patches upstream
568- added comments to all patches
569- don't touch the config with sed
570
571* Thu Feb 20 2014 Avesh Agarwal <avagarwa@redhat.com> - 5.1.1-6
572- Fixed full hardening for strongswan (full relro and PIE).
573  The previous macros had a typo and did not work
574  (see bz#1067119).
575- Fixed tnc package description to reflect the current state of
576  the package.
577- Fixed pki binary and moved it to /usr/libexece/strongswan as
578  others binaries are there too.
579
580* Wed Feb 19 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.1-5
581- #903638 - SELinux is preventing /usr/sbin/xtables-multi from 'read' accesses on the chr_file /dev/random
582
583* Thu Jan 09 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.1-4
584- Removed redundant patches and *.spec commands caused by branch merging
585
586* Wed Jan 08 2014 Pavel Šimerda <psimerda@redhat.com> - 5.1.1-3
587- rebuilt
588
589* Mon Dec 2 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.1.1-2
590- Resolves: 973315
591- Resolves: 1036844
592
593* Fri Nov 1 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.1.1-1
594- Support for PT-TLS  (RFC 6876)
595- Support for SWID IMC/IMV
596- Support for command line IKE client charon-cmd
597- Changed location of pki to /usr/bin
598- Added swid tags files
599- Added man pages for pki and charon-cmd
600- Renamed pki to strongswan-pki to avoid conflict with
601  pki-core/pki-tools package.
602- Update local patches
603- Fixes CVE-2013-6075
604- Fixes CVE-2013-6076
605- Fixed autoconf/automake issue as configure.ac got changed
606  and it required running autoreconf during the build process.
607- added strongswan signature file to the sources.
608
609* Thu Sep 12 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.1.0-3
610- Fixed initialization crash of IMV and IMC particularly
611  attestation imv/imc as libstrongswas was not getting
612  initialized.
613
614* Fri Aug 30 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.1.0-2
615- Enabled fips support
616- Enabled TNC's ifmap support
617- Enabled TNC's pdp support
618- Fixed hardocded package name in this spec file
619
620* Wed Aug 7 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.1.0-1
621- rhbz#981429: New upstream release
622- Fixes CVE-2013-5018: rhbz#991216, rhbz#991215
623- Fixes rhbz#991859 failed to build in rawhide
624- Updated local patches and removed which are not needed
625- Fixed errors around charon-nm
626- Added plugins libstrongswan-pkcs12.so, libstrongswan-rc2.so,
627  libstrongswan-sshkey.so
628- Added utility imv_policy_manager
629
630* Thu Jul 25 2013 Jamie Nguyen <jamielinux@fedoraproject.org> - 5.0.4-5
631- rename strongswan-NetworkManager to strongswan-charon-nm
632- fix enable_nm macro
633
634* Mon Jul 15 2013 Jamie Nguyen <jamielinux@fedoraproject.org> - 5.0.4-4
635- %%files tries to package some of the shared objects as directories (#984437)
636- fix broken systemd unit file (#984300)
637- fix rpmlint error: description-line-too-long
638- fix rpmlint error: macro-in-comment
639- fix rpmlint error: spelling-error Summary(en_US) fuctionality
640- depend on 'systemd' instead of 'systemd-units'
641- use new systemd scriptlet macros
642- NetworkManager subpackage should have a copy of the license (#984490)
643- enable hardened_build as this package meets the PIE criteria (#984429)
644- invocation of "ipsec _updown iptables" is broken as ipsec is renamed
645  to strongswan in this package (#948306)
646- invocation of "ipsec scepclient" is broken as ipsec is renamed
647  to strongswan in this package
648- add /etc/strongswan/ipsec.d and missing subdirectories
649- conditionalize building of strongswan-NetworkManager subpackage as the
650  version of NetworkManager in EL6 is too old (#984497)
651
652* Fri Jun 28 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.4-3
653- Patch to fix a major crash issue when Freeradius loads
654  attestatiom-imv and does not initialize libstrongswan which
655  causes crash due to calls to PTS algorithms probing APIs.
656  So this patch fixes the order of initialization. This issues
657  does not occur with charon because libstrongswan gets
658  initialized earlier.
659- Patch that allows to outputs errors when there are permission
660  issues when accessing strongswan.conf.
661- Patch to make loading of modules configurable when libimcv
662  is used in stand alone mode without charon with freeradius
663  and wpa_supplicant.
664
665* Tue Jun 11 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.4-2
666- Enabled TNCCS 1.1 protocol
667- Fixed libxm2-devel build dependency
668- Patch to fix the issue with loading of plugins
669
670* Wed May 1 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.4-1
671- New upstream release
672- Fixes for CVE-2013-2944
673- Enabled support for OS IMV/IMC
674- Created and applied a patch to disable ECP in fedora, because
675  Openssl in Fedora does not allow ECP_256 and ECP_384. It makes
676  it non-compliant to TCG's PTS standard, but there is no choice
677  right now. see redhat bz # 319901.
678- Enabled Trousers support for TPM based operations.
679
680* Sat Apr 20 2013 Pavel Šimerda <psimerda@redhat.com> - 5.0.3-2
681- Rebuilt for a single specfile for rawhide/f19/f18/el6
682
683* Fri Apr 19 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.3-1
684- New upstream release
685- Enabled curl and eap-identity plugins
686- Enabled support for eap-radius plugin.
687
688* Thu Apr 18 2013 Pavel Šimerda <psimerda@redhat.com> - 5.0.2-3
689- Add gettext-devel to BuildRequires because of epel6
690- Remove unnecessary comments
691
692* Tue Mar 19 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.2-2
693- Enabled support for eap-radius plugin.
694
695* Mon Mar 11 2013 Avesh Agarwal <avagarwa@redhat.com> - 5.0.2-1
696- Update to upstream release 5.0.2
697- Created sub package strongswan-tnc-imcvs that provides trusted network
698  connect's IMC and IMV funtionality. Specifically it includes PTS
699  based IMC/IMV for TPM based remote attestation and scanner and test
700  IMCs and IMVs. The Strongswan's IMC/IMV dynamic libraries can be used
701  by any third party TNC Client/Server implementation possessing a
702  standard IF-IMC/IMV interface.
703
704* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.0.1-2
705- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
706
707* Thu Oct 04 2012 Pavel Šimerda <psimerda@redhat.com> - 5.0.1-1
708- Update to release 5.0.1
709
710* Thu Oct 04 2012 Pavel Šimerda <psimerda@redhat.com> - 5.0.0-4.git20120619
711- Add plugins to interoperate with Windows 7 and Android (#862472)
712  (contributed by Haim Gelfenbeyn)
713
714* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.0.0-3.git20120619
715- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
716
717* Sun Jul 08 2012 Pavel Šimerda <pavlix@pavlix.net> - 5.0.0-2.git20120619
718- Fix configure substitutions in initscripts
719
720* Wed Jul 04 2012 Pavel Šimerda <psimerda@redhat.com> - 5.0.0-1.git20120619
721- Update to current upstream release
722- Comment out all stuff that is only needed for git builds
723- Remove renaming patch from git
724- Improve init patch used for EPEL
725
726* Thu Jun 21 2012 Pavel Šimerda <psimerda@redhat.com> - 5.0.0-0.3.git20120619
727- Build with openssl plugin enabled
728
729* Wed Jun 20 2012 Pavel Šimerda <psimerda@redhat.com> - 5.0.0-0.2.git20120619
730- Add README.Fedora with link to 4.6 to 5.0 migration information
731
732* Tue Jun 19 2012 Pavel Šimerda - 5.0.0-0.1.git20120619
733- Snapshot of upcoming major release
734- Move patches and renaming upstream
735  http://wiki.strongswan.org/issues/194
736  http://wiki.strongswan.org/issues/195
737- Notified upstream about manpage issues
738
739* Tue Jun 19 2012 Pavel Šimerda - 4.6.4-2
740- Make initscript patch more distro-neutral
741- Add links to bugreports for patches
742
743* Fri Jun 01 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.4-1
744- New upstream version (CVE-2012-2388)
745
746* Sat May 26 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.3-2
747- Add --enable-nm to configure
748- Add NetworkManager-devel to BuildRequires
749- Add NetworkManager-glib-devel to BuildRequires
750- Add strongswan-NetworkManager package
751
752* Sat May 26 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.3-1
753- New version of Strongswan
754- Support for RFC 3110 DNSKEY (see upstream changelog)
755- Fix corrupt scriptlets
756
757* Fri Mar 30 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.2-2
758- #808612 - strongswan binary renaming side-effect
759
760* Sun Feb 26 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.2-1
761- New upstream version
762- Changed from .tar.gz to .tar.bz2
763- Added libstrongswan-pkcs8.so
764
765* Wed Feb 15 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-8
766- Fix initscript's status function
767
768* Wed Feb 15 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-7
769- Expand tabs in config files for better readability
770- Add sysvinit script for epel6
771
772* Wed Feb 15 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-6
773- Fix program name in systemd unit file
774
775* Tue Feb 14 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-5
776- Improve fedora/epel conditionals
777
778* Sat Jan 21 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-4
779- Protect configuration directory from ordinary users
780- Add still missing directory /etc/strongswan
781
782* Fri Jan 20 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-3
783- Change directory structure to avoid clashes with Openswan
784- Prefixed all manpages with 'strongswan_'
785- Every file now includes 'strongswan' somewhere in its path
786- Removed conflict with Openswan
787- Finally fix permissions on strongswan.conf
788
789* Fri Jan 20 2012 Pavel Šimerda <pavlix@pavlix.net> - 4.6.1-2
790- Change license tag from GPL to GPLv2+
791- Change permissions on /etc/strongswan.conf to 644
792- Rename ipsec.8 manpage to strongswan.8
793- Fix empty scriptlets for non-fedora builds
794- Add ldconfig scriptlet
795- Add missing directories and files
796
797* Sun Jan 01 2012 Pavel Šimerda <pavlix@pavlix.net - 4.6.1-1
798- Bump to version 4.6.1
799
800* Sun Jan 01 2012 Pavel Šimerda <pavlix@pavlix.net - 4.6.0-3
801- Add systemd scriptlets
802- Add conditions to also support EPEL6
803
804* Sat Dec 10 2011 Pavel Šimerda <pavlix@pavlix.net> - 4.6.0-2
805- Experimental build for development
Note: See TracBrowser for help on using the repository browser.