source: projects/specs/trunk/s/strigi/strigi-vl.spec @ 6655

Revision 6655, 6.6 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release or rebuild with exiv2-0.23

Line 
1Name:           strigi
2Summary:        A desktop search program
3Summary(ja):    デスクトップ検索プログラム
4Version:        0.7.5
5Release:        3%{?_dist_release}
6
7Group:          Applications/Productivity
8License:        LGPLv2+
9#URL:           http://strigi.sourceforge.net/
10URL:            http://www.vandenoever.info/software/strigi/
11
12Source0:        http://www.vandenoever.info/software/strigi/strigi-%{version}.tar.bz2
13Source1:        strigiclient.desktop
14Source2:        strigi-daemon.desktop
15
16## upstreamable patches
17# exlicitly mark convenience libs static
18Patch50:        strigi-0.7.5-static_convenience_libs.patch
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21BuildRequires:  bison
22BuildRequires:  bzip2-devel
23BuildRequires:  cmake >= 2.6.0
24#BuildRequires: clucene-core-devel
25BuildRequires:  cppunit-devel
26BuildRequires:  dbus-devel dbus-x11
27BuildRequires:  desktop-file-utils
28BuildRequires:  exiv2-devel
29BuildRequires:  gamin-devel
30BuildRequires:  libxml2-devel
31BuildRequires:  qt4-devel
32BuildRequires:  zlib-devel
33
34%description
35Strigi is a fast and light desktop search engine. It can handle a large range
36of file formats such as emails, office documents, media files, and file
37archives. It can index files that are embedded in other files. This means email
38attachments and files in zip files are searchable as if they were normal files
39on your harddisk.
40
41Strigi is normally run as a background daemon that can be accessed by many
42other programs at once. In addition to the daemon, Strigi comes with powerful
43replacements for the popular unix commands 'find' and 'grep'. These are called
44'deepfind' and 'deepgrep' and can search inside files just like the strigi
45daemon can.
46
47%package        libs
48Summary:        Strigi libraries
49Summary(ja):    Strigi 検索エンジンライブラリ
50Group:          System Environment/Libraries
51
52%description    libs
53Strigi search engine libraries
54
55%package        devel
56Summary:        Development files for the strigi desktop search engine
57Summary(ja):    Strigi デスクトップ検索エンジンの開発用ファイル
58Group:          Development/Libraries
59Requires:       %{name}-libs = %{version}-%{release}
60
61%description    devel
62Development files for the strigi desktop search engine
63
64
65%prep
66%setup -q
67%patch50 -p1 -b .static_convenience_libs
68
69%build
70mkdir build
71cd build
72export CFLAGS="%{optflags}"
73export CXXFLAGS="%{optflags}"
74export FFLAGS="%{optflags}"
75%ifarch x86_64 ppc64
76%define lib_suffix 64
77%else
78%define lib_suffix %{nil}
79%endif
80cmake \
81    -DCMAKE_INSTALL_PREFIX=%{_prefix} \
82    -DLIB_DESTINATION=%{_libdir} \
83    -DLIB_SUFFIX=%{lib_suffix} \
84    -DENABLE_CLUCENE:BOOL=OFF \
85    -DENABLE_CLUCENE_NG:BOOL=OFF \
86    -DENABLE_DBUS:BOOL=ON \
87    -DENABLE_FAM:BOOL=ON \
88    -DENABLE_FFMPEG:BOOL=OFF \
89    -DENABLE_INOTIFY:BOOL=ON \
90    %{?_cmake_skip_rpath} \
91    ..
92make VERBOSE=1 %{?_smp_mflags}
93
94%install
95rm -rf $RPM_BUILD_ROOT
96cd build
97make DESTDIR=$RPM_BUILD_ROOT install
98
99desktop-file-install \
100        --vendor="" \
101        --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
102        %{SOURCE1}
103
104# Add an autostart desktop file for the strigi daemon
105install -p -m644 -D %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart/strigi-daemon.desktop
106
107%clean
108rm -rf $RPM_BUILD_ROOT
109
110%post libs -p /sbin/ldconfig
111
112%postun libs -p /sbin/ldconfig
113
114%files
115%defattr(-,root,root,-)
116%doc AUTHORS COPYING ChangeLog
117%{_sysconfdir}/xdg/autostart/strigi-daemon.desktop
118%{_bindir}/*
119%{_datadir}/applications/strigiclient.desktop
120%{_datadir}/dbus-1/services/*
121%{_datadir}/strigi
122#{_libdir}/strigi/strigiindex_clucene.so
123
124%files libs
125%defattr(-,root,root,-)
126%{_libdir}/*.so.*
127%{_libdir}/strigi
128%exclude %{_libdir}/strigi/*.cmake
129#exclude %{_libdir}/strigi/strigiindex_clucene.so
130
131%files devel
132%defattr(-,root,root,-)
133%{_includedir}/strigi
134%{_libdir}/*.so
135%{_libdir}/pkgconfig/libstream*.pc
136%{_libdir}/strigi/*.cmake
137%{_libdir}/libsearchclient/*.cmake
138%{_libdir}/libstreamanalyzer/*.cmake
139%{_libdir}/libstreams/*.cmake
140
141%changelog
142* Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.5-3
143- rebuild with exiv2-0.23
144
145* Mon May 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.5-2
146- rebuild with exiv2-0.22
147
148* Sun Sep 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.5-1
149- updated to 0.7.5
150- dropt clucene support
151
152* Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.2-5
153- rebuilt with exiv2-0.21.1
154
155* Thu Sep 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.2-4
156- rebuilt with rpm-4.8.1
157- added Japanese summaries
158
159* Wed May  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.2-3
160- rebuilt with exiv2-0.19
161
162* Sun Apr 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 0.7.2-2
163- rebuilt to support strigiclient (x86_64)
164
165* Fri Feb 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.2-1
166- new upstream release
167- built with new toolchain
168
169* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.0-1
170- new upstream release
171
172* Mon Apr 13 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.6.4-2
173- rebuild with exiv2-0.18.1-1
174
175* Tue Feb 17 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.6.4-1
176- new upstream release
177- update Patch0 and delete Patch1
178
179* Wed Jan 21 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.11-2
180- add Patch0 and Patch1
181
182* Sun Dec  7 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.11-1
183- new upstream release
184
185* Tue Aug  5 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.10-1
186- new upstream release
187
188* Sun May  4 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.9-1
189- new upstream release
190
191* Wed Nov 21 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.7-0vl1
192- new upstream release
193
194* Thu Sep  6 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.5-0vl1
195- new upstream release
196
197* Thu Aug 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.4-0vl1
198- new upstream release
199
200* Thu Jun 28 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.1-5vl2
201- rebuild with qt4-4.3.0-0vl1
202
203* Sun May 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.1-5vl1
204- initial release for VineSeed
205
206* Wed May 16 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.1-5
207- Split out a strigi-libs subpackage as suggested in BZ#223586
208_ Include a strigidaemon autostart desktop file
209
210* Sat May 05 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.1-4
211- Add dbus-devel BR.
212
213* Sat May 05 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.1-3
214- Misc. fixes from package review
215
216* Fri May 04 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.1-2
217- Updates from reviews:
218-       Have the -devel subpackage require pkgconfig
219-       Add a versioned dependency on cmake and remove dbus-qt buildrequire
220
221* Fri May 04 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.1-1
222- New release
223
224* Wed May 02 2007 Deji Akingunola <dakingun@gmail.com> - 0.3.11-3
225- Allow building on FC6
226
227* Thu Feb 22 2007 Deji Akingunola <dakingun@gmail.com> - 0.3.11-2
228- Assorted fixed arising from reviews
229
230* Wed Jan 17 2007 Deji Akingunola <dakingun@gmail.com> - 0.3.11-1
231- Initial packaging for Fedora Extras
Note: See TracBrowser for help on using the repository browser.