source: projects/specs/trunk/s/strigi/strigi-vl.spec @ 953

Revision 953, 5.6 KB checked in by inagaki, 14 years ago (diff)

updated: exiv2, geeqie, gnome-commander, kdebase-runtime, kdebase-workspace, kdegraphics, kphotoalbum, strigi and ufraw

Line 
1Name:           strigi
2Version:        0.7.2
3Release:        3%{?_dist_release}
4Summary:        A desktop search program for KDE
5Group:          Applications/Productivity
6License:        LGPL
7URL:            http://strigi.sourceforge.net/
8Source0:        strigi-%{version}.tar.bz2
9Source1:        strigiclient.desktop
10Source2:        strigi-daemon.desktop
11Patch0:         strigi-0.6.2-multilib.patch
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14BuildRequires:  cmake >= 2.4.5
15BuildRequires:  exiv2-devel >= 0.12
16BuildRequires:  clucene-core-devel
17BuildRequires:  qt4-devel
18BuildRequires:  dbus-devel
19BuildRequires:  expat-devel
20BuildRequires:  libxml2-devel
21BuildRequires:  bzip2-devel
22BuildRequires:  zlib-devel
23BuildRequires:  gamin-devel
24BuildRequires:  desktop-file-utils
25
26%description
27Strigi is a fast and light desktop search engine. It can handle a large range
28of file formats such as emails, office documents, media files, and file
29archives. It can index files that are embedded in other files. This means email
30attachments and files in zip files are searchable as if they were normal files
31on your harddisk.
32
33Strigi is normally run as a background daemon that can be accessed by many
34other programs at once. In addition to the daemon, Strigi comes with powerful
35replacements for the popular unix commands 'find' and 'grep'. These are called
36'deepfind' and 'deepgrep' and can search inside files just like the strigi
37daemon can.
38
39%package        libs
40Summary:        Strigi libraries
41Group:          System Environment/Libraries
42
43%description    libs
44Strigi search engine libraries
45
46%package        devel
47Summary:        Development files for the strigi desktop search engine
48Group:          Development/Libraries
49Requires:       %{name}-libs = %{version}-%{release}
50Requires:       pkgconfig
51
52%description    devel
53Development files for the strigi desktop search engine
54
55
56%prep
57%setup -q
58%patch0 -p1 -b .multilibs
59
60%build
61mkdir build
62cd build
63export CFLAGS="%{optflags}"
64export CXXFLAGS="%{optflags}"
65export FFLAGS="%{optflags}"
66%ifarch x86_64 ppc64
67%define lib_suffix 64
68%else
69%define lib_suffix %{nil}
70%endif
71cmake \
72    -DCMAKE_INSTALL_PREFIX=%{_prefix} \
73    -DLIB_DESTINATION=%{_libdir} \
74    -DLIB_SUFFIX=%{lib_suffix} \
75    -DENABLE_EXPAT:BOOL=ON \
76    -DENABLE_INOTIFY:BOOL=ON \
77    -DENABLE_DBUS:BOOL=ON \
78    -DENABLE_FAM:BOOL=ON \
79    ..
80make VERBOSE=1 %{?_smp_mflags}
81
82%install
83rm -rf %{buildroot}
84cd build
85make DESTDIR=%{buildroot} install
86
87desktop-file-install \
88        --vendor="" \
89        --dir=%{buildroot}%{_datadir}/applications \
90        %{SOURCE1}
91
92# Add an autostart desktop file for the strigi daemon
93mkdir -p %{buildroot}%{_sysconfdir}/xdg/autostart
94cp -pr %{SOURCE2} %{buildroot}%{_sysconfdir}/xdg/autostart/
95
96find %{buildroot}%{_libdir} -type f -name "*.so*" -exec chmod 755 {} ';'
97
98%clean
99rm -rf %{buildroot}
100
101%post libs -p /sbin/ldconfig
102
103%postun libs -p /sbin/ldconfig
104
105%files
106%defattr(-,root,root,-)
107%doc AUTHORS COPYING ChangeLog README TODO
108%{_bindir}/*
109%{_datadir}/applications/strigiclient.desktop
110%{_sysconfdir}/xdg/autostart/strigi-daemon.desktop
111%{_datadir}/strigi
112%{_datadir}/dbus-1/services/*
113
114%files libs
115%defattr(-,root,root,-)
116%{_libdir}/*.so.*
117%{_libdir}/strigi
118%exclude %{_libdir}/strigi/*.cmake
119
120%files devel
121%defattr(-,root,root,-)
122%{_libdir}/*.so
123%{_libdir}/pkgconfig/libstream*.pc
124%{_libdir}/strigi/*.cmake
125%{_includedir}/strigi
126
127%changelog
128* Wed May  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.2-3
129- rebuilt with exiv2-0.19
130
131* Sun Apr 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 0.7.2-2
132- rebuilt to support strigiclient (x86_64)
133
134* Fri Feb 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.2-1
135- new upstream release
136- built with new toolchain
137
138* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.0-1
139- new upstream release
140
141* Mon Apr 13 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.6.4-2
142- rebuild with exiv2-0.18.1-1
143
144* Tue Feb 17 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.6.4-1
145- new upstream release
146- update Patch0 and delete Patch1
147
148* Wed Jan 21 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.11-2
149- add Patch0 and Patch1
150
151* Sun Dec  7 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.11-1
152- new upstream release
153
154* Tue Aug  5 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.10-1
155- new upstream release
156
157* Sun May  4 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.9-1
158- new upstream release
159
160* Wed Nov 21 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.7-0vl1
161- new upstream release
162
163* Thu Sep  6 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.5-0vl1
164- new upstream release
165
166* Thu Aug 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.4-0vl1
167- new upstream release
168
169* Thu Jun 28 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.1-5vl2
170- rebuild with qt4-4.3.0-0vl1
171
172* Sun May 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.1-5vl1
173- initial release for VineSeed
174
175* Wed May 16 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.1-5
176- Split out a strigi-libs subpackage as suggested in BZ#223586
177_ Include a strigidaemon autostart desktop file
178
179* Sat May 05 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.1-4
180- Add dbus-devel BR.
181
182* Sat May 05 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.1-3
183- Misc. fixes from package review
184
185* Fri May 04 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.1-2
186- Updates from reviews:
187-       Have the -devel subpackage require pkgconfig
188-       Add a versioned dependency on cmake and remove dbus-qt buildrequire
189
190* Fri May 04 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.1-1
191- New release
192
193* Wed May 02 2007 Deji Akingunola <dakingun@gmail.com> - 0.3.11-3
194- Allow building on FC6
195
196* Thu Feb 22 2007 Deji Akingunola <dakingun@gmail.com> - 0.3.11-2
197- Assorted fixed arising from reviews
198
199* Wed Jan 17 2007 Deji Akingunola <dakingun@gmail.com> - 0.3.11-1
200- Initial packaging for Fedora Extras
Note: See TracBrowser for help on using the repository browser.