source: projects/specs/trunk/s/strigi/strigi-vl.spec @ 9791

Revision 9791, 6.7 KB checked in by Takemikaduchi, 8 years ago (diff)

GNOME 3.18.1, BlueZ 5.35, ICU 56.1, Mesa 11.0.4, PulseAudio 7.1, xserver 1.17.4, etc.

Line 
1Name:           strigi
2Summary:        A desktop search program
3Summary(ja):    デスクトップ検索プログラム
4Version:        0.7.8
5Release:        3%{?_dist_release}
6
7Group:          Applications/Productivity
8License:        LGPLv2+
9#URL:           http://strigi.sourceforge.net/
10URL:            http://www.vandenoever.info/software/strigi/
11
12Source0:        http://www.vandenoever.info/software/strigi/strigi-%{version}.tar.bz2
13Source1:        strigiclient.desktop
14Source2:        strigi-daemon.desktop
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17BuildRequires:  bison
18BuildRequires:  bzip2-devel
19BuildRequires:  cmake >= 2.6.0
20#BuildRequires: clucene-core-devel
21BuildRequires:  cppunit-devel
22BuildRequires:  dbus-devel dbus-x11
23BuildRequires:  desktop-file-utils
24BuildRequires:  exiv2-devel
25BuildRequires:  gamin-devel
26BuildRequires:  libxml2-devel
27BuildRequires:  qt4-devel
28BuildRequires:  zlib-devel
29
30%description
31Strigi is a fast and light desktop search engine. It can handle a large range
32of file formats such as emails, office documents, media files, and file
33archives. It can index files that are embedded in other files. This means email
34attachments and files in zip files are searchable as if they were normal files
35on your harddisk.
36
37Strigi is normally run as a background daemon that can be accessed by many
38other programs at once. In addition to the daemon, Strigi comes with powerful
39replacements for the popular unix commands 'find' and 'grep'. These are called
40'deepfind' and 'deepgrep' and can search inside files just like the strigi
41daemon can.
42
43%package        libs
44Summary:        Strigi libraries
45Summary(ja):    Strigi 検索エンジンライブラリ
46Group:          System Environment/Libraries
47
48%description    libs
49Strigi search engine libraries
50
51%package        devel
52Summary:        Development files for the strigi desktop search engine
53Summary(ja):    Strigi デスクトップ検索エンジンの開発用ファイル
54Group:          Development/Libraries
55Requires:       %{name}-libs = %{version}-%{release}
56
57%description    devel
58Development files for the strigi desktop search engine
59
60
61%prep
62%setup -q
63
64%build
65mkdir build
66cd build
67export CFLAGS="%{optflags}"
68export CXXFLAGS="%{optflags}"
69export FFLAGS="%{optflags}"
70%ifarch x86_64 ppc64
71%define lib_suffix 64
72%else
73%define lib_suffix %{nil}
74%endif
75cmake \
76    -DCMAKE_INSTALL_PREFIX=%{_prefix} \
77    -DLIB_DESTINATION=%{_libdir} \
78    -DLIB_SUFFIX=%{lib_suffix} \
79    -DENABLE_CLUCENE:BOOL=OFF \
80    -DENABLE_CLUCENE_NG:BOOL=OFF \
81    -DENABLE_DBUS:BOOL=ON \
82    -DENABLE_FAM:BOOL=ON \
83    -DENABLE_FFMPEG:BOOL=OFF \
84    -DENABLE_INOTIFY:BOOL=ON \
85    %{?_cmake_skip_rpath} \
86    ..
87make VERBOSE=1 %{?_smp_mflags}
88
89%install
90rm -rf $RPM_BUILD_ROOT
91cd build
92make DESTDIR=$RPM_BUILD_ROOT install
93
94desktop-file-install \
95        --vendor="" \
96        --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
97        %{SOURCE1}
98
99# Add an autostart desktop file for the strigi daemon
100install -p -m644 -D %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart/strigi-daemon.desktop
101
102%clean
103rm -rf $RPM_BUILD_ROOT
104
105%post libs -p /sbin/ldconfig
106
107%postun libs -p /sbin/ldconfig
108
109%files
110%defattr(-,root,root,-)
111%doc AUTHORS COPYING ChangeLog
112%{_sysconfdir}/xdg/autostart/strigi-daemon.desktop
113%{_bindir}/*
114%{_datadir}/applications/strigiclient.desktop
115%{_datadir}/dbus-1/services/*
116%{_datadir}/strigi
117
118%files libs
119%defattr(-,root,root,-)
120%{_libdir}/*.so.*
121%{_libdir}/strigi
122
123%files devel
124%defattr(-,root,root,-)
125%{_includedir}/strigi
126%{_libdir}/*.so
127%{_libdir}/pkgconfig/libstream*.pc
128%{_libdir}/cmake/LibSearchClient
129%{_libdir}/cmake/LibStreamAnalyzer
130%{_libdir}/cmake/LibStreams
131%{_libdir}/cmake/Strigi/
132
133%changelog
134* Fri Nov 06 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.8-3
135- rebuild with exiv2-0.25
136
137* Wed Dec 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.8-2
138- rebuild with exiv2-0.24
139
140* Wed Jun 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.8-1
141- new upstream release
142- remove Patch50 (strigi-0.7.5-static_convenience_libs.patch)
143
144* Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.5-3
145- rebuild with exiv2-0.23
146
147* Mon May 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.5-2
148- rebuild with exiv2-0.22
149
150* Sun Sep 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.5-1
151- updated to 0.7.5
152- dropt clucene support
153
154* Sun Jul 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.2-5
155- rebuilt with exiv2-0.21.1
156
157* Thu Sep 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.2-4
158- rebuilt with rpm-4.8.1
159- added Japanese summaries
160
161* Wed May  5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.2-3
162- rebuilt with exiv2-0.19
163
164* Sun Apr 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 0.7.2-2
165- rebuilt to support strigiclient (x86_64)
166
167* Fri Feb 12 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.2-1
168- new upstream release
169- built with new toolchain
170
171* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.7.0-1
172- new upstream release
173
174* Mon Apr 13 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.6.4-2
175- rebuild with exiv2-0.18.1-1
176
177* Tue Feb 17 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.6.4-1
178- new upstream release
179- update Patch0 and delete Patch1
180
181* Wed Jan 21 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.11-2
182- add Patch0 and Patch1
183
184* Sun Dec  7 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.11-1
185- new upstream release
186
187* Tue Aug  5 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.10-1
188- new upstream release
189
190* Sun May  4 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.9-1
191- new upstream release
192
193* Wed Nov 21 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.7-0vl1
194- new upstream release
195
196* Thu Sep  6 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.5-0vl1
197- new upstream release
198
199* Thu Aug 16 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.4-0vl1
200- new upstream release
201
202* Thu Jun 28 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.1-5vl2
203- rebuild with qt4-4.3.0-0vl1
204
205* Sun May 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.1-5vl1
206- initial release for VineSeed
207
208* Wed May 16 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.1-5
209- Split out a strigi-libs subpackage as suggested in BZ#223586
210_ Include a strigidaemon autostart desktop file
211
212* Sat May 05 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.1-4
213- Add dbus-devel BR.
214
215* Sat May 05 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.1-3
216- Misc. fixes from package review
217
218* Fri May 04 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.1-2
219- Updates from reviews:
220-       Have the -devel subpackage require pkgconfig
221-       Add a versioned dependency on cmake and remove dbus-qt buildrequire
222
223* Fri May 04 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.1-1
224- New release
225
226* Wed May 02 2007 Deji Akingunola <dakingun@gmail.com> - 0.3.11-3
227- Allow building on FC6
228
229* Thu Feb 22 2007 Deji Akingunola <dakingun@gmail.com> - 0.3.11-2
230- Assorted fixed arising from reviews
231
232* Wed Jan 17 2007 Deji Akingunola <dakingun@gmail.com> - 0.3.11-1
233- Initial packaging for Fedora Extras
Note: See TracBrowser for help on using the repository browser.