source: projects/specs/trunk/s/strace/strace-vl.spec @ 521

Revision 521, 8.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:      Tracks and displays system calls associated with a running process.
2Summary(ja):  動作中のプロセスと関連するシステムコールの追跡/表示
3Name:         strace
4Version:      4.5.18
5Release:      1%{?_dist_release}
6License:      BSD
7Group:        Development/Tools
8URL:          http://sourceforge.net/projects/strace/
9Source0:      %{name}-%{version}.tar.bz2
10BuildRoot:    %{_tmppath}/%{name}-%{version}-root
11BuildRequires: kernel-headers >= 2.4.0
12
13Vendor:       Project Vine
14Distribution: Vine Linux
15
16%define strace64_arches ppc64
17
18%description
19The strace program intercepts and records the system calls called and
20received by a running process.  Strace can print a record of each
21system call, its arguments and its return value.  Strace is useful for
22diagnosing problems and debugging, as well as for instructional
23purposes.
24
25Install strace if you need a tool to track the system calls made and
26received by a process.
27
28%description -l ja
29strace プログラムは動作中のプロセスがコール/受信したたシステムコールを
30検知して記録します。strace は、各システムコールとその引数および戻り値の
31記録を印刷することができます。strace は教育目的だけではなく、障害の診断や
32デバッグにおいても役に立ちます。
33
34
35%ifarch %{strace64_arches}
36%package -n strace64
37Summary: Tracks and displays system calls associated with a running process.
38Summary(ja):  動作中のプロセスと関連するシステムコールの追跡/表示
39Group: Development/Debuggers
40
41%description -n strace64
42The strace program intercepts and records the system calls called and
43received by a running process.  Strace can print a record of each
44system call, its arguments and its return value.  Strace is useful for
45diagnosing problems and debugging, as well as for instructional
46purposes.
47
48Install strace if you need a tool to track the system calls made and
49received by a process.
50
51This package provides the `strace64' program to trace 64-bit processes.
52The `strace' program in the `strace' package is for 32-bit processes.
53
54%description -n strace64 -l ja
55strace プログラムは動作中のプロセスがコール/受信したたシステムコールを
56検知して記録します。strace は、各システムコールとその引数および戻り値の
57記録を印刷することができます。strace は教育目的だけではなく、障害の診断や
58デバッグにおいても役に立ちます。
59
60このパッケージは 64 ビットプロセス用の `strace64' プログラムを提供します。
61`strace' パッケージに含まれる `strace' プログラムは 32 ビットプロセス用です。
62%endif
63
64%prep
65%setup -q
66
67%build
68%configure
69make
70
71%install
72rm -rf %{buildroot}
73mkdir -p %{buildroot}%{_mandir}/man1
74mkdir -p %{buildroot}%{_bindir}
75%makeinstall man1dir=%{buildroot}%{_mandir}/man1
76
77# remove unpackaged files from the buildroot
78rm -f %{buildroot}%{_bindir}/strace-graph
79
80%ifarch %{strace64_arches}
81ln %{buildroot}%{_bindir}/strace %{buildroot}%{_bindir}/strace64
82%endif
83
84%clean
85rm -rf %{buildroot}
86
87
88%files
89%defattr(-,root,root)
90%doc COPYRIGHT ChangeLog NEWS README README-linux
91%{_bindir}/*
92%{_mandir}/man1/*
93
94%ifarch %{strace64_arches}
95%files -n strace64
96%defattr(-,root,root)
97%{_bindir}/strace64
98%endif
99
100%changelog
101* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.5.18-1
102- new upstream release
103- spec in utf-8
104
105* Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.15-1
106- updated to 4.5.15
107- rebuilt with new toolchains
108
109* Sun Sep 10 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 4.5.13-1vl2
110- change Group to Development/Tools. <BTS:VineLinux:163>
111
112* Sat Nov 12 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.13-1vl1
113- updated to 4.5.13
114- added some documents
115- added Japanese summary and description
116
117* Mon Jan 05 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-1vl1
118- rebuild with new toolchains
119- based on Fedora 4.5.1-1
120
121* Tue Sep 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.99-1vl1
122- rebuild with new toolchains
123- dropped BuildPreReq: autoconf
124- based on Redhat Rawhide 4.4.99-1
125  * Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-1
126  - new upstream version, groks more new system calls, PF_INET6 sockets
127
128* Thu Mar 07 2002 Toru Sagami <sagami@vinelinux.org> 4.4-1.2vl3
129- kernel24-headers -> kernel-headers >= 2.4.0 for BuildPreReq
130
131* Wed Feb 20 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.4-1.2vl2
132- added BuildPreReq: kernel24-headers
133
134* Mon Jan 14 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.4-1.2vl1
135- now based on Debian's strace_4.4-1.2 and built for Vine Linux
136- rebuilt with kernel24-headers
137
138* Sun Jul 22 2001 Florian La Roche <Florian.LaRoche@redhat.de>
139- disable s390 patches, they are already included
140
141* Wed Jul 18 2001 Preston Brown <pbrown@redhat.com> 4.3-1
142- new upstream version.  Seems to have integrated most new syscalls
143- tracing threaded programs is now functional.
144
145* Mon Jun 11 2001 Than Ngo <than@redhat.com>
146- port s390 patches from IBM
147
148* Wed May 16 2001 Nalin Dahyabhai <nalin@redhat.com>
149- modify new syscall patch to allocate enough heap space in setgroups32()
150
151* Wed Feb 14 2001 Jakub Jelinek <jakub@redhat.com>
152- #include <time.h> in addition to <sys/time.h>
153
154* Fri Jan 26 2001 Karsten Hopp <karsten@redhat.com>
155- clean up conflicting patches. This happened only
156  when building on S390
157
158* Fri Jan 19 2001 Bill Nottingham <notting@redhat.com>
159- update to CVS, reintegrate ia64 support
160
161* Sat Dec  8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
162- Get S/390 support into the normal package
163
164* Sat Nov 18 2000 Florian La Roche <Florian.LaRoche@redhat.de>
165- added S/390 patch from IBM, adapting it to not conflict with
166  IA64 patch
167
168* Sat Aug 19 2000 Jakub Jelinek <jakub@redhat.com>
169- doh, actually apply the 2.4 syscalls patch
170- make it compile with 2.4.0-test7-pre4+ headers, add
171  getdents64 and fcntl64
172
173* Thu Aug  3 2000 Jakub Jelinek <jakub@redhat.com>
174- add a bunch of new 2.4 syscalls (#14036)
175
176* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
177- automatic rebuild
178- excludearch ia64
179
180* Fri Jun  2 2000 Matt Wilson <msw@redhat.com>
181- use buildinstall for FHS
182
183* Wed May 24 2000 Jakub Jelinek <jakub@redhat.com>
184- make things compile on sparc
185- fix sigreturn on sparc
186
187* Fri Mar 31 2000 Bill Nottingham <notting@redhat.com>
188- fix stat64 misdef (#10485)
189
190* Tue Mar 21 2000 Michael K. Johnson <johnsonm@redhat.com>
191- added ia64 patch
192
193* Thu Feb 03 2000 Cristian Gafton <gafton@redhat.com>
194- man pages are compressed
195- version 4.2 (why are we keeping all these patches around?)
196
197* Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
198- update to 4.1 (with sparc socketcall patch).
199
200* Fri Nov 12 1999 Jakub Jelinek <jakub@redhat.com>
201- fix socketcall on sparc.
202
203* Thu Sep 02 1999 Cristian Gafton <gafton@redhat.com>
204- fix KERN_SECURELVL compile problem
205
206* Tue Aug 31 1999 Cristian Gafton <gafton@redhat.com>
207- added alpha patch from HJLu to fix the osf_sigprocmask interpretation
208
209* Sat Jun 12 1999 Jeff Johnson <jbj@redhat.com>
210- update to 3.99.1.
211
212* Wed Jun  2 1999 Jeff Johnson <jbj@redhat.com>
213- add (the other :-) jj's sparc patch.
214
215* Wed May 26 1999 Jeff Johnson <jbj@redhat.com>
216- upgrade to 3.99 in order to
217-    add new 2.2.x open flags (#2955).
218-    add new 2.2.x syscalls (#2866).
219- strace 3.1 patches carried along for now.
220
221* Sun May 16 1999 Jeff Johnson <jbj@redhat.com>
222- don't rely on (broken!) rpm %patch (#2735)
223
224* Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
225- strip binary
226
227* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
228- auto rebuild in the new build environment (release 16)
229
230* Tue Feb  9 1999 Jeff Johnson <jbj@redhat.com>
231- vfork est arrive!
232
233* Tue Feb  9 1999 Christopher Blizzard <blizzard@redhat.com>
234- Add patch to follow clone() syscalls, too.
235
236* Sun Jan 17 1999 Jeff Johnson <jbj@redhat.com>
237- patch to build alpha/sparc with glibc 2.1.
238
239* Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
240- patch to build on ARM
241
242* Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com>
243- fix typo (printf, not tprintf).
244
245* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
246- fix compile problem on sparc.
247
248* Tue Aug 18 1998 Cristian Gafton <gafton@redhat.com>
249- buildroot
250
251* Mon Jul 20 1998 Cristian Gafton <gafton@redhat.com>
252- added the umoven patch from James Youngman <jay@gnu.org>
253- fixed build problems on newer glibc releases
254
255* Mon Jun 08 1998 Prospector System <bugs@redhat.com>
256- translations modified for de, fr, tr
Note: See TracBrowser for help on using the repository browser.