source: projects/specs/trunk/s/stow/stow-vl.spec @ 521

Revision 521, 2.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:      Manage the installation of software packages from source
2Name:         stow
3Version:      1.3.3
4Release:      9%{?_dist_release}
5
6License:      GPLv2+
7Group:        Development/Tools
8URL:          http://www.gnu.org/software/stow/stow.html
9Source:       http://ftp.gnu.org/gnu/stow/stow-%{version}.tar.gz
10BuildRoot:    %{_tmppath}/%{name}-%{version}-root
11BuildArch:    noarch
12Requires(pre):   /sbin/install-info
13Requires(post):  /sbin/install-info
14
15%description
16GNU Stow is a program for managing the installation of software packages,
17keeping them separate (/usr/local/stow/emacs vs. /usr/local/stow/perl, for
18example) while making them appear to be installed in the same place
19(/usr/local). Software to ease the keeping track of software built from
20source, making it easy to install, delete, move etc.
21
22%prep
23%setup -q
24
25%build
26%configure
27
28%install
29rm -rf $RPM_BUILD_ROOT
30make DESTDIR=$RPM_BUILD_ROOT install
31# Remove info database, will be generated at install-time by scriptlets
32rm -f $RPM_BUILD_ROOT%{_infodir}/dir
33
34%post
35/sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir 2>/dev/null || :
36
37%preun
38if [ $1 -eq 0 ]; then
39  /sbin/install-info --delete %{_infodir}/%{name}.info \
40    %{_infodir}/dir 2>/dev/null || :
41fi
42
43%clean
44rm -rf $RPM_BUILD_ROOT
45
46%files
47%defattr(-,root,root)
48%doc COPYING README AUTHORS INSTALL ChangeLog NEWS THANKS TODO
49%doc %{_mandir}/man8/stow*
50%doc %{_infodir}/stow*
51%{_bindir}/*
52
53%changelog
54* Sat Jan 30 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.3-9
55- initial build for Vine Linux
56
57* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.3-8
58- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
59
60* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.3-7
61- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
62
63* Sun Aug 26 2007 Aurelien Bompard <abompard@fedoraproject.org> 1.3.3-6
64- fix license tag
65
66* Thu Aug 31 2006 Aurelien Bompard <abompard@fedoraproject.org> 1.3.3-5
67- rebuild
68
69* Tue Jun 20 2006 Aurelien Bompard <gauret[AT]free.fr> 1.3.3-4
70- remove the _infodir/dir file in %%install
71
72* Wed Feb 22 2006 Aurelien Bompard <gauret[AT]free.fr> 1.3.3-3
73- rebuild for FC5
74
75* Fri Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
76- rebuilt
77
78* Sat May 15 2004 Aurelien Bompard <gauret[AT]free.fr> 0:1.3.3-0.fdr.1
79- initial RPM
Note: See TracBrowser for help on using the repository browser.