source: projects/specs/trunk/s/stone/stone-vl.spec @ 521

Revision 521, 4.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# ----------------------------------------------------------
2# (1) Data definition
3# ----------------------------------------------------------
4
5%define _mandir %{_datadir}/man
6%define _source_dir stone-2.3d-2.3.2.7
7
8Summary: The stone is TCP and UDP packet repeater.
9Summary(ja): TCP & UDP パケットリピータ stone
10Name: stone
11Version: 2.3e
12Release: 1%{_dist_release}
13URL: http://www.gcd.org/sengoku/stone/
14Source0: http://www.gcd.org/sengoku/stone/%{name}-%{version}.tar.gz
15# 'rfc1321.txt', 'global.h', 'md5.h', and 'md5c.c'
16Source1: stone-Source1.tar.gz
17Source2: stone.init
18Source3: stone.conf
19Source4: stone.1.gz
20Source5: stone.1.ja.gz
21# adapted for Vine Linux
22Patch0: stone-%{version}-Makefile.patch
23License: GPL
24Group: Applications/Internet
25
26BuildRoot: %{_tmppath}/%{name}-%{version}-root
27Prefix: %{_prefix}
28
29Requires: openssl
30BuildPrereq: openssl-devel
31
32
33%description
34Stone is a TCP/IP packet repeater in the application layer.  It
35repeats TCP and UDP packets from inside to outside of a firewall, or
36from outside to inside.
37
38%description -l ja
39stone は、アプリケーションレベルの TCP & UDP パケットリピーターです。
40ファイアウォールの内から外へ、あるいは外から内へ、TCP パケットあるいは
41UDP パケットを中継します。
42
43
44
45# ----------------------------------------------------------
46# (2) Scripts
47# ----------------------------------------------------------
48
49# --- prep
50%prep
51rm -rf ${RPM_BUILD_ROOT}
52# %setup -a 1 -n ${RPM_PACKAGE_NAME}-${RPM_PACKAGE_VERSION}
53%setup -a 1 -n %{_source_dir}
54%patch0 -p0 -b .vine
55
56# --- build
57%build
58make linux-ssl SSL_FLAGS='-DUSE_SSL' SSL_LIBS='-lssl -lcrypto'
59
60
61# --- install
62%install
63install -d --mode=0755 ${RPM_BUILD_ROOT}%{_bindir}
64install -d --mode=0755 ${RPM_BUILD_ROOT}%{_mandir}/man1
65install -d --mode=0755 ${RPM_BUILD_ROOT}%{_mandir}/ja/man1
66install --mode=0755 stone ${RPM_BUILD_ROOT}%{_bindir}/stone
67install --mode=0644 %{SOURCE4} ${RPM_BUILD_ROOT}%{_mandir}/man1/stone.1.gz
68install --mode=0644 %{SOURCE5} ${RPM_BUILD_ROOT}%{_mandir}/ja/man1/stone.1.gz
69mkdir -p %{buildroot}/etc/rc.d/init.d
70install --mode=0755 %{SOURCE2} ${RPM_BUILD_ROOT}/etc/rc.d/init.d/stone
71install --mode=0644 %{SOURCE3} ${RPM_BUILD_ROOT}/etc/stone.conf
72
73# --- clean
74%clean
75rm -rf ${RPM_BUILD_ROOT}
76
77
78
79# ----------------------------------------------------------
80# (3) File Lists
81# ----------------------------------------------------------
82
83%files
84%defattr(-,root,root)
85%doc README.txt README.en.txt GPL.txt rfc1321.txt
86%{_bindir}/stone
87%{_mandir}/man1/stone.1*
88%{_mandir}/ja/man1/stone.1*
89%config /etc/rc.d/init.d/stone
90%config(noreplace) /etc/stone.conf
91
92
93
94# ----------------------------------------------------------
95# (4) Change Log
96# ----------------------------------------------------------
97
98%changelog
99* Mon Jun 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.3e-1
100- new upstream release
101- new versioning policy and spec in UTF-8
102- update patch0 (_GNU_SOURCE macro is required glibc >= 2.8)
103
104* Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3c-0vl4
105- rebuild with new environment
106
107* Wed Oct 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3c-0vl3
108- rebuilt for Vine Linux 4.0
109
110* Fri Oct  6 2006 Takeru INOUE <takeru.inoue@ieee.org>
111- 2.3c-0vl1
112- Updated
113
114* Sun Jul 16 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3b-0vl2
115- rebuilt for VineSeed (4.0)
116
117* Sun Jul 16 2006 Takeru INOUE <takeru.inoue@ieee.org>
118- 2.3b-0vl1
119- Build for Vine 3.2
120
121* Sat Jul  8 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3-0vl2
122- rebuilt for VineSeed
123- changed Group to Applications/Internet
124
125* Mon Mar 27 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
126- 2.3-0vl1
127- new upstream release
128- update Patch0
129- Build for Vine 3.2
130
131* Sun Mar 23 2003 Takeru INOUE <takeru.inoue@gamma.ocn.ne.jp>
132- 2.1x-0vl0
133- updated
134- add /etc/rc.d/init.d/stone and /etc/stone.conf
135
136* Fri Dec  6 2002 Takashi `Muneharu' Sugimoto <muneharu@raug.net>
137- 2.1w-0vl1
138- change the file list
139* Thu Oct 31 2002 Takashi Sugimoto
140- 2.1w-0vl0
141- updated
142* Mon Aug 19 2002 Takashi Sugimoto
143- 2.1v-0vl0
144- updated
145* Wed Apr 10 2002 Takashi Sugimoto
146- 2.1r-0.1vl3
147
Note: See TracBrowser for help on using the repository browser.