source: projects/specs/trunk/s/stone/stone-vl.spec @ 10089

Revision 10089, 4.8 KB checked in by iwamoto, 8 years ago (diff)

stone: rebuilt with openssl 1.0.2g and disable SSL2

Line 
1# ----------------------------------------------------------
2# (1) Data definition
3# ----------------------------------------------------------
4
5%define _mandir %{_datadir}/man
6%define _source_dir stone-2.3d-2.3.2.7
7
8Summary: The stone is TCP and UDP packet repeater.
9Summary(ja): TCP & UDP パケットリピータ stone
10Name: stone
11Version: 2.3e
12Release: 5%{_dist_release}
13
14License: GPL
15Group: Applications/Internet
16URL: http://www.gcd.org/sengoku/stone/
17
18Source0: http://www.gcd.org/sengoku/stone/%{name}-%{version}.tar.gz
19# 'rfc1321.txt', 'global.h', 'md5.h', and 'md5c.c'
20Source1: stone-Source1.tar.gz
21Source2: stone.init
22Source3: stone.conf
23Source4: stone.1.gz
24Source5: stone.1.ja.gz
25# adapted for Vine Linux
26Patch0: stone-%{version}-Makefile.patch
27
28BuildRoot: %{_tmppath}/%{name}-%{version}-root
29BuildRequires: nkf
30BuildRequires: openssl-devel
31
32Requires: openssl
33Requires: gcc-cpp
34
35Vendor: Project Vine
36Distribution: Vine Linux
37Packager: iwamoto
38
39%description
40Stone is a TCP/IP packet repeater in the application layer.  It
41repeats TCP and UDP packets from inside to outside of a firewall, or
42from outside to inside.
43
44%description -l ja
45stone は、アプリケーションレベルの TCP & UDP パケットリピーターです。
46ファイアウォールの内から外へ、あるいは外から内へ、TCP パケットあるいは
47UDP パケットを中継します。
48
49
50
51# ----------------------------------------------------------
52# (2) Scripts
53# ----------------------------------------------------------
54
55# --- prep
56%prep
57rm -rf ${RPM_BUILD_ROOT}
58# %setup -a 1 -n ${RPM_PACKAGE_NAME}-${RPM_PACKAGE_VERSION}
59%setup -a 1 -n %{_source_dir}
60%patch0 -p0 -b .vine
61
62nkf -w README.txt > README.txt.utf8
63mv README.txt.utf8 README.txt
64nkf -w GPL.txt > GPL.txt.utf8
65mv GPL.txt.utf8 GPL.txt
66
67
68# --- build
69%build
70make linux-ssl SSL_FLAGS='-DUSE_SSL -DOPENSSL_NO_SSL2 ' SSL_LIBS='-lssl -lcrypto'
71
72
73# --- install
74%install
75rm -rf ${RPM_BUILD_ROOT}
76install -d --mode=0755 ${RPM_BUILD_ROOT}%{_bindir}
77install -d --mode=0755 ${RPM_BUILD_ROOT}%{_mandir}/man1
78install -d --mode=0755 ${RPM_BUILD_ROOT}%{_mandir}/ja/man1
79install --mode=0755 stone ${RPM_BUILD_ROOT}%{_bindir}/stone
80install --mode=0644 %{SOURCE4} ${RPM_BUILD_ROOT}%{_mandir}/man1/stone.1.gz
81install --mode=0644 %{SOURCE5} ${RPM_BUILD_ROOT}%{_mandir}/ja/man1/stone.1.gz
82mkdir -p %{buildroot}/etc/rc.d/init.d
83install --mode=0755 %{SOURCE2} ${RPM_BUILD_ROOT}/etc/rc.d/init.d/stone
84install --mode=0644 %{SOURCE3} ${RPM_BUILD_ROOT}/etc/stone.conf
85
86# --- clean
87%clean
88rm -rf ${RPM_BUILD_ROOT}
89
90
91# ----------------------------------------------------------
92# (3) File Lists
93# ----------------------------------------------------------
94
95%files
96%defattr(-,root,root)
97%doc README.txt README.en.txt GPL.txt rfc1321.txt
98%{_bindir}/stone
99%{_mandir}/man1/stone.1*
100%{_mandir}/ja/man1/stone.1*
101%config /etc/rc.d/init.d/stone
102%config(noreplace) /etc/stone.conf
103
104
105# ----------------------------------------------------------
106# (4) Change Log
107# ----------------------------------------------------------
108
109%changelog
110* Tue Mar 15 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.3e-5
111- rebuilt with openssl 1.0.2g and disable SSL2
112
113* Sun Dec 14 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.3e-4
114- rebuilt on current VineSeed
115- added BR: nkf to convert document encoding to UTF
116
117* Mon Dec 30 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.3e-3
118- add R:gcc-cpp (cpp is required to parse conf file)
119- add Distri/Vendor/Packager tags
120
121* Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.3e-2
122- rebuild with openssl-1.0.0c
123
124* Mon Jun 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.3e-1
125- new upstream release
126- new versioning policy and spec in UTF-8
127- update patch0 (_GNU_SOURCE macro is required glibc >= 2.8)
128
129* Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3c-0vl4
130- rebuild with new environment
131
132* Wed Oct 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3c-0vl3
133- rebuilt for Vine Linux 4.0
134
135* Fri Oct  6 2006 Takeru INOUE <takeru.inoue@ieee.org>
136- 2.3c-0vl1
137- Updated
138
139* Sun Jul 16 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3b-0vl2
140- rebuilt for VineSeed (4.0)
141
142* Sun Jul 16 2006 Takeru INOUE <takeru.inoue@ieee.org>
143- 2.3b-0vl1
144- Build for Vine 3.2
145
146* Sat Jul  8 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3-0vl2
147- rebuilt for VineSeed
148- changed Group to Applications/Internet
149
150* Mon Mar 27 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
151- 2.3-0vl1
152- new upstream release
153- update Patch0
154- Build for Vine 3.2
155
156* Sun Mar 23 2003 Takeru INOUE <takeru.inoue@gamma.ocn.ne.jp>
157- 2.1x-0vl0
158- updated
159- add /etc/rc.d/init.d/stone and /etc/stone.conf
160
161* Fri Dec  6 2002 Takashi `Muneharu' Sugimoto <muneharu@raug.net>
162- 2.1w-0vl1
163- change the file list
164* Thu Oct 31 2002 Takashi Sugimoto
165- 2.1w-0vl0
166- updated
167* Mon Aug 19 2002 Takashi Sugimoto
168- 2.1v-0vl0
169- updated
170* Wed Apr 10 2002 Takashi Sugimoto
171- 2.1r-0.1vl3
172
Note: See TracBrowser for help on using the repository browser.