source: projects/specs/trunk/s/star/star-vl.spec @ 8571

Revision 8571, 14.5 KB checked in by daisuke, 10 years ago (diff)

star: new package, provides more posix compatible pax, rmt ...

Line 
1Summary:  An archiving tool with ACL support
2Summary(ja):  An archiving tool with ACL support
3Name: star
4Version: 1.5.2
5Release: 1%{?_dist_release}
6License: CDDL
7Group: Applications/Archiving
8URL: http://cdrecord.berlios.de/old/private/star.html
9Source: ftp://ftp.berlios.de/pub/star/%{name}-%{version}.tar.bz2
10
11#use gcc for compilation, change defaults for Linux
12Patch1: star-1.5-newMake.patch
13#do not segfault with data-change-warn option (#255261)
14Patch3: star-1.5-changewarnSegv.patch
15#Prevent buffer overflow for filenames with length of 100 characters (#556664)
16Patch4: star-1.5.2-bufferoverflow.patch
17#Fix some invalid manpage references (#624612)
18Patch5: star-1.5.1-manpagereferences.patch
19# note that the H=crc format uses Sum32 algorithm, not CRC
20Patch7: star-1.5.1-crc.patch
21
22# fix man-page-day objections
23# ~> proposed upstream:
24#    https://lists.berlios.de/pipermail/star-developers/2013-April/000027.html
25# ~> #948866
26Patch8: star-1.5.2-man-page-day.patch
27
28# Disable profiling on aarch64 as it's not currently supported upstream
29Patch9: star-aarch64.patch
30
31# Allow rmt to access all files.
32# ~> downstream
33# ~> #968980
34Patch10: star-1.5.2-rmt-rh-access.patch
35
36# Use ssh rather than rsh by default
37# ~> downstream
38# ~> related to #968980
39Patch11: star-1.5.2-use-ssh-by-default.patch
40
41BuildRequires: libattr-devel libacl-devel libtool
42BuildRequires: e2fsprogs-devel
43
44# Historically, star installed /usr/bin/spax binary also so we don't want to
45# break the compatibility.  We don't care about scpio because scpio binary was
46# not installed.
47Requires: spax
48
49%description
50Star saves many files together into a single tape or disk archive,
51and can restore individual files from the archive. Star supports ACL.
52
53%package -n     spax
54Summary:        Portable archive exchange
55Group:          Applications/Archiving
56Obsoletes:      pax < 3.4-2
57Provides:       pax
58
59%description -n spax
60The pax utility shall read and write archives, write lists of the members of
61archive files and copy directory hierarchies as is defined in IEEE Std 1003.1.
62
63%package -n     scpio
64Summary:        Copy file archives in and out (LEGACY)
65Group:          Applications/Archiving
66
67%description -n scpio
68The scpio utility, depending on the options used: copies files to an archive
69file, extracts files from an archive file, lists files from an archive file or
70copies files from one directory tree to another.
71
72%package -n     rmt
73Summary: Provides certain programs with access to remote tape devices
74Group: Applications/Archiving
75
76%description -n rmt
77The rmt utility provides remote access to tape devices for programs
78like dump (a filesystem backup program), restore (a program for
79restoring files from a backup), and tar (an archiving program).
80
81%prep
82%setup -q
83%patch1 -p1 -b .newMake
84%patch3 -p1 -b .changewarnSegv
85%patch4 -p1 -b .namesoverflow
86%patch5 -p1 -b .references
87%patch7 -p1 -b .crc
88%patch8 -p1 -b .man-page-day
89%patch9 -p1 -b .aarch64
90%patch10 -p1 -b .rmt-access-rules
91%patch11 -p1 -b .ssh-by-default
92
93cp -a star/all.mk star/Makefile
94
95star_recode()
96{
97    for i in $@; do
98        iconv -f iso_8859-1 -t utf-8 $i > .tmp_file
99        mv .tmp_file $i
100    done
101}
102
103star_recode AN-1.5 AN-1.5.2 star/star.4
104
105cp -a READMEs/README.linux .
106
107for PLAT in %{arm} %{power64} aarch64 x86_64 s390 s390x sh3 sh4 sh4a sparcv9; do
108    for AFILE in gcc cc; do
109            [ ! -e RULES/${PLAT}-linux-${AFILE}.rul ] \
110            && ln -s i586-linux-${AFILE}.rul RULES/${PLAT}-linux-${AFILE}.rul
111    done
112done
113
114%build
115export MAKEPROG=gmake
116# Autoconfiscate
117(cd autoconf; AC_MACRODIR=. AWK=gawk ./autoconf)
118
119#make %%{?_smp_mflags} PARCH=%%{_target_cpu} CPPOPTX="-DNO_FSYNC" \
120# ~~> enable debug by COPTX='-g3 -O0' LDOPTX='-g3 -O0'
121make %{?_smp_mflags} PARCH=%{_target_cpu} \
122COPTX="$RPM_OPT_FLAGS -DTRY_EXT2_FS" CC="%{__cc}" \
123K_ARCH=%{_target_cpu} \
124CONFFLAGS="%{_target_platform} --prefix=%{_prefix} \
125    --exec-prefix=%{_exec_prefix} --bindir=%{_bindir} \
126    --sbindir=%{_sbindir} --sysconfdir=%{_sysconfdir} \
127    --datadir=%{_datadir} --includedir=%{_includedir} \
128    --libdir=%{_libdir} --libexec=%{_libexecdir} \
129    --localstatedir=%{_localstatedir} --sharedstatedir=%{_sharedstatedir} \
130    --mandir=%{_mandir} --infodir=%{_infodir}" < /dev/null
131
132%install
133export MAKEPROG=gmake
134mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man4
135
136make install RPM_INSTALLDIR=${RPM_BUILD_ROOT} PARCH=%{_target_cpu} K_ARCH=%{_target_cpu} < /dev/null
137
138ln -s star.1.gz ${RPM_BUILD_ROOT}%{_mandir}/man1/ustar.1
139ln -s %{_sbindir}/rmt ${RPM_BUILD_ROOT}%{_sysconfdir}/rmt
140
141# compat links
142ln -sf spax %{buildroot}%{_bindir}/pax
143ln -sf spax.1.gz %{buildroot}%{_mandir}/man1/pax.1.gz
144
145# XXX Nuke unpackaged files.
146( cd ${RPM_BUILD_ROOT}
147  rm -f .%{_bindir}/mt
148  rm -f .%{_bindir}/smt
149  rm -f .%{_bindir}/tartest
150  rm -f .%{_bindir}/tar
151  rm -f .%{_bindir}/gnutar
152  rm -f .%{_bindir}/star_fat
153  rm -f .%{_bindir}/star_sym
154  rm -f .%{_bindir}/suntar
155  rm -rf .%{_docdir}/rmt
156  rm -rf .%{_prefix}%{_sysconfdir}
157  rm -rf .%{_prefix}/include
158  rm -rf .%{_prefix}/lib # hard-wired intently
159  rm -rf .%{_mandir}/man3
160  rm -rf .%{_mandir}/man5/{makefiles,makerules}.5*
161  rm -rf .%{_mandir}/man1/{tartest,gnutar,smt,mt,suntar,match}.1*
162)
163
164%clean
165
166%global general_docs README AN* COPYING CDDL.Schily.txt TODO README.linux
167
168%files
169%doc %{general_docs}
170%{_bindir}/star
171%{_bindir}/ustar
172%{_mandir}/man1/star.1*
173%{_mandir}/man1/ustar.1*
174%{_mandir}/man5/star.5*
175
176%files -n scpio
177%doc %{general_docs}
178%doc %{_mandir}/man1/scpio.1*
179%{_bindir}/scpio
180
181%files -n spax
182%doc %{general_docs}
183%doc %{_mandir}/man1/spax.1*
184%doc %{_mandir}/man1/pax.1*
185%{_bindir}/spax
186%{_bindir}/pax
187
188%files -n rmt
189%doc %{general_docs}
190%{_sbindir}/rmt
191%{_mandir}/man1/rmt.1*
192%config %{_sysconfdir}/default/rmt
193# This symlink is used by cpio, star, spax, scpio, .. thus it is needed.  Even
194# if the cpio may be configured to use /sbin/rmt rather than /etc/rmt, star (and
195# thus spax, ..) has the lookup path hardcoded to '/etc/rmt' (it means that even
196# non rpm based systems will try to look for /etc/rmt).  And - the conclusion is
197# - it does not make sense to fight against /etc/rmt symlink ATM (year 2013).
198%{_sysconfdir}/rmt
199
200%changelog
201* Tue Jun 17 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.5.2-1
202- initial build for Vine Linux
203- add Obsoletes/Provides pax to spax
204
205* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.2-11
206- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
207
208* Fri Jan 17 2014 Pavel Raiskup <praiskup@redhat.com> - 1.5.2-10
209- enable build for ppc64le (#1054401)
210
211* Mon Jan 13 2014 Peter Robinson <pbrobinson@fedoraproject.org> 1.5.2-9
212- Temporarily disable profiling on aarch64
213
214* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.2-8
215- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
216
217* Thu Jun 20 2013 Pavel Raiskup <praiskup@redhat.com> - 1.5.2-7
218- we should provide /etc/rmt symlink for a while (related to #968980)
219- use the ssh as the default remote access method
220
221* Thu May 30 2013 Pavel Raiskup <praiskup@redhat.com> - 1.5.2-6
222- subpackage also 'rmt' (#968980)
223
224* Fri May 24 2013 Pavel Raiskup <praiskup@redhat.com> - 1.5.2-5
225- add missing ghost files (#960007)
226- fix the upgrade path, sorry for the noise (#959917, #960007)
227
228* Mon May 06 2013 Pavel Raiskup <praiskup@redhat.com> - 1.5.2-2
229- package spax and scpio separately (#959917)
230- fedora-review fixes, unapplied patch
231- make the spax to be pax alternative (#960007)
232
233* Wed Apr 10 2013 Pavel Raiskup <praiskup@redhat.com> - 1.5.2-1
234- rebase to most up2date upstream tarball, remove patches already upstream, fix
235  code movements in patches (#928758)
236- fix man-page-day objections (private #948866)
237- fix the build for aarch64 (#926571)
238
239* Thu Mar 21 2013 Pavel Raiskup <praiskup@redhat.com> - 1.5.1-12
240- package also the 'scpio' utility (#771926)
241
242* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-11
243- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
244
245* Thu Oct 18 2012 Pavel Raiskup <praiskup@redhat.com> - 1.5.1-10
246- do not crash during extracting if extended attributes are not set on all
247  archived files (#861848)
248- note in man page that H=crc format uses Sum32 algorithm (FIPS refuses CRC)
249
250* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-9
251- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
252
253* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-8
254- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
255
256* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-7
257- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
258
259* Tue Jan 04 2011 Ondrej Vasik <ovasik@redhat.com> 1.5.1-6
260- fix segfault with multivol option due to signedness(#666015)
261
262* Wed Sep 29 2010 jkeating - 1.5.1-5
263- Rebuilt for gcc bug 634757
264
265* Tue Sep 14 2010 Ondrej Vasik <ovasik@redhat.com> 1.5.1-4
266- fix another instance of buffer overflow for files with
267  long names(#632384)
268
269* Tue Aug 17 2010 Ondrej Vasik <ovasik@redhat.com> 1.5.1-3
270- Fix some invalid manpage references (#624612)
271- ship star.4 manpage with star format description
272
273* Wed Feb 03 2010 Ondrej Vasik <ovasik@redhat.com> 1.5.1-2
274- fix buffer overflow for files with names of length
275  100 chars(#556664)
276
277* Wed Jan 13 2010 Ondrej Vasik <ovasik@redhat.com> 1.5.1-1
278- new upstream release 1.5.1
279
280* Thu Aug 27 2009 Ondrej Vasik <ovasik@redhat.com> 1.5-8
281- provide symlinked manpage for ustar
282
283* Thu Aug 27 2009 Ondrej Vasik <ovasik@redhat.com> 1.5-7
284- Merge review (#226434) changes: convert AN-1.5 to utf-8,
285  spec file cosmetic/policy changes, ship README.linux in doc
286
287* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-6
288- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
289
290* Sun May 10 2009 Ville Skyttä <ville.skytta at iki.fi> - 1.5-5
291- Build with $RPM_OPT_FLAGS.
292- Convert specfile to UTF-8.
293
294* Wed Apr 08 2009 Ondrej Vasik <ovasik@redhat.com> 1.5-4
295- fix build failure due to symbols conflicting
296  with stdio(#494213)
297
298* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-3
299- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
300
301* Wed Jan 28 2009 Ondrej Vasik <ovasik@redhat.com> 1.5-2
302- remove names.c requirements from non-fat Makefiles,
303  do not ship names.c (#255261 for details)
304
305* Tue Jan 27 2009 Ondrej Vasik <ovasik@redhat.com> 1.5-1
306- use final instead of beta
307- ship missing names.c separately
308- enable optimalization again
309
310* Wed Dec 03 2008 Ondrej Vasik <ovasik@redhat.com> 1.5a89-1
311- update to latest upstream release
312
313* Fri Jun 06 2008 Dennis Gilmore <dennis@ausil.us> 1.5a84-6
314- add sparcv9 support
315
316* Mon May 12 2008 Peter Vrabec <pvrabec@redhat.com> 1.5a84-5
317- add super-H(sh3,4) architecture support (#442883)
318
319* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.5a84-4
320- Autorebuild for GCC 4.3
321
322* Fri Aug 31 2007 Dan Kopecek <dkopecek@redhat.com> 1.5a84-3
323- added -O0 to COPTX (CFLAGS) (see #255261)
324
325* Mon Aug 27 2007 Peter Vrabec <pvrabec@redhat.com> 1.5a84-2
326- fix segfault of data-change-warn option (#255261),
327  patch from dkopecek@redhat.com
328
329* Fri Aug 24 2007 Peter Vrabec <pvrabec@redhat.com> 1.5a84-1
330- new upstream release with CVE-2007-4134 fix
331
332* Sun Jun 24 2007 Peter Vrabec <pvrabec@redhat.com> 1.5a76-3
333- build star on ARM platforms (#245465)
334
335* Mon Jan 29 2007 Peter Vrabec <pvrabec@redhat.com> 1.5a76-2
336- fix buildreq. and rebuild
337
338* Thu Jan 18 2007 Jan Cholasta <grubber.x@gmail.com> 1.5a76-1
339- upgrade
340
341* Tue Aug 08 2006 Peter Vrabec <pvrabec@redhat.com> 1.5a75-1
342- upgrade
343
344* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.5a74-3.1
345- rebuild
346
347* Tue Jun 13 2006 Peter Vrabec <pvrabec@redhat.com> 1.5a74-3
348- use autoconf provided by star
349
350* Fri Jun 02 2006 Peter Vrabec <pvrabec@redhat.com> 1.5a74-2
351- update tarball
352
353* Mon Apr 24 2006 Peter Vrabec <pvrabec@redhat.com> 1.5a74-1
354- upgrade
355
356* Wed Mar 22 2006 Peter Vrabec <pvrabec@redhat.com> 1.5a73-1
357- upgrade
358
359* Wed Mar 01 2006 Peter Vrabec <pvrabec@redhat.com> 1.5a72-1
360- upgrade
361
362* Wed Feb 22 2006 Peter Vrabec <pvrabec@redhat.com> 1.5a71-1
363- upgrade
364
365* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
366- rebuilt
367
368* Tue Nov 08 2005 Peter Vrabec <pvrabec@redhat.com> 1.5a69-1
369- upgrade
370
371* Mon Oct 10 2005 Peter Vrabec <pvrabec@redhat.com> 1.5a68-1
372- upgrade
373
374* Thu Sep 22 2005 Peter Vrabec <pvrabec@redhat.com> 1.5a67-1
375- upgrade
376
377* Fri Aug 26 2005 Peter Vrabec <pvrabec@redhat.com> 1.5a65-1
378- upgrade 1.5a65-1 made by Horst H. von Brand <vonbrand@inf.utfsm.cl>
379- Source URL changed, no homepage now
380- License changed from GPL to CDDL 1.0
381- Define MAKEPROG=gmake like the Gmake.linux script does
382- Disable fat binary as per star/Makefile, update star-1.5-selinux.patch for
383  the various *.mk files used in that case
384- Axe /usr/share/man/man1/match.1*, /usr/etc/default/rmt too
385- Explicit listing in %%files, allow for compressed or plain manpages
386
387* Fri Aug 26 2005 Peter Vrabec <pvrabec@redhat.com>
388- do not remove star_fat
389
390* Fri Aug 12 2005 Peter Vrabec <pvrabec@redhat.com>
391- upgrade  1.5a64-1
392
393* Thu Aug 04 2005 Karsten Hopp <karsten@redhat.de> 1.5a54-3
394- remove /usr/bin/tar symlink
395
396* Fri Mar 18 2005 Peter Vrabec <pvrabec@redhat.com>
397- rebuilt
398
399* Mon Nov 22 2004 Peter Vrabec <pvrabec@redhat.com>
400- upgrade 1.5a54-1 & rebuild
401
402* Mon Oct 25 2004 Peter Vrabec <pvrabec@redhat.com>
403- fix dependencie (#123770)
404
405* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
406- rebuilt
407
408* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
409- rebuilt
410
411* Mon Jan 26 2004 Dan Walsh <dwalsh@redhat.com> 1.5a25-4
412- Fix call to is_selinux_enabled
413
414* Mon Jan 19 2004 Jeff Johnson <jbj@jbj.org> 1.5.a25-3
415- fix: (!(x & 1)) rather than (!x & 1) patch.
416
417* Wed Sep 24 2003 Dan Walsh <dwalsh@redhat.com> 1.5a25-2
418- turn selinux off
419
420* Tue Sep 16 2003 Dan Walsh <dwalsh@redhat.com> 1.5a25-1.sel
421- turn selinux on
422
423* Fri Sep 5 2003 Dan Walsh <dwalsh@redhat.com> 1.5a18-5
424- turn selinux off
425
426* Mon Aug 25 2003 Dan Walsh <dwalsh@redhat.com> 1.5a18-3
427- Add SELinux modification to handle setting security context before creation.
428
429* Thu Aug 21 2003 Dan Walsh <dwalsh@redhat.com> 1.5a18-2
430- Fix free_xattr bug
431
432* Wed Jul 16 2003 Dan Walsh <dwalsh@redhat.com> 1.5a18-1
433- Add SELinux support
434
435* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
436- rebuilt
437
438* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
439- rebuilt
440
441* Tue Nov 12 2002 Elliot Lee <sopwith@redhat.com> 1.5a08-3
442- Build when uname -m != _target_platform
443- Use _smp_mflags
444- Build on x86_64
445
446* Mon Nov 11 2002 Jeff Johnson <jbj@redhat.com> 1.5a08-2
447- update to 1.5a08.
448- build from cvs.
449
450* Wed Jun 26 2002 Trond Eivind Glomsrød <teg@redhat.com> 1.5a04
451- Initial build. Alpha version - it's needed for ACLs.
Note: See TracBrowser for help on using the repository browser.