source: projects/specs/trunk/s/star/star-vl.spec @ 10280

Revision 10280, 14.8 KB checked in by tomop, 8 years ago (diff)

star-1.5.3-1

Line 
1Summary:  An archiving tool with ACL support
2Summary(ja):  An archiving tool with ACL support
3Name: star
4Version: 1.5.3
5Release: 1%{?_dist_release}
6License: CDDL
7Group: Applications/Archiving
8URL: http://cdrecord.berlios.de/old/private/star.html
9Source: ftp://ftp.berlios.de/pub/star/%{name}-%{version}.tar.bz2
10Vendor: Project Vine
11Distribution: Vine Linux
12
13# do not segfault with data-change-warn option (#255261)
14Patch2: star-1.5-changewarnSegv.patch
15
16# Prevent buffer overflow for filenames with length of 100 characters (#556664)
17Patch3: star-1.5.2-bufferoverflow.patch
18
19# Fix some invalid manpage references (#624612)
20Patch4: star-1.5.1-manpagereferences.patch
21
22# note that the H=crc format uses Sum32 algorithm, not CRC
23Patch6: star-1.5.1-crc.patch
24
25# Allow rmt to access all files.
26# ~> downstream
27# ~> #968980
28Patch8: star-1.5.2-rmt-rh-access.patch
29
30# Use ssh rather than rsh by default
31# ~> downstream
32# ~> related to #968980
33Patch9: star-1.5.2-use-ssh-by-default.patch
34
35# Fix broken star.mk in 1.5.3 (included from all.mk)
36Patch10: star-1.5.3-star-mk.patch
37
38# Fix segfault for 'pax -X' (rhbz#1175009)
39# ~> downstream
40Patch11: star-1.5.3-pax-X-option.patch
41
42BuildRequires: libattr-devel libacl-devel libtool
43BuildRequires: e2fsprogs-devel
44
45# Historically, star installed /usr/bin/spax binary also so we don't want to
46# break the compatibility.  We don't care about scpio because scpio binary was
47# not installed.
48Requires: spax
49
50%description
51Star saves many files together into a single tape or disk archive,
52and can restore individual files from the archive. Star supports ACL.
53
54%package -n     spax
55Summary:        Portable archive exchange
56Group:          Applications/Archiving
57Obsoletes:      pax < 3.4-2
58Provides:       pax
59
60%description -n spax
61The pax utility shall read and write archives, write lists of the members of
62archive files and copy directory hierarchies as is defined in IEEE Std 1003.1.
63
64%package -n     scpio
65Summary:        Copy file archives in and out (LEGACY)
66Group:          Applications/Archiving
67
68%description -n scpio
69The scpio utility, depending on the options used: copies files to an archive
70file, extracts files from an archive file, lists files from an archive file or
71copies files from one directory tree to another.
72
73%package -n     rmt
74Summary: Provides certain programs with access to remote tape devices
75Group: Applications/Archiving
76
77%description -n rmt
78The rmt utility provides remote access to tape devices for programs
79like dump (a filesystem backup program), restore (a program for
80restoring files from a backup), and tar (an archiving program).
81
82%prep
83%setup -q
84%patch2 -p1 -b .changewarnSegv
85%patch3 -p1 -b .namesoverflow
86%patch4 -p1 -b .references
87%patch6 -p1 -b .crc
88%patch8 -p1 -b .rmt-access-rules
89%patch9 -p1 -b .ssh-by-default
90%patch10 -p1 -b .bug-config-1.5.3
91%patch11 -p1 -b .pax-X
92
93cp -a star/all.mk star/Makefile
94
95star_recode()
96{
97    for i in $@; do
98        iconv -f iso_8859-1 -t utf-8 $i > .tmp_file
99        mv .tmp_file $i
100    done
101}
102
103star_recode AN-1.5 AN-1.5.2 star/star.4
104
105cp -a READMEs/README.linux .
106
107for PLAT in %{arm} %{power64} aarch64 x86_64 s390 s390x sh3 sh4 sh4a sparcv9; do
108    for AFILE in gcc cc; do
109            [ ! -e RULES/${PLAT}-linux-${AFILE}.rul ] \
110            && ln -s i586-linux-${AFILE}.rul RULES/${PLAT}-linux-${AFILE}.rul
111    done
112done
113
114%build
115# This is config/work-around for atypical build system.  Variables used are
116# docummented makefiles.5.  GMAKE_NOWARN silences irritating warnings in
117# GNU/Linux ecosystem.
118%global make_flags GMAKE_NOWARN=true                                    \\\
119    RUNPATH=                                                            \\\
120    LDPATH=                                                             \\\
121    PARCH=%{_target_cpu}                                                \\\
122    K_ARCH=%{_target_cpu}                                               \\\
123    INS_BASE=$RPM_BUILD_ROOT%{_prefix}                                  \\\
124    INS_RBASE=$RPM_BUILD_ROOT                                           \\\
125    INSTALL='sh $(SRCROOT)/conf/install-sh -c -m $(INSMODEINS)'         \\\
126    COPTX="$RPM_OPT_FLAGS -DTRY_EXT2_FS"                                \\\
127    DEFCCOM=gcc
128
129# Note: disable optimalisation by COPTX='-g3 -O0' LDOPTX='-g3 -O0'
130make %{?_smp_mflags} %make_flags
131
132%install
133make install -s %make_flags
134
135ln -s spax ${RPM_BUILD_ROOT}%{_bindir}/pax
136ln -s spax.1.gz ${RPM_BUILD_ROOT}%{_mandir}/man1/pax.1
137ln -s star.1.gz ${RPM_BUILD_ROOT}%{_mandir}/man1/ustar.1
138mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}
139mkdir -p ${RPM_BUILD_ROOT}%{_pkgdocdir}
140ln -s %{_sbindir}/rmt ${RPM_BUILD_ROOT}%{_sysconfdir}/rmt
141install -p -m 644 COPYING star/README  CDDL.Schily.txt AN-* \
142    ${RPM_BUILD_ROOT}%{_pkgdocdir}
143
144# XXX Nuke unpackaged files.
145( cd ${RPM_BUILD_ROOT}
146  rm -f .%{_bindir}/mt
147  rm -f .%{_bindir}/smt
148  rm -f .%{_bindir}/tartest
149  rm -f .%{_bindir}/tar
150  rm -f .%{_bindir}/gnutar
151  rm -f .%{_bindir}/star_fat
152  rm -f .%{_bindir}/star_sym
153  rm -f .%{_bindir}/suntar
154  rm -f .%{_sysconfdir}/default/star
155  rm -rf .%{_prefix}%{_sysconfdir}
156  rm -rf .%{_prefix}/include
157  rm -rf .%{_prefix}/lib # hard-wired intently
158  rm -rf .%{_mandir}/man3
159  rm -rf .%{_mandir}/man5/{makefiles,makerules}.5*
160  rm -rf .%{_mandir}/man1/{tartest,gnutar,smt,mt,suntar,match}.1*
161  rm -rf .%{_docdir}/star/testscripts
162  rm -rf .%{_docdir}/star/TODO
163  rm -rf .%{_docdir}/rmt
164)
165
166%clean
167
168%global general_docs README AN* COPYING CDDL.Schily.txt TODO README.linux
169
170%files
171%doc %{general_docs}
172%{_bindir}/star
173%{_bindir}/ustar
174%{_mandir}/man1/star.1*
175%{_mandir}/man1/ustar.1*
176%{_mandir}/man5/star.5*
177
178%files -n scpio
179%doc %{general_docs}
180%doc %{_mandir}/man1/scpio.1*
181%{_bindir}/scpio
182
183%files -n spax
184%doc %{general_docs}
185%doc %{_mandir}/man1/spax.1*
186%doc %{_mandir}/man1/pax.1*
187%{_bindir}/spax
188%{_bindir}/pax
189
190%files -n rmt
191%doc %{general_docs}
192%{_sbindir}/rmt
193%{_mandir}/man1/rmt.1*
194%config %{_sysconfdir}/default/rmt
195# This symlink is used by cpio, star, spax, scpio, .. thus it is needed.  Even
196# if the cpio may be configured to use /sbin/rmt rather than /etc/rmt, star (and
197# thus spax, ..) has the lookup path hardcoded to '/etc/rmt' (it means that even
198# non rpm based systems will try to look for /etc/rmt).  And - the conclusion is
199# - it does not make sense to fight against /etc/rmt symlink ATM (year 2013).
200%{_sysconfdir}/rmt
201
202%changelog
203* Thu May 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.3-1
204- new upstream release.
205- updated patches.
206
207* Tue Jun 17 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.5.2-1
208- initial build for Vine Linux
209- add Obsoletes/Provides pax to spax
210
211* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.2-11
212- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
213
214* Fri Jan 17 2014 Pavel Raiskup <praiskup@redhat.com> - 1.5.2-10
215- enable build for ppc64le (#1054401)
216
217* Mon Jan 13 2014 Peter Robinson <pbrobinson@fedoraproject.org> 1.5.2-9
218- Temporarily disable profiling on aarch64
219
220* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.2-8
221- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
222
223* Thu Jun 20 2013 Pavel Raiskup <praiskup@redhat.com> - 1.5.2-7
224- we should provide /etc/rmt symlink for a while (related to #968980)
225- use the ssh as the default remote access method
226
227* Thu May 30 2013 Pavel Raiskup <praiskup@redhat.com> - 1.5.2-6
228- subpackage also 'rmt' (#968980)
229
230* Fri May 24 2013 Pavel Raiskup <praiskup@redhat.com> - 1.5.2-5
231- add missing ghost files (#960007)
232- fix the upgrade path, sorry for the noise (#959917, #960007)
233
234* Mon May 06 2013 Pavel Raiskup <praiskup@redhat.com> - 1.5.2-2
235- package spax and scpio separately (#959917)
236- fedora-review fixes, unapplied patch
237- make the spax to be pax alternative (#960007)
238
239* Wed Apr 10 2013 Pavel Raiskup <praiskup@redhat.com> - 1.5.2-1
240- rebase to most up2date upstream tarball, remove patches already upstream, fix
241  code movements in patches (#928758)
242- fix man-page-day objections (private #948866)
243- fix the build for aarch64 (#926571)
244
245* Thu Mar 21 2013 Pavel Raiskup <praiskup@redhat.com> - 1.5.1-12
246- package also the 'scpio' utility (#771926)
247
248* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-11
249- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
250
251* Thu Oct 18 2012 Pavel Raiskup <praiskup@redhat.com> - 1.5.1-10
252- do not crash during extracting if extended attributes are not set on all
253  archived files (#861848)
254- note in man page that H=crc format uses Sum32 algorithm (FIPS refuses CRC)
255
256* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-9
257- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
258
259* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-8
260- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
261
262* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-7
263- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
264
265* Tue Jan 04 2011 Ondrej Vasik <ovasik@redhat.com> 1.5.1-6
266- fix segfault with multivol option due to signedness(#666015)
267
268* Wed Sep 29 2010 jkeating - 1.5.1-5
269- Rebuilt for gcc bug 634757
270
271* Tue Sep 14 2010 Ondrej Vasik <ovasik@redhat.com> 1.5.1-4
272- fix another instance of buffer overflow for files with
273  long names(#632384)
274
275* Tue Aug 17 2010 Ondrej Vasik <ovasik@redhat.com> 1.5.1-3
276- Fix some invalid manpage references (#624612)
277- ship star.4 manpage with star format description
278
279* Wed Feb 03 2010 Ondrej Vasik <ovasik@redhat.com> 1.5.1-2
280- fix buffer overflow for files with names of length
281  100 chars(#556664)
282
283* Wed Jan 13 2010 Ondrej Vasik <ovasik@redhat.com> 1.5.1-1
284- new upstream release 1.5.1
285
286* Thu Aug 27 2009 Ondrej Vasik <ovasik@redhat.com> 1.5-8
287- provide symlinked manpage for ustar
288
289* Thu Aug 27 2009 Ondrej Vasik <ovasik@redhat.com> 1.5-7
290- Merge review (#226434) changes: convert AN-1.5 to utf-8,
291  spec file cosmetic/policy changes, ship README.linux in doc
292
293* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-6
294- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
295
296* Sun May 10 2009 Ville Skyttä <ville.skytta at iki.fi> - 1.5-5
297- Build with $RPM_OPT_FLAGS.
298- Convert specfile to UTF-8.
299
300* Wed Apr 08 2009 Ondrej Vasik <ovasik@redhat.com> 1.5-4
301- fix build failure due to symbols conflicting
302  with stdio(#494213)
303
304* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-3
305- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
306
307* Wed Jan 28 2009 Ondrej Vasik <ovasik@redhat.com> 1.5-2
308- remove names.c requirements from non-fat Makefiles,
309  do not ship names.c (#255261 for details)
310
311* Tue Jan 27 2009 Ondrej Vasik <ovasik@redhat.com> 1.5-1
312- use final instead of beta
313- ship missing names.c separately
314- enable optimalization again
315
316* Wed Dec 03 2008 Ondrej Vasik <ovasik@redhat.com> 1.5a89-1
317- update to latest upstream release
318
319* Fri Jun 06 2008 Dennis Gilmore <dennis@ausil.us> 1.5a84-6
320- add sparcv9 support
321
322* Mon May 12 2008 Peter Vrabec <pvrabec@redhat.com> 1.5a84-5
323- add super-H(sh3,4) architecture support (#442883)
324
325* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.5a84-4
326- Autorebuild for GCC 4.3
327
328* Fri Aug 31 2007 Dan Kopecek <dkopecek@redhat.com> 1.5a84-3
329- added -O0 to COPTX (CFLAGS) (see #255261)
330
331* Mon Aug 27 2007 Peter Vrabec <pvrabec@redhat.com> 1.5a84-2
332- fix segfault of data-change-warn option (#255261),
333  patch from dkopecek@redhat.com
334
335* Fri Aug 24 2007 Peter Vrabec <pvrabec@redhat.com> 1.5a84-1
336- new upstream release with CVE-2007-4134 fix
337
338* Sun Jun 24 2007 Peter Vrabec <pvrabec@redhat.com> 1.5a76-3
339- build star on ARM platforms (#245465)
340
341* Mon Jan 29 2007 Peter Vrabec <pvrabec@redhat.com> 1.5a76-2
342- fix buildreq. and rebuild
343
344* Thu Jan 18 2007 Jan Cholasta <grubber.x@gmail.com> 1.5a76-1
345- upgrade
346
347* Tue Aug 08 2006 Peter Vrabec <pvrabec@redhat.com> 1.5a75-1
348- upgrade
349
350* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.5a74-3.1
351- rebuild
352
353* Tue Jun 13 2006 Peter Vrabec <pvrabec@redhat.com> 1.5a74-3
354- use autoconf provided by star
355
356* Fri Jun 02 2006 Peter Vrabec <pvrabec@redhat.com> 1.5a74-2
357- update tarball
358
359* Mon Apr 24 2006 Peter Vrabec <pvrabec@redhat.com> 1.5a74-1
360- upgrade
361
362* Wed Mar 22 2006 Peter Vrabec <pvrabec@redhat.com> 1.5a73-1
363- upgrade
364
365* Wed Mar 01 2006 Peter Vrabec <pvrabec@redhat.com> 1.5a72-1
366- upgrade
367
368* Wed Feb 22 2006 Peter Vrabec <pvrabec@redhat.com> 1.5a71-1
369- upgrade
370
371* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
372- rebuilt
373
374* Tue Nov 08 2005 Peter Vrabec <pvrabec@redhat.com> 1.5a69-1
375- upgrade
376
377* Mon Oct 10 2005 Peter Vrabec <pvrabec@redhat.com> 1.5a68-1
378- upgrade
379
380* Thu Sep 22 2005 Peter Vrabec <pvrabec@redhat.com> 1.5a67-1
381- upgrade
382
383* Fri Aug 26 2005 Peter Vrabec <pvrabec@redhat.com> 1.5a65-1
384- upgrade 1.5a65-1 made by Horst H. von Brand <vonbrand@inf.utfsm.cl>
385- Source URL changed, no homepage now
386- License changed from GPL to CDDL 1.0
387- Define MAKEPROG=gmake like the Gmake.linux script does
388- Disable fat binary as per star/Makefile, update star-1.5-selinux.patch for
389  the various *.mk files used in that case
390- Axe /usr/share/man/man1/match.1*, /usr/etc/default/rmt too
391- Explicit listing in %%files, allow for compressed or plain manpages
392
393* Fri Aug 26 2005 Peter Vrabec <pvrabec@redhat.com>
394- do not remove star_fat
395
396* Fri Aug 12 2005 Peter Vrabec <pvrabec@redhat.com>
397- upgrade  1.5a64-1
398
399* Thu Aug 04 2005 Karsten Hopp <karsten@redhat.de> 1.5a54-3
400- remove /usr/bin/tar symlink
401
402* Fri Mar 18 2005 Peter Vrabec <pvrabec@redhat.com>
403- rebuilt
404
405* Mon Nov 22 2004 Peter Vrabec <pvrabec@redhat.com>
406- upgrade 1.5a54-1 & rebuild
407
408* Mon Oct 25 2004 Peter Vrabec <pvrabec@redhat.com>
409- fix dependencie (#123770)
410
411* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
412- rebuilt
413
414* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
415- rebuilt
416
417* Mon Jan 26 2004 Dan Walsh <dwalsh@redhat.com> 1.5a25-4
418- Fix call to is_selinux_enabled
419
420* Mon Jan 19 2004 Jeff Johnson <jbj@jbj.org> 1.5.a25-3
421- fix: (!(x & 1)) rather than (!x & 1) patch.
422
423* Wed Sep 24 2003 Dan Walsh <dwalsh@redhat.com> 1.5a25-2
424- turn selinux off
425
426* Tue Sep 16 2003 Dan Walsh <dwalsh@redhat.com> 1.5a25-1.sel
427- turn selinux on
428
429* Fri Sep 5 2003 Dan Walsh <dwalsh@redhat.com> 1.5a18-5
430- turn selinux off
431
432* Mon Aug 25 2003 Dan Walsh <dwalsh@redhat.com> 1.5a18-3
433- Add SELinux modification to handle setting security context before creation.
434
435* Thu Aug 21 2003 Dan Walsh <dwalsh@redhat.com> 1.5a18-2
436- Fix free_xattr bug
437
438* Wed Jul 16 2003 Dan Walsh <dwalsh@redhat.com> 1.5a18-1
439- Add SELinux support
440
441* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
442- rebuilt
443
444* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
445- rebuilt
446
447* Tue Nov 12 2002 Elliot Lee <sopwith@redhat.com> 1.5a08-3
448- Build when uname -m != _target_platform
449- Use _smp_mflags
450- Build on x86_64
451
452* Mon Nov 11 2002 Jeff Johnson <jbj@redhat.com> 1.5a08-2
453- update to 1.5a08.
454- build from cvs.
455
456* Wed Jun 26 2002 Trond Eivind Glomsrød <teg@redhat.com> 1.5a04
457- Initial build. Alpha version - it's needed for ACLs.
Note: See TracBrowser for help on using the repository browser.