source: projects/specs/trunk/s/ssh-import-id/ssh-import-id-vl.spec @ 10405

Revision 10405, 1.6 KB checked in by Takemikaduchi, 8 years ago (diff)

gcc-5.4.0 & python3-3.5.2

Line 
1%{!?python3_sitelib: %define python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(0))")}
2
3%define ver 4.1
4%define rel 2
5
6Summary: Import SSH public keys from Launchpad or other URLs
7Name: ssh-import-id
8Version: %{ver}
9Release: %{rel}%{?_dist_release}
10License: GPLv3
11Group: Applications/Accessories
12URL: https://launchpad.net/ssh-import-id
13Source0: https://launchpad.net/ssh-import-id/trunk/%{version}/+download/%{name}_%{version}.orig.tar.gz
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15Requires: python3-setuptools
16Requires: python3-requests
17BuildRequires: python3-devel
18BuildRequires: python3-setuptools
19BuildArch: noarch
20
21Vendor: Project Vine
22Distribution: Vine Linux
23Packager: iwaim
24
25%description
26ssh-import-id - retrieve one or more public keys from a public
27keyserver (Launchpad.net by default) and append them to the current
28user's authorized_keys file (or some other specified file)
29
30%prep
31%setup -q
32
33%build
34python3 setup.py build
35
36%install
37rm -rf $RPM_BUILD_ROOT
38python3 setup.py install --skip-build --root $RPM_BUILD_ROOT
39%{__install} -d $RPM_BUILD_ROOT%{_mandir}/man1
40%{__install} -m 0644 %{name}.1 $RPM_BUILD_ROOT%{_mandir}/man1
41
42%clean
43rm -rf $RPM_BUILD_ROOT
44
45
46%files
47%defattr(-,root,root,-)
48%doc README.md LICENSE ChangeLog
49%{_bindir}/%{name}
50%{_bindir}/%{name}-lp
51%{_bindir}/%{name}-gh
52%{python3_sitelib}/ssh_import_id-%{ver}-py*.egg-info
53%{_mandir}/man1/%{name}.1*
54
55%changelog
56* Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.1-2
57- rebuild with python3-3.5.2
58
59* Sun Mar 22 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 4.1-1
60- Initial build.
61
Note: See TracBrowser for help on using the repository browser.