source: projects/specs/trunk/s/squid26/squid26-vl.spec @ 521

Revision 521, 20.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define __perl_requires %{SOURCE98}
2
3Summary: The Squid proxy caching server.
4Summary(ja): Squid ウェブプロキシキャッシュ
5Name: squid26
6Version: 2.6.STABLE22
7Release: 2%{_dist_release}
8Epoch: 7
9License: GPL
10Group: System Environment/Daemons
11URL: http://www.squid-cache.org/
12Source: http://www.squid-cache.org/Squid/Versions/v2/2.6/squid-%{version}.tar.bz2
13Source1: http://www.squid-cache.org/Squid/FAQ/FAQ.sgml
14Source2: squid.init
15Source3: squid.logrotate
16Source4: squid.sysconfig
17Source5: squid.pam
18Source98: perl-requires-squid.sh
19
20# Upstream patches (reserved patch100-)
21
22# External patches
23
24# Local patches
25# Applying upstream patches first makes it less likely that local patches
26# will break upstream ones.
27Patch201: squid-2.6.STABLE17-config.patch
28Patch202: squid-2.6.STABLE19-location.patch
29# Patch203: squid-2.6.STABLE2-build.patch
30Patch204: squid-2.5.STABLE4-perlpath.patch
31Patch205: squid-2.5.STABLE12-smb-path.patch
32Patch206: squid-2.6.STABLE5-fd-config.patch
33Patch207: squid-2.6.STABLE2-build-vine.patch
34
35# Vine Patch
36# Patch300: squid-2.6.STABLE20-configure-linux-2.6.25.patch
37
38BuildRoot: %{_tmppath}/%{name}-%{version}-root
39Prereq: /sbin/chkconfig logrotate shadow-utils
40BuildRequires: openjade linuxdoc-tools
41BuildRequires: openldap-devel pam-devel openssl-devel krb5-devel
42BuildRequires: cyrus-sasl-devel
43Obsoletes: squid-novm
44Provides:  squid
45
46Vendor: Project Vine
47Distribution: Vine Linux
48
49%description
50Squid is a high-performance proxy caching server for Web clients,
51supporting FTP, gopher, and HTTP data objects. Unlike traditional
52caching software, Squid handles all requests in a single,
53non-blocking, I/O-driven process. Squid keeps meta data and especially
54hot objects cached in RAM, caches DNS lookups, supports non-blocking
55DNS lookups, and implements negative caching of failed requests.
56
57Squid consists of a main server program squid, a Domain Name System
58lookup program (dnsserver), a program for retrieving FTP data
59(ftpget), and some management and client tools.
60
61%description -l ja
62Squid はウェブクライアントのための高性能のプロキシキャッシュサーバで、
63FTP, gopher, HTTP データオブジェクトに対応しています。これまでの
64キャッシュソフトウェアと違い、 Squid は全ての要求を、単一の
65ブロックしない I/O 駆動のプロセスで処理します。 Squid はメタデータや
66ホットなオブジェクトを RAM に保持し、 DNS 問い合わせをキャッシュし、
67DNS 問い合わせでブロックせず、失敗した要求を負のキャッシングします。
68
69Squid は、メインのサーバプログラム squid と、 Domain Name System
70問い合わせプログラム (dnsserver) と、 FTP データを取得するプログラム
71(ftpget) と、いくつかの管理用またはクライアントツールから成ります。
72
73%define squidconfdir    %{_sysconfdir}/squid
74%define squidlibdir     %{_libdir}/squid
75%define squiddatadir    %{_datadir}/squid
76%define errordir        %{squiddatadir}/errors
77
78%prep
79%setup -q -n squid-%{version}
80
81%patch201 -p1 -b .config
82%patch202 -p1 -b .location
83# %patch203 -p1 -b .build
84%patch207 -p1 -b .build
85%patch204 -p1 -b .perlpath
86%patch205 -p1 -b .smb
87%patch206 -p1 -b .fd
88
89# %patch300 -p1
90
91%build
92# %{__automake} --foreign
93# automake-1.5 --foreign
94# aclocal
95# automake --foreign
96autoconf
97
98%configure \
99   --exec_prefix=%{_exec_prefix} \
100   --bindir=%{_sbindir} \
101   --libexecdir=%{squidlibdir} \
102   --localstatedir=/var \
103   --datadir=%{squiddatadir} \
104   --sysconfdir=%{squidconfdir} \
105   --enable-poll \
106   --enable-snmp \
107   --enable-removal-policies="heap,lru" \
108   --enable-storeio="aufs,coss,diskd,ufs" \
109   --enable-ssl \
110   --enable-delay-pools \
111   --enable-linux-netfilter \
112   --enable-carp \
113   --with-pthreads \
114   --enable-cachemgr-hostname=localhost \
115   --enable-underscores \
116   --enable-auth="basic,digest,ntlm,negotiate" \
117   --enable-basic-auth-helpers="LDAP,MSNT,NCSA,PAM,SMB,YP,getpwnam,multi-domain-NTLM,SASL" \
118   --enable-negotiate-auth-helpers="squid_kerb_auth"
119
120#   --enable-basic-auth-helpers="NCSA,PAM,SMB,MSNT"  # --enable-icmp
121
122# Some versions of autoconf fail to detect sys/resource.h correctly;
123# apparently because it generates a compiler warning.
124
125if [ -e %{_includedir}/sys/resource.h ]; then
126cat >>include/autoconf.h <<EOF
127#ifndef HAVE_SYS_RESOURCE_H
128#define HAVE_SYS_RESOURCE_H 1
129#define HAVE_STRUCT_RUSAGE 1
130#endif
131EOF
132fi
133
134make %{?_smp_mflags}
135
136mkdir faq
137cp %{_sourcedir}/FAQ.sgml faq
138cd faq
139sgml2html FAQ.sgml
140
141%install
142rm -rf %{buildroot}
143%makeinstall  \
144        sysconfdir=%{buildroot}%{squidconfdir} \
145        localstatedir=%{buildroot}/var \
146        bindir=%{buildroot}%{_sbindir} \
147        libexecdir=%{buildroot}%{squidlibdir} \
148        datadir=%{buildroot}%{squiddatadir}
149#install -m 4750 src/pinger %{buildroot}%{squidlibdir}
150
151ln -s %{errordir}/English %{buildroot}%{squidconfdir}/errors
152
153mkdir -p %{buildroot}%{_sysconfdir}/rc.d/init.d
154mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d
155mkdir -p %{buildroot}%{_sysconfdir}/sysconfig
156mkdir -p %{buildroot}%{_sysconfdir}/pam.d
157
158install -m 755 %{_sourcedir}/squid.init %{buildroot}%{_sysconfdir}/rc.d/init.d/squid
159install -m 644 %{_sourcedir}/squid.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/squid
160install -m 644 %{_sourcedir}/squid.sysconfig %{buildroot}%{_sysconfdir}/sysconfig/squid
161install -m 644 %{SOURCE5} %{buildroot}%{_sysconfdir}/pam.d/squid
162
163mkdir -p %{buildroot}/var/log/squid
164mkdir -p %{buildroot}/var/spool/squid
165
166%clean
167rm -rf %{buildroot}
168
169%files
170%defattr(-,root,root)
171%dir %{squidconfdir}
172%config(noreplace) %{squidconfdir}/squid.conf
173%config(noreplace) %{squidconfdir}/mime.conf
174%config(noreplace) %{squidconfdir}/msntauth.conf
175%config(noreplace) %{squidconfdir}/cachemgr.conf
176%{squidconfdir}/squid.conf.default
177%{squidconfdir}/mime.conf.default
178%{squidconfdir}/msntauth.conf.default
179%config(noreplace) %{squidconfdir}/errors
180%config(noreplace) %{_sysconfdir}/sysconfig/squid
181%config(noreplace) %{_sysconfdir}/pam.d/squid
182%config %{_sysconfdir}/rc.d/init.d/squid
183%config %{_sysconfdir}/logrotate.d/squid
184%{squidlibdir}
185%attr(4750,root,squid) %{squidlibdir}/ncsa_auth
186%attr(4750,root,squid) %{squidlibdir}/pam_auth
187%{squiddatadir}
188%{_sbindir}/squid
189%{_sbindir}/squidclient
190%{_sbindir}/RunCache
191%{_sbindir}/cossdump
192%{_mandir}/man8/*
193%doc faq/* README ChangeLog QUICKSTART doc/debug-sections.txt
194%doc contrib/url-normalizer.pl contrib/rredir.* contrib/user-agents.pl
195%attr(750,squid,squid) %dir /var/log/squid
196%attr(750,squid,squid) %dir /var/spool/squid
197
198%pre
199%{_sbindir}/useradd -u 23 -d /var/spool/squid -r -s /dev/null squid >/dev/null 2>&1
200
201for i in /var/log/squid /var/spool/squid ; do
202        if [ -d $i ] ; then
203                for adir in `find $i -maxdepth 0 \! -user squid`; do
204                        chown -R squid.squid $adir
205                done
206        fi
207done
208
209exit 0
210
211%post
212/sbin/chkconfig --add squid
213if [ $1 = 0 ]; then
214 case "$LANG" in
215  bg*)
216     DIR=Bulgarian
217     ;;
218  cs*)
219     DIR=Czech
220     ;;
221  da*)
222     DIR=Danish
223     ;;
224  nl*)
225     DIR=Dutch
226     ;;
227  en*)
228     DIR=English
229     ;;
230  ea*)
231     DIR=Estonian
232     ;;
233  fi*)
234     DIR=Finnish
235     ;;
236  fr*)
237     DIR=French
238     ;;
239  de*)
240     DIR=German
241     ;;
242  hu*)
243     DIR=Hungarian
244     ;;
245  it*)
246     DIR=Italian
247     ;;
248  ja*)
249     DIR=Japanese
250     ;;
251  kr*)
252     DIR=Korean
253     ;;
254  pl*)
255     DIR=Polish
256     ;;
257  pt*)
258     DIR=Portuguese
259     ;;
260  ro*)
261     DIR=Romanian
262     ;;
263  ru*)
264     DIR=Russian-koi8-r
265     ;;
266  sk*)
267     DIR=Slovak
268     ;;
269  es*)
270     DIR=Spanish
271     ;;
272  sv*)
273     DIR=Swedish
274     ;;
275  zh*)
276     DIR=Traditional_Chinese
277     ;;
278  tr*)
279     DIR=Turkish
280     ;;
281  *)
282     DIR=English
283     ;;
284 esac
285 ln -snf %{errordir}/$DIR %{squidconfdir}/errors
286fi
287
288%preun
289if [ $1 = 0 ] ; then
290        service squid stop >/dev/null 2>&1
291        rm -f /var/log/squid/*
292        /sbin/chkconfig --del squid
293fi
294
295%postun
296if [ "$1" -ge "1" ] ; then
297        service squid condrestart
298fi
299
300%changelog
301* Mon May 04 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
302- 2.6.STABLE22-2
303- change package name squid -> squid26
304- enable krb5 auth
305
306* Fri Jan 30 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
307- 2.6.STABLE22-1
308- new upstream release
309- add /etc/pam.d/squid into package
310- change permission/group of ncsa_auth,pam_auth ([vine-users:079136])
311- drop Patch300 (is included in new release)
312
313* Fri May 09 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
314- 2.6.STABLE20-1
315- new upstream release
316- add patch300 to fix linux 2.6.25 header file uncompatibility
317- run autoconf before configure
318
319* Fri Mar 28 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
320- 2.6.STABLE19-1
321- build under new versioning policy with rpm macro
322
323* Wed Mar 19 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
324- 2.6.STABLE19-0vl1
325- new upstream release with security fix (CVE-2008-1612)
326- update patch202
327- drop old patches
328
329* Fri Nov 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
330- 2.6.STABLE17-0vl1
331- new upstream release
332- update patch201
333
334* Tue Aug 21 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
335- 2.6.STABLE14-0vl1
336- new upstream release
337
338* Fri Mar 23 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
339- 2.6.STABLE12-0vl2
340- turn on daemon restart message (%postun)
341
342* Fri Mar 23 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.STABLE12-0vl1
343- new upstream release (including CVE-2007-1560)
344
345* Sun Jan 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
346- 2.6.STABLE7-0vl1
347- rebuilt for VinePlus4.0 / VineSeedPlus
348
349* Sun Jan 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
350- 2.6.STABLE7-0vl0.32
351- new upstream release (included CVE-2007-0247,0248)
352- build for VinePlus 3.x
353
354* Wed Jan 03 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
355- 2.6.STABLE6-0vl0.32
356- new upstream release
357- build for VinePlus 3.x
358- add Vendor/Distribution tag
359
360* Thu Nov 09 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
361- 2.6.STABLE5-0vl0.32
362- new upstream release
363- build for VinePlus 3.x
364- drop old patches
365
366* Wed Oct 11 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
367- 2.6.STABLE4-0vl1
368- rebuild for VineSeed/Vine 4.0
369
370* Tue Oct 05 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
371- 2.6.STABLE4-0vl0.2
372- stop automake in build section
373- enable ssl in configure
374- enable underscore in configure
375- add some file to files list
376
377* Tue Oct 05 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
378- 2.6.STABLE4-0vl0.1
379- new upstream release 2.6
380- test package
381
382* Fri Aug  4 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
383- s/Serial/Epoch/
384
385* Sun Apr 24 2005 NISHIMURA Daisuke <nishi@mozilla.gr.jp>
386- 2.5.STABLE5-0vl5
387- additional security patches 24-28; exclude WCCP patches
388
389* Mon Jan 17 2005 SATO Masakiyo <info@pocomoco.net>
390- 2.5.STABLE5-0vl4
391- add patch 21 for CAN-2005-0094:buffer overflow bug in gopherToHTML().
392- add patch 22 for CAN-2005-0095:Denial of service with forged WCCP messages.
393- add patch 23 for Sanity check username in ldap_auth.
394
395* Sat Oct 30 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp>
396- 2.5.STABLE5-0vl3
397- security fix: CAN-2004-0918: SNMP related denial of service
398
399* Sat Apr 17 2004 Tomoya TAKA <taka@vinelinux.org>
400- BuildPrereq: automake15
401- exec automake in %%build section
402
403* Sun Apr 11 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp>
404- 2.5.STABLE5-0vl1
405- new upstream release
406- "client" command is renamed "squidclient"
407- many files move:
408  - errors and icons from /usr/lib/squid to /usr/share/squid
409  - mib.txt from /etc/squid to /usr/share/squid
410  - squid.8 is installed in mandir
411- add Japanese summary and description
412- extensive use of macros for dirs
413- incorporate patch 10 (squid-2.1-make.patch) into patch 13
414
415* Fri Feb 14 2003 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
416- 2.4.STABLE7-0vl3
417- build for VineSeed
418
419* Thu Feb 13 2003 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
420- 2.4.STABLE7-0vl2
421- build for Vine 2.5/2.6
422- re-number patch 0,1,2,3 -> 10,11,12,13
423- add patch 0,1,2 from http://www.squid-cache.org/Versions/v2/2.4/bugs/
424- very small cleanup specfile
425
426* Thu Jul 04 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp>
427- 2.4.STABLE7-0vl1
428- update source to fix many security holes.
429- remove stripping (delegate to brp-strip).
430
431* Mon Jul 01 2002 kawa <kawakawa@sa.il24.net> 2.4.STABLE6-0vl2
432- add squid-2.4.STABLE6-deny_transfer_encoding.patch
433- see http://www.linuxsecurity.com/articles/server_security_article-5210.html
434
435* Sun Apr 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.STABLE6-0vl1
436- new upstream release
437
438* Fri Mar 01 2002 Toru Sagami <sagami@vinelinux.org> 2.4.STABLE3-0vl1
439- followed RHSA 2.4.STABLE3-1.7.2
440 - 2.4.STABLE3 + patches
441 - turn off HTCP at request of maintainers
442 - leave SNMP enabled in the build, but disabled in the default config
443
444* Fri Oct 05 2001 Toru Sagami <sagami@vinelinux.org> 2.4.STABLE1-5vl3
445- added a patch(#20) for Mkdir-only PUT Requests DoS Attack
446
447* Tue Sep 04 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.STABLE-5vl2
448- remove file depend (/etc/init.d/)
449
450* Sat Aug 18 2001 <sagami@vinelinux.org>
451- 2.4.STABLE1-5vl1: was ported to Vine
452- disable LDAP auth-modules
453
454* Mon Aug  6 2001 Bill Nottingham <notting@redhat.com>
455- fix uninstall (#50411)
456
457* Mon Jul 23 2001 Bill Nottingham <notting@redhat.com>
458- add some buildprereqs (#49705)
459
460* Sun Jul 22 2001 Bill Nottingham <notting@redhat.com>
461- update FAQ
462
463* Tue Jul 17 2001 Bill Nottingham <notting@redhat.com>
464- own /etc/squid, /usr/lib/squid
465
466* Tue Jun 12 2001 Nalin Dahyabhai <nalin@redhat.com>
467- rebuild in new environment
468- s/Copyright:/License:/
469
470* Tue Apr 24 2001 Bill Nottingham <notting@redhat.com>
471- update to 2.4.STABLE1 + patches
472- enable some more configure options (#24981)
473- oops, ship /etc/sysconfig/squid
474
475* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
476- rebuild in new environment
477
478* Tue Feb  6 2001 Trond Eivind Glomsrod <teg@redhat.com>
479- improve i18n
480- make the initscript use the standard OK/FAILED
481
482* Tue Jan 23 2001 Bill Nottingham <notting@redhat.com>
483- change i18n mechanism
484
485* Fri Jan 19 2001 Bill Nottingham <notting@redhat.com>
486- fix path references in QUICKSTART (#15114)
487- fix initscript translations (#24086)
488- fix shutdown logic (#24234), patch from <jos@xos.nl>
489- add /etc/sysconfig/squid for daemon options & shutdown timeouts
490- three more bugfixes from the Squid people
491- update FAQ.sgml
492- build and ship auth modules (#23611)
493
494* Thu Jan 11 2001 Bill Nottingham <notting@redhat.com>
495- initscripts translations
496
497* Mon Jan  8 2001 Bill Nottingham <notting@redhat.com>
498- add patch to use mkstemp (greg@wirex.com)
499
500* Fri Dec 01 2000 Bill Nottingham <notting@redhat.com>
501- rebuild because of broken fileutils
502
503* Sat Nov 11 2000 Bill Nottingham <notting@redhat.com>
504- fix the acl matching cases (only need the second patch)
505
506* Tue Nov  7 2000 Bill Nottingham <notting@redhat.com>
507- add two patches to fix domain ACLs
508- add 2 bugfix patches from the squid people
509
510* Fri Jul 28 2000 Bill Nottingham <notting@redhat.com>
511- clean up init script; fix condrestart
512- update to STABLE4, more bugfixes
513- update FAQ
514
515* Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
516- fix syntax error in init script
517- finish adding condrestart support
518
519* Fri Jul 14 2000 Bill Nottingham <notting@redhat.com>
520- move initscript back
521
522* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
523- automatic rebuild
524
525* Thu Jul  6 2000 Bill Nottingham <notting@redhat.com>
526- prereq /etc/init.d
527- add bugfix patch
528- update FAQ
529
530* Thu Jun 29 2000 Bill Nottingham <notting@redhat.com>
531- fix init script
532
533* Tue Jun 27 2000 Bill Nottingham <notting@redhat.com>
534- don't prereq new initscripts
535
536* Mon Jun 26 2000 Bill Nottingham <notting@redhat.com>
537- initscript munging
538
539* Sat Jun 10 2000 Bill Nottingham <notting@redhat.com>
540- rebuild for exciting FHS stuff
541
542* Wed May 31 2000 Bill Nottingham <notting@redhat.com>
543- fix init script again (#11699)
544- add --enable-delay-pools (#11695)
545- update to STABLE3
546- update FAQ
547
548* Fri Apr 28 2000 Bill Nottingham <notting@redhat.com>
549- fix init script (#11087)
550
551* Fri Apr  7 2000 Bill Nottingham <notting@redhat.com>
552- three more bugfix patches from the squid people
553- buildprereq jade, sgmltools
554
555* Sun Mar 26 2000 Florian La Roche <Florian.LaRoche@redhat.com>
556- make %pre more portable
557
558* Thu Mar 16 2000 Bill Nottingham <notting@redhat.com>
559- bugfix patches
560- fix dependency on /usr/local/bin/perl
561
562* Sat Mar  4 2000 Bill Nottingham <notting@redhat.com>
563- 2.3.STABLE2
564
565* Mon Feb 14 2000 Bill Nottingham <notting@redhat.com>
566- Yet More Bugfix Patches
567
568* Tue Feb  8 2000 Bill Nottingham <notting@redhat.com>
569- add more bugfix patches
570- --enable-heap-replacement
571
572* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
573- rebuild to fix dependencies
574
575* Fri Jan 28 2000 Bill Nottingham <notting@redhat.com>
576- grab some bugfix patches
577
578* Mon Jan 10 2000 Bill Nottingham <notting@redhat.com>
579- 2.3.STABLE1 (whee, another serial number)
580
581* Tue Dec 21 1999 Bernhard Rosenkraenzer <bero@redhat.com>
582- Fix compliance with ftp RFCs
583  (http://www.wu-ftpd.org/broken-clients.html)
584- Work around a bug in some versions of autoconf
585- BuildPrereq sgml-tools - we're using sgml2html
586
587* Mon Oct 18 1999 Bill Nottingham <notting@redhat.com>
588- add a couple of bugfix patches
589
590* Wed Oct 13 1999 Bill Nottingham <notting@redhat.com>
591- update to 2.2.STABLE5.
592- update FAQ, fix URLs.
593
594* Sat Sep 11 1999 Cristian Gafton <gafton@redhat.com>
595- transform restart in reload and add restart to the init script
596
597* Tue Aug 31 1999 Bill Nottingham <notting@redhat.com>
598- add squid user as user 23.
599
600* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
601- initscript munging
602- fix conflict between logrotate & squid -k (#4562)
603
604* Wed Jul 28 1999 Bill Nottingham <notting@redhat.com>
605- put cachemgr.cgi back in /usr/lib/squid
606
607* Wed Jul 14 1999 Bill Nottingham <notting@redhat.com>
608- add webdav bugfix patch (#4027)
609
610* Mon Jul 12 1999 Bill Nottingham <notting@redhat.com>
611- fix path to config in squid.init (confuses linuxconf)
612
613* Wed Jul  7 1999 Bill Nottingham <notting@redhat.com>
614- 2.2.STABLE4
615
616* Wed Jun 9 1999 Dale Lovelace <dale@redhat.com>
617- logrotate changes
618- errors from find when /var/spool/squid or
619- /var/log/squid didn't exist
620
621* Thu May 20 1999 Bill Nottingham <notting@redhat.com>
622- 2.2.STABLE3
623
624* Thu Apr 22 1999 Bill Nottingham <notting@redhat.com>
625- update to 2.2.STABLE.2
626
627* Sun Apr 18 1999 Bill Nottingham <notting@redhat.com>
628- update to 2.2.STABLE1
629
630* Thu Apr 15 1999 Bill Nottingham <notting@redhat.com>
631- don't need to run groupdel on remove
632- fix useradd
633
634* Mon Apr 12 1999 Bill Nottingham <notting@redhat.com>
635- fix effective_user (bug #2124)
636
637* Mon Apr  5 1999 Bill Nottingham <notting@redhat.com>
638- strip binaries
639
640* Thu Apr  1 1999 Bill Nottingham <notting@redhat.com>
641- duh. adduser does require a user name.
642- add a serial number
643
644* Tue Mar 30 1999 Bill Nottingham <notting@redhat.com>
645- add an adduser in %pre, too
646
647* Thu Mar 25 1999 Bill Nottingham <notting@redhat.com>
648- oog. chkconfig must be in %preun, not %postun
649
650* Wed Mar 24 1999 Bill Nottingham <notting@redhat.com>
651- switch to using group squid
652- turn off icmp (insecure)
653- update to 2.2.DEVEL3
654- build FAQ docs from source
655
656* Tue Mar 23 1999 Bill Nottingham <notting@redhat.com>
657- logrotate changes
658
659* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
660- auto rebuild in the new build environment (release 4)
661
662* Wed Feb 10 1999 Bill Nottingham <notting@redhat.com>
663- update to 2.2.PRE2
664
665* Wed Dec 30 1998 Bill Nottingham <notting@redhat.com>
666- cache & log dirs shouldn't be world readable
667- remove preun script (leave logs & cache @ uninstall)
668
669* Tue Dec 29 1998 Bill Nottingham <notting@redhat.com>
670- fix initscript to get cache_dir correct
671
672* Fri Dec 18 1998 Bill Nottingham <notting@redhat.com>
673- update to 2.1.PATCH2
674- merge in some changes from RHCN version
675
676* Sat Oct 10 1998 Cristian Gafton <gafton@redhat.com>
677- strip binaries
678- version 1.1.22
679
680* Sun May 10 1998 Cristian Gafton <gafton@redhat.com>
681- don't make packages conflict with each other...
682
683* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
684- added a proxy auth patch from Alex deVries <adevries@engsoc.carleton.ca>
685- fixed initscripts
686
687* Thu Apr 09 1998 Cristian Gafton <gafton@redhat.com>
688- rebuilt for Manhattan
689
690* Fri Mar 20 1998 Cristian Gafton <gafton@redhat.com>
691- upgraded to 1.1.21/1.NOVM.21
692
693* Mon Mar 02 1998 Cristian Gafton <gafton@redhat.com>
694- updated the init script to use reconfigure option to restart squid instead
695  of shutdown/restart (both safer and quicker)
696
697* Sat Feb 07 1998 Cristian Gafton <gafton@redhat.com>
698- upgraded to 1.1.20
699- added the NOVM package and tryied to reduce the mess in the spec file
700
701* Wed Jan 7 1998 Cristian Gafton <gafton@redhat.com>
702- first build against glibc
703- patched out the use of setresuid(), which is available only on kernels
704  2.1.44 and later
705
Note: See TracBrowser for help on using the repository browser.