source: projects/specs/trunk/s/sqlite/sqlite-vl.spec @ 521

Revision 521, 4.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define name sqlite
2%define version 2.8.17
3%define release 1%{?_dist_release}
4
5Name: %{name}
6Summary: SQLite is a C library that implements an embeddable SQL database engine
7Summary(ja): SQLite は組み込み型SQLデータベースエンジンを実装するCライブラリです。
8Version: %{version}
9Release: %{release}
10Source: %{name}-%{version}.tar.gz
11Patch0: %{name}-2.8.15-ja-patch
12Patch1: %{name}-2.8.14-lib64.patch.bz2
13Patch2: %{name}-64bit-fixes.patch.bz2
14Group: System Environment/Libraries
15URL: http://www.sqlite.org
16License: Public Domain
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: tcl, chrpath, ncurses-devel, readline-devel
19
20%description
21SQLite is a C library that implements an embeddable SQL database engine.
22Programs that link with the SQLite library can have SQL database access
23without running a separate RDBMS process. The distribution comes with a
24standalone command-line access program (sqlite) that can be used to
25administer an SQLite database and which serves as an example of how to
26use the SQLite library.
27%description -l ja
28SQLite は組み込み型SQLデータベースエンジンを実装するCライブラリです。
29SQLiteライブラリにリンクされたプログラムではSQLデータベースアクセスが
30できるようになります。その際、別のRDBMSプロセスは不要です。
31
32
33%package devel
34Summary: Header files and libraries for developing apps which will use sqlite
35Summary(ja): SQLiteを使ってアプリを開発するためのヘッダファイルやライブラリ
36Group: Development/Libraries
37Requires: %{name} = %{version}-%{release}
38
39%description devel
40The sqlite-devel package contains the header files and libraries needed
41to develop programs that use the sqlite database library.
42
43%description devel -l ja
44qlite-develパッケージはSQLiteデータベースライブラリを使ってプログラムを
45開発するために必要なヘッダファイルやライブラリを含んでいます。
46
47%package        static-devel
48Summary:        Static development library for the SQLite library
49Summary(ja):    SQLiteライブラリのstaticな開発用ライブラリ
50Group:          Development/Libraries
51Requires:       %{name}-devel = %{version}-%{release}
52Provides:       %{name}-static-devel = %{version}-%{release}
53
54%description    static-devel
55The sqlite-static-devel package contains the static header files
56and libraries needed to develop programs that use the sqlite database library.
57
58%description    static-devel -l ja
59sqlite-static-develはSQLiteデータベースライブラリを使ってプログラムを開発する時に必要なstaticなヘッダファイルとライブラリを含んでいます
60
61%package        tools
62Summary:        Command line tools for managing the sqlite library.
63Summary(ja):    SQLiteライブラリを管理するコマンドラインツール
64Group:          Applications/Databases
65Requires:       %{name} = %{version}-%{release}
66
67%description    tools
68The sqlite-tool package contains command line tools for managing
69the sqlite library.
70
71%description    tools -l ja
72sqlite-toolはSQLiteライブラリを管理するコマンドラインツールです。
73
74%prep
75%setup -q
76%patch0 -p0 -b .jp
77%patch1 -p0 -b .lib64
78%patch2 -p1 -b .64bit-fixes
79
80%build
81CFLAGS="%optflags -DNDEBUG=1" CXXFLAGS="%optflags -DNDEBUG=1" %configure -enable-utf8
82
83make
84make doc
85
86%install
87[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
88
89install -d %{buildroot}%{_bindir}
90install -d %{buildroot}%{_includedir}
91install -d %{buildroot}%{_libdir}
92install -d %{buildroot}%{_mandir}/man1
93
94%makeinstall
95install -m644 sqlite.1 %{buildroot}%{_mandir}/man1/
96chrpath -d %{buildroot}%{_bindir}/*
97## remove unuse files
98rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
99
100
101%clean
102[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
103
104
105%post -p /sbin/ldconfig
106
107%postun -p /sbin/ldconfig
108
109
110%files
111%defattr(-, root, root)
112%doc README
113%{_libdir}/*.so.*
114
115%files  devel
116%defattr(-, root, root)
117%doc doc/*.html doc/*.png
118%{_libdir}/*.a
119#%{_libdir}/*.la
120%{_libdir}/lib*.so
121%{_includedir}/*.h
122%{_libdir}/pkgconfig/*.pc
123
124%files static-devel
125%defattr(-, root, root)
126%{_libdir}/lib*.a
127
128%files tools
129%defattr(-, root, root)
130%{_bindir}/*
131%{_mandir}/man1/*
132
133%changelog
134* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 2.8.17-1vl5
135- applied new versioning policy, spec in utf-8
136- removed *.la
137
138* Mon May 08 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.17-0vl1
139- updated to 2.8.17
140- changed Group:
141- run /sbin/ldconfig at %post, %postun
142
143* Mon Nov 08 2004 Satoshi MACHINO <machino@vinelinux.org> 2.8.15-0vl2
144- added BuildRequires: chrpath, ncurses-devel, readline-devel
145- separated sub packages to static-devel, tool
146- added ja subscription
147
148* Tue Aug 17 2004 HOTTA Michihide <hotta@net-newbie.com> 2.8.15-0vl1
149- add BuildRequires: tcl
150- upstream release
151
152* Mon Nov 11 2003 HOTTA Michihide <hotta@net-newbie.com> 2.8.6-0vl1
153- 1st release
Note: See TracBrowser for help on using the repository browser.