source: projects/specs/trunk/s/spice/spice-vl.spec @ 7115

Revision 7115, 7.8 KB checked in by Takemikaduchi, 11 years ago (diff)

QEMU-1.2.0

Line 
1
2# build_client:
3# If you want to build both client and server change value to 1
4# If you want to only build the server change value to 0
5%define build_client        1
6
7Name:           spice
8Version:        0.12.0
9Release:        1%{?_dist_release}
10Summary:        Implements the SPICE protocol
11Group:          User Interface/Desktops
12License:        LGPLv2+
13URL:            http://www.spice-space.org/
14Source0:        http://www.spice-space.org/download/releases/%{name}-%{version}.tar.bz2
15Source1:        spice-xpi-client-spicec
16
17BuildRequires:  pkgconfig
18BuildRequires:  spice-protocol >= 0.10.1
19BuildRequires:  zlib-devel
20BuildRequires:  celt051-devel
21BuildRequires:  pixman-devel alsa-lib-devel openssl-devel libjpeg-turbo-devel
22%if %{build_client}
23BuildRequires:  libXinerama-devel libXrandr-devel cegui06-devel
24%endif
25BuildRequires:  libcacard-devel cyrus-sasl-devel
26BuildRequires:  pyparsing
27BuildRequires:  autoconf automake libtool
28
29%description
30The Simple Protocol for Independent Computing Environments (SPICE) is
31a remote display system built for virtual environments which allows
32you to view a computing 'desktop' environment not only on the machine
33where it is running, but from anywhere on the Internet and from a wide
34variety of machine architectures.
35
36%if %{build_client}
37%package client
38Summary:          Implements the client side of the SPICE protocol
39Group:            User Interface/Desktops
40
41%description client
42The Simple Protocol for Independent Computing Environments (SPICE) is
43a remote display system built for virtual environments which allows
44you to view a computing 'desktop' environment not only on the machine
45where it is running, but from anywhere on the Internet and from a wide
46variety of machine architectures.
47
48This package contains the SPICE client application.
49%endif
50
51%package server
52Summary:        Implements the server side of the SPICE protocol
53Group:          System Environment/Libraries
54
55%description server
56The Simple Protocol for Independent Computing Environments (SPICE) is
57a remote display system built for virtual environments which allows
58you to view a computing 'desktop' environment not only on the machine
59where it is running, but from anywhere on the Internet and from a wide
60variety of machine architectures.
61
62This package contains the run-time libraries for any application that wishes
63to be a SPICE server.
64
65%package server-devel
66Summary:        Header files, libraries and development documentation for spice-server
67Group:          Development/Libraries
68Requires:       %{name}-server = %{version}-%{release}
69Requires:       pkgconfig
70
71%description server-devel
72This package contains the header files, static libraries and development
73documentation for spice-server. If you like to develop programs
74using spice-server, you will need to install spice-server-devel.
75
76%prep
77%setup -q
78
79%build
80%if %{build_client}
81%define configure_client --enable-client --enable-gui
82%else
83%define configure_client --disable-client
84%endif
85
86autoreconf -fi
87%configure --enable-smartcard %{configure_client}
88make WARN_CFLAGS='' %{?_smp_mflags}
89
90%install
91make DESTDIR=%{buildroot} install
92rm -f %{buildroot}%{_libdir}/libspice-server.a
93rm -f %{buildroot}%{_libdir}/libspice-server.la
94mkdir -p %{buildroot}%{_libexecdir}
95
96%if %{build_client}
97touch %{buildroot}%{_libexecdir}/spice-xpi-client
98install -m 0755 %{SOURCE1} %{buildroot}%{_libexecdir}/
99%endif
100
101%post server -p /sbin/ldconfig
102
103%postun server -p /sbin/ldconfig
104
105%if %{build_client}
106%files client
107%defattr(-,root,root,-)
108%doc COPYING README NEWS
109%{_bindir}/spicec
110%ghost %{_libexecdir}/spice-xpi-client
111%{_libexecdir}/spice-xpi-client-spicec
112
113%endif
114
115%files server
116%defattr(-,root,root,-)
117%doc COPYING README NEWS
118%{_libdir}/libspice-server.so.*
119
120%files server-devel
121%defattr(-,root,root,-)
122%{_includedir}/spice-server
123%{_libdir}/libspice-server.so
124%{_libdir}/pkgconfig/spice-server.pc
125
126%changelog
127* Sun Nov 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.0-1
128- initial build for Vine Linux
129
130
131
132* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.1-6
133- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
134
135* Mon May 14 2012 Alon Levy <alevy@redhat.com>
136- Fix mjpeg memory leak and bad behavior.
137- Add usbredir to list of channels for security purposes. (#819484)
138
139* Sun May 13 2012 Alon Levy <alevy@redhat.com>
140- Add double free fix. (#808936)
141
142%changelog
143* Tue Apr 24 2012 Alon Levy <alevy@redhat.com>
144- Add 32 bit fixes from git master. (#815717)
145
146* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.1-2
147- Rebuilt for c++ ABI breakage
148
149* Mon Jan 23 2012 Hans de Goede <hdegoede@redhat.com> - 0.10.1-1
150- New upstream release 0.10.1
151
152* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.0-2
153- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
154
155* Thu Nov 10 2011 Alon Levy <alevy@redhat.com> - 0.10.0-1
156- New upstream release 0.10.0
157- support spice-server.i686
158
159* Wed Sep 28 2011 Marc-André Lureau <marcandre.lureau@redhat.com> - 0.9.1-2
160- Provides spice-xpi-client alternative in spice-client
161
162* Thu Aug 25 2011 Hans de Goede <hdegoede@redhat.com> - 0.9.1-1
163- New upstream release 0.9.1
164
165* Mon Jul 25 2011 Marc-André Lureau <marcandre.lureau@redhat.com> - 0.9.0-1
166- New upstream release 0.9.0
167
168* Wed Apr 20 2011 Hans de Goede <hdegoede@redhat.com> - 0.8.1-1
169- New upstream release 0.8.1
170
171* Fri Mar 11 2011 Hans de Goede <hdegoede@redhat.com> - 0.8.0-2
172- Fix being unable to send ctrl+alt+key when release mouse is bound to
173  ctrl+alt (which can happen when used from RHEV-M)
174
175* Tue Mar  1 2011 Hans de Goede <hdegoede@redhat.com> - 0.8.0-1
176- New upstream release 0.8.0
177
178* Fri Feb 11 2011 Hans de Goede <hdegoede@redhat.com> - 0.7.3-1
179- New upstream release 0.7.3
180
181* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.2-2
182- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
183
184* Wed Jan 19 2011 Hans de Goede <hdegoede@redhat.com> - 0.7.2-1
185- New upstream release 0.7.2
186
187* Fri Dec 17 2010 Hans de Goede <hdegoede@redhat.com> - 0.7.1-1
188- New upstream release 0.7.1
189- Drop all patches (all upstreamed)
190- Enable smartcard (CAC) support
191
192* Wed Nov 17 2010 Hans de Goede <hdegoede@redhat.com> - 0.6.3-4
193- Fix the info layer not showing when used through the XPI
194- Do not let the connection gui flash by when a hostname has been specified
195  on the cmdline
196- Fix spice client locking up when dealing with XIM input (#654265)
197- Fix modifier keys getting stuck (#655048)
198- Fix spice client crashing when dealing with XIM ibus input (#655836)
199- Fix spice client only showing a white screen in full screen mode
200
201* Sat Nov  6 2010 Hans de Goede <hdegoede@redhat.com> - 0.6.3-3
202- Log to ~/.spicec/cegui.log rather then to CEGUI.log in the cwd, this
203  fixes spicec from aborting when run in a non writable dir (#650253)
204
205* Fri Nov  5 2010 Hans de Goede <hdegoede@redhat.com> - 0.6.3-2
206- Various bugfixes from upstream git:
207  - Make spicec work together with the Firefox XPI for RHEV-M
208  - Make sure the spicec window gets properly raised when first shown
209
210* Mon Oct 18 2010 Hans de Goede <hdegoede@redhat.com> - 0.6.3-1
211- Update to 0.6.3
212- Enable GUI
213
214* Thu Sep 30 2010 Gerd Hoffmann <kraxel@redhat.com> - 0.6.1-1
215- Update to 0.6.1.
216
217* Tue Aug 31 2010 Alexander Larsson <alexl@redhat.com> - 0.6.0-1
218- Update to 0.6.0 (stable release)
219
220* Tue Jul 20 2010 Alexander Larsson <alexl@redhat.com> - 0.5.3-1
221- Update to 0.5.3
222
223* Tue Jul 13 2010 Gerd Hoffmann <kraxel@redhat.com> - 0.5.2-4
224- Quote %% in changelog to avoid macro expansion.
225
226* Mon Jul 12 2010 Gerd Hoffmann <kraxel@redhat.com> - 0.5.2-3
227- %%configure handles CFLAGS automatically, no need to fiddle
228  with %%{optflags} manually.
229
230* Mon Jul 12 2010 Gerd Hoffmann <kraxel@redhat.com> - 0.5.2-2
231- Fix license: LGPL.
232- Cleanup specfile, drop bits not needed any more with
233  recent rpm versions (F13+).
234- Use optflags as-is.
235-
236
237* Fri Jul 9 2010 Gerd Hoffmann <kraxel@redhat.com> - 0.5.2-1
238- initial package.
239
Note: See TracBrowser for help on using the repository browser.