source: projects/specs/trunk/s/spice/spice-vl.spec @ 10771

Revision 10771, 8.1 KB checked in by ara_t, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1
2# build_client:
3# If you want to build both client and server change value to 1
4# If you want to only build the server change value to 0
5%define build_client        1
6
7Name:           spice
8Version:        0.12.5
9Release:        2%{?_dist_release}
10Summary:        Implements the SPICE protocol
11Group:          User Interface/Desktops
12License:        LGPLv2+
13URL:            http://www.spice-space.org/
14Source0:        http://www.spice-space.org/download/releases/%{name}-%{version}.tar.bz2
15Source1:        spice-xpi-client-spicec
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildRequires:  pkgconfig
19BuildRequires:  glib2-devel >= 2.22
20BuildRequires:  spice-protocol >= 0.12.3
21BuildRequires:  zlib-devel
22BuildRequires:  celt051-devel
23BuildRequires:  pixman-devel alsa-lib-devel openssl-devel libjpeg-turbo-devel
24%if %{build_client}
25BuildRequires:  libXinerama-devel libXrandr-devel cegui06-devel
26%endif
27BuildRequires:  libcacard-devel cyrus-sasl-devel
28BuildRequires:  pyparsing
29
30%description
31The Simple Protocol for Independent Computing Environments (SPICE) is
32a remote display system built for virtual environments which allows
33you to view a computing 'desktop' environment not only on the machine
34where it is running, but from anywhere on the Internet and from a wide
35variety of machine architectures.
36
37%if %{build_client}
38%package client
39Summary:          Implements the client side of the SPICE protocol
40Group:            User Interface/Desktops
41
42%description client
43The Simple Protocol for Independent Computing Environments (SPICE) is
44a remote display system built for virtual environments which allows
45you to view a computing 'desktop' environment not only on the machine
46where it is running, but from anywhere on the Internet and from a wide
47variety of machine architectures.
48
49This package contains the SPICE client application.
50%endif
51
52%package server
53Summary:        Implements the server side of the SPICE protocol
54Group:          System Environment/Libraries
55
56%description server
57The Simple Protocol for Independent Computing Environments (SPICE) is
58a remote display system built for virtual environments which allows
59you to view a computing 'desktop' environment not only on the machine
60where it is running, but from anywhere on the Internet and from a wide
61variety of machine architectures.
62
63This package contains the run-time libraries for any application that wishes
64to be a SPICE server.
65
66%package server-devel
67Summary:        Header files, libraries and development documentation for spice-server
68Group:          Development/Libraries
69Requires:       %{name}-server = %{version}-%{release}
70Requires:       pkgconfig
71
72%description server-devel
73This package contains the header files, static libraries and development
74documentation for spice-server. If you like to develop programs
75using spice-server, you will need to install spice-server-devel.
76
77%prep
78%setup -q
79
80%build
81%if %{build_client}
82%define configure_client --enable-client --enable-gui
83%else
84%define configure_client --disable-client
85%endif
86
87%configure --enable-smartcard %{configure_client}
88make WARN_CFLAGS='' %{?_smp_mflags}
89
90%install
91make DESTDIR=%{buildroot} install
92rm -f %{buildroot}%{_libdir}/libspice-server.a
93rm -f %{buildroot}%{_libdir}/libspice-server.la
94mkdir -p %{buildroot}%{_libexecdir}
95
96%if %{build_client}
97touch %{buildroot}%{_libexecdir}/spice-xpi-client
98install -m 0755 %{SOURCE1} %{buildroot}%{_libexecdir}/
99%endif
100
101%post server -p /sbin/ldconfig
102
103%postun server -p /sbin/ldconfig
104
105%if %{build_client}
106%files client
107%defattr(-,root,root,-)
108%doc COPYING README NEWS
109%{_bindir}/spicec
110%ghost %{_libexecdir}/spice-xpi-client
111%{_libexecdir}/spice-xpi-client-spicec
112
113%endif
114
115%files server
116%defattr(-,root,root,-)
117%doc COPYING README NEWS
118%{_libdir}/libspice-server.so.*
119
120%files server-devel
121%defattr(-,root,root,-)
122%{_includedir}/spice-server
123%{_libdir}/libspice-server.so
124%{_libdir}/pkgconfig/spice-server.pc
125
126%changelog
127* Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> - 0.12.5-2
128- rebuild with gcc-5.4.0
129
130* Thu Jan 22 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.12.5-1
131- updated to 0.12.5
132- built with cyrus-sasl 2.1.26
133
134* Sun Nov 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.0-1
135- initial build for Vine Linux
136
137* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.1-6
138- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
139
140* Mon May 14 2012 Alon Levy <alevy@redhat.com>
141- Fix mjpeg memory leak and bad behavior.
142- Add usbredir to list of channels for security purposes. (#819484)
143
144* Sun May 13 2012 Alon Levy <alevy@redhat.com>
145- Add double free fix. (#808936)
146
147* Tue Apr 24 2012 Alon Levy <alevy@redhat.com>
148- Add 32 bit fixes from git master. (#815717)
149
150* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.1-2
151- Rebuilt for c++ ABI breakage
152
153* Mon Jan 23 2012 Hans de Goede <hdegoede@redhat.com> - 0.10.1-1
154- New upstream release 0.10.1
155
156* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.0-2
157- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
158
159* Thu Nov 10 2011 Alon Levy <alevy@redhat.com> - 0.10.0-1
160- New upstream release 0.10.0
161- support spice-server.i686
162
163* Wed Sep 28 2011 Marc-André Lureau <marcandre.lureau@redhat.com> - 0.9.1-2
164- Provides spice-xpi-client alternative in spice-client
165
166* Thu Aug 25 2011 Hans de Goede <hdegoede@redhat.com> - 0.9.1-1
167- New upstream release 0.9.1
168
169* Mon Jul 25 2011 Marc-André Lureau <marcandre.lureau@redhat.com> - 0.9.0-1
170- New upstream release 0.9.0
171
172* Wed Apr 20 2011 Hans de Goede <hdegoede@redhat.com> - 0.8.1-1
173- New upstream release 0.8.1
174
175* Fri Mar 11 2011 Hans de Goede <hdegoede@redhat.com> - 0.8.0-2
176- Fix being unable to send ctrl+alt+key when release mouse is bound to
177  ctrl+alt (which can happen when used from RHEV-M)
178
179* Tue Mar  1 2011 Hans de Goede <hdegoede@redhat.com> - 0.8.0-1
180- New upstream release 0.8.0
181
182* Fri Feb 11 2011 Hans de Goede <hdegoede@redhat.com> - 0.7.3-1
183- New upstream release 0.7.3
184
185* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.2-2
186- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
187
188* Wed Jan 19 2011 Hans de Goede <hdegoede@redhat.com> - 0.7.2-1
189- New upstream release 0.7.2
190
191* Fri Dec 17 2010 Hans de Goede <hdegoede@redhat.com> - 0.7.1-1
192- New upstream release 0.7.1
193- Drop all patches (all upstreamed)
194- Enable smartcard (CAC) support
195
196* Wed Nov 17 2010 Hans de Goede <hdegoede@redhat.com> - 0.6.3-4
197- Fix the info layer not showing when used through the XPI
198- Do not let the connection gui flash by when a hostname has been specified
199  on the cmdline
200- Fix spice client locking up when dealing with XIM input (#654265)
201- Fix modifier keys getting stuck (#655048)
202- Fix spice client crashing when dealing with XIM ibus input (#655836)
203- Fix spice client only showing a white screen in full screen mode
204
205* Sat Nov  6 2010 Hans de Goede <hdegoede@redhat.com> - 0.6.3-3
206- Log to ~/.spicec/cegui.log rather then to CEGUI.log in the cwd, this
207  fixes spicec from aborting when run in a non writable dir (#650253)
208
209* Fri Nov  5 2010 Hans de Goede <hdegoede@redhat.com> - 0.6.3-2
210- Various bugfixes from upstream git:
211  - Make spicec work together with the Firefox XPI for RHEV-M
212  - Make sure the spicec window gets properly raised when first shown
213
214* Mon Oct 18 2010 Hans de Goede <hdegoede@redhat.com> - 0.6.3-1
215- Update to 0.6.3
216- Enable GUI
217
218* Thu Sep 30 2010 Gerd Hoffmann <kraxel@redhat.com> - 0.6.1-1
219- Update to 0.6.1.
220
221* Tue Aug 31 2010 Alexander Larsson <alexl@redhat.com> - 0.6.0-1
222- Update to 0.6.0 (stable release)
223
224* Tue Jul 20 2010 Alexander Larsson <alexl@redhat.com> - 0.5.3-1
225- Update to 0.5.3
226
227* Tue Jul 13 2010 Gerd Hoffmann <kraxel@redhat.com> - 0.5.2-4
228- Quote %% in changelog to avoid macro expansion.
229
230* Mon Jul 12 2010 Gerd Hoffmann <kraxel@redhat.com> - 0.5.2-3
231- %%configure handles CFLAGS automatically, no need to fiddle
232  with %%{optflags} manually.
233
234* Mon Jul 12 2010 Gerd Hoffmann <kraxel@redhat.com> - 0.5.2-2
235- Fix license: LGPL.
236- Cleanup specfile, drop bits not needed any more with
237  recent rpm versions (F13+).
238- Use optflags as-is.
239-
240
241* Fri Jul 9 2010 Gerd Hoffmann <kraxel@redhat.com> - 0.5.2-1
242- initial package.
243
Note: See TracBrowser for help on using the repository browser.