source: projects/specs/trunk/s/spice/spice-vl.spec @ 9287

Revision 9287, 8.0 KB checked in by inagaki, 9 years ago (diff)

2015-01-22 Ryoichi INAGAKI <ryo1@…>

  • libesmtp, spice, spice-protcol, telepathy-salut: updated
  • ptlib: rebuilt


Line 
1
2# build_client:
3# If you want to build both client and server change value to 1
4# If you want to only build the server change value to 0
5%define build_client        1
6
7Name:           spice
8Version:        0.12.5
9Release:        1%{?_dist_release}
10Summary:        Implements the SPICE protocol
11Group:          User Interface/Desktops
12License:        LGPLv2+
13URL:            http://www.spice-space.org/
14Source0:        http://www.spice-space.org/download/releases/%{name}-%{version}.tar.bz2
15Source1:        spice-xpi-client-spicec
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildRequires:  pkgconfig
19BuildRequires:  glib2-devel >= 2.22
20BuildRequires:  spice-protocol >= 0.12.3
21BuildRequires:  zlib-devel
22BuildRequires:  celt051-devel
23BuildRequires:  pixman-devel alsa-lib-devel openssl-devel libjpeg-turbo-devel
24%if %{build_client}
25BuildRequires:  libXinerama-devel libXrandr-devel cegui06-devel
26%endif
27BuildRequires:  libcacard-devel cyrus-sasl-devel
28BuildRequires:  pyparsing
29
30%description
31The Simple Protocol for Independent Computing Environments (SPICE) is
32a remote display system built for virtual environments which allows
33you to view a computing 'desktop' environment not only on the machine
34where it is running, but from anywhere on the Internet and from a wide
35variety of machine architectures.
36
37%if %{build_client}
38%package client
39Summary:          Implements the client side of the SPICE protocol
40Group:            User Interface/Desktops
41
42%description client
43The Simple Protocol for Independent Computing Environments (SPICE) is
44a remote display system built for virtual environments which allows
45you to view a computing 'desktop' environment not only on the machine
46where it is running, but from anywhere on the Internet and from a wide
47variety of machine architectures.
48
49This package contains the SPICE client application.
50%endif
51
52%package server
53Summary:        Implements the server side of the SPICE protocol
54Group:          System Environment/Libraries
55
56%description server
57The Simple Protocol for Independent Computing Environments (SPICE) is
58a remote display system built for virtual environments which allows
59you to view a computing 'desktop' environment not only on the machine
60where it is running, but from anywhere on the Internet and from a wide
61variety of machine architectures.
62
63This package contains the run-time libraries for any application that wishes
64to be a SPICE server.
65
66%package server-devel
67Summary:        Header files, libraries and development documentation for spice-server
68Group:          Development/Libraries
69Requires:       %{name}-server = %{version}-%{release}
70Requires:       pkgconfig
71
72%description server-devel
73This package contains the header files, static libraries and development
74documentation for spice-server. If you like to develop programs
75using spice-server, you will need to install spice-server-devel.
76
77%prep
78%setup -q
79
80%build
81%if %{build_client}
82%define configure_client --enable-client --enable-gui
83%else
84%define configure_client --disable-client
85%endif
86
87%configure --enable-smartcard %{configure_client}
88make WARN_CFLAGS='' %{?_smp_mflags}
89
90%install
91make DESTDIR=%{buildroot} install
92rm -f %{buildroot}%{_libdir}/libspice-server.a
93rm -f %{buildroot}%{_libdir}/libspice-server.la
94mkdir -p %{buildroot}%{_libexecdir}
95
96%if %{build_client}
97touch %{buildroot}%{_libexecdir}/spice-xpi-client
98install -m 0755 %{SOURCE1} %{buildroot}%{_libexecdir}/
99%endif
100
101%post server -p /sbin/ldconfig
102
103%postun server -p /sbin/ldconfig
104
105%if %{build_client}
106%files client
107%defattr(-,root,root,-)
108%doc COPYING README NEWS
109%{_bindir}/spicec
110%ghost %{_libexecdir}/spice-xpi-client
111%{_libexecdir}/spice-xpi-client-spicec
112
113%endif
114
115%files server
116%defattr(-,root,root,-)
117%doc COPYING README NEWS
118%{_libdir}/libspice-server.so.*
119
120%files server-devel
121%defattr(-,root,root,-)
122%{_includedir}/spice-server
123%{_libdir}/libspice-server.so
124%{_libdir}/pkgconfig/spice-server.pc
125
126%changelog
127* Thu Jan 22 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.12.5-1
128- updated to 0.12.5
129- built with cyrus-sasl 2.1.26
130
131* Sun Nov 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.0-1
132- initial build for Vine Linux
133
134* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.1-6
135- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
136
137* Mon May 14 2012 Alon Levy <alevy@redhat.com>
138- Fix mjpeg memory leak and bad behavior.
139- Add usbredir to list of channels for security purposes. (#819484)
140
141* Sun May 13 2012 Alon Levy <alevy@redhat.com>
142- Add double free fix. (#808936)
143
144%changelog
145* Tue Apr 24 2012 Alon Levy <alevy@redhat.com>
146- Add 32 bit fixes from git master. (#815717)
147
148* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.1-2
149- Rebuilt for c++ ABI breakage
150
151* Mon Jan 23 2012 Hans de Goede <hdegoede@redhat.com> - 0.10.1-1
152- New upstream release 0.10.1
153
154* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.0-2
155- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
156
157* Thu Nov 10 2011 Alon Levy <alevy@redhat.com> - 0.10.0-1
158- New upstream release 0.10.0
159- support spice-server.i686
160
161* Wed Sep 28 2011 Marc-André Lureau <marcandre.lureau@redhat.com> - 0.9.1-2
162- Provides spice-xpi-client alternative in spice-client
163
164* Thu Aug 25 2011 Hans de Goede <hdegoede@redhat.com> - 0.9.1-1
165- New upstream release 0.9.1
166
167* Mon Jul 25 2011 Marc-André Lureau <marcandre.lureau@redhat.com> - 0.9.0-1
168- New upstream release 0.9.0
169
170* Wed Apr 20 2011 Hans de Goede <hdegoede@redhat.com> - 0.8.1-1
171- New upstream release 0.8.1
172
173* Fri Mar 11 2011 Hans de Goede <hdegoede@redhat.com> - 0.8.0-2
174- Fix being unable to send ctrl+alt+key when release mouse is bound to
175  ctrl+alt (which can happen when used from RHEV-M)
176
177* Tue Mar  1 2011 Hans de Goede <hdegoede@redhat.com> - 0.8.0-1
178- New upstream release 0.8.0
179
180* Fri Feb 11 2011 Hans de Goede <hdegoede@redhat.com> - 0.7.3-1
181- New upstream release 0.7.3
182
183* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.2-2
184- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
185
186* Wed Jan 19 2011 Hans de Goede <hdegoede@redhat.com> - 0.7.2-1
187- New upstream release 0.7.2
188
189* Fri Dec 17 2010 Hans de Goede <hdegoede@redhat.com> - 0.7.1-1
190- New upstream release 0.7.1
191- Drop all patches (all upstreamed)
192- Enable smartcard (CAC) support
193
194* Wed Nov 17 2010 Hans de Goede <hdegoede@redhat.com> - 0.6.3-4
195- Fix the info layer not showing when used through the XPI
196- Do not let the connection gui flash by when a hostname has been specified
197  on the cmdline
198- Fix spice client locking up when dealing with XIM input (#654265)
199- Fix modifier keys getting stuck (#655048)
200- Fix spice client crashing when dealing with XIM ibus input (#655836)
201- Fix spice client only showing a white screen in full screen mode
202
203* Sat Nov  6 2010 Hans de Goede <hdegoede@redhat.com> - 0.6.3-3
204- Log to ~/.spicec/cegui.log rather then to CEGUI.log in the cwd, this
205  fixes spicec from aborting when run in a non writable dir (#650253)
206
207* Fri Nov  5 2010 Hans de Goede <hdegoede@redhat.com> - 0.6.3-2
208- Various bugfixes from upstream git:
209  - Make spicec work together with the Firefox XPI for RHEV-M
210  - Make sure the spicec window gets properly raised when first shown
211
212* Mon Oct 18 2010 Hans de Goede <hdegoede@redhat.com> - 0.6.3-1
213- Update to 0.6.3
214- Enable GUI
215
216* Thu Sep 30 2010 Gerd Hoffmann <kraxel@redhat.com> - 0.6.1-1
217- Update to 0.6.1.
218
219* Tue Aug 31 2010 Alexander Larsson <alexl@redhat.com> - 0.6.0-1
220- Update to 0.6.0 (stable release)
221
222* Tue Jul 20 2010 Alexander Larsson <alexl@redhat.com> - 0.5.3-1
223- Update to 0.5.3
224
225* Tue Jul 13 2010 Gerd Hoffmann <kraxel@redhat.com> - 0.5.2-4
226- Quote %% in changelog to avoid macro expansion.
227
228* Mon Jul 12 2010 Gerd Hoffmann <kraxel@redhat.com> - 0.5.2-3
229- %%configure handles CFLAGS automatically, no need to fiddle
230  with %%{optflags} manually.
231
232* Mon Jul 12 2010 Gerd Hoffmann <kraxel@redhat.com> - 0.5.2-2
233- Fix license: LGPL.
234- Cleanup specfile, drop bits not needed any more with
235  recent rpm versions (F13+).
236- Use optflags as-is.
237-
238
239* Fri Jul 9 2010 Gerd Hoffmann <kraxel@redhat.com> - 0.5.2-1
240- initial package.
241
Note: See TracBrowser for help on using the repository browser.