source: projects/specs/trunk/s/speedbar/speedbar-vl.spec @ 521

Revision 521, 3.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define       _noVersionedDependencies        1
2%define       prereq_ge()   %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3%define       emacsen_pkgdir /usr/lib/emacsen-common/packages
4%define       origname      speedbar
5%define       origver       0.14beta4
6%define       release       1%{?_dist_release}
7
8Summary: Speedbar for Emacs
9name: %{origname}
10Version: %{origver}
11Release: %{release}
12Source0: http://prdownloads.sourceforge.net/cedet/%{name}-%{version}.tar.gz
13Source1: %{origname}-install.sh
14Source2: %{origname}-remove.sh
15License: GPL
16Group: Applications/Editors/Emacs
17URL: http://cedet.sourceforge.net/speedbar.shtml
18Vendor: Project Vine
19Packager: yoneda kenji <yoneda@n.isl.titech.ac.jp>
20Buildroot: %{_tmppath}/%{name}-%{version}-root
21BuildArchitectures: noarch
22PreReq: emacsen
23Requires: emacsen
24%prereq_ge emacsen-common
25
26%description
27Speedbar is an Emacs Lisp program which allows you to create a special
28skinny frame with a specialized directory listing in it. This listing
29will have both directories and filtered files in it. You can then load
30files into your emacs frame, or expand the files to display all the tags
31that are in them and jump to those tags. You can also expand multiple
32directories into your speedbar frame.
33
34%prep
35rm -rf $RPM_BUILD_ROOT
36%setup -q -n %{name}-%{version}
37
38%build
39[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
40[ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
41
42mkdir -p $RPM_BUILD_ROOT/%{_datadir}/emacs/site-lisp/%{origname}
43#mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/install
44#mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/remove
45mkdir -p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/install
46mkdir -p $RPM_BUILD_ROOT/%{emacsen_pkgdir}/remove
47mkdir -p $RPM_BUILD_ROOT%{_infodir}
48#touch $RPM_BUILD_ROOT%{_infodir}/dir
49
50###
51# install el files
52cp -a Makefile *.el *.texi *.xpm Project.ede \
53          ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
54
55###
56#  install info
57install -m0644 speedbar.info* ${RPM_BUILD_ROOT}%{_infodir}
58
59###
60# install  script( bytecompile el and install elc , remove )   
61%_installemacsenscript %{origname} %{SOURCE1}
62
63%_removeemacsenscript  %{origname} %{SOURCE2}
64
65%post
66###
67# bytecompile and install
68if [ "$1" = 2 ]; then
69
70%_emacsenPackageRemove %{origname}
71
72fi
73
74%_addemacsenlist %{origname}
75
76%_emacsenPackageInstall %{origname}
77
78/sbin/install-info %{_infodir}/speedbar.info* %{_infodir}/dir \
79        --section="Emacs"
80
81%preun
82if [ "$1" = 0 ]; then
83
84%_emacsenPackageRemove %{origname}
85
86%_removeemacsenlist %{origname}
87
88/sbin/install-info --delete %{_infodir}/speedbar.info* %{_infodir}/dir \
89        --section="Emacs"
90
91fi
92
93%clean
94[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
95rm -rf ${RPM_BUILD_DIR}/%{origname}-%{origver}
96
97%files
98%defattr(-,root,root)
99%{_datadir}/emacs/site-lisp/%{origname}/
100#%{_libdir}/emacsen-common/packages/install/%{origname}
101#%{_libdir}/emacsen-common/packages/remove/%{origname}
102%{emacsen_pkgdir}/install/%{origname}
103%{emacsen_pkgdir}/remove/%{origname}
104%{_infodir}/speedbar.info*
105
106
107%changeLog
108* Sat Oct 11 2008 Shu KONNO <owa@bg.wakwak.com> 0.14beta4-1vl5
109- applied new versioning policy
110- added macro %%emacsen_pkgdir
111
112* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.14beta4-0vl2
113- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
114
115* Mon Jul 22 2002 IWAI Masaharu <iwai@alib.jp> 0.14beta4-0vl1
116- emacsenize
117- update speedbar to version 0.14bera4
118
119* Tue Feb 20 2001 yoneda kenji <yoneda@n.isl.titech.ac.jp>
120- (0.13a-0s)
121- 1st Release for Vine Linux 2.1
122
123* Fri Dec 15 2000 Shinya Ohnuma <a61051@cit.nihon-u.ac.jp>
124- (0.13a-0s)
125- 1st Release for Nishi Lab users.
126
Note: See TracBrowser for help on using the repository browser.