source: projects/specs/trunk/s/soundtouch/soundtouch-vl.spec @ 10771

Revision 10771, 5.9 KB checked in by ara_t, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1Name:           soundtouch
2Version:        1.9.2
3Release:        2%{?_dist_release}
4Summary:        Audio Processing library for changing Tempo, Pitch and Playback Rates
5Summary(ja):    テンポ/ピッチ/再生レートを変更するためのオーディオプロセッシングライブラリー
6License:        LGPLv2+
7Group:          System Environment/Libraries
8URL:            http://www.surina.net/soundtouch/
9Source0:        http://www.surina.net/soundtouch/%{name}-%{version}.tar.gz
10#Patch0:         soundtouch-1.4.0-x86_64-asm-broken.patch
11
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13
14BuildRequires:  gcc-c++
15
16%description
17SoundTouch is a LGPL-licensed open-source audio processing library for
18changing the Tempo, Pitch and Playback Rates of audio streams or
19files. The SoundTouch library is suited for application developers
20writing sound processing tools that require tempo/pitch control
21functionality, or just for playing around with the sound effects.
22
23The SoundTouch library source kit includes an example utility
24SoundStretch which allows processing .wav audio files from a
25command-line interface.
26
27
28%package devel
29Summary: Libraries, headers and etc to develop soundtouch applications
30Summary(ja): soundtouch アプリケーションを開発するためのライブラリー/ヘッダー等
31Group:    Development/Libraries
32Requires: %{name} = %{version}-%{release}
33Requires: pkgconfig
34
35%description devel
36Libraries, include files, etc you can use to develop soundtouch applications.
37
38
39%prep
40%setup -q -n %{name}
41#%patch0 -p1
42
43sed -i 's|-O3||' source/SoundStretch/Makefile.*
44sed -i 's|\r||g' README.html source/SoundTouch/RateTransposer.cpp
45
46
47%build
48./bootstrap
49%configure --disable-dependency-tracking --disable-static --enable-shared
50
51# Don't use rpath!   
52sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
53sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
54
55make %{?_smp_mflags}
56
57
58%install
59rm -rf $RPM_BUILD_ROOT
60make install DESTDIR=$RPM_BUILD_ROOT
61rm $RPM_BUILD_ROOT%{_libdir}/*.la
62
63# remove redundant installed docs
64rm -rf $RPM_BUILD_ROOT%{_prefix}/share/doc/%{name}
65
66# pkgconfig compat links for compat with older (API compatible) releases
67# dunno why upstream keeps changing the pkgconfig name
68#ln -s soundtouch-1.4.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig/libSoundTouch.pc
69#ln -s soundtouch-1.4.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig/soundtouch-1.0.pc
70
71# soundtouch installs an autoheader generated header file which could very
72# well conflict with other autoheader generated header files, so we override
73# this with our own version which contains only the bare minimum:
74
75echo '#define FLOAT_SAMPLES 1' \
76  > $RPM_BUILD_ROOT%{_includedir}/soundtouch/soundtouch_config.h
77
78
79%clean
80rm -rf $RPM_BUILD_ROOT
81
82
83%post -p /sbin/ldconfig
84
85%postun -p /sbin/ldconfig
86
87
88%files
89%defattr(-,root,root,-)
90#%doc COPYING.TXT README.html
91%doc
92%{_bindir}/soundstretch
93%{_libdir}/lib*.so.*
94
95%files devel
96%defattr(-,root,root,-)
97%{_libdir}/lib*.so
98%{_libdir}/pkgconfig/*.pc
99%{_includedir}/%{name}
100%{_datadir}/aclocal/%{name}.m4
101
102
103%changelog
104* Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> - 1.9.2-2
105- rebuild with gcc-5.4.0
106
107* Thu May 05 2016 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.9.2-1
108- new upstream release
109
110* Fri Jul 04 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.8.0-1
111- new upstream release
112
113* Sat Jan 26 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.7.1-1
114- new upstream release
115
116* Fri Sep 14 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.7.0-1
117- new upstream release
118- deleted Patch0
119
120* Fri Jun 08 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.6.0-1
121- initial build for VineSeed
122
123* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.0-5
124- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
125
126* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.0-4
127- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
128
129* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.0-3
130- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
131
132* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.0-2
133- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
134
135* Sat Feb 14 2009 Hans de Goede <hdegoede@redhat.com> 1.4.0-1
136- New upstream release 1.4.0
137
138* Sat Dec 20 2008 Hans de Goede <hdegoede@redhat.com> 1.3.1-11
139- Fix compilation with libtool 2.x
140
141* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.3.1-10
142- Autorebuild for GCC 4.3
143
144* Fri Jan 11 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 1.3.1-9
145- Fix compilation with gcc 4.3
146
147* Wed Aug 22 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 1.3.1-8
148- Rebuild for buildId
149- Update license tag for new license guidelines compliance
150
151* Mon Feb 19 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 1.3.1-7
152- Fix building with automake-1.10
153
154* Tue Aug 29 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 1.3.1-6
155- FE6 Rebuild
156
157* Wed Aug  2 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 1.3.1-5
158- Patch makefiles so that our RPM_OPT_FLAGS get used instead of the custom
159  upstream CFLAGS.
160
161* Mon Jul 31 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 1.3.1-4
162- Add Requires: pkgconfig to -devel subpackage
163- Replace installed autoheader generated header file with our own version
164  which contains only the nescesarry soundtouch specific defines, thus avoiding
165  possible conflicts with other autoheader generated headers.
166
167* Mon Jul 31 2006 Paul F. Johnson <paul@all-the-johnsons.co.uk> 1.3.1-3
168- Add BR libtool
169
170* Mon Jul 31 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 1.3.1-2
171- Add BR: automake, because upstream uses symlinks to instead of copies of some
172  needed automake files.
173
174* Sat Jul 29 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 1.3.1-1
175- New upstream version 1.3.1
176- Minor specfile cleanups for livna submission.
177- Give the .so a proper version instead of 0.0.0
178- Don't use rpath in soundstretch binary
179
180* Thu Aug 26 2004 Fernando Lopez-Lezcano <nando@ccrma.stanford.edu> 1.2.1-1
181- initial build.
Note: See TracBrowser for help on using the repository browser.