source: projects/specs/trunk/s/sound-juicer/sound-juicer-vl.spec @ 521

Revision 521, 8.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name:           sound-juicer
2Summary:        Clean and lean CD ripper
3Summary(ja):    シンプルで簡単なCDリッピングツール
4Version:        2.28.1
5Release:        1%{?_dist_release}
6License:        GPL
7Group:          Applications/Multimedia
8Source:         %{name}-%{version}.tar.bz2
9
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11Requires:       cdparanoia
12BuildRequires:  gnome-media >= 2.18.0
13BuildRequires:  libmusicbrainz-devel >= 2.1.1
14BuildRequires:  libgnomeui-devel >= 2.18.0
15BuildRequires:  glib2-devel >= 2.12.0
16BuildRequires:  gstreamer-devel >= 0.10.5
17BuildRequires:  gstreamer-plugins-base-devel >= 0.10.5
18BuildRequires:  gstreamer-plugins-good-flac
19BuildRequires:  gnome-doc-utils
20BuildRequires:  GConf2-devel >= 2.18.0
21BuildRequires:  hal-devel >= 0.5.9
22BuildRequires:  scrollkeeper >= 0.3.5
23BuildRequires:  brasero-devel
24BuildRequires:  gcc-c++
25BuildRequires:  autoconf
26BuildRequires:  libcanberra-devel
27Requires(pre): GConf2
28Requires(post): GConf2
29Requires(preun): GConf2
30# http://bugzilla.gnome.org/show_bug.cgi?id=157772
31ExcludeArch: s390 s390x
32
33
34%description
35GStreamer-based CD ripping tool. Saves audio CDs to Ogg/vorbis.
36
37%description -l ja
38Sound Juicer は GStreamer ベースの CD リッピングツールです。
39CD を Ogg/vorbis に変換します。
40
41%prep
42%setup -q
43
44%build
45%configure --disable-scrollkeeper --disable-schemas-install --disable-scrollkeeper
46
47%__make AM_CFLAGS=-export-dynamic
48
49%install
50rm -rf $RPM_BUILD_ROOT
51export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1;
52%makeinstall
53unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
54
55rm -rf $RPM_BUILD_ROOT%{_localstatedir}/scrollkeeper
56rm -rf $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
57
58%find_lang %{name}
59
60%clean
61rm -rf $RPM_BUILD_ROOT
62
63%pre
64if [ "$1" -gt 1 ]; then
65    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
66    gconftool-2 --makefile-uninstall-rule \
67        %{_sysconfdir}/gconf/schemas/sound-juicer.schemas >& /dev/null ||:
68fi
69
70%preun
71if [ "$1" -eq 0 ]; then
72    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
73    gconftool-2 --makefile-uninstall-rule \
74        %{_sysconfdir}/gconf/schemas/sound-juicer.schemas > /dev/null ||:
75fi
76
77%post
78export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
79gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/sound-juicer.schemas > /dev/null ||:
80touch --no-create %{_datadir}/icons/hicolor
81if [ -x /usr/bin/gtk-update-icon-cache ]; then
82  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
83fi
84
85%postun
86touch --no-create %{_datadir}/icons/hicolor
87if [ -x /usr/bin/gtk-update-icon-cache ]; then
88  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
89fi
90
91
92%files -f sound-juicer.lang
93%defattr(-, root, root)
94%doc AUTHORS COPYING ChangeLog README NEWS
95%{_bindir}/sound-juicer
96%{_sysconfdir}/gconf/schemas/sound-juicer.schemas
97%{_datadir}/sound-juicer
98%{_datadir}/applications/sound-juicer.desktop
99%{_datadir}/gnome/help/sound-juicer
100%{_datadir}/omf/sound-juicer
101%{_datadir}/icons/hicolor/*
102%{_mandir}/man1/*
103
104%changelog
105* Sat Jan 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
106- new upstream release
107- remove configure option: --enable-hal (unrecognized option)
108- add BuildRequires: gstreamer-plugins-base-devel >= 0.10.5
109- add BuildRequires: gstreamer-plugins-good-flac
110
111* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
112- new upstream release
113
114* Tue Apr 07 2009 Shu KONNO <owa@bg.wakwak.com> 2.26.0-2
115- add BR: libcanberra-devel
116
117* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
118- new upstream release
119- add BR: brasero-devel instead of nautilus-cd-burner
120- add BR: gnome-doc-utils
121- add Requires(pre,post,postun): GConf2
122- remove unneeded Requires:
123
124* Sat Oct 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.0-1vl5
125- new upstream release
126
127* Sat Oct 11 2008 Shu KONNO <owa@bg.wakwak.com> 2.16.4-1vl5
128- applied new versioning policy, spec in utf-8
129
130* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.4-0vl2
131- rebuild with new environment/toolchain
132
133* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.4-0vl1
134- new upstream release
135
136* Sun Jun 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.4-0vl1
137- new upstream release
138
139* Sat Apr 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
140- new upstream release
141
142* Tue Apr 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
143- initial build for Vine Linux based on FC package
144- new upstream release
145
146* Wed Mar 23 2005 John (J5) Palmieri <johnp@redhat.com> 2.10.0-2
147- Rebuild for libmusicbrainz-2.1.1
148
149* Fri Mar 11 2005 John (J5) Palmieri <johnp@redhat.com> 2.10.0-1
150- Update to upstream version 2.10.0
151
152* Tue Mar 08 2005 John (J5) Palmieri <johnp@redhat.com> 2.9.91-3
153- Build in rawhide
154- Disable build on s390 and s390x
155
156* Fri Feb 25 2005 John (J5) Palmieri <johnp@redhat.com> 2.9.91-2
157- Reenabled BuildRequires for hal-devel >= 0.5.0
158- Added (Build)Requires for nautilus-cd-burner(-devel) >= 2.9.6
159
160* Wed Feb 23 2005 John (J5) Palmieri <johnp@redhat.com> 2.9.91-1
161- New upstream version (version jump resulted from sound-juicer using gnome
162  versioning scheme)
163 
164* Fri Feb 04 2005 Colin Walters <walters@redhat.com> 0.6.0-1
165- New upstream version
166- Remove obsoleted sound-juicer-idle-safety.patch
167- BR latest gnome-media
168
169* Fri Nov 12 2004 Warren Togami <wtogami@redhat.com> 0.5.14-5
170- minor spec cleanups
171- req cdparanoia and gstreamer-plugins
172
173* Tue Nov 09 2004 Colin Walters <walters@redhat.com> 0.5.14-4
174- Add sound-juicer-idle-safety.patch (bug 137847)
175
176* Wed Oct 27 2004 Colin Walters <walters@redhat.com> 0.5.14-2
177- Actually enable HAL
178- BR hal-devel
179
180* Wed Oct 13 2004 Colin Walters <walters@redhat.com> 0.5.14-1
181- New upstream
182- This release fixes corruption on re-read, upstream 153085
183- Remove upstreamed sound-juicer-0.5.13-prefs-crash.patch
184
185* Mon Oct 04 2004 Colin Walters <walters@redhat.com> 0.5.13-2
186- Apply patch to avoid prefs crash
187
188* Tue Sep 28 2004 Colin Walters <walters@redhat.com> 0.5.13-1
189- New upstream 0.5.13
190
191* Mon Sep 27 2004 Colin Walters <walters@redhat.com> 0.5.12.cvs20040927-1
192- New upstream CVS snapshot, 20040927
193
194* Mon Sep 20 2004 Colin Walters <walters@redhat.com> 0.5.12-1
195- New upstream version 0.5.12
196- Delete upstreamed patch sound-juicer-0.5.9-pref-help.patch
197- Delete upstreamed patch sound-juicer-0.5.10-gstreamer.patch
198- Delete call to autoconf
199
200* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
201- rebuilt
202
203* Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> 0.5.10.1-8
204- rebuild for new gstreamer
205
206* Thu Mar 11 2004 Brent Fox <bfox@redhat.com> 0.5.10.1-5
207- rebuild
208
209* Fri Feb 27 2004 Brent Fox <bfox@redhat.com> 0.5.10.1-3
210- rebuild
211
212* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
213- rebuilt
214
215* Thu Feb  5 2004 Brent Fox <bfox@redhat.com> 0.5.10.1-1
216- new version
217
218* Wed Jan 28 2004 Alexander Larsson <alexl@redhat.com> 0.5.9-4
219- rebuild to use new gstreamer
220
221* Fri Jan 16 2004 Brent Fox <bfox@redhat.com> 0.5.9-3
222- add %preun to clean up GConf entries on uninstall
223
224* Wed Jan 14 2004 Brent Fox <bfox@redhat.com> 0.5.9-2
225- create init patch to make help work
226
227* Tue Jan 13 2004 Brent Fox <bfox@redhat.com> 0.5.9-1
228- update to 0.5.9
229
230* Mon Dec 15 2003 Christopher Blizzard <blizzard@redhat.com> 0.5.8-1
231- Add upstream patch that fixes permissions of created directories.
232
233* Wed Dec 03 2003 Christopher Blizzard <blizzard@redhat.com> 0.5.8-0
234- Update to 0.5.8
235
236* Tue Oct 21 2003 Brent Fox <bfox@redhat.com> 0.5.5-1
237- update to 0.5.5-1
238
239* Mon Sep  1 2003 Jonathan Blandford <jrb@redhat.com>
240- warning dialog fix
241- add a quality option
242
243* Fri Aug 29 2003 Elliot Lee <sopwith@redhat.com> 0.5.2-5
244- scrollkeeper stuff should be removed
245
246* Wed Aug 27 2003 Brent Fox <bfox@redhat.com> 0.5.2-4
247- remove ExcludeArches since libmusicbrainz is building on all arches now
248
249* Wed Aug 27 2003 Brent Fox <bfox@redhat.com> 0.5.2-3
250- bump relnum
251
252* Wed Aug 27 2003 Brent Fox <bfox@redhat.com> 0.5.2-2
253- spec file cleanups
254- add exclude arch for ia64, x86_64, ppc64, and s390x
255- add %file macros
256- remove Requires for gstreamer-cdparanoia and gstreamer-vorbis
257
258* Tue Apr 22 2003 Frederic Crozat <fcrozat@mandrakesoft.com>
259- Use more macros
260
261* Sun Apr 20 2003 Ronald Bultje <rbultje@ronald.bitfreak.net>
262- Make spec file for sound-juicer (based on netRB spec file)
Note: See TracBrowser for help on using the repository browser.