source: projects/specs/trunk/s/smpeg/smpeg-vl.spec @ 10954

Revision 10954, 4.7 KB checked in by tomop, 7 years ago (diff)

gd-2.2.4-1 g/gd/gd-vl.spec

Line 
1%define svn_rev 390
2
3Summary: SDL MPEG Library
4Summary(ja): SDL MPEG ライブラリ
5Name: smpeg
6Version: 0.4.5
7Release: 1%{?_dist_release}
8License: LGPL
9Group: System Environment/Libraries
10Source0: %{name}-%{svn_rev}.tar.gz
11Patch3: smpeg-gtv.patch
12Patch4: smpeg-0.4.4-plaympeg.patch
13URL: http://icculus.org/smpeg
14
15BuildRequires: SDL-devel gtk+-devel
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17
18Vendor: Project Vine
19Distribution: Vine Linux
20
21%description
22SMPEG is based on UC Berkeley's mpeg_play software MPEG decoder
23and SPLAY, an mpeg audio decoder created by Woo-jae Jung. We have
24completed the initial work to wed these two projects in order to
25create a general purpose MPEG video/audio player for the Linux OS.
26
27%description -l ja
28SMPEG は UC Berkeley の MPEGデコーダ mpeg_play と,Woo-jae Jungによる
29MPEGオーディオデコーダ splay を元に開発されています.Linux OS 用の
30汎用 MPEG video/audio プレーヤをつくるため,両者の統合を完了したところです.
31
32%package devel
33Summary: Libraries, includes and more to develop SMPEG applications.
34Summary(ja): SMPEG アプリケーションを開発するためのライブラリやへッダファイル
35Group: Development/Libraries
36Requires: %{name}
37
38%description devel
39SMPEG is based on UC Berkeley's mpeg_play software MPEG decoder
40and SPLAY, an mpeg audio decoder created by Woo-jae Jung. We have
41completed the initial work to wed these two projects in order to
42create a general purpose MPEG video/audio player for the Linux OS.
43
44This is the libraries, include files and other resources you can use
45to develop SMPEG applications.
46
47%prep
48%setup -q
49%patch3 -p1 -b .gtv~
50%patch4 -p1 -b .plaympeg~
51
52%build
53cat >acinclude.m4 <<EOF #HACK
54AC_DEFUN([AC_TYPE_SOCKLEN_T],
55[AC_CACHE_CHECK([for socklen_t], ac_cv_type_socklen_t,
56[
57  AC_TRY_COMPILE(
58  [#include <sys/socket.h>],
59  [socklen_t len = 42; return len;],
60  ac_cv_type_socklen_t=yes,
61  ac_cv_type_socklen_t=no)
62])
63  if test $ac_cv_type_socklen_t != yes; then
64    AC_DEFINE(socklen_t, int)
65  fi
66])
67AC_DEFUN([AM_PATH_GTK], [return 1])
68EOF
69
70# for automake...
71touch NEWS AUTHORS ChangeLog
72
73./autogen.sh
74%configure --disable-debug --disable-opengl-player --with-s
75dl-prefix=%{_prefix}
76make %{?_smp_mflags}
77
78%install
79rm -rf $RPM_BUILD_ROOT
80%makeinstall
81
82mkdir -p %{buildroot}/etc/X11/applnk/Multimedia
83cat > %{buildroot}/etc/X11/applnk/Multimedia/gtv.desktop <<EOF
84[Desktop Entry]
85Name=GTV MPEG Player
86Name[ja]=GTV MPEG プレーヤ
87Type=Application
88Comment=Simple player for MPEG Movies
89Comment[ja]=MPEG ムービー プレーヤ
90Exec=gtv
91MimeType=video/mpeg
92EOF
93
94%clean
95rm -rf $RPM_BUILD_ROOT
96
97%post -p /sbin/ldconfig
98
99%postun -p /sbin/ldconfig
100
101%files
102%defattr(-, root, root)
103%doc CHANGES COPYING README
104%config(missingok) /etc/X11/applnk/Multimedia/gtv.desktop
105%{_libdir}/lib*.so.*
106%{_bindir}/plaympeg
107%{_bindir}/gtv
108%{_mandir}/*
109
110%files devel
111%defattr(-, root, root)
112%{_bindir}/smpeg-config
113%{_includedir}/*
114%{_libdir}/lib*.a
115%exclude %{_libdir}/*.la
116%{_libdir}/lib*.so
117%{_datadir}/aclocal/*.m4
118
119%changelog
120* Sun Jul 10 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4.5-1
121- new upstream release.
122
123* Thu Feb  9 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.4-2
124- rebuild
125
126* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 0.4.4-1vl5
127- applied new versioning policy, spec in utf-8
128
129* Sat Oct 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.4-0vl8
130- added Patch4-7 from DAG package
131  (http://dag.wieers.com/rpm/packages/smpeg/)
132- rebuild with new toolchains
133
134* Mon Oct 11 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.4.4-0vl7
135- rebuild without alsa
136
137* Sun May 09 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.4.4-0vl6
138- rebuild
139
140* Tue Dec  2 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.4-0vl5
141- rebuild with new toolchains
142- use legacy autoconf-2.13 and automake-1.4
143- s/Copyright/License/
144- Patch2 and 3 from http://dag.wieers.com/packages/smpeg/
145
146* Tue Mar 26 2002 Shoji Matsumoto <shom@vinelinux.org> 0.4.4-0vl4
147- add patch1 (gtv no audio patch)
148
149* Tue Aug 28 2001 Jun Nishii <jun@vinelinux.org> 0.4.4-0vl1
150- ver.up
151
152* Fri Aug 17 2001 Shoji Matsumoto <shom@vinelinux.org>
153- 0.4.2-0vl3
154- rebuild on Seed (SDL-1.2)
155
156* Wed Feb 21 2001 Jun Nishii <jun@vinelinux.org>
157- 0.4.2-0vl2
158- rebuild on Seed
159
160* Wed Dec 20 2000 Jun Nishii <jun@vinelinux.org>
161- 0.4.2-0vl1
162
163* Tue Oct 2 2000 Than Ngo <than@redhat.com>
164- update to 0.4.1
165- clean up specfile
166
167* Mon Aug 07 2000 Than Ngo <than@redhat.de>
168- add swedish translation (Bug #15336)
169
170* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
171- automatic rebuild
172
173* Fri Jun 16 2000 Preston Brown <pbrown@redhat.com>
174- better .desktop entry
175
176* Thu Jun 15 2000 Preston Brown <pbrown@redhat.com>
177- fix up for Winston, use FHS paths
178
179* Fri Mar  3 2000 Sam Lantinga <hercules@lokigames.com>
180- Split package into development and runtime packages
Note: See TracBrowser for help on using the repository browser.