source: projects/specs/trunk/s/smokeqt/smokeqt-vl.spec @ 9228

Revision 9228, 6.8 KB checked in by inagaki, 9 years ago (diff)

2015-01-04 Ryoichi INAGAKI <ryo1@…>

  • PyKDE4: changed Group
  • kross-interpreters, smokegen, smokekde, smokeqt: updated


Line 
1%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.8.6)
2
3Name:    smokeqt
4Version: 4.14.3
5Release: 1%{?_dist_release}
6Summary: Bindings for Qt libraries
7
8License: LGPLv2+
9Group:   System Environment/Libraries
10URL:     https://projects.kde.org/projects/kde/kdebindings/smoke
11
12Source0: http://download.kde.org/stable/%{version}/src/%{name}-%{version}.tar.xz
13
14BuildRequires: cmake
15BuildRequires: phonon-devel
16BuildRequires: qimageblitz-devel
17BuildRequires: qt4-devel
18BuildRequires: qwt-qt4-devel
19BuildRequires: qscintilla-devel >= 2.4
20BuildRequires: smokegen-devel >= %{version}
21
22Conflicts: kdebindings < 4.7.0
23
24Requires: qt4 >= %{_qt4_version}
25Requires: smokegen >= %{version}
26
27%description
28This package includes Bindings for Qt libraries.
29
30%package devel
31Summary: Development files for %{name}
32Summary(ja): %{name} の開発用ファイル
33Group:   Development/Libraries
34Requires: %{name} = %{version}-%{release}
35Requires: smokegen-devel
36Conflicts: kdebindings-devel < 4.7.0
37
38%description devel
39%{summary}.
40
41%prep
42%setup -q
43
44
45%build
46mkdir -p %{_target_platform}
47pushd %{_target_platform}
48%cmake ..
49popd
50
51make %{?_smp_mflags} -C %{_target_platform}
52
53
54%install
55rm -rf $RPM_BUILD_ROOT
56make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
57
58
59%post -p /sbin/ldconfig
60%postun -p /sbin/ldconfig
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65
66%files
67%doc AUTHORS COPYING.LIB
68%{_libdir}/libsmokephonon.so.3*
69%{_libdir}/libsmokeqimageblitz.so.3*
70%{_libdir}/libsmokeqsci.so.3*
71%{_libdir}/libsmokeqt3support.so.3*
72%{_libdir}/libsmokeqtcore.so.3*
73%{_libdir}/libsmokeqtdbus.so.3*
74%{_libdir}/libsmokeqtdeclarative.so.3*
75%{_libdir}/libsmokeqtgui.so.3*
76%{_libdir}/libsmokeqthelp.so.3*
77%{_libdir}/libsmokeqtmultimedia.so.3*
78%{_libdir}/libsmokeqtnetwork.so.3*
79%{_libdir}/libsmokeqtopengl.so.3*
80%{_libdir}/libsmokeqtscript.so.3*
81%{_libdir}/libsmokeqtsql.so.3*
82%{_libdir}/libsmokeqtsvg.so.3*
83%{_libdir}/libsmokeqttest.so.3*
84%{_libdir}/libsmokeqtuitools.so.3*
85%{_libdir}/libsmokeqtwebkit.so.3*
86%{_libdir}/libsmokeqtxml.so.3*
87%{_libdir}/libsmokeqtxmlpatterns.so.3*
88%{_libdir}/libsmokeqwt.so.3*
89
90%files devel
91%{_libdir}/libsmoke*.so
92%{_includedir}/smoke/*
93%{_datadir}/smokegen/*
94%{_datadir}/smoke/*
95
96
97%changelog
98* Sun Jan  4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.14.3-1
99- new upstream release
100
101* Sun Nov  9 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.14.2-1
102- splitted from kdebindings
103
104* Thu Jun 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
105- new upstream release
106
107* Thu Apr 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
108- updated to 4.6.1
109- added BR: kdesdk-devel
110- disabled attica plugins temporaly
111- rebuilt with mono-2.10.1
112
113* Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-2
114- rebuilt with rpm-4.8.1 for pkg-config
115
116* Sat Sep 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-1
117- new upstream release
118- added Patch50
119- added more japanese summaries
120
121* Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
122- new upstream release
123
124* Sun Jul  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
125- new upstream release
126
127* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
128- new upstream release
129
130* Thu Apr 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
131- new upstream release
132
133* Tue Mar  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
134- new upstream release
135- added -DCMAKE_SKIP_RPATH:BOOL=OFF option to cmake
136  (see https://bugs.kde.org/show_bug.cgi?id=214824)
137- built with new toolchain
138
139* Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
140- new upstream release
141
142* Thu Oct 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-4
143- merged 4.3.1-2 %changelog
144- re-define %%{mono_dir} to %{_prefix}/lib/mono (again)
145
146* Tue Oct 27 2009 Shu KONNO <owa@bg.wakwak.com> 4.3.2-3
147- use %%{_prefix}/lib for mono-dll (for x86_64)
148
149* Tue Oct 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-2
150- new upstream release
151- built with PyQt4-4.6
152
153* Sun Sep 06 2009 NAKAMURA Kenta <kenta@vinelinux.org> 4.3.1-2
154- define %%{mono_dir} to specify mono library install path
155
156* Sun Sep  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
157- new upstream release
158- fixed ruby modules installation path
159
160* Thu Aug 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
161- new upstream release
162- spilt sub package based on Fedora
163
164* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
165- applied new versioning policy
166- added Patch1
167  (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=484191)
168
169* Fri Nov 23 2007 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.8-0vl3
170- added --with-qt-libraries option
171
172* Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
173- rebuild for VineSeed
174
175* Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
176- new upstream release
177
178* Mon Jun 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
179- rebuild for VineSeed
180
181* Thu May 31 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
182- new upstream release
183- update Patch0
184- drop Patch1
185
186* Mon Jan 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
187- new upstream release
188- add Patch1
189- add --enable-libsuffix option
190
191* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
192- rebuild for VineSeed
193
194* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
195- new upstream release
196
197* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
198- rebuild for VineSeed
199
200* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
201- new upstream release
202
203* Thu Jun  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
204- rebuild for VineSeed
205
206* Thu Jun  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
207- new upstream release
208
209* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
210- rebuild for VineSeed
211
212* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
213- new upstream release
214
215* Wed Feb  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
216- rebuild for VineSeed
217
218* Wed Feb  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
219- new upstream release
220- renew BuildPrereq and build section
221- renew %%files
222- enable python
223- change spec to make main and devel package
224- add BuildPrereq: ruby ruby-devel
225- add Patch0 to install ruby-bindings under /usr/lib/ruby
226
227* Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
228- build for VineSeed
229- disable python and mozilla
230- objprelink (i386 only)
231
232* Wed Nov 21 2001 Than Ngo <than@redhat.com> <bero@redhat.com> 2.2.2-1
233- 2.2.2
234- build kmozilla binding only on x86/alpha
235
236* Thu Aug  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-2
237- Make sure %%{name}-kmozilla isn't built on ia64
238
239* Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010723.2
240- Move python bindings to separate package
241- Add perl bindings
242- Shut up rpmlint
243
244* Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
245- 2.1
246
247* Sun Jan 28 2001 Bernhard Rosenkraenzer <bero@redhat.com>
248- initial RPM
Note: See TracBrowser for help on using the repository browser.