source: projects/specs/trunk/s/smokeqt/smokeqt-vl.spec @ 9075

Revision 9075, 6.7 KB checked in by inagaki, 10 years ago (diff)

2014-11-09 Ryoichi INAGAKI <ryo1@…>

  • QtRuby?, kimono, korundum, qwt, qyoto, smokegen, smokekde, smokeqt: NEW
  • kdebindings: updated


Line 
1%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.8.6)
2
3Name:    smokeqt
4Version: 4.14.2
5Release: 1%{?_dist_release}
6Summary: Bindings for Qt libraries
7
8License: LGPLv2+
9Group:   System Environment/Libraries
10URL:     https://projects.kde.org/projects/kde/kdebindings/smoke
11
12Source0: http://download.kde.org/stable/%{version}/src/%{name}-%{version}.tar.xz
13
14BuildRequires: cmake
15BuildRequires: phonon-devel
16BuildRequires: qimageblitz-devel
17BuildRequires: qt4-devel
18BuildRequires: qwt-qt4-devel
19BuildRequires: qscintilla-devel >= 2.4
20BuildRequires: smokegen-devel >= %{version}
21
22Conflicts: kdebindings < 4.7.0
23
24Requires: qt4 >= %{_qt4_version}
25Requires: smokegen >= %{version}
26
27%description
28This package includes Bindings for Qt libraries.
29
30%package devel
31Summary: Development files for %{name}
32Group:   Development/Libraries
33Requires: %{name} = %{version}-%{release}
34Requires: smokegen-devel
35Conflicts: kdebindings-devel < 4.7.0
36
37%description devel
38%{summary}.
39
40%prep
41%setup -q
42
43
44%build
45mkdir -p %{_target_platform}
46pushd %{_target_platform}
47%cmake ..
48popd
49
50make %{?_smp_mflags} -C %{_target_platform}
51
52
53%install
54rm -rf $RPM_BUILD_ROOT
55make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
56
57
58%post -p /sbin/ldconfig
59%postun -p /sbin/ldconfig
60
61%clean
62rm -rf $RPM_BUILD_ROOT
63
64
65%files
66%doc AUTHORS COPYING.LIB
67%{_libdir}/libsmokephonon.so.3*
68%{_libdir}/libsmokeqimageblitz.so.3*
69%{_libdir}/libsmokeqsci.so.3*
70%{_libdir}/libsmokeqt3support.so.3*
71%{_libdir}/libsmokeqtcore.so.3*
72%{_libdir}/libsmokeqtdbus.so.3*
73%{_libdir}/libsmokeqtdeclarative.so.3*
74%{_libdir}/libsmokeqtgui.so.3*
75%{_libdir}/libsmokeqthelp.so.3*
76%{_libdir}/libsmokeqtmultimedia.so.3*
77%{_libdir}/libsmokeqtnetwork.so.3*
78%{_libdir}/libsmokeqtopengl.so.3*
79%{_libdir}/libsmokeqtscript.so.3*
80%{_libdir}/libsmokeqtsql.so.3*
81%{_libdir}/libsmokeqtsvg.so.3*
82%{_libdir}/libsmokeqttest.so.3*
83%{_libdir}/libsmokeqtuitools.so.3*
84%{_libdir}/libsmokeqtwebkit.so.3*
85%{_libdir}/libsmokeqtxml.so.3*
86%{_libdir}/libsmokeqtxmlpatterns.so.3*
87%{_libdir}/libsmokeqwt.so.3*
88
89%files devel
90%{_libdir}/libsmoke*.so
91%{_includedir}/smoke/*
92%{_datadir}/smokegen/*
93%{_datadir}/smoke/*
94
95
96%changelog
97* Sun Nov  9 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.14.2-1
98- splitted from kdebindings
99
100* Thu Jun 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
101- new upstream release
102
103* Thu Apr 14 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
104- updated to 4.6.1
105- added BR: kdesdk-devel
106- disabled attica plugins temporaly
107- rebuilt with mono-2.10.1
108
109* Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-2
110- rebuilt with rpm-4.8.1 for pkg-config
111
112* Sat Sep 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-1
113- new upstream release
114- added Patch50
115- added more japanese summaries
116
117* Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
118- new upstream release
119
120* Sun Jul  4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
121- new upstream release
122
123* Fri May  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
124- new upstream release
125
126* Thu Apr 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
127- new upstream release
128
129* Tue Mar  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
130- new upstream release
131- added -DCMAKE_SKIP_RPATH:BOOL=OFF option to cmake
132  (see https://bugs.kde.org/show_bug.cgi?id=214824)
133- built with new toolchain
134
135* Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
136- new upstream release
137
138* Thu Oct 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-4
139- merged 4.3.1-2 %changelog
140- re-define %%{mono_dir} to %{_prefix}/lib/mono (again)
141
142* Tue Oct 27 2009 Shu KONNO <owa@bg.wakwak.com> 4.3.2-3
143- use %%{_prefix}/lib for mono-dll (for x86_64)
144
145* Tue Oct 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-2
146- new upstream release
147- built with PyQt4-4.6
148
149* Sun Sep 06 2009 NAKAMURA Kenta <kenta@vinelinux.org> 4.3.1-2
150- define %%{mono_dir} to specify mono library install path
151
152* Sun Sep  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
153- new upstream release
154- fixed ruby modules installation path
155
156* Thu Aug 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
157- new upstream release
158- spilt sub package based on Fedora
159
160* Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
161- applied new versioning policy
162- added Patch1
163  (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=484191)
164
165* Fri Nov 23 2007 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.8-0vl3
166- added --with-qt-libraries option
167
168* Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
169- rebuild for VineSeed
170
171* Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
172- new upstream release
173
174* Mon Jun 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
175- rebuild for VineSeed
176
177* Thu May 31 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
178- new upstream release
179- update Patch0
180- drop Patch1
181
182* Mon Jan 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
183- new upstream release
184- add Patch1
185- add --enable-libsuffix option
186
187* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
188- rebuild for VineSeed
189
190* Tue Oct  3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
191- new upstream release
192
193* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
194- rebuild for VineSeed
195
196* Wed Aug  2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
197- new upstream release
198
199* Thu Jun  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
200- rebuild for VineSeed
201
202* Thu Jun  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
203- new upstream release
204
205* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
206- rebuild for VineSeed
207
208* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
209- new upstream release
210
211* Wed Feb  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
212- rebuild for VineSeed
213
214* Wed Feb  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
215- new upstream release
216- renew BuildPrereq and build section
217- renew %%files
218- enable python
219- change spec to make main and devel package
220- add BuildPrereq: ruby ruby-devel
221- add Patch0 to install ruby-bindings under /usr/lib/ruby
222
223* Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
224- build for VineSeed
225- disable python and mozilla
226- objprelink (i386 only)
227
228* Wed Nov 21 2001 Than Ngo <than@redhat.com> <bero@redhat.com> 2.2.2-1
229- 2.2.2
230- build kmozilla binding only on x86/alpha
231
232* Thu Aug  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-2
233- Make sure %%{name}-kmozilla isn't built on ia64
234
235* Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010723.2
236- Move python bindings to separate package
237- Add perl bindings
238- Shut up rpmlint
239
240* Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
241- 2.1
242
243* Sun Jan 28 2001 Bernhard Rosenkraenzer <bero@redhat.com>
244- initial RPM
Note: See TracBrowser for help on using the repository browser.