source: projects/specs/trunk/s/smart/smart-vl.spec @ 6628

Revision 6628, 17.9 KB checked in by daisuke, 12 years ago (diff)

new package

Line 
1%bcond_with    ksmarttray
2%bcond_without smart_update
3
4Summary:        Smart Package Manager
5Summary(ja):    Smart パッケージマネージャ
6Name:           smart
7Version:        1.4.1
8Release:        1%{?_dist_release}
9Group:          Applications/Administration
10License:        GPLv2+
11URL:            http://smartpm.org
12
13Source0:        http://labix.org/download/smart/%{name}-%{version}.tar.bz2
14#Source1:       smart-vine-distro.py
15Source2:        smart.console
16Source4:        smart-package-manager.desktop
17#Source6:       smart-newer.py
18
19BuildRequires:  desktop-file-utils
20BuildRequires:  python-devel
21BuildRequires:  rpm-python
22Requires:       rpm-python
23Requires:       usermode
24BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
25
26Vendor: Project Vine
27Distribution: Vine Linux
28Packager: daisuke
29
30%description
31Smart Package Manager is a next generation package handling tool.
32
33%package        gui
34Summary:        Smart GTK user interface
35Summary(ja):    Smart GTK ユーザインタフェース
36Group:          Applications/Administration
37Requires(post): desktop-file-utils
38Requires(postun): desktop-file-utils
39Requires:       %{name} = %{version}-%{release}
40Requires:       pygtk2
41
42%description    gui
43Smart GTK user interface.
44
45%if %{with smart_update}
46%package        update
47Summary:        Allows execution of 'smart update' by normal users (suid)
48Summary(ja):    'smart update' をユーザ権限で実行できるようにする (suid)
49Group:          Applications/Administration
50Requires:       %{name} = %{version}-%{release}
51
52%description    update
53Allows execution of 'smart update' by normal users through a
54special suid command.
55%endif
56
57%if %{with ksmarttray}
58%package -n     ksmarttray
59Summary:        KDE tray program for watching updates with Smart Package Manager
60Group:          Applications/Administration
61Requires(post): desktop-file-utils
62Requires(postun): desktop-file-utils
63Requires:       %{name}-update = %{version}-%{release}
64BuildRequires:  kdelibs-devel
65BuildRequires:  popt
66BuildRequires:  rpm-devel
67 
68%description -n ksmarttray
69KDE tray program for watching updates with Smart Package Manager.
70%endif
71
72%prep
73%setup -q
74
75%build
76%__make
77
78%if %{with ksmarttray}
79pushd contrib/ksmarttray
80make -f admin/Makefile.common
81
82%configure_kde3
83%__make
84popd
85%endif
86
87%if %{with smart_update}
88pushd contrib/smart-update
89%__make
90popd
91%endif
92
93%install
94rm -fr %{buildroot}
95%__make DESTDIR=%{buildroot} install
96
97install -m644 %{SOURCE2} -D %{buildroot}%{_sysconfdir}/security/console.apps/smart-root
98
99ln -sf consolehelper %{buildroot}%{_bindir}/smart-root
100
101mkdir -p %{buildroot}%{_sysconfdir}/pam.d
102
103cat > %{buildroot}%{_sysconfdir}/pam.d/smart-root <<EOF
104#%PAM-1.0
105auth       include      config-util
106account    include      config-util
107session    include      config-util
108EOF
109
110mkdir -p %{buildroot}%{_datadir}/applications
111desktop-file-install \
112        --dir %{buildroot}%{_datadir}/applications \
113        %{SOURCE4}
114
115install -m644 smart/interfaces/images/smart.png -D %{buildroot}%{_datadir}/pixmaps/smart-package-manager.png
116mkdir -p %{buildroot}%{_localstatedir}/lib/smart/channels
117
118#install -m644 %{SOURCE6} -D %{buildroot}%{py_sitelib}/%{name}/commands/newer.py
119
120%if %{with smart_update}
121install -m755 contrib/smart-update/smart-update -D %{buildroot}%{_bindir}/smart-update
122%endif
123
124%if %{with ksmarttray}
125pushd contrib/ksmarttray
126%makeinstall_std
127popd
128
129install -m755 contrib/servicemenus/kde_add_smart_channel.sh -D %{buildroot}%{_kde3_bindir}/kde_add_smart_channel.sh
130mkdir -p %{buildroot}%{_kde3_datadir}/apps/konqueror/servicemenus
131desktop-file-install \
132        --dir %{buildroot}%{_kde3_datadir}/apps/konqueror/servicemenus \
133        contrib/servicemenus/add_smart_channel.desktop
134
135# XDG menu entry
136mkdir -p %{buildroot}%{_kde3_datadir}/applications/
137cat > ksmarttray.desktop << EOF
138[Desktop Entry]
139Name=KSmartTray
140Comment=KDE Tray widget for updating RPM files
141Exec=%{_kde3_bindir}/ksmarttray %%F
142Icon=smart-package-manager
143Type=Application
144Categories=Qt;KDE;Settings;PackageManager;
145EOF
146
147%{_bindir}/desktop-file-install \
148        --dir %{buildroot}%{_kde3_datadir}/applications  \
149        ksmarttray.desktop
150%endif
151
152%find_lang %{name}
153
154%clean
155rm -rf %{buildroot}
156
157%files -f %{name}.lang
158%defattr(0644,root,root,0755)
159%doc HACKING README TODO IDEAS doc/*.css doc/*.html
160%config(noreplace) %{_sysconfdir}/security/console.apps/smart-root
161%config(noreplace) %{_sysconfdir}/pam.d/smart-root
162%attr(0755,root,root)%{_bindir}/%{name}
163%attr(0755,root,root)%{_bindir}/%{name}-root
164%dir %{python_sitearch}/smart
165%{python_sitearch}/smart/*
166%{python_sitearch}/*.egg-info
167%exclude %{python_sitearch}/smart/interfaces/gtk
168%dir %{_localstatedir}/lib/smart/channels
169%{_mandir}/*/*
170
171%files gui
172%defattr(0644,root,root,0755)
173%{_datadir}/applications/smart-package-manager.desktop
174%{_datadir}/pixmaps/smart-package-manager.png
175%{python_sitearch}/smart/interfaces/gtk
176
177%if %{with smart_update}
178%files update
179%attr(4755,root,root) %{_bindir}/smart-update
180%endif
181
182%if %{with ksmarttray}
183%files -n ksmarttray
184%defattr(-,root,root)
185%{_kde3_bindir}/ksmarttray
186%{_kde3_bindir}/kde_add_smart_channel.sh
187%{_kde3_datadir}/apps/ksmarttray
188%{_kde3_datadir}/applications/ksmarttray.desktop
189%{_kde3_datadir}/apps/konqueror/servicemenus/add_smart_channel.desktop
190%{_kde3_iconsdir}/hicolor/48x48/apps/ksmarttray.png
191%endif
192
193
194%changelog
195* Tue Jul 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-1
196- initial build for Vine Linux
197
198* Fri Jan 28 2011 Per Øyvind Karlsen <peroyvind@mandriva.org> 1:1.4-1.r951.1mdv2011.0
199+ Revision: 633562
200- implement distepoch support
201
202* Fri Oct 29 2010 Michael Scherer <misc@mandriva.org> 1:1.4-1.r949.2mdv2011.0
203+ Revision: 590080
204- rebuild for python 2.7
205
206* Sat Oct 02 2010 Per Øyvind Karlsen <peroyvind@mandriva.org> 1:1.4-1.r949.1mdv2011.0
207+ Revision: 582426
208- New release: 1.4 (merging in latest code from trunk)
209
210* Thu Apr 22 2010 Per Øyvind Karlsen <peroyvind@mandriva.org> 1:1.3.1-0.r948.1mdv2010.1
211+ Revision: 537821
212- update to revision 948:
213        o fix loading of old cache lacking new channel attribute (fixes #58144)
214        o revert an accidental change that were commited in r942
215- remove scriptlets for < 2009.0 releases
216- update to revision 946 to fix a build failure and a couple of test failures
217- new bzr snapshot:
218        o fixes gtk gui breakage with channel updating
219        o merges latest code from trunk & unity branch
220
221* Sat Feb 27 2010 Per Øyvind Karlsen <peroyvind@mandriva.org> 1:1.3-1mdv2010.1
222+ Revision: 512282
223- new release: 1.3 (synced mandriva branch with trunk)
224- use %%setup_compile_flags macro
225
226* Sun Sep 27 2009 Per Øyvind Karlsen <peroyvind@mandriva.org> 1:1.2-10mdv2010.0
227+ Revision: 449900
228- make multilib behaviour optionable and also apply the behaviour to package
229  upgrades as well (updates P501)
230- move distro.py to standard location as it no longer contains any arch specific
231  stuff...
232- fix slow pycurl fetcher without breaking others..
233- fix huge slowdown limiting download speed to ~160K/sec when using pycurl
234- for a dependency which only two packages of same version and different arch
235  satisfies, automatically pick the one with best arch score. This will ie.
236  make smart able to automatically pick 'lib64foo-devel' to satisfy 'foo-devel'
237  in cases where both 'libfoo-devel' & 'lib64foo-devel' provides it. (P501)
238- restore old revision after accidental removal of directory
239- fixes and updates from smart mandriva branch (P500):
240        o really fix handling of hdlist.cz to make it actually work again
241        o make sure that mirror picked by urpmisync plugin may actually be used
242        o add XZHandler for handling xz compressed files
243
244* Tue Jun 02 2009 Per Øyvind Karlsen <peroyvind@mandriva.org> 1:1.2-8mdv2010.0
245+ Revision: 382279
246- add a buildconflicts on python-curl to prevent it's different output breaking test suite
247- update to new tarball generated from my branch:
248        o fix handling of restricted channels (fixes #51249)
249        o fix handling of cdrom (fixes #51247)
250        o fix baseurl so that downloading will work again (fixes #50460)
251        o print warning if errors resulting in urpmisync being disabled occurs
252
253* Mon May 25 2009 Per Øyvind Karlsen <peroyvind@mandriva.org> 1:1.2-7mdv2010.0
254+ Revision: 379714
255- disable ksmarttray for >= 2010.0
256- * make urpmisync more sturdy, remove channels when disabled and fallback to
257  disabled if exceptions occurs (P505)
258- fix decompression of hdlist.cz (P504)
259
260* Sat Apr 25 2009 Per Øyvind Karlsen <peroyvind@mandriva.org> 1:1.2-6mdv2010.0
261+ Revision: 369038
262- skip global options urpmi.cfg for urpmichannelsync (fixes #48509,8)
263- fix dealing with urpmi medias containing dots in the name (P502)
264
265* Tue Mar 10 2009 Per Øyvind Karlsen <peroyvind@mandriva.org> 1:1.2-5mdv2009.1
266+ Revision: 353349
267- make urpmichannelsync channels default to 0 for priority to keep consistent
268  priority of packages based on their version only which is what one usually wants..
269- be sure to move hdlist if present as well updates (P0)
270
271* Mon Mar 09 2009 Per Øyvind Karlsen <peroyvind@mandriva.org> 1:1.2-4mdv2009.1
272+ Revision: 353328
273- reuse existing urpmi metadata when forcing migration to new layout and remove
274  any old leftovers (P0)
275
276* Sat Mar 07 2009 Per Øyvind Karlsen <peroyvind@mandriva.org> 1:1.2-3mdv2009.1
277+ Revision: 350674
278- add python-rpm to buildrequires (required by test suite)
279- add %%check section with test suite running to prevent more silly mistakes..:p
280- gah, previous commit/release missed the actually updated tarball, update it
281  from my branch again with more fixes:
282        o in situations where /var/lib/media/<medianame>/ doesn't exist, create it,
283          will force urpmi to migrate to new layout from old with
284          /var/lib/media/synthesis.hdlist.<medianame>.cz etc. as well.
285        o fix broken urpmichannelsync test
286        o fix locale issue which would break the test suite
287        o fix issue where dpkg installed, but not used would break smart
288
289* Fri Mar 06 2009 Per Øyvind Karlsen <peroyvind@mandriva.org> 1:1.2-2mdv2009.1
290+ Revision: 349658
291- fix mess with unresolved conflicts which made it in to the branch by accident:(
292
293* Thu Mar 05 2009 Per Øyvind Karlsen <peroyvind@mandriva.org> 1:1.2-1mdv2009.1
294+ Revision: 349177
295- update to new version based on my branch:
296        o merging in new 1.2 stable release from trunk
297        o merge in several of afb's bugfix and relevant feature branches which hasn't
298          made their way to trunk yet
299        o improve urpmichannelsync plugin making it a bit more robust
300        o merge all of our appropriate patches and throw away those who's not
301        o switch to xz compression for tarball
302  fix up after previous vandalism commit:
303        o revert back to my mandriva branch
304        o fix reckless usage of epoch tag which broke dependencies on subpackages
305        o fix #48265 properly
306
307* Thu Feb 26 2009 Helio Chissini de Castro <helio@mandriva.com> 1:1.1-3mdv2009.1
308+ Revision: 345173
309- Fixing bug https://qa.mandriva.com/show_bug.cgi?id=48265 with a easy solution, using the real upstream package.
310  In near future, we should accept only upstream tarballs, instead of use unfinished obscure branchs
311
312* Thu Dec 25 2008 Funda Wang <fwang@mandriva.org> 1.1.1-2mdv2009.1
313+ Revision: 318616
314- fix patch
315- rediff signature patch
316- rediff channel patch
317- rebuild for new python
318
319* Wed Nov 05 2008 Per Øyvind Karlsen <peroyvind@mandriva.org> 1.1.1-1mdv2009.1
320+ Revision: 300004
321- workaround nagging about missing files during build of ksmarttray
322- perform some spec cleanups and cosmetics to follow "regular" Mandriva style
323- update from my own branch based on 1.1.1:
324        o adds urpimsync plugin to natively supporting use of local urpmi
325          configuration and data (replaces existing distro.py and obsoletes
326          urpmi2smart)
327        o adds basic mirrorlist support
328- make dependency on python-liblzma versioned
329
330* Mon Sep 15 2008 Per Øyvind Karlsen <peroyvind@mandriva.org> 1.1-1mdv2009.0
331+ Revision: 285039
332- since last one never got through, bump release down back to 1
333- bump release
334- cool down on overeager macro usage for %%{name}
335- change conflicts on python-curl to suggests
336- add dependency on python-liblzma since we need it for info.xml.lzma
337- add support for info.xml metadata and fix crash with curl (P200, from my own branch:)
338- fix string splitting in urpmi2smart that got broken due to a second ':' showing
339  up in new mirrorurl variable
340- new release
341- remove conflict on python-curl, new version of python-curl works without
342  segfaulting :)
343- always pass -pX argument to %%patchX
344
345* Fri Aug 15 2008 Nicolas Lécureuil <nlecureuil@mandriva.com> 1.0-1mdv2009.0
346+ Revision: 272233
347- Update to Smart 1.0
348  Remove patches 0, 2,6 ,11 ( Merged upstream )
349  Added comment about patch 13 ( i do not know if this is still needed to use it )
350
351* Fri Aug 08 2008 Thierry Vignaud <tv@mandriva.org> 0.52-7mdv2009.0
352+ Revision: 269254
353- rebuild early 2009.0 package (before pixel changes)
354
355  + Pixel <pixel@mandriva.com>
356    - rpm filetriggers deprecates update_menus/update_scrollkeeper/update_mime_database/update_icon_cache/update_desktop_database/post_install_gconf_schemas
357    - ensure comment does not appear in ksmarttray's %%postun
358
359* Sat Jun 07 2008 Funda Wang <fwang@mandriva.org> 0.52-6mdv2009.0
360+ Revision: 216583
361- use media_info and synthesis by default
362- move kde3 stuff to /opt
363
364  + Pixel <pixel@mandriva.com>
365    - adapt to %%_localstatedir now being /var instead of /var/lib (#22312)
366
367* Thu Jan 31 2008 Tomasz Pawel Gajc <tpg@mandriva.org> 0.52-5mdv2008.1
368+ Revision: 160889
369- fix smart widht when running in terminal, patch 105
370
371  + Olivier Blin <oblin@mandriva.com>
372    - restore BuildRoot
373
374  + Thierry Vignaud <tv@mandriva.org>
375    - kill re-definition of %%buildroot on Pixel's request
376
377* Mon Dec 17 2007 Tomasz Pawel Gajc <tpg@mandriva.org> 0.52-4mdv2008.1
378+ Revision: 121130
379- use SUSE patches
380- drop patches 100-102
381- rebuild for new rpm
382- new license policy
383- do not package LICENSE file
384
385* Mon Oct 22 2007 David Walluck <walluck@mandriva.org> 0.52-3mdv2008.1
386+ Revision: 101073
387- always include ksmarttray patches in src.rpm
388- always apply ksmarttray patches regardless of whether we are building it
389
390* Thu Oct 18 2007 Tomasz Pawel Gajc <tpg@mandriva.org> 0.52-2mdv2008.1
391+ Revision: 99836
392- drop patch 9 (merged in one SUSE patch)
393- add three SUSE patches (x86_64 support)
394
395* Tue Oct 09 2007 Tomasz Pawel Gajc <tpg@mandriva.org> 0.52-1mdv2008.1
396+ Revision: 96573
397- remove patch 2 as it has been applied upstream
398- new version
399- *.pyc files should be shipped
400
401* Thu Sep 27 2007 Tomasz Pawel Gajc <tpg@mandriva.org> 0.51-17mdv2008.0
402+ Revision: 93301
403- do not hardcode libdir
404- conflicts python-curl as it crashesh smart while updating channels
405- do not ship *.pyc files
406-  add full url for source0
407- enable ksmarttray (somehow i just disabled it ;)
408- use smart's makefile
409- fix mixture of tabs and spaces
410- do not use vendor in desktop files
411- move patch 12 to ksmarttray section
412- suggests python-curl
413
414* Sat Sep 15 2007 David Walluck <walluck@mandriva.org> 0.51-16mdv2008.0
415+ Revision: 85891
416- require smart = %%{version}-%%{release} from subpackages so we don't get breakage
417
418* Sat Sep 15 2007 David Walluck <walluck@mandriva.org> 0.51-15mdv2008.0
419+ Revision: 85877
420- fix conflicts with gui subpackage
421
422* Fri Sep 14 2007 Tomasz Pawel Gajc <tpg@mandriva.org> 0.51-14mdv2008.0
423+ Revision: 85627
424- check rpm signatures and add default pgp keyserver
425  provide patch 14, which prevents segfaults on slower connections
426  provide patch 15, which add support for fail on curl authentification error
427  provide patch 16, which add Hide-Unlocked option in View menu
428  provide patch 17, which should haven't slowndown on curl downloading
429  set requires on python-curl, especially useful for people using proxies
430
431* Thu Sep 13 2007 Thierry Vignaud <tv@mandriva.org> 0.51-13mdv2008.0
432+ Revision: 85237
433- bump conflicts in order to fix upgrade (#33465)
434
435* Thu Sep 13 2007 David Walluck <walluck@mandriva.org> 0.51-12mdv2008.0
436+ Revision: 84932
437- bump release
438- remove executable bit from smart-package-manager.desktop
439- document some outstanding issues
440
441* Thu Sep 13 2007 David Walluck <walluck@mandriva.org> 0.51-10mdv2008.0
442+ Revision: 84913
443- partial fix for upstream ksmarttray update bug
444- fix for bug #28782 (detectsys)
445
446* Sun Sep 09 2007 David Walluck <walluck@mandriva.org> 0.51-9mdv2008.0
447+ Revision: 83949
448- include modified urpmi2smart.py script
449- replace references to i568 with i586 in distro.i586
450- always include distro.i586 as a source regardless of arch and update at install time
451- use %%bcond_without macros for spec options
452- add patch to fix downloading over scp
453- use desktop-file-install and make sure .desktop files validate
454- show ksmarttray in menus
455
456  + Tomasz Pawel Gajc <tpg@mandriva.org>
457    - update channel list
458      remove JPackage because it is dead
459      add non-free channel
460      provide separate channel list for i586 and x86_64
461
462* Mon Sep 03 2007 Tomasz Pawel Gajc <tpg@mandriva.org> 0.51-6mdv2008.0
463+ Revision: 78579
464- use script fo find translations
465- remove options for older mdv release
466- drop exclude for some files
467- ksmarttray will be shown only in KDE menus
468
469* Wed Aug 29 2007 Tomasz Pawel Gajc <tpg@mandriva.org> 0.51-5mdv2008.0
470+ Revision: 74263
471- remove doubled/unneeded buildrequires
472- do not use  %%{_sourcedir}
473- remove %%ifarch, rely on libsuffix for configure script
474- small cleans in a spec file
475- drop source 5 (smart has french translation already)
476- provide patch 8 (fixes gui)
477- provide patch 9 (speed up listing packages in channels)
478- provide patch 5 (should speed up gui responsiveness)
479
480* Tue Aug 28 2007 Tomasz Pawel Gajc <tpg@mandriva.org> 0.51-4mdv2008.0
481+ Revision: 72632
482- fix build on x86_64
483- provides smart newer, a command which shows packages that have available upgrades
484- add ksmarttray's konqueror service menus
485- add scriplets
486- provide patch 4, which adds handling of rpm gpg signatures
487- provide patch 3 (mirrors for channels)
488- provide patch 2 (should speed up cache loading)
489- provide patch 7 (ksmarttray can start smart-gui now)
490
491* Fri Aug 10 2007 Tomasz Pawel Gajc <tpg@mandriva.org> 0.51-3mdv2008.0
492+ Revision: 61015
493- provide patch 6 (enable build of ksmarttray)
494- drop X-MandrivaLinux from desktop file
495
496* Mon Jun 11 2007 Olivier Thauvin <nanardon@mandriva.org> 0.51-2mdv2008.0
497+ Revision: 37984
498- rebuild for rpm
499
500* Mon May 21 2007 Andreas Hasenack <andreas@mandriva.com> 0.51-1mdv2008.0
501+ Revision: 29383
502- updated to version 0.51
503- removed patches that were already included
504
505* Wed May 02 2007 Funda Wang <fwang@mandriva.org> 0.50-5mdv2008.0
506+ Revision: 20377
507- Move translations into main package, because vt under x11 may need
508  translations.
509
Note: See TracBrowser for help on using the repository browser.