source: projects/specs/trunk/s/slocate/slocate-vl.spec @ 521

Revision 521, 8.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:     Finds files on a system via a central database.
2Summary(ja): システム上のファイルをデータベースを使って検索します
3Name: slocate
4Version: 2.7
5Release: 24%{?_dist_release}
6License: GPL
7Group: Applications/System
8Source0: http://ftp.debian.org/debian/pool/main/s/slocate/slocate_2.7-4.tar.gz
9Source1: slocate.cron
10Source2: updatedb.conf
11Source3: updatedb.conf.5
12Patch0: slocate-2.7-4.info.patch
13Patch1: slocate-wht.patch
14Patch2: slocate-2.6-manpage.patch
15Patch3: slocate-2.7-fts.patch
16Patch4: slocate-2.7-lazy-mtab.patch
17Patch5: slocate-2.7-4.autofoo.patch
18Patch6: slocate-2.7-4.bounds.patch
19Patch7: slocate-2.7-4.config.patch
20BuildRequires: gzip
21Prereq: shadow-utils
22Buildroot: %{_tmppath}/%{name}-%{version}-root
23
24
25%description
26Slocate is a security-enhanced version of locate. Just like locate,
27slocate searches through a central database (which is updated nightly)
28for files which match a given pattern. Slocate allows you to quickly
29find files anywhere on your system.
30
31%description -l ja
32slocate は locate のセキュリティ対策バージョンです.locate と同様に,
33slocate は (毎晩自動更新される) データベースを元に,指定したパターンに
34マッチするファイルを検索します.slocate を使って,システム上のどこにある
35ファイルでも高速に探し出すことが出来ます.
36
37
38%prep
39%setup -q
40%patch0 -p1 -b .info
41%patch1 -p1 -b .wht
42# *sigh*
43gunzip doc/*.gz
44%patch2 -p1 -b .manpage
45%patch3 -p1 -b .fts
46%patch4 -p1 -b .lazy
47%patch5 -p1 -b .autofoo
48%patch6 -p1 -b .bounds
49%patch7 -p1 -b .config
50
51%build
52autoreconf -f -i
53CFLAGS="$RPM_OPT_FLAGS -fsigned-char -D_GNU_SOURCE=1 -D_FILE_OFFSET_BITS=64" %configure
54make
55
56
57%install
58rm -rf $RPM_BUILD_ROOT
59mkdir -p $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man{1,5}}
60mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily
61mkdir -p $RPM_BUILD_ROOT/var/lib/slocate
62install slocate $RPM_BUILD_ROOT%{_bindir}
63ln -sf slocate $RPM_BUILD_ROOT%{_bindir}/locate
64ln -sf slocate $RPM_BUILD_ROOT%{_bindir}/updatedb
65install doc/slocate.1.linux $RPM_BUILD_ROOT%{_mandir}/man1/slocate.1
66install doc/updatedb.1 $RPM_BUILD_ROOT%{_mandir}/man1
67ln -sf slocate.1 $RPM_BUILD_ROOT%{_mandir}/man1/locate.1
68install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily
69install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}
70install %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/man5
71
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76
77%pre
78/usr/sbin/groupadd -g 21 -r -f slocate
79
80
81%preun
82if [ "$1" = "0" ]; then
83  /usr/sbin/groupdel slocate
84  rm -f /var/lib/slocate/slocate.db
85fi
86
87
88%files
89%defattr(-,root,root)
90%doc ChangeLog INSTALL README LICENSE MIRRORS
91%attr(2755,root,slocate) %{_bindir}/slocate
92%attr(-,root,slocate) %{_bindir}/locate
93%attr(-,root,slocate) %{_bindir}/updatedb
94%attr(644,root,root) %{_mandir}/man[15]/*
95%attr(755,root,root) %{_sysconfdir}/cron.daily/slocate.cron
96%attr(644,root,root) %config %{_sysconfdir}/updatedb.conf
97%dir %attr(750,root,slocate) /var/lib/slocate
98
99
100%changelog
101* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 2.7-24vl5
102- applied new versioning policy, spec in utf-8
103
104* Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.7-24vl2
105- changed Group to Applications/System
106
107* Tue Aug 02 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.7-24vl1
108- added Patches based on Fedora development
109  * Tue Jun 21 2005 Miloslav Trmac <mitr@redhat.com> - 2.7-24
110  - Add missing OOM handling to lazy-mtab.patch
111  * Sun May  1 2005 Miloslav Trmac <mitr@redhat.com> - 2.7-23
112  - Remove "nodev" filesystems from PRUNEFS
113  * Sat Apr 16 2005 Miloslav Trmac <mitr@redhat.com> - 2.7-22
114  - Point the user at updatedb.conf if the database is too old
115  * Sat Apr 16 2005 Miloslav Trmac <mitr@redhat.com> - 2.7-21
116  - Don't assume paths in /etc/mtab don't contain symlinks (#139950, #110575)
117  - Use %%config(noreplace) for /etc/updatedb.conf (#155014)
118  * Sun Apr  3 2005 Miloslav Trmac <mitr@redhat.com> - 2.7-20
119  - Don't run updatedb by default
120  * Tue Mar 29 2005 Miloslav Trmac <mitr@redhat.com> - 2.7-19
121  - Add updatedb.conf(5) (#135952)
122  * Mon Mar 28 2005 Miloslav Trmac <mitr@redhat.com> - 2.7-18
123  - Drop unnecessary BuildRequires: autoconf
124  - Remove /mnt/floppy from PRUNEPATHS, it's in /media now
125  * Fri Mar 25 2005 Miloslav Trmac <mitr@redhat.com> - 2.7-17
126  - Update to debian slocate_2.7-4 (#151710)
127  - Fix comment parsing in /etc/updatedb.conf (#135952)
128  - Exclude /var/spool/squid and /var/spool/cups (#150388)
129  - Remove 'export' lines from /etc/updatedb.conf to avoid the false impression
130    that the file is a shell script
131  * Fri Mar  4 2005 Miloslav Trmac <mitr@redhat.com> - 2.7-16
132  - Fix crash when no filesystems are pruned
133  - Rebuild with gcc 4
134  * Tue Feb 16 2005 Miloslav Trmac <mitr@redhat.com> - 2.7-15
135  - Fix slocate-2.7-fts.patch
136  - Automatically prune all nodev filesystems, remove those entries from
137    PRUNEFS (#123914)
138  * Tue Feb 15 2005 Miloslav Trmac <mitr@redhat.com> - 2.7-14
139  - Process the filesystem type exclusion list when finding the mount points,
140    not only before starting the filesystem tree walk (#139950)
141  - Clean up the spec file (#135192, original patch by Robert Scheck)
142  * Wed Nov  3 2004 Thomas Woerner <twoerner@redhat.com> 2.7-13
143  - added /media to PRUNEPATHS
144  * Wed Oct 20 2004 Thomas Woerner <twoerner@redhat.com> 2.7-12
145  - added /mnt/floppy to PRUNEPATHS
146  * Fri May 21 2004 Bill Nottingham <notting@redhat.com> 2.7-10
147  - exclude cifs (#122499)
148  * Fri Apr 16 2004 Karsten Hopp <karsten@redhat.de> 2.7-9
149  - exlude usbdevfs (#113816)
150  * Mon Mar 29 2004 Karsten Hopp <karsten@redhat.de> 2.7-8
151  - use included sl_fts.h, fix handling of large files (#105950)
152  - use one single file to configure updatedb (#112964)
153
154* Sun Feb 08 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.7-5vl1
155- updated 2.7 and added patch6 from Fedora 2.7-5
156  * Wed Jan 21 2004 Mark Cox <mjc@redhat.com>
157  - drop privs for non slocate gid databases (CAN-2003-0848)
158
159* Mon Oct 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6-10vl1
160- rebuild with new toolchains
161- s/Copyright/License/
162- based on Redhat Rawhide 2.6-10
163
164* Sat Jan 26 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.5-1vl3
165- fixed spec typo to install gzipped man page correctly
166
167* Mon Sep 03 2001 Toru Sagami <sagami@vinelinux.org>
168- 2.5-1vl2
169- place /var/lib in absolute without using %%_localstatedir macros
170
171* Sun Jan 14 2001 Tomoya TAKA <tomoya@olive.plala.or.jp> 2.5-1vl1
172- based on 2.5-1 from Rawhide
173- rebuilt for Vine Linux
174- use better macros
175- added Japanese summary and description
176
177* Fri Jan  6 2001 Bill Nottingham <notting@redhat.com>
178- update to 2.5
179
180* Mon Dec 18 2000 Bill Nottingham <notting@redhat.com>
181- update to the mysterious 2.4 release
182
183* Mon Nov 27 2000 Bill Nottingham <notting@redhat.com>
184- update to 2.3; fixes database reading problem
185
186* Wed Aug 23 2000 Than Ngo <than@redhat.com>
187- add a default updatedb.conf (Bug #13475)
188
189* Wed Aug 23 2000 Jakub Jelinek <jakub@redhat.com>
190- fix build with glibc defining DT_WHT but not defining S_IFWHT.
191
192* Sun Jul 23 2000 Nalin Dahyabhai <nalin@redhat.com>
193- don't print a message telling how to rebuild the database if we're
194  rebuilding the database
195
196* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
197- automatic rebuild
198
199* Thu Jun 22 2000 Bill Nottingham <notting@redhat.com>
200- update to 2.2
201- fix it to not have debugging (oops)
202
203* Sat Jun 10 2000 Bill Nottingham <notting@redhat.com>
204- rebuild, FHS manpages, etc.
205
206* Sun Mar 26 2000 Florian La Roche <Florian.LaRoche@redhat.com>
207- simplify preun
208
209* Fri Mar 17 2000 Bill Nottingham <notting@redhat.com>
210- fix a segfault
211
212* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
213- handle compressed man pages
214
215* Tue Oct 21 1999 Bill Nottingham <notting@redhat.com>
216- update to 2.1
217
218* Mon Oct 18 1999 Bill Nottingham <notting@redhat.com>
219- fix a bug that was causing segfaults.
220
221* Mon Sep 20 1999 Bill Nottingham <notting@redhat.com>
222- remove group database on final uninstall
223
224* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
225- add a note about creating the database if opening of it fails.
226
227* Tue Jul  6 1999 Bill Nottingham <notting@redhat.com>
228- update to 2.0
229- use new -f (filesystem type) option to simplify cron script
230- link updatedb back to slocate to allow parsing of updatedb.conf
231  config files
232
233* Mon Jun 14 1999 Bill Nottingham <notting@redhat.com>
234- don't exclude VFAT partitions
235- add some docs
236
237* Tue Jun  1 1999 Jeff Johnson <jbj@redhat.com>
238- update to 1.6.
239- use /etc/cron.daily as /usr/bin/updatedb to more perfectly imitate the
240  findutils updatedb.
241- exclude vfat partitions too (#3164).
242
243* Tue May 11 1999 Bill Nottingham <notting@redhat.com>
244- update to 1.5
245- make database dir 0750
246
247* Mon Apr 19 1999 Bill Nottingham <notting@redhat.com>
248- fix updatedb cron script
249
250* Mon Apr 12 1999 Bill Nottingham <notting@redhat.com>
251- add updatedb as a link to slocate
252- add an updatedb man page
253
254* Fri Mar 26 1999 Michael Maher <mike@redhat.com>
255- added man page
256
257* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
258- auto rebuild in the new build environment (release 3)
259
260* Mon Feb 15 1999 Bill Nottingham <notting@redhat.com>
261- %post groupadd changed to %pre
Note: See TracBrowser for help on using the repository browser.