source: projects/specs/trunk/s/slib/slib-vl.spec @ 521

Revision 521, 3.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define guile_mver      1.8
2
3Summary:      Platform independent library for scheme
4Summary(ja):    プラットフォームに依存しない sheme ライブラリ
5Name:         slib
6Version:      3b1
7Release:      1%{?_dist_release}
8License:      SLIB
9Group:        Development/Languages
10BuildArch:    noarch
11Source0:      http://swiss.csail.mit.edu/ftpdir/scm/slib-%{version}.zip
12Patch1:       slib-3b1-guile.patch
13URL:          http://swissnet.ai.mit.edu/~jaffer/SLIB.html
14BuildRoot:    %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
15PreReq:       guile
16Requires(post): /sbin/install-info
17Requires(preun): /sbin/install-info
18
19%description
20"SLIB" is a portable library for the programming language Scheme.
21It provides a platform independent framework for using "packages" of
22Scheme procedures and syntax.  As distributed, SLIB contains useful
23packages for all Scheme implementations.  Its catalog can be
24transparently extended to accommodate packages specific to a site,
25implementation, user, or directory.
26
27%prep
28%setup -q -n %{name}
29%patch1 -p1 -b .guile
30sed -r -i "s,/usr/(local/)?lib/slib,%{_datadir}/slib,g" *.init
31
32%build
33
34%install
35rm -rf ${RPM_BUILD_ROOT}
36mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/slib
37cp *.scm *.init *.xyz *.txt *.dat *.ps ${RPM_BUILD_ROOT}%{_datadir}/slib
38mkdir -p ${RPM_BUILD_ROOT}%{_infodir}
39install -m644 slib.info ${RPM_BUILD_ROOT}%{_infodir}
40
41# create sym link to work with guile
42mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/guile/%{guile_mver}
43pushd ${RPM_BUILD_ROOT}%{_datadir}/guile/%{guile_mver}
44ln -s ../../slib ${RPM_BUILD_ROOT}%{_datadir}/guile/%{guile_mver}/slib
45popd
46
47%clean
48rm -rf ${RPM_BUILD_ROOT}
49
50%post
51/sbin/install-info %{_infodir}/slib.info.gz %{_infodir}/dir
52:
53
54# build guile catalog
55/usr/bin/guile -c "((use-modules (ice-9 slib))(require 'new-catalog)(quit))"
56
57%preun
58if [ "$1" = 0 ]; then
59    /sbin/install-info --delete %{_infodir}/slib.info.gz %{_infodir}/dir
60fi
61:
62
63%files
64%defattr(-,root,root)
65%dir %{_datadir}/slib
66%doc ANNOUNCE README COPYING FAQ ChangeLog
67%{_datadir}/slib/*
68%{_infodir}/slib.*
69%{_datadir}/guile/%{guile_mver}/slib
70%changelog
71* Mon Jan 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3b1-1
72- initial build for Vine Linux based on fedora development
73- create sym link to work with guile
74- update guile catalog in %%post
75
76* Thu Feb 14 2008 Miroslav Lichvar <mlichvar@redhat.com> 3b1-1
77- update to 3b1
78
79* Wed Jan 09 2008 Miroslav Lichvar <mlichvar@redhat.com> 3a5-1
80- update to 3a5
81- replace slib paths only in .init files
82
83* Fri Jun 22 2007 Miroslav Lichvar <mlichvar@redhat.com> 3a4-2
84- fix summary and buildroot (#226421)
85
86* Tue Jan 23 2007 Miroslav Lichvar <mlichvar@redhat.com> 3a4-1
87- update to 3a4
88- make scriptlets safer (#223717)
89
90* Wed Jul 12 2006 Miroslav Lichvar <mlichvar@redhat.com> 3a3-2
91- fix requires for install-info
92- drop slibcat, include *.dat and grapheps.ps files
93
94* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 3a3-1.1
95- rebuild
96
97* Tue May 09 2006 Miroslav Lichvar <mlichvar@redhat.com> 3a3-1
98- update to slib3a3
99- install info, remove html
100- fix typo in description (#189650)
101
102* Mon Feb 27 2006 Miroslav Lichvar <mlichvar@redhat.com> 3a1-6
103- spec cleanup
104
105* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
106- rebuilt
107
108* Thu Sep  8 2005 Jindrich Novy <jnovy@redhat.com> 3a1-5
109- regenerate slibcat to remove all links to umb-scheme
110  to make gnucash work with slib
111- don't ship slib.spec from the upstream tarball
112- replace bogus links to /usr/lib
113- don't ship unneeded files in slib directory
114- add slib html documentation
115
116* Thu Sep 08 2005 Florian La Roche <laroche@redhat.com> 3a1-4
117- no need to provide slib for this package
118
119* Tue Sep  6 2005 Jindrich Novy <jnovy@redhat.com> 3a1-3
120- use _datadir instead of /usr/local/lib and don't use
121  /usr/local prefix (#167490)
122
123* Wed Dec  8 2004 Jindrich Novy <jnovy@redhat.com> 3a1-2
124- remove symlinks creation for guile, it's done by guile itself
125
126* Wed Oct  6 2004 Jindrich Novy <jnovy@redhat.com> 3a1-1
127- new package
128- original spec file from R. J. Meier and Radey Shouman
Note: See TracBrowser for help on using the repository browser.