source: projects/specs/trunk/s/skencil/skencil-vl.spec @ 521

Revision 521, 4.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: python-based vector drawing program
2Summary(ja): ベクタ型ドローイングプログラム
3Name: skencil
4Version: 0.6.17
5Release: 3.svn20070606%{?_dist_release}
6License: LGPL, Python style
7Distribution: Vine Linux
8Vendor: Project Vine
9Group: Applications/Graphics
10URL: http://www.nongnu.org/skencil/
11Source0: http://dl.sf.net/sketch/skencil-0.6.tar.gz
12Source1: skencil-logo.png
13Source2: skencil.desktop
14Source3: skencil.xml
15Patch1: skencil-font.patch
16Patch2: skencil-0.6.17-fill-missing-bldshared.patch
17# https://bugs.launchpad.net/ubuntu/+source/skencil/+bug/361636
18Patch3: skencil-0.6.17-deletecommand.patch
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21Requires: python >= 1.5.1, tkinter, python-imaging
22BuildRequires: python >= 1.5.1, python-imaging
23BuildRequires: xorg-x11-devel desktop-file-utils
24Prefix: %{_prefix}
25obsoletes: sketch < %{version}
26
27%description
28Skencil is an interactive X11 vector drawing program. It is written
29almost completely in Python, an object oriented interpreted programming
30language.
31
32%prep
33%setup -q -n skencil-0.6
34%patch1 -p1 -b .font
35%patch2 -p1 -b .bldshared
36%patch3 -p2 -b .deletecommand
37%ifarch x86_64
38grep -rl lib/ . | xargs perl -pi -e's,lib/,%{_lib}/,g'
39grep -rl lib\' . | xargs perl -pi -es,lib\',%{_lib}\',g
40%endif
41
42# remove .svn directories
43find . -type d -name .svn -print0 | xargs -0r rm -rf
44
45%build
46%{__python} setup.py configure --with-nls
47%{__python} setup.py build
48
49%install
50rm -rf $RPM_BUILD_ROOT
51%{__python} setup.py install --prefix=%{_prefix} --dest-dir=$RPM_BUILD_ROOT
52
53%{__install} -m 755 Tools/mkfontdb.py $RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}/
54ln -s %{_libdir}/%{name}-%{version}/mkfontdb.py $RPM_BUILD_ROOT%{_bindir}/mkfontdb
55
56mkdir -p $RPM_BUILD_ROOT%{_datadir}/pixmaps
57mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
58mkdir -p $RPM_BUILD_ROOT%{_datadir}/mime/packages
59install -m 0644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/pixmaps/
60desktop-file-install --dir $RPM_BUILD_ROOT%{_datadir}/applications %{SOURCE2}
61install -m 0644 %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/mime/packages/
62
63strip -S $RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}/Lib/*.so
64strip -S $RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}/Sketch/Modules/*.so
65
66%clean
67rm -rf %{buildroot}
68
69%post
70%{_bindir}/update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
71%{_bindir}/update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
72
73%postun
74%{_bindir}/update-mime-database %{_datadir}/mime > /dev/null 2>&1 || :
75%{_bindir}/update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
76
77%files
78%defattr(-, root, root)
79%doc Doc Examples Misc README INSTALL BUGS CREDITS COPYING TODO PROJECTS FAQ NEWS
80%doc --parents */README */COPYING
81%{_libdir}/%{name}-%{version}
82%{_bindir}/mkfontdb
83%{_bindir}/sk2ppm
84%{_bindir}/sk2ps
85%{_bindir}/skconvert
86%{_bindir}/skencil
87%{_bindir}/sketch
88%{_bindir}/skshow
89%{_datadir}/pixmaps/*
90%{_datadir}/applications/*
91%{_datadir}/mime/packages/*
92
93%changelog
94* Wed Dec 16 2009 Kazutaka HARADA <kazutaka@vinelinux.org> - 0.6.17-3.svn20070606
95- update source to latest svn version of 0.6 seriese
96- add Patch3 to fix tcl command deleteion error
97  (<BTS:VineLinux:848>)
98
99* Thu Aug 21 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.6.17-2
100- add Patch2 to fix build failure
101
102* Wed Jun 25 2008 Shu KONNO <owa@bg.wakwak.com> 0.6.17-1vl5
103- applied new versioning policy and spec in utf-8
104- added BuildRequires: xorg-x11-devel desktop-file-utils
105
106* Fri Jan 18 2008 Shu KONNO <owa@bg.wakwak.com> 0.6.17-0vl1
107- updated skencil to 0.6.17
108- added skencil.desktop
109- dropt savannah-bug-10345.diff (fixed)
110
111* Mon May 23 2005 Shu KONNO <owa@bg.wakwak.com> 0.6.16-0vl3
112- added skencil-font.patch (by Ishikawa)
113
114* Sun May 22 2005 Shu KONNO <owa@bg.wakwak.com> skencil-0.6.16-0vl2
115- changed name to skencil
116- changed URL
117- updated 0.6.16
118- rebuilt with python-2.4
119- added savannah-bug-10345.diff
120  http://savannah.nongnu.org/bugs/?func=detailitem&item_id=10345
121
122* Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 0.6.13-0vl1
123- updated 0.6.13
124
125* Tue Jul 24 2001 Satoshi MACHINO <machino@vinelinux.org> 0.6.12-0vl1
126- updated
127
128* Thu Nov  9 2000 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
129- 0.6.7-0vl2
130- added BuildPrereq:
131
132* Thu Aug 03 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
133- Update to 0.6.7
134
135* Sat Jan 12 2000 SAITO Atsushi <saito4@slb.com>
136- Update to 0.6.4
137
138* Sat Dec  4 1999 SAITO Atsushi <saito4@slb.com>
139- Update to 0.6.3
140
141* Thu Oct  8 1999 SAITO Atsushi <saito4@slb.com>
142- Update to 0.6.2
143
144* Tue Aug 17 1999 SAITO Atsushi <saito4@slb.com>
145- Update to 0.6.1
146
147* Sun Mar  7 1999 MATSUMOTO Shoji <vine@flatout.org>
148- make spec
Note: See TracBrowser for help on using the repository browser.