source: projects/specs/trunk/s/silversearcher-ag/silversearcher-ag-vl.spec @ 10139

Revision 10139, 2.3 KB checked in by ara_t, 8 years ago (diff)

ag: 高速検索プログラム

Line 
1%define pkg_name    the_silver_searcher
2%define pkg_version 0.31.0
3%define pkg_release 3%{?_dist_release}
4
5Summary:     ag: The silver searcher
6Summary(ja): ag: 高速検索プログラム
7Name:        silversearcher-ag
8Version:     %{pkg_version}
9Release:     %{pkg_release}
10License:     Apache License 2.0
11
12Group:  Applications/Accessories
13URL:    https://github.com/ggreer/the_silver_searcher
14Source: %{pkg_name}-%{pkg_version}.tar.gz
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: pcre-devel xz-devel zlib-devel
18Requires: pcre xz zlib
19
20Vendor: Project Vine
21Distribution: Vine Linux
22Packager: ara_t
23
24
25%description
26The Silver Searcher
27An attempt to make something better than ack
28(which itself is better than grep).
29
30Why use Ag?
31* It searches code about 3–5x faster than ack.
32* It ignores file patterns from your .gitignore and .hgignore.
33* If there are files in your source repo you don't want to search,
34  just add their patterns to a .agignore file. *cough* extern *cough*
35* The command name is 33% shorter than ack!
36
37How is it so fast?
38* Searching for literals (no regex) uses Boyer-Moore-Horspool strstr.
39* Files are mmap()ed instead of read into a buffer.
40* If you're building with PCRE 8.21 or greater,
41  regex searches use the JIT compiler.
42* Ag calls pcre_study() before executing the regex on a jillion files.
43* Instead of calling fnmatch() on every pattern in your ignore files,
44  non-regex patterns are loaded into an array and binary searched.
45* Ag uses Pthreads to take advantage of multiple CPU cores and
46  search files in parallel.
47
48%description -l ja
49The Silver Searcher: 高速検索プログラム
50* ackより3-5倍高速
51* .gitignore、.hgignoreに記載されているものを検索対象から除外
52* 検索対象から除外したいファイルは.agignoreに記載
53* agというコマンド名で、ackと比べてコマンドが短い(33%減!)
54
55
56%prep
57%{__rm} -rf ${RPM_BUILD_ROOT}
58%setup -q -n %{pkg_name}-%{pkg_version}
59
60./build.sh
61%{configure}
62
63%build
64%{__make} %{?_smp_mflags}
65
66%install
67%{make_install}
68
69%clean
70%{__rm} -rf ${RPM_BUILD_ROOT}
71
72
73%files
74%defattr(-, root, root)
75%{_bindir}/
76%{_datadir}/
77
78
79%changelog
80* Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 0.31.0-3
81- correct SPEC file
82
83* Wed Feb 17 2016 Toshiaki Ara <ara_t@384.jp> 0.31.0-2
84- add LICENSE
85
86* Tue Sep 22 2015 Toshiaki Ara <ara_t@384.jp> 0.31.0-1
87- new package
88
Note: See TracBrowser for help on using the repository browser.