source: projects/specs/trunk/s/shotwell/shotwell-vl.spec @ 564

Revision 564, 4.3 KB checked in by kudoh, 14 years ago (diff)
Line 
1Name:           shotwell
2Version:        0.5.0
3Release:        1%{?_dist_release}
4Summary:        A photo organizer for the GNOME desktop
5Summary(ja):    GNOME デスクトップ向けの画像整理ソフト
6
7Group:          Applications/Graphics
8# LGPLv2+ for the code
9# CC-BY-SA for some of the icons
10License:        LGPLv2+ and CC-BY-SA
11URL:            http://www.yorba.org/shotwell/
12Source0:        http://www.yorba.org/download/shotwell/0.4/shotwell-%{version}.tar.bz2
13# svn co svn://svn.yorba.org/shotwell/branches/shotwell-0.4, make dist
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16
17BuildRequires:  gtk2-devel
18BuildRequires:  libgudev1-devel
19BuildRequires:  GConf2-devel
20BuildRequires:  sqlite3-devel
21BuildRequires:  vala-devel
22BuildRequires:  libgee-devel
23BuildRequires:  hal-devel
24BuildRequires:  dbus-glib-devel
25BuildRequires:  unique-devel
26BuildRequires:  libexif-devel
27BuildRequires:  libgphoto2-devel
28BuildRequires:  WebKit-gtk-devel
29BuildRequires:  desktop-file-utils
30BuildRequires:  gettext
31
32%description
33Shotwell is a new open source photo organizer designed for the GNOME desktop
34environment. It allows you to import photos from your camera, view and edit
35them, and share them with others.
36
37%description -l ja
38Shotwell は GNOME デスクトップ環境用に設計された新しいオープンソースの
39画像整理ソフトです。
40あなたのカメラから写真を取り込んだり、それらを表示・編集したり、
41他の人々と共有するなどができます。
42
43%prep
44%setup -q -n %{name}-%{version}
45
46%build
47./configure --prefix=/usr --disable-schemas-install
48sed -i -e 's/\\n/\n/g' configure.mk
49sed -i -e 's/^CFLAGS=.*$/CFLAGS=%{optflags}/' Makefile
50make %{?_smp_mflags}
51
52
53%install
54rm -rf $RPM_BUILD_ROOT
55export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
56export XDG_DISABLE_MAKEFILE_UPDATES=1
57make install DESTDIR=$RPM_BUILD_ROOT
58
59desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell.desktop
60desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell-viewer.desktop
61
62%find_lang %{name}
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67%post
68touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
69update-desktop-database &> /dev/null || :
70export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
71gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
72
73%pre
74if [ "$1" -gt 1 ]; then
75  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
76  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
77fi
78
79%preun
80if [ "$1" -eq 0 ]; then
81  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
82  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
83fi
84
85%postun
86if [ $1 -eq 0 ] ; then
87  touch --no-create %{_datadir}/icons/hicolor &>/dev/null
88  gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
89fi
90update-desktop-database &> /dev/null || :
91
92%posttrans
93gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
94
95%files -f %{name}.lang
96%defattr(-,root,root,-)
97%doc README COPYING MAINTAINERS NEWS THANKS AUTHORS
98%{_sysconfdir}/gconf/schemas/shotwell.schemas
99%{_bindir}/shotwell
100%{_datadir}/shotwell
101%{_datadir}/applications/shotwell.desktop
102%{_datadir}/applications/shotwell-viewer.desktop
103%{_datadir}/icons/hicolor/*
104
105
106%changelog
107* Sat Mar 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
108- new upstream release
109- added BuildRequires:  libgudev1-devel
110- applied new naming policy to spec
111
112* Wed Jan 20 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.3-1
113- new upstream release
114- proved Japanese description
115
116* Thu Jan 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.2-1
117- new upstrema release
118
119* Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.1-1
120- intial build for VineSeed
121
122* Fri Dec 18 2009 Matthias Clasen <mclasen@redhat.com> - 0.4.0-0.1.20091218svn
123* Thu Nov 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
124- Update to 0.3.2
125
126* Tue Nov  3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.0-1
127- Version 0.3.0
128
129* Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.2.0-3
130- Rebuild against new libgee
131
132* Sun Aug 12 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-2.fc12
133- Bring icon cache handling in sync with current guidelines
134
135* Sun Aug  9 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-1.fc12
136- Initial packaging
Note: See TracBrowser for help on using the repository browser.