source: projects/specs/trunk/s/shotwell/shotwell-vl.spec @ 5151

Revision 5151, 7.5 KB checked in by kudoh, 12 years ago (diff)

shotwell-vl.spec

Line 
1Name:           shotwell
2Version:        0.11.6
3Release:        1%{?_dist_release}
4Summary:        A photo manager for the GNOME desktop
5Summary(ja):    GNOME デスクトップ向けの写真管理ツール
6
7Group:          Applications/Graphics
8# LGPLv2+ for the code
9# CC-BY-SA for some of the icons
10License:        LGPLv2+ and CC-BY-SA
11URL:            http://www.yorba.org/shotwell/
12
13Source0:        http://www.yorba.org/download/shotwell/0.10/shotwell-%{version}.tar.bz2
14# http://trac.yorba.org/ticket/3379
15Source1:        shotwell-icons.tar.bz2
16Source2:        shotwell-0.8.1-vine2-ja.po
17
18Patch0:         shotwell-0.11.1-vala-0.14.patch
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21
22BuildRequires:  GConf2-devel
23BuildRequires:  LibRaw-devel
24BuildRequires:  LibRaw-static
25BuildRequires:  WebKit-gtk-devel
26BuildRequires:  dbus-glib-devel
27BuildRequires:  desktop-file-utils
28BuildRequires:  gettext
29BuildRequires:  gtk2-devel
30BuildRequires:  gstreamer-devel
31BuildRequires:  gstreamer-plugins-base-devel
32BuildRequires:  hal-devel
33BuildRequires:  json-glib-devel
34BuildRequires:  libexif-devel
35BuildRequires:  libgee-devel
36BuildRequires:  libgphoto2-devel
37BuildRequires:  libgudev1-devel
38BuildRequires:  libgexiv2-devel >= 0.2.0
39BuildRequires:  libsoup-devel
40BuildRequires:  libxml2-devel
41BuildRequires:  sqlite3-devel
42BuildRequires:  unique-devel
43BuildRequires:  vala-devel >= 0.9.5
44
45Vendor: Project Vine
46Distribution: Vine Linux
47Packager: kudoh
48
49%description
50Shotwell is a new open source photo manager designed for the GNOME desktop
51environment. It allows you to import photos from your camera, view and edit
52them, and share them with others.
53
54%description -l ja
55Shotwell は GNOME デスクトップ環境用に設計された新しいオープンソースの
56画像管理ツールです。
57あなたのカメラから写真を取り込んだり、それらを表示・編集したり、
58他の人々と共有するなどができます。
59
60%prep
61%setup -q -n %{name}-%{version}
62%patch0 -p1 -b .vala014
63pushd po
64%__rm -f ja.po
65%__cp %{SOURCE2} ja.po
66popd
67
68%build
69# We can't use the configure macro: it's not a standard autotools configure script
70export CFLAGS="%{optflags}"
71export LIB=%{_lib}
72
73# HACK: Remove fatal-warnings to succeed build with vala 0.13.
74sed -i "s:--fatal-warnings ::g" Makefile plugins/Makefile.plugin.mk
75./configure --prefix=%{_prefix} --lib=%{_lib} --disable-schemas-install
76#sed -i -e 's/\\n/\n/g' configure.mk
77#sed -i -e 's/^CFLAGS=.*$/CFLAGS=%{optflags}/' Makefile
78#sed -i -e 's|LIB_DIRS=.*$|LIB_DIRS=%{_libdir}|' libraw-config
79make %{?_smp_mflags}
80
81
82%install
83rm -rf $RPM_BUILD_ROOT
84export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
85export XDG_DISABLE_MAKEFILE_UPDATES=1
86# otherwise gettext always returns English text regardless of LANGUAGE asked
87export LANG=en_US.utf8
88make install DESTDIR=$RPM_BUILD_ROOT
89
90desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell.desktop
91desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell-viewer.desktop
92
93# put hi-res icons in place
94(
95  cd $RPM_BUILD_ROOT%{_datadir}/icons/hicolor
96  rm -rf 16x16 24x24 scalable
97  tar xf %{SOURCE1}
98)
99     
100%find_lang %{name} --all-name
101
102%clean
103rm -rf $RPM_BUILD_ROOT
104
105%post
106touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
107update-desktop-database &> /dev/null || :
108
109%postun
110if [ $1 -eq 0 ] ; then
111  touch --no-create %{_datadir}/icons/hicolor &>/dev/null
112  gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
113  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
114fi
115update-desktop-database &> /dev/null || :
116
117%posttrans
118gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
119glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
120
121%files -f %{name}.lang
122%defattr(-,root,root,-)
123%doc README COPYING MAINTAINERS NEWS THANKS AUTHORS
124%{_bindir}/shotwell
125%{_bindir}/shotwell-video-thumbnailer
126%{_libdir}/shotwell/plugins/builtin
127%{_datadir}/GConf/gsettings/shotwell.convert
128%{_datadir}/glib-2.0/schemas/org.yorba.shotwell-extras.gschema.xml
129%{_datadir}/glib-2.0/schemas/org.yorba.shotwell.gschema.xml
130%{_datadir}/gnome/help/
131%{_datadir}/shotwell
132%{_datadir}/applications/shotwell.desktop
133%{_datadir}/applications/shotwell-viewer.desktop
134%{_datadir}/icons/hicolor/*
135%exclude %{_datadir}/icons/hicolor/icon-theme.cache
136%exclude %{_datadir}/glib-2.0/schemas/gschemas.compiled
137
138
139%changelog
140* Sun Nov 13 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.6-1
141- new upstream release
142
143* Thu Oct 20 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.5-1
144- new upstream release
145
146* Fri Oct 14 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.4-1
147- new upstream release
148
149* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.11.2-1
150- new upstream release
151- add Patch0 (shotwell-0.11.1-vala-0.14.patch)
152- add BuildRequires: gstreamer-plugins-base-devel
153
154* Sat Aug 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.1-2
155- rebuilt with libgexiv2-0.2.2-2
156
157* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.1-1
158- new upstream release
159
160* Sat Jun 18 2011 IWAI, Masaharu <iwai@alib.jp> 0.8.1-5
161- add ja.po (Source2): fix <BTS:VineLinux:1142>
162- update Summary and description
163
164* Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.1-4
165- add hi-res icons (SOURCE1)
166- add LANG=en_US.utf8 to get gettext to actually generate translated strings
167
168* Sat Jun 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-3
169- dropt Patch0
170- added BuildRequires: LibRaw-static
171
172* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.8.1-2
173- add Patch1 (shotwell-0.8.1-vala.patch)
174
175* Wed Jan 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-1
176- new upstream release
177- added BuildRequires: gstreamer-devel, json-glib-devel, libsoup-devel, libxml2-devel
178
179* Tue Sep 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-2
180- rebuilt with rpm-4.8.1 for pkg-config
181- fixed %%changelog in Tue Sep 14 2010
182
183* Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-1
184- new upstream release
185- changed source URL
186- added Patch0 to work around desktop file incorrect comment
187- changed BuildRequires: vala-devel >= 0.9.5
188
189* Fri Aug 27 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.1-1
190- new upstream release
191
192* Sat Aug 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.0-1
193- new upstream release
194- changed BuildRequires: libgexiv2-devel >= 0.2.0
195
196* Thu Jul 22 2010 Shu KONNO <owa@bg.wakwak.com> - 0.6.1-2
197- fixed LIB_DIRS in libraw-config (for lib64)
198
199* Wed Jul 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.1-1
200- new upstream release
201- added BuildRequires: LibRaw-devel, libgexiv2-devel
202
203* Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.2-1
204- new upstream release
205
206* Sat Mar 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
207- new upstream release
208- added BuildRequires:  libgudev1-devel
209- applied new naming policy to spec
210
211* Wed Jan 20 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.3-1
212- new upstream release
213- proved Japanese description
214
215* Thu Jan 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.2-1
216- new upstrema release
217
218* Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.1-1
219- intial build for VineSeed
220
221* Fri Dec 18 2009 Matthias Clasen <mclasen@redhat.com> - 0.4.0-0.1.20091218svn
222* Thu Nov 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
223- Update to 0.3.2
224
225* Tue Nov  3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.0-1
226- Version 0.3.0
227
228* Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.2.0-3
229- Rebuild against new libgee
230
231* Sun Aug 12 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-2.fc12
232- Bring icon cache handling in sync with current guidelines
233
234* Sun Aug  9 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-1.fc12
235- Initial packaging
Note: See TracBrowser for help on using the repository browser.