source: projects/specs/trunk/s/shotwell/shotwell-vl.spec @ 1417

Revision 1417, 4.8 KB checked in by owa, 14 years ago (diff)

fixed libraw-config

Line 
1Name:           shotwell
2Version:        0.6.1
3Release:        2%{?_dist_release}
4Summary:        A photo organizer for the GNOME desktop
5Summary(ja):    GNOME デスクトップ向けの画像整理ソフト
6
7Group:          Applications/Graphics
8# LGPLv2+ for the code
9# CC-BY-SA for some of the icons
10License:        LGPLv2+ and CC-BY-SA
11URL:            http://www.yorba.org/shotwell/
12Source0:        http://www.yorba.org/download/shotwell/0.4/shotwell-%{version}.tar.bz2
13# svn co svn://svn.yorba.org/shotwell/branches/shotwell-0.4, make dist
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16
17BuildRequires:  GConf2-devel
18BuildRequires:  LibRaw-devel
19BuildRequires:  WebKit-gtk-devel
20BuildRequires:  dbus-glib-devel
21BuildRequires:  desktop-file-utils
22BuildRequires:  gettext
23BuildRequires:  gtk2-devel
24BuildRequires:  hal-devel
25BuildRequires:  libexif-devel
26BuildRequires:  libgee-devel
27BuildRequires:  libgphoto2-devel
28BuildRequires:  libgudev1-devel
29BuildRequires:  libgexiv2-devel
30BuildRequires:  sqlite3-devel
31BuildRequires:  unique-devel
32BuildRequires:  vala-devel
33
34%description
35Shotwell is a new open source photo organizer designed for the GNOME desktop
36environment. It allows you to import photos from your camera, view and edit
37them, and share them with others.
38
39%description -l ja
40Shotwell は GNOME デスクトップ環境用に設計された新しいオープンソースの
41画像整理ソフトです。
42あなたのカメラから写真を取り込んだり、それらを表示・編集したり、
43他の人々と共有するなどができます。
44
45%prep
46%setup -q -n %{name}-%{version}
47
48%build
49./configure --prefix=/usr --disable-schemas-install
50sed -i -e 's/\\n/\n/g' configure.mk
51sed -i -e 's/^CFLAGS=.*$/CFLAGS=%{optflags}/' Makefile
52sed -i -e 's|LIB_DIRS=.*$|LIB_DIRS=%{_libdir}|' libraw-config
53make %{?_smp_mflags}
54
55
56%install
57rm -rf $RPM_BUILD_ROOT
58export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
59export XDG_DISABLE_MAKEFILE_UPDATES=1
60make install DESTDIR=$RPM_BUILD_ROOT
61
62desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell.desktop
63desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell-viewer.desktop
64
65%find_lang %{name}
66
67%clean
68rm -rf $RPM_BUILD_ROOT
69
70%post
71touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
72update-desktop-database &> /dev/null || :
73export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
74gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
75
76%pre
77if [ "$1" -gt 1 ]; then
78  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
79  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
80fi
81
82%preun
83if [ "$1" -eq 0 ]; then
84  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
85  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
86fi
87
88%postun
89if [ $1 -eq 0 ] ; then
90  touch --no-create %{_datadir}/icons/hicolor &>/dev/null
91  gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
92fi
93update-desktop-database &> /dev/null || :
94
95%posttrans
96gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
97
98%files -f %{name}.lang
99%defattr(-,root,root,-)
100%doc README COPYING MAINTAINERS NEWS THANKS AUTHORS
101%{_sysconfdir}/gconf/schemas/shotwell.schemas
102%{_bindir}/shotwell
103%{_datadir}/shotwell
104%{_datadir}/applications/shotwell.desktop
105%{_datadir}/applications/shotwell-viewer.desktop
106%{_datadir}/icons/hicolor/*
107
108
109%changelog
110* Thu Jul 22 2010 Shu KONNO <owa@bg.wakwak.com> - 0.6.1-2
111- fixed LIB_DIRS in libraw-config (for lib64)
112
113* Wed Jul 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.1-1
114- new upstream release
115- added BuildRequires: LibRaw-devel, libgexiv2-devel
116
117* Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.2-1
118- new upstream release
119
120* Sat Mar 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
121- new upstream release
122- added BuildRequires:  libgudev1-devel
123- applied new naming policy to spec
124
125* Wed Jan 20 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.3-1
126- new upstream release
127- proved Japanese description
128
129* Thu Jan 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.2-1
130- new upstrema release
131
132* Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.1-1
133- intial build for VineSeed
134
135* Fri Dec 18 2009 Matthias Clasen <mclasen@redhat.com> - 0.4.0-0.1.20091218svn
136* Thu Nov 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
137- Update to 0.3.2
138
139* Tue Nov  3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.0-1
140- Version 0.3.0
141
142* Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.2.0-3
143- Rebuild against new libgee
144
145* Sun Aug 12 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-2.fc12
146- Bring icon cache handling in sync with current guidelines
147
148* Sun Aug  9 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-1.fc12
149- Initial packaging
Note: See TracBrowser for help on using the repository browser.