source: projects/specs/trunk/s/shotwell/shotwell-vl.spec @ 1343

Revision 1343, 4.6 KB checked in by kudoh, 14 years ago (diff)
Line 
1Name:           shotwell
2Version:        0.6.1
3Release:        1%{?_dist_release}
4Summary:        A photo organizer for the GNOME desktop
5Summary(ja):    GNOME デスクトップ向けの画像整理ソフト
6
7Group:          Applications/Graphics
8# LGPLv2+ for the code
9# CC-BY-SA for some of the icons
10License:        LGPLv2+ and CC-BY-SA
11URL:            http://www.yorba.org/shotwell/
12Source0:        http://www.yorba.org/download/shotwell/0.4/shotwell-%{version}.tar.bz2
13# svn co svn://svn.yorba.org/shotwell/branches/shotwell-0.4, make dist
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16
17BuildRequires:  GConf2-devel
18BuildRequires:  LibRaw-devel
19BuildRequires:  WebKit-gtk-devel
20BuildRequires:  dbus-glib-devel
21BuildRequires:  desktop-file-utils
22BuildRequires:  gettext
23BuildRequires:  gtk2-devel
24BuildRequires:  hal-devel
25BuildRequires:  libexif-devel
26BuildRequires:  libgee-devel
27BuildRequires:  libgphoto2-devel
28BuildRequires:  libgudev1-devel
29BuildRequires:  libgexiv2-devel
30BuildRequires:  sqlite3-devel
31BuildRequires:  unique-devel
32BuildRequires:  vala-devel
33
34%description
35Shotwell is a new open source photo organizer designed for the GNOME desktop
36environment. It allows you to import photos from your camera, view and edit
37them, and share them with others.
38
39%description -l ja
40Shotwell は GNOME デスクトップ環境用に設計された新しいオープンソースの
41画像整理ソフトです。
42あなたのカメラから写真を取り込んだり、それらを表示・編集したり、
43他の人々と共有するなどができます。
44
45%prep
46%setup -q -n %{name}-%{version}
47
48%build
49./configure --prefix=/usr --disable-schemas-install
50sed -i -e 's/\\n/\n/g' configure.mk
51sed -i -e 's/^CFLAGS=.*$/CFLAGS=%{optflags}/' Makefile
52make %{?_smp_mflags}
53
54
55%install
56rm -rf $RPM_BUILD_ROOT
57export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
58export XDG_DISABLE_MAKEFILE_UPDATES=1
59make install DESTDIR=$RPM_BUILD_ROOT
60
61desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell.desktop
62desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell-viewer.desktop
63
64%find_lang %{name}
65
66%clean
67rm -rf $RPM_BUILD_ROOT
68
69%post
70touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
71update-desktop-database &> /dev/null || :
72export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
73gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
74
75%pre
76if [ "$1" -gt 1 ]; then
77  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
78  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
79fi
80
81%preun
82if [ "$1" -eq 0 ]; then
83  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
84  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
85fi
86
87%postun
88if [ $1 -eq 0 ] ; then
89  touch --no-create %{_datadir}/icons/hicolor &>/dev/null
90  gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
91fi
92update-desktop-database &> /dev/null || :
93
94%posttrans
95gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
96
97%files -f %{name}.lang
98%defattr(-,root,root,-)
99%doc README COPYING MAINTAINERS NEWS THANKS AUTHORS
100%{_sysconfdir}/gconf/schemas/shotwell.schemas
101%{_bindir}/shotwell
102%{_datadir}/shotwell
103%{_datadir}/applications/shotwell.desktop
104%{_datadir}/applications/shotwell-viewer.desktop
105%{_datadir}/icons/hicolor/*
106
107
108%changelog
109* Wed Jul 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.1-1
110- new upstream release
111- added BuildRequires: LibRaw-devel, libgexiv2-devel
112
113* Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.2-1
114- new upstream release
115
116* Sat Mar 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
117- new upstream release
118- added BuildRequires:  libgudev1-devel
119- applied new naming policy to spec
120
121* Wed Jan 20 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.3-1
122- new upstream release
123- proved Japanese description
124
125* Thu Jan 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.2-1
126- new upstrema release
127
128* Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.1-1
129- intial build for VineSeed
130
131* Fri Dec 18 2009 Matthias Clasen <mclasen@redhat.com> - 0.4.0-0.1.20091218svn
132* Thu Nov 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
133- Update to 0.3.2
134
135* Tue Nov  3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.0-1
136- Version 0.3.0
137
138* Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.2.0-3
139- Rebuild against new libgee
140
141* Sun Aug 12 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-2.fc12
142- Bring icon cache handling in sync with current guidelines
143
144* Sun Aug  9 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-1.fc12
145- Initial packaging
Note: See TracBrowser for help on using the repository browser.