source: projects/specs/trunk/s/shotwell/shotwell-vl.spec @ 10431

Revision 10431, 9.4 KB checked in by tomop, 8 years ago (diff)

shotwell-0.23.2-1

Line 
1Name:           shotwell
2Version:        0.23.2
3Release:        1%{?_dist_release}
4Summary:        A photo manager for the GNOME desktop
5Summary(ja):    GNOME デスクトップ向けの写真管理ツール
6
7Group:          Applications/Graphics
8# LGPLv2+ for the code
9# CC-BY-SA for some of the icons
10License:        LGPLv2+ and CC-BY-SA
11URL:            http://www.yorba.org/shotwell/
12Source0:        http://www.yorba.org/download/shotwell/stable/shotwell-%{version}.tar.xz
13# https://bugzilla.gnome.org/show_bug.cgi?id=715578
14Source2:        shotwell.1
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18BuildRequires:  GConf2-devel
19BuildRequires:  LibRaw-devel
20BuildRequires:  LibRaw-static
21BuildRequires:  dbus-glib-devel
22BuildRequires:  desktop-file-utils
23BuildRequires:  gettext
24BuildRequires:  gtk3-devel
25#BuildRequires:  gstreamer-devel
26#BuildRequires:  gstreamer-plugins-base-devel
27BuildRequires:  gstreamer1-devel
28BuildRequires:  gstreamer1-plugins-base-devel
29BuildRequires:  json-glib-devel
30BuildRequires:  libexif-devel
31BuildRequires:  libgee-devel
32BuildRequires:  libgee-vala
33BuildRequires:  libgphoto2-devel
34BuildRequires:  eudev-libgudev1-devel
35BuildRequires:  libgexiv2-devel >= 0.2.0
36BuildRequires:  libsoup-devel
37BuildRequires:  libxml2-devel
38BuildRequires:  lcms2-devel
39BuildRequires:  sqlite3-devel
40BuildRequires:  unique3-devel
41BuildRequires:  vala-devel >= 0.9.5
42BuildRequires:  rest-devel
43BuildRequires:  gnome-doc-utils
44BuildRequires:  webkitgtk4-devel
45
46# used by shotwell-settings-migrator
47Requires: dconf
48
49Vendor: Project Vine
50Distribution: Vine Linux
51Packager: kudoh
52
53%description
54Shotwell is a new open source photo manager designed for the GNOME desktop
55environment. It allows you to import photos from your camera, view and edit
56them, and share them with others.
57
58%description -l ja
59Shotwell は GNOME デスクトップ環境用に設計された新しいオープンソースの
60画像管理ツールです。
61あなたのカメラから写真を取り込んだり、それらを表示・編集したり、
62他の人々と共有するなどができます。
63
64%prep
65%setup -q -n %{name}-%{version}
66
67%build
68./configure \
69  --prefix=%{_prefix} \
70  --lib=%{_lib} \
71  --disable-schemas-compile \
72  --disable-icon-update
73
74#make %{?_smp_mflags}
75make
76
77
78%install
79rm -rf $RPM_BUILD_ROOT
80export XDG_DISABLE_MAKEFILE_UPDATES=1
81# otherwise gettext always returns English text regardless of LANGUAGE asked
82export LANG=en_US.utf8
83make install DESTDIR=$RPM_BUILD_ROOT
84
85desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell.desktop
86desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell-viewer.desktop
87
88# install man page
89mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
90cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_mandir}/man1
91
92%find_lang %{name} --all-name
93
94%clean
95rm -rf $RPM_BUILD_ROOT
96
97%post
98touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
99update-desktop-database &> /dev/null || :
100
101%postun
102if [ $1 -eq 0 ] ; then
103  touch --no-create %{_datadir}/icons/hicolor &>/dev/null
104  gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
105  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
106fi
107update-desktop-database &> /dev/null || :
108
109%posttrans
110gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
111glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
112
113%files -f %{name}.lang
114%defattr(-,root,root,-)
115%license COPYING
116%doc README MAINTAINERS NEWS THANKS AUTHORS
117%{_bindir}/shotwell
118%{_libdir}/*
119%{_libexecdir}/shotwell
120%{_datadir}/shotwell
121%{_datadir}/applications/shotwell.desktop
122%{_datadir}/applications/shotwell-viewer.desktop
123%{_datadir}/appdata/shotwell.appdata.xml
124%{_datadir}/GConf/gsettings/shotwell.convert
125%{_datadir}/glib-2.0/schemas/*.xml
126%{_datadir}/icons/hicolor/*/apps/shotwell.png
127%{_datadir}/icons/hicolor/symbolic/apps/shotwell-symbolic.svg
128%{_datadir}/gnome/help/shotwell
129%{_mandir}/man1/*
130
131
132%changelog
133* Wed Jun 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.23.2-1
134- new upstream release.
135- remove %%_smp_mflags: Makefile has wrong dependency(?).
136
137* Tue Nov 03 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.22.0-2
138- rebuild with exiv2-0.25
139
140* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.22.0-1
141- new upstream release
142
143* Mon Feb 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.20.2-2
144- rebuild with libgphoto2-2.5.7
145
146* Mon Nov 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.20.2-1
147- new upstream release
148
149* Thu Jul 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.18.1-1
150- new upstream release
151- change BuildRequires: eudev-libgudev1-devel instead of libgudev1-devel
152
153* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.18.0-1
154- new upstream release
155- add BuildRequires: gnome-doc-utils
156
157* Sun Feb 09 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.15.1-4
158- rebuild with LibRaw-0.16.0
159
160* Sun Jan 19 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15.1-3
161- rebuilt with LibRaw-0.15.4
162
163* Wed Dec 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.15.1-2
164- rebuild with exiv2-0.24
165
166* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.15.1-1
167- new upstream release
168- remove Patch1 (0001-Port-to-GStreamer-1.0.patch)
169- change BuildRequires: libgee-devel instead of libgee06-devel
170- add BuildRequires: libgee-vala
171
172* Fri Jan 11 2013 IWAI, Masaharu <iwai@alib.jp> - 0.13.1-2
173- build with libgphoto2 2.5.0-1
174
175* Sat Oct 20 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.13.1-1
176- new upstream release
177- changed archive typr to xz
178- changed BuildRequires: libgee-devel to libgee06-devel
179- changed BuildRequires: gstreamer-devel and gstreamer-plugins-base-devel to
180  gstreamer1-devel and gstreamer1-plugins-base-devel
181- added Requires: dconf
182- added Patch0,1 from Fedora
183
184* Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.12.3-2
185- rebuild with exiv2-0.23
186
187* Thu May 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.12.3-1
188- new upstream release
189- dropt Source2
190
191* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.12.2-1
192- new upstream release
193- remove Patch0
194- change BuildRequires: gtk3-devel instead of gtk2-devel
195- change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
196- change BuildRequires: unique3-devel instead of unique-devel
197- remove BuildRequires: hal-devel
198- add BuildRequires: rest-devel, lcms2-devel
199
200* Sun Nov 13 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.6-1
201- new upstream release
202
203* Thu Oct 20 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.5-1
204- new upstream release
205
206* Fri Oct 14 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.4-1
207- new upstream release
208
209* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.11.2-1
210- new upstream release
211- add Patch0 (shotwell-0.11.1-vala-0.14.patch)
212- add BuildRequires: gstreamer-plugins-base-devel
213
214* Sat Aug 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.1-2
215- rebuilt with libgexiv2-0.2.2-2
216
217* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.1-1
218- new upstream release
219
220* Sat Jun 18 2011 IWAI, Masaharu <iwai@alib.jp> 0.8.1-5
221- add ja.po (Source2): fix <BTS:VineLinux:1142>
222- update Summary and description
223
224* Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.1-4
225- add hi-res icons (SOURCE1)
226- add LANG=en_US.utf8 to get gettext to actually generate translated strings
227
228* Sat Jun 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-3
229- dropt Patch0
230- added BuildRequires: LibRaw-static
231
232* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.8.1-2
233- add Patch1 (shotwell-0.8.1-vala.patch)
234
235* Wed Jan 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-1
236- new upstream release
237- added BuildRequires: gstreamer-devel, json-glib-devel, libsoup-devel, libxml2-devel
238
239* Tue Sep 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-2
240- rebuilt with rpm-4.8.1 for pkg-config
241- fixed %%changelog in Tue Sep 14 2010
242
243* Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-1
244- new upstream release
245- changed source URL
246- added Patch0 to work around desktop file incorrect comment
247- changed BuildRequires: vala-devel >= 0.9.5
248
249* Fri Aug 27 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.1-1
250- new upstream release
251
252* Sat Aug 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.0-1
253- new upstream release
254- changed BuildRequires: libgexiv2-devel >= 0.2.0
255
256* Thu Jul 22 2010 Shu KONNO <owa@bg.wakwak.com> - 0.6.1-2
257- fixed LIB_DIRS in libraw-config (for lib64)
258
259* Wed Jul 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.1-1
260- new upstream release
261- added BuildRequires: LibRaw-devel, libgexiv2-devel
262
263* Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.2-1
264- new upstream release
265
266* Sat Mar 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
267- new upstream release
268- added BuildRequires:  libgudev1-devel
269- applied new naming policy to spec
270
271* Wed Jan 20 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.3-1
272- new upstream release
273- proved Japanese description
274
275* Thu Jan 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.2-1
276- new upstrema release
277
278* Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.1-1
279- intial build for VineSeed
280
281* Fri Dec 18 2009 Matthias Clasen <mclasen@redhat.com> - 0.4.0-0.1.20091218svn
282* Thu Nov 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
283- Update to 0.3.2
284
285* Tue Nov  3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.0-1
286- Version 0.3.0
287
288* Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.2.0-3
289- Rebuild against new libgee
290
291* Wed Aug 12 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-2.fc12
292- Bring icon cache handling in sync with current guidelines
293
294* Sun Aug  9 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-1.fc12
295- Initial packaging
Note: See TracBrowser for help on using the repository browser.