source: projects/specs/trunk/s/shotwell/shotwell-vl.spec @ 9791

Revision 9791, 9.8 KB checked in by Takemikaduchi, 9 years ago (diff)

GNOME 3.18.1, BlueZ 5.35, ICU 56.1, Mesa 11.0.4, PulseAudio 7.1, xserver 1.17.4, etc.

Line 
1Name:           shotwell
2Version:        0.22.0
3Release:        2%{?_dist_release}
4Summary:        A photo manager for the GNOME desktop
5Summary(ja):    GNOME デスクトップ向けの写真管理ツール
6
7Group:          Applications/Graphics
8# LGPLv2+ for the code
9# CC-BY-SA for some of the icons
10License:        LGPLv2+ and CC-BY-SA
11URL:            http://www.yorba.org/shotwell/
12
13Source0:        http://www.yorba.org/download/shotwell/stable/shotwell-%{version}.tar.xz
14# http://trac.yorba.org/ticket/3379
15Source1:        shotwell-icons.tar.bz2
16
17# http://redmine.yorba.org/issues/5181
18Patch0:         shotwell-usrmove.patch
19
20BuildRoot:      %{_tmppath}/%{name}-%{version}-root
21
22BuildRequires:  GConf2-devel
23BuildRequires:  LibRaw-devel
24BuildRequires:  LibRaw-static
25BuildRequires:  WebKit3-gtk-devel
26BuildRequires:  dbus-glib-devel
27BuildRequires:  desktop-file-utils
28BuildRequires:  gettext
29BuildRequires:  gtk3-devel
30#BuildRequires:  gstreamer-devel
31#BuildRequires:  gstreamer-plugins-base-devel
32BuildRequires:  gstreamer1-devel
33BuildRequires:  gstreamer1-plugins-base-devel
34BuildRequires:  json-glib-devel
35BuildRequires:  libexif-devel
36BuildRequires:  libgee-devel
37BuildRequires:  libgee-vala
38BuildRequires:  libgphoto2-devel
39BuildRequires:  eudev-libgudev1-devel
40BuildRequires:  libgexiv2-devel >= 0.2.0
41BuildRequires:  libsoup-devel
42BuildRequires:  libxml2-devel
43BuildRequires:  lcms2-devel
44BuildRequires:  sqlite3-devel
45BuildRequires:  unique3-devel
46BuildRequires:  vala-devel >= 0.9.5
47BuildRequires:  rest-devel
48BuildRequires:  gnome-doc-utils
49
50# used by shotwell-settings-migrator
51Requires: dconf
52
53Vendor: Project Vine
54Distribution: Vine Linux
55Packager: kudoh
56
57%description
58Shotwell is a new open source photo manager designed for the GNOME desktop
59environment. It allows you to import photos from your camera, view and edit
60them, and share them with others.
61
62%description -l ja
63Shotwell は GNOME デスクトップ環境用に設計された新しいオープンソースの
64画像管理ツールです。
65あなたのカメラから写真を取り込んだり、それらを表示・編集したり、
66他の人々と共有するなどができます。
67
68%prep
69%setup -q -n %{name}-%{version}
70%patch0 -p1 -b .usrmove
71
72%build
73# We can't use the configure macro: it's not a standard autotools configure script
74export CFLAGS="%{optflags}"
75export LIB=%{_lib}
76
77# HACK: Remove fatal-warnings to succeed build with vala 0.13.
78#sed -i "s:--fatal-warnings ::g" Makefile plugins/Makefile.plugin.mk
79./configure --prefix=%{_prefix} --lib=%{_lib} --disable-schemas-install
80#sed -i -e 's/\\n/\n/g' configure.mk
81make %{?_smp_mflags}
82
83
84%install
85rm -rf $RPM_BUILD_ROOT
86export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
87export XDG_DISABLE_MAKEFILE_UPDATES=1
88# otherwise gettext always returns English text regardless of LANGUAGE asked
89export LANG=en_US.utf8
90make install DESTDIR=$RPM_BUILD_ROOT
91
92desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell.desktop
93desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell-viewer.desktop
94
95# put hi-res icons in place
96(
97  cd $RPM_BUILD_ROOT%{_datadir}/icons/hicolor
98  rm -rf 16x16 24x24 scalable
99  tar xf %{SOURCE1}
100)
101
102%find_lang %{name} --all-name
103
104%clean
105rm -rf $RPM_BUILD_ROOT
106
107%post
108touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
109update-desktop-database &> /dev/null || :
110
111%postun
112if [ $1 -eq 0 ] ; then
113  touch --no-create %{_datadir}/icons/hicolor &>/dev/null
114  gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
115  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
116fi
117update-desktop-database &> /dev/null || :
118
119%posttrans
120gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
121glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
122
123%files -f %{name}.lang
124%defattr(-,root,root,-)
125%doc README COPYING MAINTAINERS NEWS THANKS AUTHORS
126%{_bindir}/shotwell
127%{_libexecdir}/shotwell/shotwell-settings-migrator
128%{_libexecdir}/shotwell/shotwell-video-thumbnailer
129%{_libdir}/shotwell/plugins/builtin
130%{_datadir}/GConf/gsettings/shotwell.convert
131%{_datadir}/glib-2.0/schemas/org.yorba.shotwell-extras.gschema.xml
132%{_datadir}/glib-2.0/schemas/org.yorba.shotwell.gschema.xml
133%{_datadir}/gnome/help/
134%{_datadir}/shotwell
135%{_datadir}/appdata/shotwell.appdata.xml
136%{_datadir}/applications/shotwell.desktop
137%{_datadir}/applications/shotwell-viewer.desktop
138%{_datadir}/icons/hicolor/*
139%exclude %{_datadir}/icons/hicolor/icon-theme.cache
140%exclude %{_datadir}/glib-2.0/schemas/gschemas.compiled
141
142
143%changelog
144* Tue Nov 03 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.22.0-2
145- rebuild with exiv2-0.25
146
147* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.22.0-1
148- new upstream release
149
150* Mon Feb 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.20.2-2
151- rebuild with libgphoto2-2.5.7
152
153* Mon Nov 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.20.2-1
154- new upstream release
155
156* Thu Jul 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.18.1-1
157- new upstream release
158- change BuildRequires: eudev-libgudev1-devel instead of libgudev1-devel
159
160* Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.18.0-1
161- new upstream release
162- add BuildRequires: gnome-doc-utils
163
164* Sun Feb 09 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.15.1-4
165- rebuild with LibRaw-0.16.0
166
167* Sun Jan 19 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.15.1-3
168- rebuilt with LibRaw-0.15.4
169
170* Wed Dec 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.15.1-2
171- rebuild with exiv2-0.24
172
173* Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.15.1-1
174- new upstream release
175- remove Patch1 (0001-Port-to-GStreamer-1.0.patch)
176- change BuildRequires: libgee-devel instead of libgee06-devel
177- add BuildRequires: libgee-vala
178
179* Fri Jan 11 2013 IWAI, Masaharu <iwai@alib.jp> - 0.13.1-2
180- build with libgphoto2 2.5.0-1
181
182* Sat Oct 20 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.13.1-1
183- new upstream release
184- changed archive typr to xz
185- changed BuildRequires: libgee-devel to libgee06-devel
186- changed BuildRequires: gstreamer-devel and gstreamer-plugins-base-devel to
187  gstreamer1-devel and gstreamer1-plugins-base-devel
188- added Requires: dconf
189- added Patch0,1 from Fedora
190
191* Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.12.3-2
192- rebuild with exiv2-0.23
193
194* Thu May 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.12.3-1
195- new upstream release
196- dropt Source2
197
198* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.12.2-1
199- new upstream release
200- remove Patch0
201- change BuildRequires: gtk3-devel instead of gtk2-devel
202- change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
203- change BuildRequires: unique3-devel instead of unique-devel
204- remove BuildRequires: hal-devel
205- add BuildRequires: rest-devel, lcms2-devel
206
207* Sun Nov 13 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.6-1
208- new upstream release
209
210* Thu Oct 20 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.5-1
211- new upstream release
212
213* Fri Oct 14 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.4-1
214- new upstream release
215
216* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.11.2-1
217- new upstream release
218- add Patch0 (shotwell-0.11.1-vala-0.14.patch)
219- add BuildRequires: gstreamer-plugins-base-devel
220
221* Sat Aug 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.1-2
222- rebuilt with libgexiv2-0.2.2-2
223
224* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.1-1
225- new upstream release
226
227* Sat Jun 18 2011 IWAI, Masaharu <iwai@alib.jp> 0.8.1-5
228- add ja.po (Source2): fix <BTS:VineLinux:1142>
229- update Summary and description
230
231* Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.1-4
232- add hi-res icons (SOURCE1)
233- add LANG=en_US.utf8 to get gettext to actually generate translated strings
234
235* Sat Jun 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-3
236- dropt Patch0
237- added BuildRequires: LibRaw-static
238
239* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.8.1-2
240- add Patch1 (shotwell-0.8.1-vala.patch)
241
242* Wed Jan 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-1
243- new upstream release
244- added BuildRequires: gstreamer-devel, json-glib-devel, libsoup-devel, libxml2-devel
245
246* Tue Sep 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-2
247- rebuilt with rpm-4.8.1 for pkg-config
248- fixed %%changelog in Tue Sep 14 2010
249
250* Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-1
251- new upstream release
252- changed source URL
253- added Patch0 to work around desktop file incorrect comment
254- changed BuildRequires: vala-devel >= 0.9.5
255
256* Fri Aug 27 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.1-1
257- new upstream release
258
259* Sat Aug 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.0-1
260- new upstream release
261- changed BuildRequires: libgexiv2-devel >= 0.2.0
262
263* Thu Jul 22 2010 Shu KONNO <owa@bg.wakwak.com> - 0.6.1-2
264- fixed LIB_DIRS in libraw-config (for lib64)
265
266* Wed Jul 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.1-1
267- new upstream release
268- added BuildRequires: LibRaw-devel, libgexiv2-devel
269
270* Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.2-1
271- new upstream release
272
273* Sat Mar 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
274- new upstream release
275- added BuildRequires:  libgudev1-devel
276- applied new naming policy to spec
277
278* Wed Jan 20 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.3-1
279- new upstream release
280- proved Japanese description
281
282* Thu Jan 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.2-1
283- new upstrema release
284
285* Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.1-1
286- intial build for VineSeed
287
288* Fri Dec 18 2009 Matthias Clasen <mclasen@redhat.com> - 0.4.0-0.1.20091218svn
289* Thu Nov 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
290- Update to 0.3.2
291
292* Tue Nov  3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.0-1
293- Version 0.3.0
294
295* Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.2.0-3
296- Rebuild against new libgee
297
298* Wed Aug 12 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-2.fc12
299- Bring icon cache handling in sync with current guidelines
300
301* Sun Aug  9 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-1.fc12
302- Initial packaging
Note: See TracBrowser for help on using the repository browser.