source: projects/specs/trunk/s/shotwell/shotwell-vl.spec @ 6078

Revision 6078, 7.8 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1Name:           shotwell
2Version:        0.12.2
3Release:        1%{?_dist_release}
4Summary:        A photo manager for the GNOME desktop
5Summary(ja):    GNOME デスクトップ向けの写真管理ツール
6
7Group:          Applications/Graphics
8# LGPLv2+ for the code
9# CC-BY-SA for some of the icons
10License:        LGPLv2+ and CC-BY-SA
11URL:            http://www.yorba.org/shotwell/
12
13Source0:        http://www.yorba.org/download/shotwell/stable/shotwell-%{version}.tar.bz2
14# http://trac.yorba.org/ticket/3379
15Source1:        shotwell-icons.tar.bz2
16Source2:        shotwell-0.8.1-vine2-ja.po
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19
20BuildRequires:  GConf2-devel
21BuildRequires:  LibRaw-devel
22BuildRequires:  LibRaw-static
23BuildRequires:  WebKit3-gtk-devel
24BuildRequires:  dbus-glib-devel
25BuildRequires:  desktop-file-utils
26BuildRequires:  gettext
27BuildRequires:  gtk3-devel
28BuildRequires:  gstreamer-devel
29BuildRequires:  gstreamer-plugins-base-devel
30BuildRequires:  json-glib-devel
31BuildRequires:  libexif-devel
32BuildRequires:  libgee-devel
33BuildRequires:  libgphoto2-devel
34BuildRequires:  libgudev1-devel
35BuildRequires:  libgexiv2-devel >= 0.2.0
36BuildRequires:  libsoup-devel
37BuildRequires:  libxml2-devel
38BuildRequires:  lcms2-devel
39BuildRequires:  sqlite3-devel
40BuildRequires:  unique3-devel
41BuildRequires:  vala-devel >= 0.9.5
42BuildRequires:  rest-devel
43
44Vendor: Project Vine
45Distribution: Vine Linux
46Packager: kudoh
47
48%description
49Shotwell is a new open source photo manager designed for the GNOME desktop
50environment. It allows you to import photos from your camera, view and edit
51them, and share them with others.
52
53%description -l ja
54Shotwell は GNOME デスクトップ環境用に設計された新しいオープンソースの
55画像管理ツールです。
56あなたのカメラから写真を取り込んだり、それらを表示・編集したり、
57他の人々と共有するなどができます。
58
59%prep
60%setup -q -n %{name}-%{version}
61pushd po
62%__rm -f ja.po
63%__cp %{SOURCE2} ja.po
64popd
65
66%build
67# We can't use the configure macro: it's not a standard autotools configure script
68export CFLAGS="%{optflags}"
69export LIB=%{_lib}
70
71# HACK: Remove fatal-warnings to succeed build with vala 0.13.
72sed -i "s:--fatal-warnings ::g" Makefile plugins/Makefile.plugin.mk
73./configure --prefix=%{_prefix} --lib=%{_lib} --disable-schemas-install
74#sed -i -e 's/\\n/\n/g' configure.mk
75#sed -i -e 's/^CFLAGS=.*$/CFLAGS=%{optflags}/' Makefile
76#sed -i -e 's|LIB_DIRS=.*$|LIB_DIRS=%{_libdir}|' libraw-config
77make %{?_smp_mflags}
78
79
80%install
81rm -rf $RPM_BUILD_ROOT
82export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
83export XDG_DISABLE_MAKEFILE_UPDATES=1
84# otherwise gettext always returns English text regardless of LANGUAGE asked
85export LANG=en_US.utf8
86make install DESTDIR=$RPM_BUILD_ROOT
87
88desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell.desktop
89desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell-viewer.desktop
90
91# put hi-res icons in place
92(
93  cd $RPM_BUILD_ROOT%{_datadir}/icons/hicolor
94  rm -rf 16x16 24x24 scalable
95  tar xf %{SOURCE1}
96)
97     
98%find_lang %{name} --all-name
99
100%clean
101rm -rf $RPM_BUILD_ROOT
102
103%post
104touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
105update-desktop-database &> /dev/null || :
106
107%postun
108if [ $1 -eq 0 ] ; then
109  touch --no-create %{_datadir}/icons/hicolor &>/dev/null
110  gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
111  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
112fi
113update-desktop-database &> /dev/null || :
114
115%posttrans
116gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
117glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
118
119%files -f %{name}.lang
120%defattr(-,root,root,-)
121%doc README COPYING MAINTAINERS NEWS THANKS AUTHORS
122%{_bindir}/shotwell
123%{_bindir}/shotwell-video-thumbnailer
124%{_libdir}/shotwell/plugins/builtin
125%{_datadir}/GConf/gsettings/shotwell.convert
126%{_datadir}/glib-2.0/schemas/org.yorba.shotwell-extras.gschema.xml
127%{_datadir}/glib-2.0/schemas/org.yorba.shotwell.gschema.xml
128%{_datadir}/gnome/help/
129%{_datadir}/shotwell
130%{_datadir}/applications/shotwell.desktop
131%{_datadir}/applications/shotwell-viewer.desktop
132%{_datadir}/icons/hicolor/*
133%exclude %{_datadir}/icons/hicolor/icon-theme.cache
134%exclude %{_datadir}/glib-2.0/schemas/gschemas.compiled
135
136
137%changelog
138* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.12.2-1
139- new upstream release
140- remove Patch0
141- change BuildRequires: gtk3-devel instead of gtk2-devel
142- change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
143- change BuildRequires: unique3-devel instead of unique-devel
144- remove BuildRequires: hal-devel
145- add BuildRequires: rest-devel, lcms2-devel
146
147* Sun Nov 13 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.6-1
148- new upstream release
149
150* Thu Oct 20 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.5-1
151- new upstream release
152
153* Fri Oct 14 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.4-1
154- new upstream release
155
156* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.11.2-1
157- new upstream release
158- add Patch0 (shotwell-0.11.1-vala-0.14.patch)
159- add BuildRequires: gstreamer-plugins-base-devel
160
161* Sat Aug 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.1-2
162- rebuilt with libgexiv2-0.2.2-2
163
164* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.1-1
165- new upstream release
166
167* Sat Jun 18 2011 IWAI, Masaharu <iwai@alib.jp> 0.8.1-5
168- add ja.po (Source2): fix <BTS:VineLinux:1142>
169- update Summary and description
170
171* Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.1-4
172- add hi-res icons (SOURCE1)
173- add LANG=en_US.utf8 to get gettext to actually generate translated strings
174
175* Sat Jun 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-3
176- dropt Patch0
177- added BuildRequires: LibRaw-static
178
179* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.8.1-2
180- add Patch1 (shotwell-0.8.1-vala.patch)
181
182* Wed Jan 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-1
183- new upstream release
184- added BuildRequires: gstreamer-devel, json-glib-devel, libsoup-devel, libxml2-devel
185
186* Tue Sep 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-2
187- rebuilt with rpm-4.8.1 for pkg-config
188- fixed %%changelog in Tue Sep 14 2010
189
190* Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-1
191- new upstream release
192- changed source URL
193- added Patch0 to work around desktop file incorrect comment
194- changed BuildRequires: vala-devel >= 0.9.5
195
196* Fri Aug 27 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.1-1
197- new upstream release
198
199* Sat Aug 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.0-1
200- new upstream release
201- changed BuildRequires: libgexiv2-devel >= 0.2.0
202
203* Thu Jul 22 2010 Shu KONNO <owa@bg.wakwak.com> - 0.6.1-2
204- fixed LIB_DIRS in libraw-config (for lib64)
205
206* Wed Jul 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.1-1
207- new upstream release
208- added BuildRequires: LibRaw-devel, libgexiv2-devel
209
210* Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.2-1
211- new upstream release
212
213* Sat Mar 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
214- new upstream release
215- added BuildRequires:  libgudev1-devel
216- applied new naming policy to spec
217
218* Wed Jan 20 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.3-1
219- new upstream release
220- proved Japanese description
221
222* Thu Jan 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.2-1
223- new upstrema release
224
225* Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.1-1
226- intial build for VineSeed
227
228* Fri Dec 18 2009 Matthias Clasen <mclasen@redhat.com> - 0.4.0-0.1.20091218svn
229* Thu Nov 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
230- Update to 0.3.2
231
232* Tue Nov  3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.0-1
233- Version 0.3.0
234
235* Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.2.0-3
236- Rebuild against new libgee
237
238* Sun Aug 12 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-2.fc12
239- Bring icon cache handling in sync with current guidelines
240
241* Sun Aug  9 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-1.fc12
242- Initial packaging
Note: See TracBrowser for help on using the repository browser.