source: projects/specs/trunk/s/shotwell/shotwell-vl.spec @ 521

Revision 521, 4.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name:           shotwell
2Version:        0.4.3
3Release:        1%{?_dist_release}
4Summary:        A photo organizer for the GNOME desktop
5Summary(ja):    GNOME デスクトップ向けの画像整理ソフト
6
7Group:          Applications/Graphics
8# LGPLv2+ for the code
9# CC-BY-SA for some of the icons
10License:        LGPLv2+ and CC-BY-SA
11URL:            http://www.yorba.org/shotwell/
12Source0:        http://www.yorba.org/download/shotwell/0.4/shotwell-%{version}.tar.bz2
13# svn co svn://svn.yorba.org/shotwell/branches/shotwell-0.4, make dist
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16
17BuildRequires:  gtk2-devel
18BuildRequires:  GConf2-devel
19BuildRequires:  sqlite3-devel
20BuildRequires:  vala-devel
21BuildRequires:  libgee-devel
22BuildRequires:  hal-devel
23BuildRequires:  dbus-glib-devel
24BuildRequires:  unique-devel
25BuildRequires:  libexif-devel
26BuildRequires:  libgphoto2-devel
27BuildRequires:  WebKit-gtk-devel
28BuildRequires:  desktop-file-utils
29BuildRequires:  gettext
30
31%description
32Shotwell is a new open source photo organizer designed for the GNOME desktop
33environment. It allows you to import photos from your camera, view and edit
34them, and share them with others.
35
36%description -l ja
37Shotwell は GNOME デスクトップ環境用に設計された新しいオープンソースの
38画像整理ソフトです。
39あなたのカメラから写真を取り込んだり、それらを表示・編集したり、
40他の人々と共有するなどができます。
41
42%prep
43%setup -q -n %{name}-%{version}
44
45%build
46./configure --prefix=/usr --disable-schemas-install
47sed -i -e 's/\\n/\n/g' configure.mk
48sed -i -e 's/^CFLAGS=.*$/CFLAGS=%{optflags}/' Makefile
49make %{?_smp_mflags}
50
51
52%install
53rm -rf $RPM_BUILD_ROOT
54export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
55export XDG_DISABLE_MAKEFILE_UPDATES=1
56make install DESTDIR=$RPM_BUILD_ROOT
57
58desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell.desktop
59desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell-viewer.desktop
60
61%find_lang %{name}
62
63%clean
64rm -rf $RPM_BUILD_ROOT
65
66%post
67touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
68update-desktop-database &> /dev/null || :
69export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
70gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
71
72%pre
73if [ "$1" -gt 1 ]; then
74  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
75  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
76fi
77
78%preun
79if [ "$1" -eq 0 ]; then
80  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
81  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
82fi
83
84%postun
85if [ $1 -eq 0 ] ; then
86  touch --no-create %{_datadir}/icons/hicolor &>/dev/null
87  gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
88fi
89update-desktop-database &> /dev/null || :
90
91%posttrans
92gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
93
94%files -f %{name}.lang
95%defattr(-,root,root,-)
96%doc README COPYING MAINTAINERS NEWS THANKS AUTHORS
97%{_sysconfdir}/gconf/schemas/shotwell.schemas
98%{_bindir}/shotwell
99%{_datadir}/shotwell
100%{_datadir}/applications/shotwell.desktop
101%{_datadir}/applications/shotwell-viewer.desktop
102%{_datadir}/icons/hicolor/scalable/apps/shotwell.svg
103
104
105%changelog
106* Wed Jan 20 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.3-1
107- new upstrema release
108- proved Japanese description
109
110* Thu Jan 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.2-1
111- new upstrema release
112
113* Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.1-1
114- intial build for VineSeed
115
116* Fri Dec 18 2009 Matthias Clasen <mclasen@redhat.com> - 0.4.0-0.1.20091218svn
117* Thu Nov 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
118- Update to 0.3.2
119
120* Tue Nov  3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.0-1
121- Version 0.3.0
122
123* Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.2.0-3
124- Rebuild against new libgee
125
126* Sun Aug 12 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-2.fc12
127- Bring icon cache handling in sync with current guidelines
128
129* Sun Aug  9 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-1.fc12
130- Initial packaging
Note: See TracBrowser for help on using the repository browser.