source: projects/specs/trunk/s/shotwell/shotwell-vl.spec @ 6970

Revision 6970, 8.6 KB checked in by kudoh, 12 years ago (diff)

r/rekonq/rekonq-vl.spec

RevLine 
[521]1Name:           shotwell
[6970]2Version:        0.13.1
3Release:        1%{?_dist_release}
[4172]4Summary:        A photo manager for the GNOME desktop
5Summary(ja):    GNOME デスクトップ向けの写真管理ツール
[521]6
7Group:          Applications/Graphics
8# LGPLv2+ for the code
9# CC-BY-SA for some of the icons
10License:        LGPLv2+ and CC-BY-SA
11URL:            http://www.yorba.org/shotwell/
[4104]12
[6970]13Source0:        http://www.yorba.org/download/shotwell/stable/shotwell-%{version}.tar.xz
[4104]14# http://trac.yorba.org/ticket/3379
15Source1:        shotwell-icons.tar.bz2
[521]16
[6970]17# http://redmine.yorba.org/issues/5181
18Patch0:         shotwell-usrmove.patch
19# http://redmine.yorba.org/issues/5548
20Patch1:         0001-Port-to-GStreamer-1.0.patch
21
[521]22BuildRoot:      %{_tmppath}/%{name}-%{version}-root
23
[1343]24BuildRequires:  GConf2-devel
25BuildRequires:  LibRaw-devel
[4055]26BuildRequires:  LibRaw-static
[6078]27BuildRequires:  WebKit3-gtk-devel
[1343]28BuildRequires:  dbus-glib-devel
29BuildRequires:  desktop-file-utils
30BuildRequires:  gettext
[6078]31BuildRequires:  gtk3-devel
[6970]32#BuildRequires:  gstreamer-devel
33#BuildRequires:  gstreamer-plugins-base-devel
34BuildRequires:  gstreamer1-devel
35BuildRequires:  gstreamer1-plugins-base-devel
[2491]36BuildRequires:  json-glib-devel
[1343]37BuildRequires:  libexif-devel
[6970]38BuildRequires:  libgee06-devel
[1343]39BuildRequires:  libgphoto2-devel
[564]40BuildRequires:  libgudev1-devel
[1628]41BuildRequires:  libgexiv2-devel >= 0.2.0
[2491]42BuildRequires:  libsoup-devel
43BuildRequires:  libxml2-devel
[6078]44BuildRequires:  lcms2-devel
[521]45BuildRequires:  sqlite3-devel
[6078]46BuildRequires:  unique3-devel
[1803]47BuildRequires:  vala-devel >= 0.9.5
[6078]48BuildRequires:  rest-devel
[521]49
[6970]50# used by shotwell-settings-migrator
51Requires: dconf
52
[4104]53Vendor: Project Vine
54Distribution: Vine Linux
55Packager: kudoh
56
[521]57%description
[4172]58Shotwell is a new open source photo manager designed for the GNOME desktop
[521]59environment. It allows you to import photos from your camera, view and edit
60them, and share them with others.
61
62%description -l ja
63Shotwell は GNOME デスクトップ環境用に設計された新しいオープンソースの
[4172]64画像管理ツールです。
[521]65あなたのカメラから写真を取り込んだり、それらを表示・編集したり、
66他の人々と共有するなどができます。
67
68%prep
69%setup -q -n %{name}-%{version}
[6970]70%patch0 -p1 -b .usrmove
71%patch1 -p1
[521]72
73%build
[4812]74# We can't use the configure macro: it's not a standard autotools configure script
75export CFLAGS="%{optflags}"
76export LIB=%{_lib}
77
78# HACK: Remove fatal-warnings to succeed build with vala 0.13.
[6970]79#sed -i "s:--fatal-warnings ::g" Makefile plugins/Makefile.plugin.mk
[4812]80./configure --prefix=%{_prefix} --lib=%{_lib} --disable-schemas-install
81#sed -i -e 's/\\n/\n/g' configure.mk
[521]82make %{?_smp_mflags}
83
84
85%install
86rm -rf $RPM_BUILD_ROOT
87export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
88export XDG_DISABLE_MAKEFILE_UPDATES=1
[4104]89# otherwise gettext always returns English text regardless of LANGUAGE asked
90export LANG=en_US.utf8
[521]91make install DESTDIR=$RPM_BUILD_ROOT
92
93desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell.desktop
94desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell-viewer.desktop
95
[4104]96# put hi-res icons in place
97(
98  cd $RPM_BUILD_ROOT%{_datadir}/icons/hicolor
99  rm -rf 16x16 24x24 scalable
100  tar xf %{SOURCE1}
101)
[6970]102
[4616]103%find_lang %{name} --all-name
[521]104
105%clean
106rm -rf $RPM_BUILD_ROOT
107
108%post
109touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
110update-desktop-database &> /dev/null || :
111
112%postun
113if [ $1 -eq 0 ] ; then
114  touch --no-create %{_datadir}/icons/hicolor &>/dev/null
115  gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
[4812]116  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
[521]117fi
118update-desktop-database &> /dev/null || :
119
120%posttrans
121gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
[4812]122glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
[521]123
124%files -f %{name}.lang
125%defattr(-,root,root,-)
126%doc README COPYING MAINTAINERS NEWS THANKS AUTHORS
127%{_bindir}/shotwell
[4616]128%{_bindir}/shotwell-video-thumbnailer
[6970]129%{_libexecdir}/shotwell/shotwell-settings-migrator
[4616]130%{_libdir}/shotwell/plugins/builtin
[4812]131%{_datadir}/GConf/gsettings/shotwell.convert
132%{_datadir}/glib-2.0/schemas/org.yorba.shotwell-extras.gschema.xml
133%{_datadir}/glib-2.0/schemas/org.yorba.shotwell.gschema.xml
[1628]134%{_datadir}/gnome/help/
[521]135%{_datadir}/shotwell
136%{_datadir}/applications/shotwell.desktop
137%{_datadir}/applications/shotwell-viewer.desktop
[564]138%{_datadir}/icons/hicolor/*
[3330]139%exclude %{_datadir}/icons/hicolor/icon-theme.cache
[4812]140%exclude %{_datadir}/glib-2.0/schemas/gschemas.compiled
[521]141
142
143%changelog
[6970]144* Sat Oct 20 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.13.1-1
145- new upstream release
146- changed archive typr to xz
147- changed BuildRequires: libgee-devel to libgee06-devel
148- changed BuildRequires: gstreamer-devel and gstreamer-plugins-base-devel to
149  gstreamer1-devel and gstreamer1-plugins-base-devel
150- added Requires: dconf
151- added Patch0,1 from Fedora
152
[6655]153* Sun Jul 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.12.3-2
154- rebuild with exiv2-0.23
155
[6163]156* Thu May 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.12.3-1
157- new upstream release
158- dropt Source2
159
[6078]160* Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.12.2-1
161- new upstream release
162- remove Patch0
163- change BuildRequires: gtk3-devel instead of gtk2-devel
164- change BuildRequires: WebKit3-gtk-devel instead of WebKit-gtk-devel
165- change BuildRequires: unique3-devel instead of unique-devel
166- remove BuildRequires: hal-devel
167- add BuildRequires: rest-devel, lcms2-devel
168
[5151]169* Sun Nov 13 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.6-1
170- new upstream release
171
[5025]172* Thu Oct 20 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.5-1
173- new upstream release
174
[4967]175* Fri Oct 14 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.11.4-1
[5025]176- new upstream release
[4967]177
[4812]178* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.11.2-1
179- new upstream release
180- add Patch0 (shotwell-0.11.1-vala-0.14.patch)
181- add BuildRequires: gstreamer-plugins-base-devel
182
[4663]183* Sat Aug 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.1-2
184- rebuilt with libgexiv2-0.2.2-2
185
[4616]186* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.1-1
187- new upstream release
188
[4172]189* Sat Jun 18 2011 IWAI, Masaharu <iwai@alib.jp> 0.8.1-5
190- add ja.po (Source2): fix <BTS:VineLinux:1142>
191- update Summary and description
192
[4104]193* Fri Jun 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.1-4
194- add hi-res icons (SOURCE1)
195- add LANG=en_US.utf8 to get gettext to actually generate translated strings
196
[4055]197* Sat Jun 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-3
198- dropt Patch0
199- added BuildRequires: LibRaw-static
200
[3330]201* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.8.1-2
202- add Patch1 (shotwell-0.8.1-vala.patch)
203
[2491]204* Wed Jan 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-1
205- new upstream release
206- added BuildRequires: gstreamer-devel, json-glib-devel, libsoup-devel, libxml2-devel
207
[1939]208* Tue Sep 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-2
209- rebuilt with rpm-4.8.1 for pkg-config
210- fixed %%changelog in Tue Sep 14 2010
211
[1803]212* Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-1
213- new upstream release
214- changed source URL
[1939]215- added Patch0 to work around desktop file incorrect comment
[1803]216- changed BuildRequires: vala-devel >= 0.9.5
217
[1677]218* Fri Aug 27 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.1-1
219- new upstream release
220
[1628]221* Sat Aug 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.0-1
222- new upstream release
223- changed BuildRequires: libgexiv2-devel >= 0.2.0
224
[1417]225* Thu Jul 22 2010 Shu KONNO <owa@bg.wakwak.com> - 0.6.1-2
226- fixed LIB_DIRS in libraw-config (for lib64)
227
[1343]228* Wed Jul 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.1-1
229- new upstream release
230- added BuildRequires: LibRaw-devel, libgexiv2-devel
231
[1007]232* Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.2-1
233- new upstream release
234
[564]235* Sat Mar 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
236- new upstream release
237- added BuildRequires:  libgudev1-devel
238- applied new naming policy to spec
239
[521]240* Wed Jan 20 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.3-1
[564]241- new upstream release
[521]242- proved Japanese description
243
244* Thu Jan 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.2-1
245- new upstrema release
246
247* Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.1-1
248- intial build for VineSeed
249
250* Fri Dec 18 2009 Matthias Clasen <mclasen@redhat.com> - 0.4.0-0.1.20091218svn
251* Thu Nov 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
252- Update to 0.3.2
253
254* Tue Nov  3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.0-1
255- Version 0.3.0
256
257* Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.2.0-3
258- Rebuild against new libgee
259
260* Sun Aug 12 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-2.fc12
261- Bring icon cache handling in sync with current guidelines
262
263* Sun Aug  9 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-1.fc12
264- Initial packaging
Note: See TracBrowser for help on using the repository browser.